CraftBukkit - Built-In Permissions problem!

Discussion in 'Bukkit Help' started by mrweqa, Jul 22, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Ubuntu 11.04 i386
    Java Version "1.6.0_22" - OpenJRE
    Using Hamachi
    CraftBukkit Build 1000

    I enjoy using bukkit on my server and have been doing so since Minecraft Beta 1.2!
    But in the new CraftBukkit build 1000, it now has built-in-permissions!
    I thought that was great, until I realized I can't use "*" for all commands.
    And I don't enjoy it at all. Is there anyway to disable it?
  2. Offline



    Read the permissions FAQ. Clearly, the idea is that doing away with '*' was a good thing as '*' was just a holdover until a better system was written. This is that better system. Use permissions.yml to make your own permissions.

    More information here: Link
  3. Offline


    Hi there.

    I still want to find a way to disable built-in permissions as I would rather prefer a plugin of permissions and I love the "*" permissions which allows admins to access all commands. However when I use permissions in the built-in one sometimes it doesn't work with that plugin so its not usable, however with plugin permissions it always works.
  4. Offline


    I use Permissions 3.x. When I start the server it says "permissions.yml is empty, ignoring it". So just use permisisons 3.x, which has the '*'.
  5. Offline


    Thanks for the advice, but whenever I empty the permissions.yml file and try and use permissions 3.1.6 it says
    something along the lines of this "tried to access class com.nikkojin.permissions" and all my plugins come up with errors because of it :/
  6. Offline


Thread Status:
Not open for further replies.

Share This Page