Craftbukkit 714 (MC 1.5) Problem

Discussion in 'Bukkit Help' started by Monkeylard, Apr 23, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    When I would run my minecraft server with craftbukkit on the new tested build (714) The server would start up fine in the terminal but when i attempt to connect nothing happens. I made no changes to the server connection or ip address, one moment im running my minecraft on 1.4 and the server on 670 and its working fine, then I update my minecraft to 1.5 and update my craftbukkit.jar to 714 and the server is just impossible to connect to. Can someone please help me out? (Im new to the bukkit community):)
  2. Offline


    whats the message that uor getting in the client?
  3. Offline


    First wait till a recommend build comes out.
    Then wait till plugins update to correspond WITH the recommended build.
    Then try again.
    If you fail, THEN come back and ask for help, including any errors you recieve, plugin lists, configs that we may ask for ect.
  4. Offline


    First it says connecting to the server for a while then it says
    Failed to connect to the server
    Connection timed out : Connect

    Thanks for the feedback :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  5. Offline


    it sounds like you dont have the right updateed server/client what is the servers craftbukkit number? and what is the clients version?
  6. Offline


    By craftbukkit number do you mean build? My craftbukkit build is 714 and my minecraft client is running on 1.5_01
  7. Offline


    Same issue Here Monkey lard:)
    Cept I get end of stream and the server says the client lost connection:eek:

    Still though Waiting for the stable will be the best:D
  8. Offline


    My server doesnt even notice when i try to connect to my server, it doesnt pop up in the server log when i try to join, I agree i think waiting for a trust worthy reccomended build will be best :)
    MCbyWay likes this.
  9. Offline


    Isn't build 714 made for 1.5_02?
  10. Offline


    Admittedly it's tempting and we all wanna finally get to 1.5.
    But I guess patience is the best thing:D

    Good luck on your server Monkeylard[diamond]
  11. Offline


    Is there a 1.5_02 out yet?:eek:
    By the way nice avatar haha:D
  12. Offline


    If you are connecting to the server on the same computer then u should try connecting by typing 'localhost'because for me when i connect to my server using the real ip it doesnt connect.
  13. Offline


    Yes it is. I have tried 1.5.02 on 709 and 711

    For some reason I will always be unable to connect to the server even using a 1.5 client, surprisingly enough I get the error: endofstream on my client and the server just replies that I have disconnected with no errors.

    Not sure what I'm doing wrong here xD
    It's confusing cause everywhere else it seems to work for people :rolleyes:

    1.5.02 is a server side update to help with a lotta bugs, but gives new ones too >.<"

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  14. Offline


    It appeared some hours after 1.5 and 1.5_01
    1.5_02 is a serverupdate - client still shows 1.5_01 in the upper-left corner
    MCbyWay likes this.
  15. Offline


    I agree, however even when i deleted my craftbukkit.jar and replaced it with build 670 it still did not work. All craftbukkit builds that i would try to use after i tried 714 just simply would not let me connect no matter what computer is used, build 714 worked for my friend but not for me.:(

    Anyways thanks for the help and the very quick reply! :D
    MCbyWay likes this.
  16. Offline


    Just tried 1.5.02 with CB 711 to test again for you Monkeylard.

    Still unable tp connect with end of stream but I'm at least getting an error in the console now.
    My brain just noticed something. Be back in a sec I think I might know what's wrong on my side.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  17. Offline


    I am not connecting to the server with my server computer, I am using a different one, also my friends cant connect to my server either (Before i got build 714 all my friends could connect with no problems and have fun). I have been using hamachi for server connection so that my friends with the cracked version of minecraft could connect to me (this method also worked before I got build 714)
  18. Offline


    Wow... That...was VERY interesting....

    I have 711 working for me at last.

    I am currently on a mac and using Open JDK instead of the standard java package supplied by Apple. My impression is that Apple's java is just too outdated to perform well enough for my standards. HOWEVER, I switched back to Apple's standard java as a test for this specific bukkit build: The result I am able to connect using this version of java to run the server.

    Now, what system are you using Monkeylard and which java version?

    I understand you still want to give CB 711 a shot before the promoted build is out :cool:
  19. Offline


    Ah, right, I never read too far into it, sorry.
    I thought the compatibility was an issue, considering the 1.5 connecting to a 1.4 server ALWAYS gave me trouble, but now thinking it would be an "End of Stream" error.

    Thank you! :)
  20. Offline


    Im using Windows XP for the computer my server runs on, my java for that computer is version 6 update 24

    After the 1.5 update came out I left my server on 1.4 for a while and dident update my client or my server and I had no problems at all, but then I got a little impatient and wanted to update both my client and server to 1.5 for more features. Too bad I cant exactly pinpoint the problem with my server because the logs dont even show anyone attempting to connect. :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  21. Offline


    Hmmm... Unfortunately I'm no longer an expert at this point >.<"

    I guessed that you were using Java 1.7 Beta off Oracle, but to begin with your error was connection timed out while mine was "End of stream" ... hmmm.

    Sorry I really don't know how to continue at this point, you are using a hamachi set up while I'm using the normal Dynamic IP for my friends.

    I'm only aware that 1.5 server and client handles network differently then before so that's been a problem for all of us, Good luck once again Monkeylard. [creeper]

    Unfortunately I was unable to solve your problem:(
  22. Offline


    Thats fine, thanks for trying to help me out so much! I had no idea that the Bukkit community was so helpful and awesome! :D
    THEY DESERVE CAKE!!![cake][cake][cake][cake][cake][cake]
    MCbyWay likes this.
  23. Offline


    Don't even show attempts of connection... 0.0

    Since your set up is different... hmm...

    The issue... I do not think is to bukkit or minecraft any longer...

    Your java is fine and so is your server and client.

    Search harder Monkeylard I'm positive that despite what you may think there must have been a change somewhere for you setup!;)

    Attempt to downgrade your server as well as client, if you are able to then attempt to connect once more. If you are still unable to connect then the issue is the set up rather then MC or Bukkit!

    Sorry to make you go through so much trial and error but I do want to help:)


    There are a lot of helpful people around here!
    People like andrewkm are also being helpful as they don't want as many threads of random spam to no avail as waiting does provide the best solution as compared to many threads that don't get anywhere.

    You are simply doing what I am, a 17 year old kid trying to BUILD A WORLD with his close friends xD
    So! I shall help RAWR! xD

    However... it's 4am over here so I'm kinda sleepy my response will be a little slow as you may have noticed xD

    If you need the old server files I can send a link and the MC if you are on a windows system as you say you can use this link here:

    To downgrade your minecraft! ( Though to be honest I have not tested this program yet! xD )

    EDIT: I could provide the actual minecraft 1.4.01 files but technically that ain't allowed if I remember correctly ^^

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  24. how about i take the cake.LOL.
    from what you describe, i would try rebooting the router. it sounds like your setup is bad, not MC or Bukkit
    MCbyWay likes this.
  25. Offline


    My thoughts exactly.
    There would at least be something popping up in the console otherwise if I am not mistaken.

    However... this cake is mine....I'm not kidding...
  26. Offline


    I just changed my server's craftbukkit build to 687 and downgraded my minecraft to 1.4 and also tested 1.4_01 and I still cannot connect... :'(

    Thanks for the program, it works very well for me :)

    Anyways, I think you should get some sleep, you've done enough already. :)

    Ok, i'll be right back with the results from rebooting my router. Thanks for the idea, I think you're probably right. :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
    MCbyWay likes this.
  27. Offline


    At least we clarified that the issue is the setup so all you need to do is fix that! =D

    Then you can get back to 1.5!

    Good luck! I hope you can continue MC! xD

    @aidan matzko take it from here, I'm gonna go back to sleep xD

    Tell me how it goes yeah?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  28. Offline


    Hey guys, i'm back and after rebooting my router the server still does not allow me to connect to it. :'(
    I have also noticed a severe error the server has been getting about half way through finishing with it's start up, apparently I have been getting this error for a while but I have not caught it untill now. After further looking at my logs, the number at the end of this error would change sometimes. I hope some one will figure out what all this mumbo jumbo "" stuff means

    The error:

    [SEVERE] Wrapped java.lang.ClassNotFoundException: com.earth2me.essentials.Console (<Unknown source>#107) in <Unknown source> at line number 107
  29. wait a minute. what plugins are you using. have you tried these things:(not in order)
    1)Vanilla MC
    2)Bukkit w/o plugins
    3)MC 1.4 NVM you tried that.... sounds like a routing error. try the first 2 tho

    nope, i already ate the cake. early bird gets the early worm :D

    fyi, that is a essentials error. it looks like it atleast...

    @MCbyWay wait you liked my post. YOUR NOT SLEEPING! lol

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  30. Offline


    Ive tried bukkit without plugins multiple times with different builds, but not vanilla MC because I am so used to the simplicity of installing plugins to craftbukkit and also I have been using craftbukkit for ALL of my servers :p
    However i will try Vanillia MC because if that works then it must be bukkit.
Thread Status:
Not open for further replies.

Share This Page