CraftBukkit 1.4.6-R0.3 is now available!

Discussion in 'Bukkit News' started by EvilSeph, Dec 30, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    EvilSeph Retired Staff

    A new CraftBukkit Beta Build (1.4.6-R0.3) that provides Minecraft 1.4.6 compatibility and addresses issues found in the previous beta is now available in time for the holidays! Although Minecraft 1.4.7 is scheduled to release sometime after New Year's day, we've already fixed the issues it addresses in this beta. The previous beta contains a change that made a bug with enchantments being lost more noticeable and frequent. Upgrading to this new beta is highly recommended.

    Will plugins break with this build?
    Provided the developers of the plugins you are using are keeping up with the development of Bukkit, all your plugins should work fine, with the exception of plugins that use Minecraft or CraftBukkit code.

    Important Note: this Beta Build contains a new safeguard to protect servers against unchecked and thus potentially damaging plugins. See the announcement here for more information:
    http://forums.bukkit.org/threads/sa...cked-and-potentially-damaging-plugins.116749/

    What is a Beta build?
    A Beta Build is in between a developer build and a Recommended Build. These builds simply work and are promoted much more frequently than a Recommended Build. While we will do some testing before promoting a beta build, we will not be running it through our extensive test process. As such, there are no guarantees that they will not contain minor bugs. If we do find out they are broken, we will mark it as such on DLB and promote a new one. A beta build may contain incomplete API and new features but they should not interfere with running the build in any way.

    This particular Beta build, like every first Beta build for a Minecraft update, is primarily made available to help facilitate more testing coverage to bring us closer to a Recommended Build sooner. Please consider running this Beta build to give us a hand with discovering issues we need to address in order to reach a Recommended Build.

    Known Issues:
    • Monsters, villagers, etc. using portals (added in Minecraft 1.4) has been temporarily disabled.
    For more detailed information on what is contained in this update, please see the changelog here.

    Download CraftBukkit 1.4.6-R0.3 here
     
    karcraft123, En3der, gomeow and 9 others like this.
  2. Offline

    spiral6

    Awesome, a random update just a few days after the R 0.2 update! Good work!
     
  3. Offline

    Maltheus

    Great job on the quick updates! Although I'm really disappointed that you can no longer teleport entities with passengers. I very much relied on that capability.
     
  4. Offline

    SKB12321

    this won't work, it says that it's compatible with 1.4.5, i have 1.4.6, help please
     
  5. Offline

    TnT Retired Staff

    This is a build for 1.4.6.
     
  6. Offline

    Jadedwolf

    "Known Issues:
    Monsters, villagers, etc. using portals (added in Minecraft 1.4) has been temporarily disabled"
    This is starting to be ridiculous by the way, it's beyond incompetence to have such a major feature disabled for this long.
    I'm not going to name names, but you know who is working on this issue and he needs to get his shit sorted and quit wasting everyone's time.
     
    s32ialx likes this.
  7. Offline

    Praqoon

    I had 1.4.6-R0.2 installed on a test server. I was just about to update the help.yml to the live server and logged in as Admin. There was a red message saying "CraftBukkit is broken and you are advised to upgrade." So I upgraded to 1.4.6-R0.3 first, then I copied the help.yml file from the test server to the live server. Voila... no boot - server froze

    2012-12-31 13:22:53 [SEVERE] Cannot load help.yml
    org.bukkit.configuration.InvalidConfigurationException: expected '<document start>', but found BlockMappingStart in "<string>", line 53, column 2:
    ignore-plugins:

    And when I checked the log I saw the above error. I had to change it back to the the original file (I always make backups before updating) before it would work again. So, if it's working for you it must be a problem with my Linux setup. Both the test server and live server are running Slackware64 13.37 with the same software installed for reasons of compatibility. I reverted back to 1.4.6.-R0.2 to see if the new help.yml file worked and it did.

    <edit> forgot to mention, both 1.4.6-R0.2 and 1.4.6-R0.3 I had installed are the BETA versions. I'm not a fan of dev builds unless there is no other option. :)
     
  8. Offline

    TnT Retired Staff

    Praqoon
    Provide that broken help.yml please - seems its an issue in that ignore-plugins: list.

    PM it to me if you wish.
     
  9. Offline

    Praqoon

    Sure thing TnT... PM on the way in 5 mins. :)
     
  10. Offline

    Zai44

    good job! the R0.2 was a problem when i always logined and i got errors and my players too! with this works 100% great work!
     
  11. Offline

    feildmaster Retired Staff

    I'm sorry, do you want to work on it? I expect a PR in 48 hundred hours.

    I don't know who you think it is that's tasked on this issue, but I'll tell you that it doesn't matter who is working on it. It matters on if it works or not.
     
  12. Offline

    LEOcab

    I'm just wondering, is there a reason to update from R0.1 to R0.3? Any bugs fixed or something? A year of server hosting has taught me not to fix what isn't broken. :p
     
    Praqoon likes this.
  13. Offline

    Riden1014

    Um, Yes i really need to update my server and i cant because of i can't get the new craft bukkit update when click craft bukkit it brings me to the 1.4.5 update. Help me?
     
  14. Offline

    SwordsMiner

    I recall, (Atleast from my own server and other servers), that there is a bug with hitting blocks and entities, atleast there is for alot of server owners.
     
    Praqoon likes this.
  15. Offline

    RazorzEdge425

    Is there something like bukkit that Won't keep going to the beta builds and stay on recommended?
     
    Praqoon likes this.
  16. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı Retired Staff

    Sounds like you're using a faulty host-provided panel. Ask your host for help.

    Sounds like you're using a faulty host-provided panel. Ask your host for help.
     
  17. Offline

    TnT Retired Staff

    Well, we were sitting around thinking "You know, 0.3 sounds far better than 0.1. Lets update to 0.3"

    Now for a serious answer - yes, we fixed bugs. See the change logs here, and here.
     
    np98765 likes this.
  18. Offline

    Temido2222

    My server says there is an R4 out
     
  19. Offline

    Fire_Dragon_64

    Nice and fast updates !!!!
     
  20. Offline

    OfficeBooks

    Thanks Bukkit! I Missed My Plugins!
     
  21. Offline

    YoFuzzy3

    Probably because you've got the suggested channel set to dev.
     
  22. Offline

    s32ialx

    So are you just going to make 1.4.7R.0.3 beta automatically minecraft already explained it was only a minor change that was made and shouldn't really effect anything "This release is compatible with 1.4.6 and has almost no bytecode changes, so mods that have been updated for 1.4.6 should work in 1.4.7 too. The only affected file is the one called “qz”, which is the arrow projectile’s class"
     
  23. Offline

    RiotShielder

    Well you have to admit it has been like 4 months since this feature was added. I aprreciate that this is all free, but it's quite a wait. Honestly I have no idea why people are so mad about it. Not exactly a crucial feature
     
    Praqoon likes this.
  24. Offline

    Praqoon

    I couldn't give a rat's ass if this feature worked or not. If it was left out of the game completely it would be one less thing to fix/whine about. ;)
     
  25. Offline

    RiotShielder

    I agree
     
  26. Offline

    batbat

    I have a feeling it is more complicated than just changing a bit of code. If you haven't noticed when you set up a Bukkit server it splits the worlds into three folders, Normal, Nether, and End. I have a feeling it has something to do with that and probably requires a significant change in the way Bukkit and/or Vanilla Minecraft handles the mobs using portals feature.

    So maybe cut them some slack. Or if you have a solution perhaps you can offer to help fix it.
     
  27. Offline

    Haribo98

    I'm sorry, what? You're mocking the people who spend day after day working on getting a version of Bukkit stable and working for you (I can see) as a developer and those others who runs servers and play on them. 1 feature disabled, a feature I'm sure many won't care about. Don't go hating on them, they work extremely hard to get a working version available.

    Calm it. If you're so bothered about it, try and be the guy who "gets his shit sorted".
     
  28. Offline

    Freeman_all

    this good server, here only downloads of browser 10 minutes;
    (P.S. :I do not know much English)
     
  29. Offline

    s32ialx

    Well I still haven't got an answer what are you going to do bukkit? release 1.4.7 R0.3 as the start of 1.4.7 becuase there is only just a minor change are you going to force all plugin developers to update to 1.4.7 with this new safeguard? also and onto 1.5 around Feb
     
  30. Offline

    TnT Retired Staff

    The fix 1.4.7 brings has already been included in CraftBukkit. We may update, but its not high priority as it doesn't come with a protocol change, or any other benefit.

    Also, you asked 12 hours ago, on new years eve. Relax.
     
    s32ialx and troed like this.
Thread Status:
Not open for further replies.

Share This Page