CraftBukkit 1.4.5-R1.0 is now available!

Discussion in 'Bukkit News' started by EvilSeph, Dec 19, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    EvilSeph Retired Staff

    A new CraftBukkit Recommended Build (1.4.5-R1.0) that provides Minecraft 1.4.5 compatibility is now available. This Recommended Build has been promoted so that servers have something reliable to use until they are ready to update to the upcoming Minecraft 1.4.6.

    Please note: Minecraft 1.4.5 clients will not be able to connect to Minecraft 1.4.6 servers.

    Will plugins break with this build?
    Provided the developers of the plugins you are using are keeping up with the development of Bukkit, all your plugins should work fine, with the exception of plugins that use Minecraft or CraftBukkit code.

    Important Note: this Recommended Build contains a new safeguard to protect servers against unchecked and thus potentially damaging plugins. See the announcement here for more information:
    http://forums.bukkit.org/threads/sa...cked-and-potentially-damaging-plugins.116749/

    Known Issues:
    • Monsters, villagers, etc. using portals (added in Minecraft 1.4) has been temporarily disabled.

    For more detailed information on what is contained in this update, please see the changelog here.

    Download CraftBukkit 1.4.5-R1.0 here
     
    number1_Master, Sigong, TnT and 4 others like this.
  2. Offline

    RiotShielder

    Good thing that all the plugins I use are based off of the Call of Duty server code
     
  3. Offline

    pkt

    Lol, this update broke a ton of plugins
     
  4. Offline

    TnT Retired Staff

    I'm sure they will update quickly :)
     
  5. Offline

    bbjake10

    I sure hope that my plugins will be updated soon. Without WorldGuard Creepers can blowup all of my buildings. sssssssssssSSSSSSSSSSSSSSSSS BOOM!!! NOOOOO!!!
     
  6. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı Retired Staff

    WorldGuard depends on WorldEdit. I believe WorldEdit is updated in dev builds. :)
     
  7. Offline

    bbjake10

    Oh ok. Thanks.
     
  8. Offline

    RiotShielder

    Is this suppose to happen on every start?
    Also running 70 plugins, the only plugins that throw an error for me are
    Voxel Sniper (On startup)
    JSONAPI (On startup)
    DisguiseCraft (On startup)
    Heroes (On startup)
    MobCatcher (On startup)
    Towny (On block break)
    bPerms (A nasty spam error)
     
  9. Offline

    ossipetz

    Thanks for the RB! :)
     
  10. Offline

    Cirno

    It's just a deprecated function; sooner or later, the authors will update it to fix the issue.
     
  11. Offline

    RiotShielder

    I think it is a cruel joke that Bukkit releases an RB the day before an update :p
     
  12. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı Retired Staff

    It is a AuthorNagException, pointing out that a method in the plugin in the future will need updating.

    As for bPerms, it needs an update. I'm sure codename_B will update it soon. :)
     
  13. Offline

    RiotShielder

    So I assume it's a CraftBukkit nag thing, not anything I need to worry about?
     
  14. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı Retired Staff

    As it sort of suggests, it's for nagging the author. It doesn't prevent the plugin from loading. :)
     
  15. Offline

    Maltheus

    So a big difference from the last beta, is that a north-south rail used to report it's direction as WEST (for whatever reason), but now it's reporting it as SOUTH. Was this an intentional change? I don't want to recode my plugins if it wasn't.
     
  16. Offline

    CollinPotato

    I updated to this build and no one had any permissions. I use PermissionsEx 1.19.3. I updated to the latest build of Pex and still no dice. Anyone else having this problem?
     
  17. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı Retired Staff

  18. Offline

    TfT_02

    Thanks for another CraftBukkit RB. :)
     
  19. Offline

    brandcool86

    Great To see a RB build out :). Already running it with no errors as i updated my plugins.

    Thanks bukkit!

    (hoping to see a Dev-build out before the fireworks update :p) If not the next day :D)

    Happy coding :)
     
  20. Offline

    Persian

    Yay, Thank you everyone who worked soo hard to get this out before 1.4.6!!!
     
    h31ix likes this.
  21. Offline

    fashizzles

    Released the night before 1.4.6; Minecraft 1.4.6 wont allow players to join your server while in 1.4.5? (Confused)
     
  22. Offline

    Talkyn

    Lol. Another user of 1.4.5R0.2 that upgraded to be surprised. I've never gone from a Beta to a RB an had my console puke so much at me :D.

    I'll be holding off until Sk89Q and team get updates rolled out for their plugins I think. Could have broken PEX as well but I'm no expert. I suppose this API and 'watchdog' stuff will force some large revisions in even our most belov'd plugins.

    Regardless, I have to say I really appreciate the whole team at Bukkit for all their hard work. I know its not easy and I can't imagine the man-hours you fine folks must put in on our behalf. Thank You.
     
  23. Offline

    s32ialx

    your clearly not running the sk8rq's bleeding edge builds and pex works fine also...
     
  24. Offline

    nanneters

    Very well done Bukkit team !
     
  25. Offline

    3ric

    Thanks Bukkit team. You guys kick ass.
     
  26. Online

    timtower Moderator Moderator

    I will stick to R0.2, works fine for me, don't want to search for new plugins, I use a bunch that wont get updated any more
     
    poiNt_3D likes this.
  27. Offline

    XxDawnsusxX

    coreprotect wasn't the problem

    its the new craftbukkit
     
  28. Offline

    djl0st12

    http://gyazo.com/73186ee3f50588f6745bb56b2987fdf1 On the rb. and every plugin I have is running like a racehorse. Did I originally have errors? Yes. Did I look at the errors, determine what plugin was out of date with the new build? yes. Did I go to the plugin authors page and find the solution? Yes. So in short, will the new rb work 100 percent with no effort. No. Will it run perfectly if you arent lazy and sort out the plugins that need to be updated? Absolutely . Thank you bukkit :) well done. Now on to 1.4.6 :)

    Sk8 has released a fix for both of his plugins. See my post above. Both worldguard and worldedit are working perfectly for me on 1.4.5 rb

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 30, 2016
  29. Offline

    bracher

    Hey, Ive just updates to the lastest Builds, And its saying my server is out of date, Ive tried 5 different ones now and keeps saying my server is out of date but it is a 1.4.5 can anyone help?
     
  30. Offline

    ManBeastPig

    But now 1.4.6 just came out.

    I hate MOJANG.
     
    AndyMcB1 and PlannedBoredom like this.
  31. Offline

    PlannedBoredom

    Well that must suck...
    Bukkit:*Releases anticipated RB*
    Mojang:*Releases new Minecraft update*
    Plugin Devs: :(
     
    Felixx61 likes this.
Thread Status:
Not open for further replies.

Share This Page