CraftBukkit 1.3.1-R1.0 is now available!

Discussion in 'Bukkit News' started by EvilSeph, Aug 7, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    A new CraftBukkit Recommended Build (1.3.1-R1.0) that provides Minecraft 1.3.1 compatibility is now available.

    Important information about this first Recommended Build following a Minecraft update:
    The first Recommended Build, as always, is a slightly more polished development build that we're promoting to a Recommended Build so that people who rely on a Recommended Build being available can try out our development builds and decide if they want to use them.

    Will plugins break with this build?
    Provided the developers of the plugins you are using are keeping up with the development of Bukkit, all your plugins should work fine.

    Download CraftBukkit 1.3.1-R1.0 here
    hansolo23, flap, Terence and 37 others like this.
  2. Offline


    • Idiocy like this is not allowed.
    I have just about had enough with the lagg on this new craftbukkit:mad:.... I have experienced lagg so much that my server crashes and people are complaining i have shit internet but it is this new bukkit Rb thats doing all this lagg... i told them that and then after that more lagg on the next day!!!!.... BUKKIT, FIX THIS LAG! NOW ANND RELEASE A NEW RB!! SO NO COMPLAINTS ABOUT LAGG ANYMORE
  3. Offline


    Build #2322, fixed the lagging. but chunk rollback occasionally (when player login/logout? or chunk load/unload?).
    my server players are frustrated...
  4. Offline


    Be nice, dude. All this stuff is free and you demand, demand, demand...

    Here is your solution:
  5. Offline


    [​IMG] Hey I have a Question have all the plugins been updated for the new version of bukkit?[​IMG]
  6. Offline


    Ask the plugin developers? Just go to the server mods and see what updates...
  7. Offline


    I'm having this problem, but my friend did it and his plugins work with 1.3.1 so i don't know.
  8. Offline


    lemme gues, you run a pay2 win server but never donated to bukkit? I never donated to bukkit, but I run a server just for the fun of it. And when I got some money in my paypal, I will donate something, but atleast I am not demanding.
  9. Offline


    why donate???
  10. Offline


    since those guys are putting their frree time in this project, no money given?
    paalbra likes this.
  11. Offline


    AWESOME! I was waiting a long time for the recommended build. The dev version had alot of bugs and game crashes. Thanks for the hard work BUKKIT!:D Heres a pie and some diamonds for your hard work.[cake][diamond][diamond]
  12. Offline


    Hi all!
    Just wondering, are any extra ports needed or other extra configuration?
    I've got a FreeBSD box I've been running my server on and it worked fine for 1.2.5 but with this version people can't connect. Server appears to be running fine, no complaints in the log, just no-one can connect.
    I tried running the exact same config on my Windows computer just by copying the files over, and it worked without a problem.

    Oh, when I say players can't connect it's not an error, just the "End of stream" message.
  13. Offline


    Alright, im pretty amish and dont know much about servers *at all*. I am running a server via LethalDrive, and use FileZila Client to access and modify things. I put the Craftbukkit 1.3.1 .jar into the main folder and deleted the old 1.2.5 .jar. I deleted all the plugins to get a fresh new server, then Stopped and Started the server back up. But when I login, I get the "Internal exception: connection reset" error. of course, I dont know what that means or what im doing wrong. Im probably doing alot wrong. My guess is that putting the 1.3.1 .jar into FileZila wasnt enough, do I also have to wait for LethalDrive to put the 1.3.1 recommended build into the Server Version list to be able to install it properly?
  14. Offline


    Show Spoiler

    # A fatal error has been detected by the Java Runtime Environment:
    # EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x0000000065c0ccec, pid=5004, tid=5720
    # JRE version: 7.0_02-b13
    # Java VM: Java HotSpot(TM) 64-Bit Server VM (22.0-b10 mixed mode windows-amd64 compressed oops)
    # Problematic frame:
    # V [jvm.dll+0x4ccec]
    # Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
    # If you would like to submit a bug report, please visit:

    --------------- T H R E A D ---------------

    Current thread (0x0000000007412800): JavaThread "Server thread" [_thread_in_vm, id=5720, stack(0x0000000008420000,0x0000000008520000)]

    siginfo: ExceptionCode=0xc0000005, reading address 0x0000000000000018

    RAX=0x0000000000000000, RBX=0x000000000638d180, RCX=0x000000000000002f, RDX=0x00000000bae02d18
    RSP=0x000000000851d600, RBP=0x000000000851d638, RSI=0x000000000851e0c0, RDI=0x0000000000000000
    R8 =0x00000000bae01d88, R9 =0x000000000000002f, R10=0x0000000000000001, R11=0x00000000bae020d0
    R12=0x0000000007412800, R13=0x000000000851dbe0, R14=0x000000000851dc18, R15=0x0000000000000014
    RIP=0x0000000065c0ccec, EFLAGS=0x0000000000010246

    Top of Stack: (sp=0x000000000851d600)
    0x000000000851d600: 000000000638d180 000000000851e0c0
    0x000000000851d610: 000000000638d180 000000000851e0c0
    0x000000000851d620: 000000000638d180 0000000065bfff7d
    0x000000000851d630: 000000000851e0c0 000000000851dbe0
    0x000000000851d640: 00000000000000b7 0000000000000014
    0x000000000851d650: 0000000000000000 0000000007412800
    0x000000000851d660: 000000000851d770 0000000065c0d8f8
    0x000000000851d670: 00000000021bccb0 0000000000000d02
    0x000000000851d680: 000000000638d180 0000000000000003
    0x000000000851d690: 000000000000001f 000000000851dfe0
    0x000000000851d6a0: 000000000634cad0 0000000000001800
    0x000000000851d6b0: 00000000021bccb0 00000000087dddb0
    0x000000000851d6c0: 0000007100000070 000000010000000e
    0x000000000851d6d0: 0000000008730310 000000000638d180
    0x000000000851d6e0: 0000000000000018 000000000851dfe0
    0x000000000851d6f0: 00000000bc34ee10 000000000000001f

    Instructions: (pc=0x0000000065c0ccec)
    0x0000000065c0cccc: b6 45 71 0b d0 e8 ca 21 06 00 4c 8b 0f 48 8b 15
    0x0000000065c0ccdc: c8 a1 60 00 4c 8b c0 48 8b cf 41 ff 51 60 33 ff
    0x0000000065c0ccec: 48 8b 48 18 48 89 45 50 48 8b 41 20 48 89 45 70
    0x0000000065c0ccfc: 48 85 c0 75 04 8b cf eb 4e 4d 8b b4 24 08 01 00

    Register to memory mapping:

    RAX=0x0000000000000000 is an unknown value
    RBX=0x000000000638d180 is an unknown value
    RCX=0x000000000000002f is an unknown value
    RDX=0x00000000bae02d18 is an oop
    - klass: {other class}
    RSP=0x000000000851d600 is pointing into the stack for thread: 0x0000000007412800
    RBP=0x000000000851d638 is pointing into the stack for thread: 0x0000000007412800
    RSI=0x000000000851e0c0 is pointing into the stack for thread: 0x0000000007412800
    RDI=0x0000000000000000 is an unknown value
    R8 =0x00000000bae01d88 is an oop
    {constant pool}
    - klass: {other class}
    - holder: 0x00000000bae02da0
    - cache: 0x00000000baea5bd0
    - 1 : : 'java/lang/StringBuilder' {0xbae87f10}
    - 2 : : klass_index=1 name_and_type_index=51
    - 3 : : klass_index=18 name_and_type_index=52
    - 4 : : klass_index=53 name_and_type_index=54
    - 5 : : klass_index=1 name_and_type_index=55
    - 6 : : "@" {0xfd0f9d88}
    - 7 : : klass_index=18 name_and_type_index=57
    - 8 : : klass_index=58 name_and_type_index=59
    - 9 : : klass_index=1 name_and_type_index=60
    - 10 : : 'java/lang/IllegalArgumentException'
    - 11 : : "timeout value is negative" {0xfd0f9d20}
    - 12 : : klass_index=10 name_and_type_index=63
    - 13 : : 999999
    - 14 : : "nanosecond timeout value out of range" {0xfd0f9ca0}
    - 15 : : 500000
    - 16 : : klass_index=18 name_and_type_index=65
    - 17 : : klass_index=18 name_and_type_index=66
    - 18 : : 'java/lang/Object' {0xbae02da0}
    - 19 : : '<init>'
    - 20 : : '()V'
    - 21 : : 'Code'
    - 22 : : 'LineNumberTable'
    - 23 : : 'registerNatives'
    - 24 : : 'getClass'
    - 25 : : '()Ljava/lang/Class;'
    - 26 : : 'Signature'
    - 27 : : '()Ljava/lang/Class<*>;'
    - 28 : : 'hashCode'
    - 29 : : '()I'
    - 30 : : 'equals'
    - 31 : : '(Ljava/lang/Object;)Z'
    - 32 : : 'StackMapTable'
    - 33 : : 'clone'
    - 34 : : '()Ljava/lang/Object;'
    - 35 : : 'Exceptions'
    - 36 : : 'java/lang/CloneNotSupportedException'
    - 37 : : 'toString'
    - 38 : : '()Ljava/lang/String;'
    - 39 : : 'notify'
    - 40 : : 'notifyAll'
    - 41 : : 'wait'
    - 42 : : '(J)V'
    - 43 : : 'java/lang/InterruptedException' {0xbb3f71b0}
    - 44 : : '(JI)V'
    - 45 : : 'finalize'
    - 46 : : 'java/lang/Throwable'
    - 47 : : '<clinit>'
    - 48 : : 'SourceFile'
    - 49 : : ''
    - 50 : : 'java/lang/StringBuilder'
    - 51 : : name_index=19 signature_index=20
    - 52 : : name_index=24 signature_index=25
    - 53 : : 'java/lang/Class' {0xbae15858}
    - 54 : : name_index=72 signature_index=38
    - 55 : : name_index=73 signature_index=74
    - 56 : : '@'
    - 57 : : name_index=28 signature_index=29
    - 58 : : 'java/lang/Integer' {0xbaea0720}
    - 59 : : name_index=76 signature_index=77
    - 60 : : name_index=37 signature_index=38
    - 61 : : 'java/lang/IllegalArgumentException'
    - 62 : : 'timeout value is negative'
    - 63 : : name_index=19 signature_index=78
    - 64 : : 'nanosecond timeout value out of range'
    - 65 : : name_index=41 signature_index=42
    - 66 : : name_index=23 signature_index=20
    - 67 : : 'java/lang/Object'
    - 68 : : 'java/lang/CloneNotSupportedException'
    - 69 : : 'java/lang/InterruptedException'
    - 70 : : 'java/lang/Throwable'
    - 71 : : 'java/lang/Class'
    - 72 : : 'getName'
    - 73 : : 'append'
    - 74 : : '(Ljava/lang/String;)Ljava/lang/StringBuilder;'
    - 75 : : 'java/lang/Integer'
    - 76 : : 'toHexString'
    - 77 : : '(I)Ljava/lang/String;'
    - 78 : : '(Ljava/lang/String;)V'

    R9 =0x000000000000002f is an unknown value
    R10=0x0000000000000001 is an unknown value
    R11=0x00000000bae020d0 is an oop
    - klass: 'java/lang/Object'[]
    - length: 14
    R12=0x0000000007412800 is a thread
    R13=0x000000000851dbe0 is pointing into the stack for thread: 0x0000000007412800
    R14=0x000000000851dc18 is pointing into the stack for thread: 0x0000000007412800
    R15=0x0000000000000014 is an unknown value

    Stack: [0x0000000008420000,0x0000000008520000], sp=0x000000000851d600, free space=1013k
    Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
    V [jvm.dll+0x4ccec]
    C 0x00000000000000b7

    Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
    j lishid.orebfuscator.hook.OrebfuscatorPlayerListenerHook.TryUpdateNetServerHandler(Lorg/bukkit/entity/Player;)V+28
    j lishid.orebfuscator.hook.OrebfuscatorPlayerListenerHook.onPlayerJoin(Lorg/bukkit/event/player/PlayerJoinEvent;)V+5
    v ~StubRoutines::call_stub
    j sun.reflect.NativeMethodAccessorImpl.invoke0(Ljava/lang/reflect/Method;Ljava/lang/Object;[Ljava/lang/Object;)Ljava/lang/Object;+0
    j sun.reflect.NativeMethodAccessorImpl.invoke(Ljava/lang/Object;[Ljava/lang/Object;)Ljava/lang/Object;+87
    j sun.reflect.DelegatingMethodAccessorImpl.invoke(Ljava/lang/Object;[Ljava/lang/Object;)Ljava/lang/Object;+6
    j java.lang.reflect.Method.invoke(Ljava/lang/Object;[Ljava/lang/Object;)Ljava/lang/Object;+57
    j org.bukkit.plugin.RegisteredListener.callEvent(Lorg/bukkit/event/Event;)V+36
    j org.bukkit.plugin.SimplePluginManager.fireEvent(Lorg/bukkit/event/Event;)V+54
    j org.bukkit.plugin.SimplePluginManager.callEvent(Lorg/bukkit/event/Event;)V+100
    j net.minecraft.server.ServerConfigurationManagerAbstract.c(Lnet/minecraft/server/EntityPlayer;)V+154
    j net.minecraft.server.ServerConfigurationManagerAbstract.a(Lnet/minecraft/server/INetworkManager;Lnet/minecraft/server/EntityPlayer;)V+340
    j net.minecraft.server.NetLoginHandler.d()V+53
    j net.minecraft.server.NetLoginHandler.c()V+8
    j net.minecraft.server.DedicatedServerConnectionThread.a()V+44
    j net.minecraft.server.DedicatedServerConnection.b()V+4
    j net.minecraft.server.MinecraftServer.q()V+344
    v ~StubRoutines::call_stub

    --------------- P R O C E S S ---------------

    Java Threads: ( => current thread )
    0x000000000bb14800 JavaThread "Connection #1 write thread" [_thread_blocked, id=5292, stack(0x000000000e280000,0x000000000e380000)]
    0x000000000bb16800 JavaThread "Connection #1 read thread" [_thread_in_native, id=4056, stack(0x000000000de20000,0x000000000df20000)]
    0x000000000bb17800 JavaThread "Thread-177" [_thread_blocked, id=5376, stack(0x000000000df20000,0x000000000e020000)]
    0x000000000bb15000 JavaThread "File IO Thread" [_thread_blocked, id=5796, stack(0x000000000dc00000,0x000000000dd00000)]
    0x000000000bb13800 JavaThread "com.mchange.v2.async.ThreadPoolAsynchronousRunner$PoolThread-#2" daemon [_thread_blocked, id=3188, stack(0x000000000d970000,0x000000000da70000)]
    0x000000000bb13000 JavaThread "com.mchange.v2.async.ThreadPoolAsynchronousRunner$PoolThread-#1" daemon [_thread_blocked, id=5764, stack(0x000000000d7b0000,0x000000000d8b0000)]
    0x000000000bb12000 JavaThread "com.mchange.v2.async.ThreadPoolAsynchronousRunner$PoolThread-#0" daemon [_thread_blocked, id=4348, stack(0x000000000d5f0000,0x000000000d6f0000)]
    0x000000000bb11800 JavaThread "Timer-0" daemon [_thread_blocked, id=1356, stack(0x00000000092b0000,0x00000000093b0000)]
    0x00000000086fc800 JavaThread "Thread-9" [_thread_blocked, id=3544, stack(0x0000000009470000,0x0000000009570000)]
    0x00000000087b2800 JavaThread "Thread-6" [_thread_blocked, id=5528, stack(0x0000000008100000,0x0000000008200000)]
    0x000000000775f800 JavaThread "Listen thread" [_thread_in_native, id=4032, stack(0x0000000008fd0000,0x00000000090d0000)]
    0x0000000007403800 JavaThread "Thread-5" daemon [_thread_in_native, id=4192, stack(0x00000000085d0000,0x00000000086d0000)]
    0x000000000024b000 JavaThread "DestroyJavaVM" [_thread_blocked, id=5684, stack(0x00000000023d0000,0x00000000024d0000)]
    =>0x0000000007412800 JavaThread "Server thread" [_thread_in_vm, id=5720, stack(0x0000000008420000,0x0000000008520000)]
    0x00000000073ec800 JavaThread "Thread-4" daemon [_thread_blocked, id=5460, stack(0x0000000008220000,0x0000000008320000)]
    0x00000000063f8800 JavaThread "Snooper Timer" daemon [_thread_blocked, id=1828, stack(0x0000000007f20000,0x0000000008020000)]
    0x000000000635f800 JavaThread "Service Thread" daemon [_thread_blocked, id=5256, stack(0x0000000007280000,0x0000000007380000)]
    0x000000000635e000 JavaThread "C2 CompilerThread1" daemon [_thread_blocked, id=2716, stack(0x00000000069a0000,0x0000000006aa0000)]
    0x0000000006351000 JavaThread "C2 CompilerThread0" daemon [_thread_blocked, id=3428, stack(0x0000000007000000,0x0000000007100000)]
    0x000000000634d800 JavaThread "Attach Listener" daemon [_thread_blocked, id=1736, stack(0x0000000006dc0000,0x0000000006ec0000)]
    0x0000000006348800 JavaThread "Signal Dispatcher" daemon [_thread_blocked, id=5136, stack(0x0000000006bc0000,0x0000000006cc0000)]
    0x0000000002233800 JavaThread "Finalizer" daemon [_thread_blocked, id=240, stack(0x0000000006ac0000,0x0000000006bc0000)]
    0x0000000002229800 JavaThread "Reference Handler" daemon [_thread_blocked, id=5196, stack(0x0000000006690000,0x0000000006790000)]

    Other Threads:
    0x0000000002225000 VMThread [stack: 0x0000000006870000,0x0000000006970000] [id=5572]
    0x0000000006369000 WatcherThread [stack: 0x0000000007140000,0x0000000007240000] [id=6096]

    VM state:not at safepoint (normal execution)

    VM Mutex/Monitor currently owned by a thread: None

    PSYoungGen total 305856K, used 115119K [0x00000000eaab0000, 0x0000000100000000, 0x0000000100000000)
    eden space 262208K, 27% used [0x00000000eaab0000,0x00000000ef0808f0,0x00000000faac0000)
    from space 43648K, 99% used [0x00000000faac0000,0x00000000fd55b3a8,0x00000000fd560000)
    to space 43648K, 0% used [0x00000000fd560000,0x00000000fd560000,0x0000000100000000)
    PSOldGen total 699072K, used 124695K [0x00000000c0000000, 0x00000000eaab0000, 0x00000000eaab0000)
    object space 699072K, 17% used [0x00000000c0000000,0x00000000c79c5d58,0x00000000eaab0000)
    PSPermGen total 25664K, used 25504K [0x00000000bae00000, 0x00000000bc710000, 0x00000000c0000000)
    object space 25664K, 99% used [0x00000000bae00000,0x00000000bc6e8018,0x00000000bc710000)

    Code Cache [0x00000000024d0000, 0x0000000002750000, 0x00000000054d0000)
    total_blobs=1258 nmethods=835 adapters=374 free_code_cache=46699Kb largest_free_block=47772544

    Dynamic libraries:
    0x000000013f7f0000 - 0x000000013f823000C:\Program Files\Java\jre7\bin\java.exe
    0x0000000077400000 - 0x00000000775ac000C:\Windows\SYSTEM32\ntdll.dll
    0x0000000077080000 - 0x000000007719f000C:\Windows\system32\kernel32.dll
    0x000007fefdbd0000 - 0x000007fefdc3c000C:\Windows\system32\KERNELBASE.dll
    0x000007fefe260000 - 0x000007fefe33b000C:\Windows\system32\ADVAPI32.dll
    0x000007fefe510000 - 0x000007fefe5af000C:\Windows\system32\msvcrt.dll
    0x000007fefdfe0000 - 0x000007fefdfff000C:\Windows\SYSTEM32\sechost.dll
    0x000007fefdcb0000 - 0x000007fefddde000C:\Windows\system32\RPCRT4.dll
    0x0000000077300000 - 0x00000000773fa000C:\Windows\system32\USER32.dll
    0x000007fefdc40000 - 0x000007fefdca7000C:\Windows\system32\GDI32.dll
    0x000007fefe4d0000 - 0x000007fefe4de000C:\Windows\system32\LPK.dll
    0x000007fefe400000 - 0x000007fefe4ca000C:\Windows\system32\USP10.dll
    0x000007fefbf70000 - 0x000007fefc164000C:\Windows\WinSxS\\COMCTL32.dll
    0x000007fefe1e0000 - 0x000007fefe251000C:\Windows\system32\SHLWAPI.dll
    0x000007fefe4e0000 - 0x000007fefe50e000C:\Windows\system32\IMM32.DLL
    0x000007fefdec0000 - 0x000007fefdfc9000C:\Windows\system32\MSCTF.dll
    0x00000000662a0000 - 0x0000000066371000C:\Program Files\Java\jre7\bin\msvcr100.dll
    0x0000000065bc0000 - 0x000000006629a000C:\Program Files\Java\jre7\bin\server\jvm.dll
    0x000007fefa580000 - 0x000007fefa589000C:\Windows\system32\WSOCK32.dll
    0x000007feff430000 - 0x000007feff47d000C:\Windows\system32\WS2_32.dll
    0x000007fefdfd0000 - 0x000007fefdfd8000C:\Windows\system32\NSI.dll
    0x000007fef9ae0000 - 0x000007fef9b1b000C:\Windows\system32\WINMM.dll
    0x00000000775d0000 - 0x00000000775d7000C:\Windows\system32\PSAPI.DLL
    0x0000000070bc0000 - 0x0000000070bcf000C:\Program Files\Java\jre7\bin\verify.dll
    0x0000000070230000 - 0x0000000070258000C:\Program Files\Java\jre7\bin\java.dll
    0x0000000070210000 - 0x0000000070225000C:\Program Files\Java\jre7\bin\zip.dll
    0x000007fefd140000 - 0x000007fefd157000C:\Windows\system32\CRYPTSP.dll
    0x000007fefce40000 - 0x000007fefce87000C:\Windows\system32\rsaenh.dll
    0x000007fefcbb0000 - 0x000007fefcbce000C:\Windows\system32\USERENV.dll
    0x000007fefd870000 - 0x000007fefd87f000C:\Windows\system32\profapi.dll
    0x000007fefd7a0000 - 0x000007fefd7af000C:\Windows\system32\CRYPTBASE.dll
    0x00000000701f0000 - 0x0000000070209000C:\Program Files\Java\jre7\bin\net.dll
    0x000007fefd0e0000 - 0x000007fefd134000C:\Windows\system32\mswsock.dll
    0x000007fefd0d0000 - 0x000007fefd0d7000C:\Windows\System32\wship6.dll
    0x000007fefbb80000 - 0x000007fefbb95000C:\Windows\system32\NLAapi.dll
    0x000007fefcf60000 - 0x000007fefcfbb000C:\Windows\system32\DNSAPI.dll
    0x000007fef5230000 - 0x000007fef523b000C:\Windows\System32\winrnr.dll
    0x000007fef5210000 - 0x000007fef5225000C:\Windows\system32\napinsp.dll
    0x000007fef51f0000 - 0x000007fef5209000C:\Windows\system32\pnrpnsp.dll
    0x000007fef51e0000 - 0x000007fef51f0000C:\Windows\system32\wshbth.dll
    0x0000000073680000 - 0x00000000736ae000C:\Program Files\Common Files\Microsoft Shared\Windows Live\WLIDNSP.DLL
    0x0000000073650000 - 0x0000000073676000C:\Program Files\Bonjour\mdnsNSP.dll
    0x000007fefb7f0000 - 0x000007fefb817000C:\Windows\system32\Iphlpapi.DLL
    0x000007fefb7a0000 - 0x000007fefb7ab000C:\Windows\system32\WINNSI.DLL
    0x000007fefcab0000 - 0x000007fefcab7000C:\Windows\System32\wshtcpip.dll
    0x000007fefa1f0000 - 0x000007fefa1f8000C:\Windows\system32\rasadhlp.dll
    0x000007fefb6c0000 - 0x000007fefb713000C:\Windows\System32\fwpuclnt.dll
    0x00000000701d0000 - 0x00000000701e1000C:\Program Files\Java\jre7\bin\nio.dll
    0x000007fefbf40000 - 0x000007fefbf49000C:\Users\Timo\AppData\Local\Temp\jansi-64-git-Bukkit-1.3.1-R1.0-b2320jnks.dll
    0x0000000072900000 - 0x00000000729a3000C:\Windows\WinSxS\amd64_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.6161_none_08e61857a83bc251\MSVCR90.dll
    0x00000000701a0000 - 0x00000000701c4000C:\Program Files\Java\jre7\bin\sunec.dll
    0x000000006fa40000 - 0x000000006fa4b000C:\Program Files\Java\jre7\bin\sunmscapi.dll
    0x000007fefda60000 - 0x000007fefdbc8000C:\Windows\system32\CRYPT32.dll
    0x000007fefd910000 - 0x000007fefd91f000C:\Windows\system32\MSASN1.dll
    0x000000006fa30000 - 0x000000006fa3b000C:\Program Files\Java\jre7\bin\management.dll
    0x0000000069340000 - 0x00000000693c5000C:\Users\Timo\AppData\Local\Temp\sqlite-3.7.2-sqlitejdbc.dll

    VM Arguments:
    jvm_args: -Xmx1024M -Xms1024M
    java_command: craftbukkit-1.3.1-R1.0.jar
    Launcher Type: SUN_STANDARD

    Environment Variables:
    PATH=C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Broadcom\Broadcom 802.11\Driver;C:\Program Files (x86)\ATI Technologies\ATI.ACE\Core-Static
    PROCESSOR_IDENTIFIER=Intel64 Family 6 Model 37 Stepping 2, GenuineIntel

    --------------- S Y S T E M ---------------

    OS: Windows 7 , 64 bit Build 7600

    CPU:total 4 (2 cores per cpu, 2 threads per core) family 6 model 37 stepping 2, cmov, cx8, fxsr, mmx, sse, sse2, sse3, ssse3, sse4.1, sse4.2, popcnt, ht

    Memory: 4k page, physical 3004272k(658180k free), swap 6006644k(2197472k free)

    vm_info: Java HotSpot(TM) 64-Bit Server VM (22.0-b10) for windows-amd64 JRE (1.7.0_02-b13), built on Nov 17 2011 13:51:15 by "java_re" with unknown MS VC++:1600

    time: Wed Aug 08 11:39:08 2012
    elapsed time: 62 seconds

    [Mod edit (chrizc): use spoiler tags, or an off-site pastebin for large amounts of code/errors]

    ????? wat nu!?
  15. Offline


    Disable your stupid Orebfuscator plugin.

    Tight git.

    You try coding a wrapper for a badly optimised game. I challenge you.
    and I WANt YoU tO uPDAtE it wHEn MineCRAft upDAteS aND YOU MusT dO It iN tWEnTy MinUTEs cos im a shouty twelve year old with bad parents who never taught me manners!!!!!!
    flyingtacoz and jakejigsaw like this.
  16. Offline


    I find most of this funny. Clearly the dev team is working hard on this, trying to make everyone happy...offering a FREE SERVICE and still people go mad about their poor little servers.

    Here's a the forums, wait until you see posts about how happy the testers are about the build, and THEN install it on your precious server.

    I have a modest lil server for just myself and my mates, and super excited for Bukkit 1.3.1, but you know what, I'm not going to rush in to the first build blindly. I think you guys are fools for updating your "important" 1.2.5 servers without reading this forum, and even bigger fools for blaming

    You types of people are the reason why meths was given a disgusting smell and purple colour, because you cannot think for yourself, nor research things before throwing it down your mouths.

    Good work, I'm sure you're working hard to produce a more stable version. Looking forward to it! :)
  17. Offline


    I've found a bug. If you enter Ender your level disappear :/

    EDIT: Level comes back if you gain any exp ball.
  18. Offline


    About every 50 seconds my CPU-load rises to about 60-70% for 3-5 seconds and then it goes back to normal level again (15-20%). I've tried without plugins but I still get the same behaivour... (However I've not tried vanilla 1.3.1 so I'm not 100% sure if these short load-peaks are related to bukkit). If I stop the server the CPU-load stays at 1-3% load all the time.

    Does anyone else experience this???

    Oh.. and thanks for your great work!!!!:):):)
  19. Offline


    You guys.......... You should read my Fix. I have had my 3 servers running on my Box for 8 hours now with no lag what so ever running bukkit 2322 - look at the top-ish of page 8
  20. Offline


    Not really, though I will check it out. My programming friend and I looked into this pretty extensively and he thinks he may have found the bit of code that is doing it which would mean it's something bukkit programmed. IF that's the case (and this is well outside my realm of understanding), then it would indeed be a Bukkit issue. If that's the case then I would be interested in knowing why such a decision was made, because it means any server which would like to use Zombe's in a "non-cheating" way, i.e. they don't care and do not recognize it as cheating (รก la the Yogscast I would wager, OMFGcata for sure, FyreUK, and my server to name a few), is now being forced to look into plugins (which were never necessary before) to allow such a simple feature as flight. Also, and I could be wrong on this (it's rather early where I am) but I think I remember it doing the same thing to creative flight as well after a while. All around flying seems a bit borked at the moment :)
  21. Offline


    Thanks Bukkit! After spending a day, it turned out that the plugin "Survival Games" was giving me 100%CPU. With it gone, the server is running smooth with no lag.
    On another server, oreobfuscation plugin caused the problem.

    Again, thanks Bukkit for the hard work :)
  22. Offline


    Not a Bukkit problem.
  23. Offline

    Cosmin Tanislav

    Realy nice work in a week from the relase Bukkit already done a recommended build!
  24. Offline


    When we updated to the newest Bukkit 1.3.1-R1. everything the users had made and collected during the day disappeared and seems to have been rollbacked. Why?
  25. Offline


    Hi all,
    I have a stupid question... i'm not even sure i posted this in the right place. I am currently running a server for MC 1.2.5 on CB 1.2.5-R5.0, my question is, will just moving my world folders over to new CB 1.3.4-R1.0
    server enable and allow MC 1.3 client users to benefit from all the new updates and features on my server?
  26. Offline


    I am also wondering what this is. Why is it a warning?
    Full trace when stopping a clean 1.3.1-R1.0 server
    16:12:48 [INFO] CONSOLE: Stopping the server..
    16:12:50 [INFO] Stopping server
    16:12:50 [INFO] Saving players
    16:12:50 [WARNING] DSCT: Socket closed
    16:12:50 [INFO] Saving worlds
    16:12:50 [INFO] Closing listening thread
    16:12:50 [INFO] Saving chunks for level 'world'/net.minecraft.server.WorldProviderNormal@1d8baaf
    16:12:52 [INFO] Saving chunks for level 'world_nether'/net.minecraft.server.WorldProviderHell@4814f9
    16:12:54 [INFO] Saving chunks for level 'world_the_end'/net.minecraft.server.WorldProviderTheEnd@700ff8
    16:12:54 [INFO] Stopping server
  27. Offline


    No. You can go find another mod if you want to be disrespectful and unappreciative of the ridiculous amount of work that goes into supporting this project. This is a hobby, for all of us. We do not have to sit here and take crap from people like you.

    I have barely slept since Minecraft 1.3.1 was released. But obviously that means absolutely nothing and the world revolves around you. Get the hell out of my community.
  28. Offline


    I get that too, does it happen without plugins on your server?

    If you find it's a bug with Bukkit itself, report it at (But make sure someone else hasn't already reported it first - no point making duplicates)

    If you do find it is a plugin, disable all your plugins and re-enable them one by one to find the source of the problem. is a similar issue.
  29. Offline


    Its a known issue. It happens without plugins. Amaranth will enjoy this post. :D
  30. Offline



    First make a full backup of everything.
    Second, replace the craftbukkit.jar with the new craftbukkit.jar

    start server.

    I only had issues with 3 of my plugins:


    There is a new Citizens release that fixed that one

    I havent looked to see if there is a newer NCP or Superjump yet though.

    I was very surprised that of the 32 addons im running, only 3 of them had problems and those 3 arent really game breakers.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 27, 2016
    ha11oga11o likes this.
  31. Offline


    Thanks for the quick reply,. doing this will add all the new features to my current world?
Thread Status:
Not open for further replies.

Share This Page