CraftBukkit 1.2.5-R2.0 is now available!

Discussion in 'Bukkit News' started by EvilSeph, May 17, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    Mr Burkes

    This new build has fixed old gameplay bugs and opened up server bugs such as sometimes, for no reason, a Block.Fluids exception or something similar is thrown. Instead of dealing with this every hour, I have decided to downgrade. If I try R2.0 again, I will definitely show the stacktrace so you all can tackle the issue. Other than that, good work!

    P.S. What's up with the new jline? It throws an exception at random intervals for my *nix server.
  2. I was getting this on my debian squeeze install as well, until I checked and found that I didn't have libjline-java installed. One apt-get later and no more error on logout.
  3. Offline


    Thanks for that info, same here!:rolleyes:[cake]

    Edit: In fact, it seemed to work, but finally it doesn't (errormsgs again) - also joining the server seem to be problematic after some time (endofstream all the time until serverrestart) - i have no clue whats going on and keep --nojline in place. [sheep]
  4. Offline



    nice Update, but there are some noteable "bugs"....

    You see the "thing" in front of the motd (mcDocs), this is with and without ColorCodes. (or it's NoCheat+ with the motd-blocking-codes...)

    Interesting Places causes the "A" symbols.

    not on the Pictures. I've got no colors in the console ;( (Ubuntu Linux, with RTK)

    BukkitSpeak. If anyone Joins or Chats in TeamSpeak3, ALL Users get a clientCrash.
    No Console Errors, just the user disconnects.

    I think there's something with the Unicode/Chat/Text changes....
    My files are always in UTF-8 without BOM.
  5. Offline


    I se you can do --nojline and -nojline
  6. Offline


    I actually signed up on the forum to comment on this build.

    This build lags out my server. I keep getting overloaded messages.
    I dont why.
    I reverted back to 1.3 becuse of it. Even with 30 people on the server i cant get 1.3 to even stutter but 2.0 lags with only 1 person (or noone) on.

    With the beta 1.3 I cant even get overloaded messages when im grinding the cpu out by rendering my dynmap on all cores full throttle.
    Its one of the best builds ive used.

    Something major had to have been changed between 1.3 and 2.0

    I use all these plugins.
    09:35:09 [INFO] Plugins (46): MagicCarpet, Minequery, WorldEdit, NoCheatPlus, PasswordSaveOnStop,
    VoxelSniper, CommandBook, Vault, Multiverse-Core, PermissionsEx, WorldGuard, dynmap, Dynmap-WorldG
    uard, Spectate, iConomy, etCommon, Points, HawkEye, CraftBookCommon, LimitedCreative, AdminPrivate
    Chat, mcbans, Lockette, Modifyworld, Votifier, Herochat, CraftBookCircuits, ChangeGameMode, Reside
    nce, WorldBorder, CraftBookMechanisms, ChatManager, WarpSigns2, Multiverse-Portals, Multiverse-Inv
    entories, Multiverse-SignPortals, VanishNoPacket, SignShop, DeathControl, RedstoneChips, Residence
    Signs, Dynmap-HeroChat, CraftBookVehicles, BasicCircuits, SensorLibrary, dynmap-residence

    Server stats
    java -server -Xmn3480M -Xms6256M -Xmx13480M -XX:+UseFastAccessorMethods -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:parallelGCThreads=7 -XX:+CMSParallelRemarkEnabled -XX:+DisableExplicitGC -XX:MaxGCPauseMillis=500 -XX:SurvivorRatio=16 -XX:TargetSurvivorRatio=90 -XX:UseSSE=3 -XX:+UseLargePages -Xnoclassgc -XX:+UseAdaptiveGCBoundary -XX:+AggressiveOpts -XX:MaxPermSize=128m -jar craftbukkit.jar

    I run Deb 6
    java version "1.7.0_03"
    Java(TM) SE Runtime Environment (build 1.7.0_03-b04)
    Java HotSpot(TM) 64-Bit Server VM (build 22.1-b02, mixed mode)

    Dedicated xeon server
    24gb ram

    Thanks though dev team but i'll have to pass for now :) I always appreciate progress :D
  7. Offline


    Ever think of trying (the bit below)...?
    java -Xms6256M -Xmx13480M -jar craftbukkit.jar
  8. Offline


    I'm sorry to say that this didn't make any difference to me. Still getting the same errors on my Ubuntu 10.04.4 LTS.
    I do believe this might be another bug which might not be related to craftbukkit at all. I've experienced that if you join and disconnect to a server fast you might get connectivity issues. Also if you go to the server list in the client when your server is starting there might also be issues. If you restart the client this issue will be resolved(At least for me). This leads me to believe that this is something different, but i haven't tried to google or search the forums about the matter.

    Then again this might not be exactly what you're experiencing now.

    I'm personally still going to use R2.0, but sadly with the -nojline parameter.
  9. Offline


    I use my windows computer to test my plugins, and I really don't see the point in getting Jline working, shouldn't it be opt-in, rather than opt-out, especially with all the problems people are having with it? anyway, good work on the cpu issue, now my computer doesn't melt when I try to use bukkit.
  10. Offline


    Try the latest dev build. Jline has been included in CraftBukkit for about a year now, we just ran into some problems with our implementation of the latest version of jline. The dev builds have that corrected now.
  11. Offline


    In the past standard garbage collection resulted in stutters and block lag as soon as medium sized groups of players began hammering away power mining with their efficiency 5 picks and shovels. Eventually I found that the garbage collection was bottlenecking me which forced me micromanaging it in that way. When I did the complaints, weeping and gnashing of teeth from players went away as well.
    For the hell of it I tried the normal command line out (since I have not tried it with the new version). With just me online it was ok till i got the efficiency pick out and it began slightly stuttering and giving me a few invisible blocks again. I also got spikes of cpu usage at 150. When our regulars got on I changed back to the old version so they could play without my fumbeling around.
    It's probably the plugins doing it. Since this version of bukkit is so new I'm guessing that the plugins are a little out dated and are not utilizing the performance enhancements of the new version.
    Performance on my server is a hard thing to troubleshoot since it's almost always busy and the severe stuttering in 2.0 occurs with only a few 10+ players on. I try not to be rude and torment them with my testing. I will give them a break for tonight and -verbosecg tommorow and investigate more however I honestly don't think thats the cause.
    I will say that 2.0 is still 1000% better then 1.0 was which had me ripping out hair. The thing that bothers me is that it does not lag in the slightest in beta 1.3 with many players on and I don't know what the big difference is.
  12. Offline


    how can i keep colors in console without a bunch of errors? thanks
  13. Offline


    is this even r2.0? when i run it it says r1.3
  14. Offline


    It's not critical, I can live with it, it's just annoying having the colour symbols appearing all over the output, but as I only use it for testing at the moment, I'll wait for a beta build.
  15. Offline


    Its 2.0, the version string was not incremented in the update.
  16. Offline


    Hey what happened to the plugin list on here?? I've checked twice today and there is no listing!! HELP!!
  17. Offline


    Everything was working perfectly then all of a sudden when I did /reload nothing is working, warps, plugins, and even permissions. What happened? This happened in 1.2.5 r1.3 but then I updated to this and it fixed itself but now It happened again is there going to be a new build soon?
  18. Offline


    As a Follow up to anyone else with the lag issue I updated to the dev build and updated PermissionsEX and my lag is gone.
  19. Offline


    lol, had to /say YOUR SIGNATURE IS AWESOME!!!!!!! <3 the song
  20. Offline


    Thanks very much! hey do you know why the plugin page of is working?? The query list isn't showing any plugins.
  21. Offline


    Why does it have and arrow pointing to the left then [m
    Wondering cause it's kind of annoying.
  22. Offline


    We haven't experienced any of the chat format errors, but (and I don't know how BukkitSpeak formats messages btw TS and MC) if any message any user types exceeds a certain length everyone in their vicinity crashes and no console message is kicked out. The update to this newer version is the ONLY thing which has changed recently, and we never experienced any such problems before.
  23. Offline


    Never a good idea to use /reload as it always causes some sort of issue with one plugin or another if not all. Always reload individual plugins (if they support it) or restart the server.
  24. Offline


    You need 1.2.5-based clients and any client mods could potentially undo the fix 1.2.5 has for this.
  25. Offline


    please help, i've downloaded it but everytime i try to load the server it says it is out of date and wont let me log onto it, havent been able to play in a long time
  26. Offline


    ya, use bukkit dev.
  27. Offline


    Why bukkit dev? And why isn't the form plugin page not working?
    fredghostkyle1 likes this.
  28. Offline


    The forum plugin search is currently broken is all, but since the site is where the staff focus their time for approvals, the will be a better search too to use.
  29. Offline


    Turns out SimpleTips likes to destroy every plugin it touches, fixed the config.yml and everything returned! :D
  30. Offline


    I don't know what happened with bukkit. This build, along with the previous beta build, has done something extremely funky with how it manages memory. My server used to be VERY stable, and although small (supporting up to 20 players), would hardly crash. Now, if I have more than 8 people on-line, I suddenly get oom errors. This is extremely frustrating for me. What has bukkit done that messes with memory so much now? All the down time is causing me to lose users quickly... :(
Thread Status:
Not open for further replies.

Share This Page