Could someone help a girl out? :)

Discussion in 'Bukkit Help' started by poutyyy, Aug 12, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    poutyyy

    I am in need of help with my essentials permissions. I'm not too sure if I'm doing it right. As of right now I am testing out my "sign sell"option to where I can set up a sign that you can sell items to. This is my permissions file and it doesn't seem to be working. If someone could help me I would really appreciate it :) Thanks!


    Code:
    users:
        poutyyy:
            permissions:
                permissions.example: true
            groups:
            - admin
    groups:
        default:
            permissions: [essentials.signs.use.sell]
                permissions.build: true
        admin:
            permissions:
                permissions.*: true
            inheritance:
            - user
        user:
            permissions:
                permissions.build: true
            worlds:
                creative:
                    coolplugin.item: true
            inheritance:
            - default
    messages:
        build: '&cYou do not have permission to build here.'
     
    debug: false
     
  2. Offline

    Hoolean

    Code:
    users:
        poutyyy:
            permissions:
                permissions.example: true
            groups:
            - admin
    groups:
        default:
            permissions:
                essentials.signs.use.sell
                permissions.build: true
        admin:
            permissions:
                permissions.*: true
            inheritance:
            - user
        user:
            permissions:
                permissions.build: true
            worlds:
                creative:
                    coolplugin.item: true
            inheritance:
            - default
    messages:
        build: '&cYou do not have permission to build here.'
     
    debug: false
    For default you had "essentials.signs.use.sell" in the wrong place. Hope I've helped :D

    Also make sure the sell sign is enabled in your essentials config! :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 27, 2016
  3. Offline

    poutyyy

    I tried that, I also tried to make it so default players can use /spawn. I'm assuming I use the permission essential.spawn? but it doesn't seem to work, none of the signs work for default users, as of right now i'm only using a few to test them out. I'm not too sure what I'm doing wrong. Please help :)


    Code:
    users:
        Sniped_501:
            permissions:
                permissions.example: true
            groups:
            - admin
        poutyyy:
            permissions:
                permissions.example: true
            groups:
            - default
        bobyhobo123:
            permissions:
                permissions.example: true
            groups:
            - default
    groups:
        default:
            permissions:
                essentials.spawn
                essentials.signs.create.trade
                essentials.signs.use.balance
                permissions.build: true
        admin:
            permissions:
                permissions.*: true
            inheritance:
            - user
        user:
            permissions:
                - 'essentials.spawn'
                permissions.build: true
            worlds:
                creative:
                    coolplugin.item: true
            inheritance:
            - default
    messages:
        build: '&cYou do not have permission to build here.'
     
    debug: false
     
  4. Offline

    Kaikz

    HAY GURRRRRL GAMURRRR
     
  5. Offline

    Omnitv

    Are you using permissionsEx, PermissionsBukkit, bPermissions, Essentials Groupmanager.
     
  6. Offline

    poutyyy

    I am having some major trouble with these permissions. What i'm trying to do is get the /spawn to work for default players. Also I want to get the signs to work from essentials for default players. I've been messing around with the "weather" sign just to test it out, I cant figure out why it wont work for default players. If anyone can help that would be amazing!! I am using permissionsbukkit 1.6

    Here is one example for what I tried.
    Code:
    users:
        Sniped_501:
            permissions:
                permissions.example: true
            groups:
            - admin
        poutyyy:
            permissions:
                essentials.signs.use.weather: true
                Essentials.spawn: true
            groups:
            - default
        bobyhobo123:
            permissions:
                permissions.example: true
            groups:
            - default
    groups:
        default:
            permissions:
                permissions.build: true
        admin:
            permissions:
                permissions.*: true
            inheritance:
            - user
        user:
            permissions:
                - 'essentials.spawn'
                permissions.build: true
            worlds:
                creative:
                    coolplugin.item: true
            inheritance:
            - default
    messages:
        build: '&cYou do not have permission to build here.'
     
    debug: false

    Here is my second example after I tried putting them under a group instead of my user and it still didn't work.
    Code:
    users:
        Sniped_501:
            permissions:
                permissions.example: true
            groups:
            - admin
        poutyyy:
            permissions:
                permissions.example: true
            groups:
            - default
        bobyhobo123:
            permissions:
                permissions.example: true
            groups:
            - default
    groups:
        default:
            permissions:
                essentials.spawn: true
                essentials.signs.use.weather: true
                permissions.build: true
        admin:
            permissions:
                permissions.*: true
            inheritance:
            - user
        user:
            permissions:
                - 'essentials.spawn'
                permissions.build: true
            worlds:
                creative:
                    coolplugin.item: true
            inheritance:
            - default
    messages:
        build: '&cYou do not have permission to build here.'
     
    debug: false
    I am using permissionsbukkit

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 27, 2016
  7. Offline

    Omnitv

    Try this:
    PHP:
    users:
        
    Sniped_501:
            
    permissions:
                
    permissions.exampletrue
            groups
    :
            - 
    admin
        poutyyy
    :
            
    permissions:
                
    permissions.exampletrue
            groups
    :
            - default
        
    bobyhobo123:
            
    permissions:
                
    permissions.exampletrue
            groups
    :
            - default
    groups:
        default:
            
    permissions:
                
    essentials.spawntrue
                essentials
    .signs.use.weathertrue
                permissions
    .buildtrue
        admin
    :
            
    permissions:
                
    permissions.*: true
            inheritance
    :
            - 
    user
        user
    :
            
    permissions:
                
    essentials.spawntrue
                permissions
    .buildtrue
            worlds
    :
                
    creative:
                    
    coolplugin.itemtrue
            inheritance
    :
            - default
    messages:
        
    build'&cYou do not have permission to build here.'
     
    debugfalse
     
  8. Offline

    poutyyy

    Thanks, the /spawn now works for default players but the sign doesn't for some reason. What did you do to make the /spawn to work, and how would I go about making the weather sign work? Thanks a lot!
     
  9. Offline

    Omnitv

    This was the issue:
    PHP:
        user:
            
    permissions:
                - 
    'essentials.spawn' // This does not work with the ''
                
    permissions.buildtrue
            worlds
    :
    This is the permission node for the weather sign
    essentials.signs.use.weather

    Found here http://wiki.ess3.net/doc/permissions

    Should work this time:
    Code:
    users:
        Sniped_501:
            permissions:
                permissions.example: true
            groups:
            - admin
        poutyyy:
            permissions:
                permissions.example: true
            groups:
            - default
        bobyhobo123:
            permissions:
                permissions.example: true
            groups:
            - default
    groups:
        default:
            permissions:
                essentials.spawn: true
                essentials.signs.use.weather: true
                permissions.build: true
        admin:
            permissions:
                permissions.*: true
            inheritance:
            - user
        user:
            permissions:
                essentials.spawn: true
                permissions.build: true
                essentials.signs.use.weather: true
            worlds:
                creative:
                    coolplugin.item: true
            inheritance:
            - default
    messages:
        build: '&cYou do not have permission to build here.'
     
    debug: false
     
  10. Offline

    Necrodoom

    enable it. paste essentials config.yml
     
  11. Offline

    poutyyy

    Okay, that seemed to work Omnity, I also seen you put the permissions under the group "user" do you have to put it under there in order to allow the default group to use it?
     
  12. Offline

    Omnitv

    Oh mah bad thought you meant users only. :p silly-eh mergh.
    Im sure you can do that yourself right?
    (omnity lol)
     
  13. Offline

    poutyyy

    Yeah, I figured it out - not too sure what I was doing in the beginning for it not to work but thanks I have it figured out now :). Do you know any good anit-greifing plugins that does not require Mysql?
     
  14. Offline

    KollegahDerBoss

    Use CoreProtect, it does not require MySQL or any hard configuration.
     
  15. Offline

    ShootToMaim

    No such thing as girls on the internet.
     
    Omnitv likes this.
Thread Status:
Not open for further replies.

Share This Page