"Could not load plugin, Unsupported Class Version" error

Discussion in 'Plugin Development' started by Mindlessmink, Jul 13, 2017.

Thread Status:
Not open for further replies.
  1. Offline

    Mindlessmink

    Okay, so I took a break from bukkit coding for about half a year and I come back rusty, so I colab with my friend to make a One in the chamber fork plugin. We finish a section of the plugin then test it on his test server. There was a couple errors here and there, so then the next day (today) I don't edit the code. I boot up my test server which keep in mind is on the exact same spigot jar as his and look at the errors. But however the plugin won't load on my server and I'm presented with this console error : https://pastebin.com/akm1WkKK

    Please forgive if this is a rookie mistake, but please cut me some slack as I haven't programmed for a while.

    Many thanks - Mink.
     
  2. Offline

    Machine Maker

    @Mindlessmink this probably means you are developing the plugin with a different java version than your server is running. I think the Version 52 means that you are using Java 8 when writing the plugin but are using a different jre for your server. This also answers the question of why it worked on your friends server but not yours.
     
  3. Offline

    Mindlessmink

    Ahhh, you're definetly right. I haven't updated my java :p Thanks.
     
  4. Offline

    Machine Maker

    @Mindlessmink Glad I could help. Please make sure to remember to mark this thread as solved.
     
Thread Status:
Not open for further replies.

Share This Page