Inactive [CHAT/MECH] DimensionDoor v2.1.1 Multiworld management made easy [1.3.1-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by grandwazir, Jun 28, 2011.

  1. Offline


    Bukkit still calls it "Skylands" ?

    But it doesn't work when we type "/dd create another_world skylands" and it says "Only Normal, Nether, Skylands". =p

    Then I tried "/dd create another_world the_end" and it worked.
  2. Offline


    Bukkit creates 4 world files now for me. Default ones I got were: World, Wolrd_Nether, World_Skylands, and World_end.

    Not sure why it creates Skylands in default tho. (I mean when I create a bukkit server without plugins)
  3. Offline

    Olof Larsson

  4. Offline


    I think it's automatically set to do that. I believe it's in the config tho
  5. Offline


    Ya i know, Now
    Thanks anyway
  6. Offline


    does this plugin still work with the new rec build?
  7. Offline


    Appears to work fine yes.
  8. Offline


    it's a shame bukkit doesn't provide skylands anymore...
    are old skyland maps still working with the newer releases?
  9. Offline


    deleteActionBarOnReturn: true
    deleteItemInHandOnReturn: true

    Is it possible if you add ''deleteInventoryOnReturn''? So that it wouldn't work for JUSt creative worlds?
  10. Offline


    Have a look at the plugin MultiInv if you want to do that sort of thing. It is a fully featured multiworld inventory manager.

    Also there will be a new version released in a couple of days, complete with some minor bug fixes.
  11. Offline


    Ok, thanks.
  12. can't wait for the 1.0 version, people are whining for the world...

    thanks and take your time though :D
  13. Offline


    No need to wait any longer, the new version is released and available from the main post or from dev.bukkit when it gets approved. Thanks for your support :D
    Bulluk likes this.
  14. hurray thanks alot :D
  15. Offline


    This plugin deleted half of my world! And I didn't even do ANYTHING that affected the world!
  16. Offline


    The only possible way this plugin could delete a world is if you specified a different environment to that of the world you are importing with /dd create. It does state very specifically in the documentation to be careful when you are doing this. There is no other way to lose data.

    If you would like some further support you will need to provide some logs for me to look at.
  17. Offline


    Looking to get my Minecraft server up to date and easier to manage. I'm liking the look of this plugin, but craftbukkituptodate.jar requires plugins to be on the site to auto-update them. Do you have plans to move there?
  18. Offline


  19. Offline


    a big bug! stack items in creative mode, throw it, and then place the whole action bar with other items. drop the old items and now it is in your inventory... armor can take to other world to....
  20. Offline


    I get this error when I launch a server with and without any plugins besides DimensionDoor:

    174 recipes
    27 achievements
    18:54:00 [INFO] Starting minecraft server version 1.0.1
    18:54:00 [INFO] Loading properties
    18:54:00 [INFO] Starting Minecraft server on *:25565
    18:54:00 [INFO] This server is running Craftbukkit version git-Bukkit-1.0.1-R1-b
    1597jnks (MC: 1.0.1) (Implementing API version 1.0.1-R1)
    18:54:00 [ALLVARLIG] not found
    18:54:00 [ALLVARLIG] Could not load 'plugins\DimensionDoor.jar' in folder 'plugi
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at org.bukkit.craftbukkit.CraftServer.<init>(
    at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigur
    at net.minecraft.server.MinecraftServer.init(
    Caused by: java.lang.RuntimeException: java.lang.IllegalArgumentException: Error
    constructing com.avaje.ebeaninternal.server.core.DefaultServerFactory
    at com.avaje.ebean.EbeanServerFactory.createServerFactory(EbeanServerFac
    at com.avaje.ebean.EbeanServerFactory.<clinit>(
    ... 10 more
    Caused by: java.lang.IllegalArgumentException: Error constructing com.avaje.ebea
    at com.avaje.ebeaninternal.api.ClassUtil.newInstance(

    at com.avaje.ebeaninternal.api.ClassUtil.newInstance(
    at com.avaje.ebean.EbeanServerFactory.createServerFactory(EbeanServerFac
    ... 11 more
    Caused by: java.lang.RuntimeException: C:\Users\S
    pelkonto\Desktop\Skit\Servrar\Mest använda servrar\Byggserver\craftbukkit-1.0.1
    -R1.jar (Det gÕr inte att hitta s÷kvõgen)
    at com.avaje.ebeaninternal.server.core.XmlConfigLoader.load(XmlConfigLoa
    at com.avaje.ebeaninternal.server.core.DefaultServerFactory.<init>(Defau
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

    at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)

    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Sou
    at java.lang.reflect.Constructor.newInstance(Unknown Source)
    at java.lang.Class.newInstance0(Unknown Source)
    at java.lang.Class.newInstance(Unknown Source)
    at com.avaje.ebeaninternal.api.ClassUtil.newInstance(

    ... 13 more
    Caused by: C:\Users\Spelkonto\Desktop\Skit\Servra
    r\Mest anv├ñnda servrar\Byggserver\craftbukkit-1.0.1-R1.jar (Det gÕr inte att hi
    tta s÷kvõgen)
    at Method)
    at<init>(Unknown Source)
    at java.util.jar.JarFile.<init>(Unknown Source)
    at java.util.jar.JarFile.<init>(Unknown Source)
    at com.avaje.ebeaninternal.server.core.XmlConfigLoader.checkJar(XmlConfi
    ... 22 more
  21. Offline


    oh btw u can take items out of creative by using a brewing stand

    derp new version wasnt downloaded XD
  22. Offline


    My server crashed when I tried to make a Skylands world...

    Show Spoiler
    2011-12-25 11:06:17 [INFO] [DimensionDoor] yocow has created a new world called Heaven
    2011-12-25 11:06:17 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    2011-12-25 11:06:39 [INFO] Connection reset
    2011-12-25 11:06:39 [SEVERE] Broken pipe
    2011-12-25 11:06:39 [SEVERE] at Method)
    2011-12-25 11:06:39 [SEVERE] at
    2011-12-25 11:06:39 [SEVERE] at
    2011-12-25 11:06:39 [SEVERE] at
    2011-12-25 11:06:39 [SEVERE] at
    2011-12-25 11:06:39 [SEVERE] at
    2011-12-25 11:06:39 [SEVERE] at net.minecraft.server.Packet51MapChunk.a(
    2011-12-25 11:06:39 [SEVERE] at net.minecraft.server.Packet.a(
    2011-12-25 11:06:39 [SEVERE] at net.minecraft.server.NetworkManager.g(
    2011-12-25 11:06:39 [SEVERE] at net.minecraft.server.NetworkManager.d(
    2011-12-25 11:06:39 [SEVERE] at

    EDIT: It didn't crash the server, but when I got back on and tried to teleport to the world it was a normal world.
  23. Offline


    Can somebody please help me?

    2011-12-28 22:19:07 [INFO] DataSourcePool [DimensionDoor] autoCommit[false] transIsolation[SERIALIZABLE] min[2] max[20]
    2011-12-28 22:19:07 [SEVERE] FATAL: DataSourcePool [DimensionDoor] is down!!!
    2011-12-28 22:19:07 [INFO] Reseting DataSourcePool [DimensionDoor] min:2 max:20 free:0 busy:0 waiting:0 highWaterMark:0 waitCount:0 hitCount:0
    2011-12-28 22:19:07 [INFO] Busy Connections:
    2011-12-28 22:19:07 [SEVERE] Could not load 'plugins/DimensionDoor.jar' in folder 'plugins':
    com.avaje.ebeaninternal.server.lib.sql.DataSourceException: java.sql.SQLException: Access denied for user 'ni33523_1_DB'@'localhost' (using password: YES)
        at com.avaje.ebeaninternal.server.lib.sql.DataSourcePool.<init>(
        at com.avaje.ebeaninternal.server.lib.sql.DataSourceManager.getDataSource(
        at com.avaje.ebeaninternal.server.lib.sql.DataSourceGlobalManager.getDataSource(
        at com.avaje.ebeaninternal.server.core.DefaultServerFactory.getDataSourceFromConfig(
        at com.avaje.ebeaninternal.server.core.DefaultServerFactory.setDataSource(
        at com.avaje.ebeaninternal.server.core.DefaultServerFactory.createServer(
        at com.avaje.ebeaninternal.server.core.DefaultServerFactory.createServer(
        at com.avaje.ebean.EbeanServerFactory.create(
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(
        at org.bukkit.craftbukkit.CraftServer.reload(
        at org.bukkit.Bukkit.reload(
        at org.bukkit.command.defaults.ReloadCommand.execute(
        at org.bukkit.command.SimpleCommandMap.dispatch(
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
        at net.minecraft.server.NetServerHandler.handleCommand(
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.Packet3Chat.a(
        at net.minecraft.server.NetworkManager.b(
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
        at net.minecraft.server.MinecraftServer.w(
    Caused by: java.sql.SQLException: Access denied for user 'ni33523_1_DB'@'localhost' (using password: YES)
        at com.mysql.jdbc.SQLError.createSQLException(
        at com.mysql.jdbc.MysqlIO.checkErrorPacket(
        at com.mysql.jdbc.MysqlIO.checkErrorPacket(
        at com.mysql.jdbc.MysqlIO.checkErrorPacket(
        at com.mysql.jdbc.MysqlIO.secureAuth411(
        at com.mysql.jdbc.MysqlIO.doHandshake(
        at com.mysql.jdbc.ConnectionImpl.coreConnect(
        at com.mysql.jdbc.ConnectionImpl.connectOneTryOnly(
        at com.mysql.jdbc.ConnectionImpl.createNewIO(
        at com.mysql.jdbc.ConnectionImpl.<init>(
        at com.mysql.jdbc.JDBC4Connection.<init>(
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
        at java.lang.reflect.Constructor.newInstance(
        at com.mysql.jdbc.Util.handleNewInstance(
        at com.mysql.jdbc.ConnectionImpl.getInstance(
        at com.mysql.jdbc.NonRegisteringDriver.connect(
        at java.sql.DriverManager.getConnection(
        at java.sql.DriverManager.getConnection(
        at com.avaje.ebeaninternal.server.lib.sql.DataSourcePool.createUnpooledConnection(
        at com.avaje.ebeaninternal.server.lib.sql.DataSourcePool.createConnectionForQueue(
        at com.avaje.ebeaninternal.server.lib.sql.PooledConnectionQueue.ensureMinimumConnections(
        at com.avaje.ebeaninternal.server.lib.sql.DataSourcePool.initialise(
        at com.avaje.ebeaninternal.server.lib.sql.DataSourcePool.<init>(
        ... 27 more
  24. Offline


    Your username or password is wrong in your bukkit.yml. You will need to amend it to be able to continue.
    Gazghol likes this.
  25. Offline


    um....people can take blocks back to the normal worlds cause if you drop block stacks they go into your inventory not your hotbar....
  26. Offline


    Major problem... I've deleted a world called "mine" with the ./dd remove mine command and also removed the files for the directory. But when I try to make a new world with the name "mine" it creates the world spawn in my "games" world... It's weird...I have the server IP if you want to join and check out this bug.

    EDIT: Ah..but creating a world under a NEW name, "mines" fixes the problem...I'd really like to use the name "mine" though...:/
  27. Offline


    I have a problem. I got the plugin, and now my server won't even start. Sure, it says it runs, but it doesn't. No one can get on the server, not even me. I have to restart my computer and delete the plugin for my server to work, but others are still in other dimensions. Help?
  28. Offline


    Request : I'd like to be able to modify the Generator of a World . . .

    Something like : /dd modify world generator CleanroomGenerator:.

    Then it would stop the chunk generation of that world.
    Like playing with the Classic version of Minecraft.

    I've tried by adding the info in the DimensionDoor.db file, but oddly, it was useless... ^^;

    Then I've added this in the bukkit.yml file, and it worked (obviously) :
        generator: CleanroomGenerator:.
    So, while waiting for DimensionDoor to maybe be able to do that, I'm modifying the bukkit.yml instead... =p

    I'm also wondering If a can make a normal world... then modify it to a nether world... so it would be a normal world with a red sky...
  29. i have 2 proplems:
    dimension door allows players to teleport into: Semicraft_nether and Semicraft_the_end <-- when i teleport to these , they bug and kill the player :D Can i somehow "block" players for not using them? I have nether and end made via portals already (natural)


    used /dd remove semicraft_the_end but it didnt do anything useful, keeps re-creating it when server restarts.
    Id want per world permission if possible?
    u know, have to add line to perms for normal users: dimensiondoor.teleport.*worldname*
    for example:

    if i have 4 worlds, i want players to be able teleport only into 1 world.

    i want players to be able teleport only into Zombieland, i use permission node: dimensiondoor.teleport.Zombieland

    the players can use command /dd teleport Semicraft / Semicraft_the_end / Semicraft_nether
    only be able to use /dd teleport Zombieland

    can this be done? or how else i can block the players to use /dd teleport Semicraft / Semicraft_the_end / Semicraft_nether
  30. Offline


    I'm using this plugin currently and I can't find out how to get the inventories not transfered between the worlds. Can you tell me what to edit? Thanks.

Share This Page