Inactive [CHAT/MECH] DimensionDoor v2.1.1 Multiworld management made easy [1.3.1-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by grandwazir, Jun 28, 2011.

  1. Offline


    it is a world i have been using for a long time then i restart the server and couldnt load it
  2. Offline


    I recently had to revert to a vanilla bukkit server, and have been slowly adding mods back, but no one is actually able to use any commands from your mod. I gave the admin group the permission dimensiondoor.* true, and when we type /dd it gives us the help info but also says that it was an invalid command. When we try to do /dd list it tells us we don't have permission.

    We found out the issue. We are using the bukkit permissions, and are having to add each node separately instead of all in one. Could you add a dimensiondoor.* node for easier use?
  3. Offline



    When I try to change DD settings in game for spawnAnimals true its still not spawning them correctly. I am using sql lite. Can I just manually change it in the database file? Is it suspose to be a 1 or a 0, mobs are set to 0. Thanks.
  4. Offline


    Give it a try and see what happens. 1 is true and 0 is false. Let me know how it goes as I do not test extensively with SQLite.

    Both are possible with the new version I have released tonight. Check out the instructions for details on how to create flat worlds.

    Sorry about that, previously the database upgrade path was broken. Upgrade to the latest version (1.6) and it will update your database automatically. That said if you were to ever lose your database you would not lose spawn locations, as that is stored by the actual world not DimensionDoor.

    As I was fixing the CamelCase issue I added this. You can now use dimensiondoor.* with built in permissions to grant access to all commands.

    Did you not say earlier that it worked properly with only DimensionDoor loaded? Unload all your plugins and load just the new version of DimensionDoor and see if that fixes the issue.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  5. Offline


    hey im trying to import two of my pervious worlds (i used to use Multiworld) but everytime i do: /dd create [world name] Normal
    it always says 'Not enough arguments!'
    (yes worlds are both Normal)
    i can create a NEW world if i use a seed... but with no seed it wont work... please help
    (i have newest version of this plugin, and i have CB1000)
  6. Offline


    I've tested this :

    dd create ocean normal g:CleanroomGenerator:9,stone,3,dirt,7,sand,9,water

    ... And it doesn't work. =(

    Regardless of the parameters, it's always generating a map with layer0 as bedrock, followed by 64 stone.
  7. Offline


    Hello, I have a small irritating problem.
    When i try to /dd create Heaven Skylands
    It sends me back the help section
    /dd create teleport reload etc, etc.
  8. Offline


    Whoops! I'll make the change and release a new version tonight - sorry about that.
    Let me see if I can duplicate that locally.

    @Deathlysteve-, @remi112 @Gimlao All issues are fixed in the new version. You can download it now from the main post.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  9. Offline


    Many thanks ! =)
  10. Offline


    Heey, this plugin is amazing, you have done such a great Job with it :p
    Just one thing, for some reason, this plugin stops the spawning of animals, any way to fix that? Thanks ;)
  11. Offline


    Thanks! It should only stop the spawning of animals when you ask it to. What are your world settings?
  12. Offline


    When I type '/dd info ethan' it says:
    environment: NORMAL
    spawnAnimals: true

    And in the file the settings are:
    #Minecraft server properties
    #Mon Jul 04 18:08:41 EST 2011
  13. Offline


    A world management that disabled a world if no players are on that world would be cool
  14. Offline


    @grandwazir dude is there a way so I let people bring stuff from and to the Nether but from world mine 1 to world mine 2?
  15. Offline


    Use MultiInv to do that.

    It is something I have thought about doing - I'll ad it to the list for the next version.

    @zerabug Are you using the latest version of DD? There was a bug in one version which had the problem you are describing.
  16. Offline


    Sorry to be a bother but Do i need permissions to make this plugin work because im op and i dont have permissions on my server.
  17. Offline


    Have a look under the documention section in the main post for configuring permissions. Copy the 3rd bit (the one called give server operators all commands by default) into your permissions.yml and it should work.
  18. Offline


    Thanks so much
  19. Offline


    What the heck?
    I opened up the DimensionDoor file with notepad and this popped up:
    SQLite format 3   @                                                                     -â
    ü ß ßÉ                                                                                                                                                                                                                                                                                                                                                                               ƒg‡tabledd_worldsdd_worldsCREATE TABLE dd_worlds ( name                      varchar(255) primary key, environment               integer not null, generator_id              varchar(255), generator_plugin          varchar(255), isolated_chat             integer(1) not null, pvp                       integer(1) not null, spawn_animals             integer(1) not null, spawn_monsters            integer(1) not null, constraint ck_dd_worlds_environment check (environment in (0,1,2)))1E indexsqlite_autoindex_dd_worlds_1dd_worlds   
       ¶ èɶ                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                              pvp      +  creative_nether       creative  
       × óß×                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                         pvp+creative_nethercreative
    Can Anyone tell me how to fix / change it so it works?
    If it is right, when I play minecraft, it says "An internal error occurred while attempting to perform this command"
  20. Offline


    @zecheesy You are not meant to edit the file directly. Configure your worlds using the in game commands instead. You will need to delete that file if you have tried to change it in notepad. DimensionDoor will make a new one.
  21. Offline


    I can't do a single command.. It just says "An internal error occurred while attempting to perform this command"
  22. Offline


    You will get that error if you edited the database manually. Have you deleted it and let DD recreate it? Also if you post the relevant errors from your server.log I can help you better.
  23. Offline


    Yes i deleted it.... still..... I dont see anything wrong in my server.log..
    Does any plgin interfere with this?
  24. Offline


    Ive found a bug.
    Whenever i try to remove a world it tells me i cant and i need to set permissions to 755.
    Please help.
  25. Offline


    dunno where my problem is D: on localhost it worked, but on my root server it didn't D:
  26. Offline


    I'm getting the exact same error on mysql. Other plugins are connecting to the DB okay and have created tables etc.
  27. Offline


    This issue is fixed in the latest version of DimensionDoor (1.6.3) - sorry for the inconvenience.

    This is not a bug in DimensionDoor as it does not touch your world data at all. If you need to change permissions to files on Linux check this article for more details.

    I'll need your server log with the errors in it to help you further. However try downloading 1.6.3 first. If it fails to create the database you will get that error.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  28. Offline


    @grandwazir thank you that fixed the mysql table problem.

    Have a cookie :D

    However, there seems to be an issue between DD and bananaMaze. I cant work out exactly what's going on, but after two or three visits to bananaMaze, DD starts teleporting me to what seems to be my skylands world - I cant tell as I appear in the void and plummet to my death, but I am re-spawned in Skylands.

    There's no errors, no useful feedback at all. :S All I get is the view falling away from a partially formed world and death. Only happening with bananaMaze, which is semi self managed, so it might be something between your two plugins?
  29. Offline


    That is weird. The only thing I can think off is that the spawn location is outside the terrain that bananaMaze generates and you fall into the void. I doubt it is that though. All your worlds have unique names yeah? It should be impossible for DD to teleport you to the wrong world.
  30. Offline


    I thought it might be an issue with terrain not yet generated, but bananaMaze has no holes, it's a solid block of bedrock with a solid block of stone above it, and this world has had the area around spawn already pre-generated. When I look up as I fall, I see the bottom of islands, so I'm assuming it's skylands. My world names are unique; 'dungeon', 'survivor', 'skylands' and 'foyer'.

    All I can think is that there's some world handling code in bananaMaze that's conflicting. BananaMaze is weird in that it generates itself automatically, without being entered into the bukkit.yml. So I guess it's not just a world-gen, but also a handler of some sort.

Share This Page