Problem/Bug Chat Control causing Internal Server Error while not being on the Server

Discussion in 'General Help' started by viddie, Mar 18, 2015.

Thread Status:
Not open for further replies.
  1. Offline


    Hey community,
    I am currently having a few problems with the plugin chat control:
    - I was trying to install the plugin EchoPet
    - while performing the command /pet cow(or any other pet's name) I get kicked for "Internal Server Error", Server Console saying:
    [16:24:59 WARN]: Failed to handle packet for /
            at kangarko.chatcontrol.utils.Common.stripColors( ~[?:?]
            at kangarko.chatcontrol.filter.Log4jFilter.checkMessage( ~[?:?]
            at kangarko.chatcontrol.filter.Log4jFilter.filter( ~[?:?]
            at org.apache.logging.log4j.core.filter.CompositeFilter.filter( ~[spigot.jar:git-Spigot-1571]
            at org.apache.logging.log4j.core.filter.CompositeFilter.filter( ~[spigot.jar:git-Spigot-1571]
            at org.apache.logging.log4j.core.filter.AbstractFilterable.isFiltered( ~[spigot.jar:git-Spigot-1571]
            at org.apache.logging.log4j.core.config.LoggerConfig.log( ~[spigot.jar:git-Spigot-1571]
            at org.apache.logging.log4j.core.config.LoggerConfig.log( [spigot.jar:git-Spigot-1571]
            at org.apache.logging.log4j.core.Logger.log( [spigot.jar:git-Spigot-1571]
            at org.apache.logging.log4j.spi.AbstractLogger.error( [spigot.jar:git-Spigot-1571]
            at org.bukkit.craftbukkit.v1_7_R4.util.ForwardLogHandler.publish( ~[spigot.jar:git-Spigot-1571]
            at java.util.logging.Logger.log( ~[?:1.7.0_65]
            at java.util.logging.Logger.doLog( ~[?:1.7.0_65]
            at java.util.logging.Logger.log( ~[?:1.7.0_65]
            at net.minecraft.server.v1_7_R4.PlayerConnection.handleCommand( ~[spigot.jar:git-Spigot-1571]
            at net.minecraft.server.v1_7_R4.PlayerConnection.a( ~[spigot.jar:git-Spigot-1571]
            at net.minecraft.server.v1_7_R4.PacketPlayInChat.a( ~[spigot.jar:git-Spigot-1571]
            at net.minecraft.server.v1_7_R4.PacketPlayInChat.handle( ~[spigot.jar:git-Spigot-1571]
            at net.minecraft.server.v1_7_R4.NetworkManager.a( ~[spigot.jar:git-Spigot-1571]
            at net.minecraft.server.v1_7_R4.ServerConnection.c( [spigot.jar:git-Spigot-1571]
            at net.minecraft.server.v1_7_R4.MinecraftServer.v( [spigot.jar:git-Spigot-1571]
            at net.minecraft.server.v1_7_R4.DedicatedServer.v( [spigot.jar:git-Spigot-1571]
            at net.minecraft.server.v1_7_R4.MinecraftServer.u( [spigot.jar:git-Spigot-1571]
            at [spigot.jar:git-Spigot-1571]
            at [spigot.jar:git-Spigot-1571]
    After deleting chat control and all components i am still getting the exact same error.
    Anybody can help me out?
  2. Offline


    @viddie Please post the latest.log in a pastebin. Did you reload/restart your server after removing that plugin?
  3. if(ServerJar == Spigot){ ServerJar.setAlternate(true); Thread.move(this); }
  4. Offline


    Yes i restarted a few times after removig it, still didn't work. Now, one day later, i tried to reproduce the error for you, and my minecraft and the server crashed on doing "/pet cow". Here is the pastebin for the new error:
    Because i couldn't reproduce the last error i dont have any logs from it, plus it is not in the latest log.
  5. Offline


    @viddie, EchoPet has always been a liability. The error you have there is the plugin's fault. Not much we can do for you with that.
Thread Status:
Not open for further replies.

Share This Page