Solved Can't transfer my world

Discussion in 'Bukkit Help' started by megaloadon, Dec 29, 2021.

Thread Status:
Not open for further replies.
  1. Offline


    Hi !
    I have a problem:
    I recently tried to install plugins for my server with my friends, and I can't seem to use my vanilla world.
    I am aware that the nether and end are not stored the same way but I managed to do the copy/paste to the right folder stuff (as seen here : ).

    Anyway, I am ending in a really bizarre situation:
    All the items that has been placed are placed ( like paintings or item frames ), all our animals are here, the seed is the right one, everyone has it's stuff and all, but the world is completely reseted, no more constructions, no more mines, everything's gone. I tried to look up the web but haven't found anything.
    My thought is that the world is loaded and THEN the world is generated (in the console bukkit says the world is generating).

    I am playing on minecraft 1.18.1 and the server use craftbukkit 1.18.1.
    Could anyone help me to migrate my world properly ? How can I prevent bukkit from generating/overwriting world ? Is there some steps that I've missed while migrating the world ?

    I tried switching to spigot 1.18.1 and now it is even weirder, there are some places that works (our constructions are here) and some places that don't (completely reseted) and the weirder thing is that the "light-map" seems cutted (we can clearly see the line separating the loaded chunks and the others, the builds on certain chunks are gone (not only one by one, seems to have a clear cut on the whole world) but the torches that were there seems to continue lighting up the chunks next to it).
    Screenshot so it is more understandable:
    (there should be a castle, it isn't there but as you can see the not-existing-anymore torches continue to light the area)
    Apparently every chunk from 0 and above don't load, and chunks with negative positions are loaded correctly ( on the screenshot, the path is on -1 , -4 and the unloaded region is on 0, -4)

    EDIT 2:
    Apparently, deleting and retrying to set-up a server again and again finally made a way through this issue, now it's fixed, but I still don't know why or how this happened ..
    Last edited: Dec 29, 2021
Thread Status:
Not open for further replies.

Share This Page