Problem/Bug Can't see my own Admin Command errors

Discussion in 'Bukkit Help' started by Mr Pie 5, Nov 2, 2015.

Thread Status:
Not open for further replies.
  1. Offline

    Mr Pie 5

    Back when my server was pure Vanilla (a few days ago), when I ran an admin command (give, entitydata, etc.), if I put something in wrong, it would give me a red error message pointing me towards the issue.
    Now I run a Bukkit server with a couple plugins and when I put in an invalid admin command, it will give me nothing. No output whatsoever. Other OPs on the server can see my errors, but I can't - which is the exact opposite of how it used to be. If I have logAdminCommands enabled, it will print the error to the console, but I still can't see it in my chat.

    It's inconvenient in that I have to take longer finding the error in my command, but it also means that I can't use /entitydata or /blockdata without making a change, which would previously allow me to view all the tags for that entity or block.

    Does anybody have any idea how I can see my own errors and hide them from other OPs?

    I am using the Bukkit 1.8.8 jar
    I have the following plugins:
    EasyRules (the issue was happening prior to installing this one though)

    Edit: I can no longer ctrl+middle click to copy blocks with their NBT data either.
    Last edited: Nov 3, 2015
  2. Offline


    @Mr Pie 5 I have this error where it doesn't send me the error message when running "vanilla" commands. Not sure if there is a configurable option to fix that problem. To disable other ops from seeing these types of messages, I believe disabling the 'broadcast-console-to-ops' in the file will fit the bill.
  3. Offline

    Mr Pie 5

    I want ops to continue to be able to see the commands of other ops, but only the commands that actually ran.
  4. Offline

    Mr Pie 5

    Update: it also seems that I can no longer ctrl+middle click to copy blocks with their NBT data intact. They still say (+NBT) in my inventory, but they don't have it once placed.
  5. Offline

    Mr Pie 5

  6. Offline


    I'm also having this issue, others see the messages but I can't, and it's really concerning.
Thread Status:
Not open for further replies.

Share This Page