Can't get FastAsyncVoxelSniper to work on my server

Discussion in 'Bukkit Help' started by NateMotta, Nov 7, 2022.

  1. Offline

    NateMotta

    [16:34:41] [Server thread/ERROR]: Error occurred while enabling FastAsyncVoxelSniper v2.8.0 (Is it up to date?)
    104 java.lang.NoSuchMethodError: 'java.lang.String com.sk89q.worldedit.world.block.BlockType.getResource()'
    105 at com.thevoxelbox.voxelsniper.config.VoxelSniperConfigLoader.<clinit>(VoxelSniperConfigLoader.java:53) ~[fastasyncvoxelsniper-2.8.0.jar:?]
    106 at com.thevoxelbox.voxelsniper.VoxelSniperPlugin.loadConfig(VoxelSniperPlugin.java:117) ~[fastasyncvoxelsniper-2.8.0.jar:?]
    107 at com.thevoxelbox.voxelsniper.VoxelSniperPlugin.onEnable(VoxelSniperPlugin.java:71) ~[fastasyncvoxelsniper-2.8.0.jar:?]
    108 at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:264) ~[paper-api-1.19-R0.1-SNAPSHOT.jar:?]
    109 at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:370) ~[paper-api-1.19-R0.1-SNAPSHOT.jar:?]
    110 at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:542) ~[paper-api-1.19-R0.1-SNAPSHOT.jar:?]
    111 at org.bukkit.craftbukkit.v1_19_R1.CraftServer.enablePlugin(CraftServer.java:563) ~[paper-1.19.jar:git-Paper-81]
    112 at org.bukkit.craftbukkit.v1_19_R1.CraftServer.enablePlugins(CraftServer.java:477) ~[paper-1.19.jar:git-Paper-81]
    113 at net.minecraft.server.MinecraftServer.loadWorld0(MinecraftServer.java:634) ~[paper-1.19.jar:git-Paper-81]
    114 at net.minecraft.server.MinecraftServer.loadLevel(MinecraftServer.java:420) ~[paper-1.19.jar:git-Paper-81]
    115 at net.minecraft.server.dedicated.DedicatedServer.initServer(DedicatedServer.java:306) ~[paper-1.19.jar:git-Paper-81]
    116 at net.minecraft.server.MinecraftServer.runServer(MinecraftServer.java:1122) ~[paper-1.19.jar:git-Paper-81]
    117 at net.minecraft.server.MinecraftServer.lambda$spin$0(MinecraftServer.java:303) ~[paper-1.19.jar:git-Paper-81]
    118 at java.lang.Thread.run(Thread.java:833) ~[?:?]

    I just don't know the problem, I'm not good at programming.
     
  2. Online

    timtower Administrator Administrator Moderator

    Voxelsniper is the wrong version for that worldedit version
     

Share This Page