Solved Cannot open port 25565

Discussion in 'Bukkit Help' started by Quavelen, Mar 15, 2013.

Thread Status:
Not open for further replies.
  1. Offline


    Okay. I am having an issue with connecting to my own server.

    I have no error reports.
    My server starts up nice, and fast.

    I am not using any Mods, or plugins of any kind.

    I am running Windows 7 Ultimate 64Bit.

    I have a Dell Dimension E510 Desktop Computer with a Pentium 4 Procressor @3.6GHz.
    My graphics card is an OverClocked NvidiaGeforce 9600GT.

    I have 4GB of RAM.

    My Minecraft is version 1.4.7

    My Java is Version 7 Update 17.

    Every time I start it up, and open my Minecraft Client, I see this:

    I have Port Forwarded my router with port 25565 on both UDP, and TCP.
    I have also restarted my router, and my computer after I added these settings to my router.




    My server boots up just fine, and I have no error messages:

    210 recipes
    27 achievements
    13:49:00 [INFO] Starting minecraft server version 1.4.7
    13:49:00 [INFO] Loading properties
    13:49:00 [INFO] Default game type: SURVIVAL
    13:49:00 [INFO] Generating keypair
    13:49:01 [INFO] Starting Minecraft server on
    13:49:01 [INFO] This server is running CraftBukkit version git-Bukkit-1.4.7-R1.0
    -b2624jnks (MC: 1.4.7) (Implementing API version 1.4.7-R1.0)
    13:49:02 [INFO] Preparing level "world"
    13:49:02 [INFO] Preparing start region for level 0 (Seed: -6847349592826619902)
    13:49:03 [INFO] Preparing spawn area: 24%
    13:49:04 [INFO] Preparing start region for level 1 (Seed: -6847349592826619902)
    13:49:04 [INFO] Preparing spawn area: 0%
    13:49:05 [INFO] Preparing spawn area: 93%
    13:49:05 [INFO] Preparing start region for level 2 (Seed: -6847349592826619902)
    13:49:06 [INFO] Server permissions file permissions.yml is empty, ignoring it
    13:49:06 [INFO] Done (4.686s)! For help, type "help" or "?"

    I have tried both the Bukkit Server, and the Server files. Both give me the same issue.
    I have looked up many different tutorials on Youtube about this, and none of them have solved my problem. I have requested help from a few of these people who created the tutorials as well. I still have no solution.

    I have opened up my file, and set my servers IP to "localhost" and this did not work. I have left this field blank as well. This did not change anything either. As you can see above, I have also set it to my IPv4 address. This does not seem to produce any positive results either.

    I have added both UDP, and TCP port exceptions for Outgoing, and Incoming in my firewall.
    I have added programme exceptions in my firewall for every Java file in my computers database, such as: Java.exe; Javaw.exe; Javacpl.exe; Javaws.exe; and every other Java related file.

    I have searched on Google many variations of: Cannot connect to bukkit server; Cant connect to my own minecraft server; bukkit server not connecting.

    I have used the tool to check if the 25565 port is open, and it gives me this error:

    So somehow, even though I have taken all of these steps, the port is still not open.

    I have tried asking two of my friends who own their own Minecraft servers.
    Neither of them were able to help me with this.

    Basically, what my question is:

    How can I open the port 25565?
    I would greatly appreciate it if someone could tell me something that I missed that could rectify this issue.

    If no one does know a solution to this, then does anyone possibly have an idea that might lead to a solution? Or were/who might I ask to get this problem solved?
  2. Offline

    Super User

    Your problem is you didn't PF properly.
  3. Offline


    Um.. could you please explain to me what I need to do to Port Forward correctly?

    I followed a tutorial on the website.
  4. Offline


    Quav, ive had the same problem, we went thru 3 different routers, we phoned our internet provider, but no matter what we did all our ports were blocked. I just decided to buy my own server on a host in europe.
    Quavelen likes this.
  5. Offline


    Well, I just looked up yet another guide on port forwarding. This time I used, and found a guide specific to my router. It turns out I did port forward correctly, so that is not the issue.

    I am still awaiting a response from someone who can help me with this strange error.

    From all that I have done, the port should be open. I do not understand why it still says that it is closed.
    I have again restarted both my router, and my computer. This did not resolve the issue.

    Could someone please explain to me what I need to do to fix this....?
    abdulla likes this.
  6. Offline


    Ok the issue may be that your fire wall is not allowing traffic on the port (I had to open windows firewall on the port).

    Also do you have a static ip set up? If you do not the internal ip you are forwarding to many no longer be your pc xD. Here is how if you don't:
    1. Control Panel
    2. Network and Internet
    3. Network and Sharing Center
    4. You will see connections written next to the wi-fi symbol click that
    5. Then go to properties
    6. Click internet protocol version 4 (for you this may be different)
    7. Click properties with protocol v4 selected
    8. Then click use the following ip adress
    9. Enter what internal ip you wanna use like
    10. Enter for subnet mask
    11. Figure out what dns server you use and enter that below, Or you can use obtain automatically, but I am not sure that will work.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 31, 2016
  7. Offline


    As I stated above in my original post, I do have exceptions in my firewall. It is allowing all traffic in, and out of my firewall on the port 25565. Here is a screenshot of them in my advanced firewall settings:

    Yes. I do have a static IP set up.
    I'm sorry, I should have mentioned that in my original post.
    It is set at, the very same IP that I port forwarded with, and the very same IP that I have been trying to connect to my server with.
  8. Offline


    Something is wrong there should not be a 0 there it should be
  9. Offline


    I just tried that Iroh. It did not work. All it did was mess up my internet connection.

    I really wish someone could give me an answer to this.... =/

    I cannot afford a VPS, and I would love to be able to host my own Minecraft server.
    Port Forwarding should work, but for me; it seems to not have the desired effect.

    Can someone with knowledge about this please help me figure out how to open this port?
  10. Offline


    What about your

    If people could see that it might be of use :)
  11. Offline


    Your right... I completely forgot about that! xD
    They are still set at the default options, except for view distance. That I reduced to 6, because it should improve performance.
    Here are my

  12. Offline


    You need to set server ip to your internal ip. For instance I am
  13. Offline


    If I do that, I get this error message:
    210 recipes
    27 achievements
    12:04:04 [INFO] Starting minecraft server version 1.4.7
    12:04:04 [INFO] Loading properties
    12:04:04 [INFO] Default game type: SURVIVAL
    12:04:04 [INFO] Generating keypair
    12:04:05 [INFO] Starting Minecraft server on
    12:04:05 [WARNING] **** FAILED TO BIND TO PORT!
    12:04:05 [WARNING] The exception was: Cannot assign requ
    ested address: JVM_Bind
    12:04:05 [WARNING] Perhaps a server is already running on that port?
    If I leave it blank, I get no errors, and it starts up just fine. I just cannot connect to my server.
    I cannot connect to my server by typing "localhost" either.
  14. Offline


    That is not because of the server ip thing...That is because either the server didn't close correctely or you didn't use the stop command that error will go away in like 5 minutes if you do not try and launch the server again. Also always use /stop no just close the window.
  15. Offline


    I always use /stop to shut down the server Iroh.

    I'm not new to minecraft. >_> Lol.

    I've tried re-starting the server ten times with the server IP in the properties file. I counted. I still have the same "cannot bind port" error.

    But this is not my issue as my thread states. We are getting off topic.
    My issue is:

    How can I open Port 25565?
    I have done everything that I know of that needs to be done to open it.
  16. Offline


    1. Click Start, and then click My Network Places.
    2. Under Network Tasks, click View Network Connections. (Or, right-click My Network Places on the desktop, and then click Properties.)
    3. Right-click the connection that you use for the Internet, and then click Properties.
    4. Click the Advanced tab, and then click Settings.

      Note If the Settings button is unavailable, ICF is not enabled on this connection, and you do not have to open any ports (because they are all already open).
    5. Click Add to open a new port.
    6. In the Description box, type a friendly name. For example, type File Sharing : Port 445.
    7. In the Name or IP address of the computer hosting this service on your network box, type

      Note You can specify the IP address of an internal computer. But you typically will use
    8. In the External port and Internal port boxes, type the port number. Generally, this number is the same.
    9. Click either TCP or UDP, and then click OK.
    10. Repeat steps 1 through 9 for each port that you want to open.
    This is how microsoft says to do it that is all I got :)
  17. Offline


    Umm.. is this for windows 7?
    Because that is my Operating system.

    Well, I just followed what you said, and there is no advanced tab:


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 31, 2016
  18. Offline


    Yes it is from their site. Sorry it doesn't work. Those are all the ideas I had.
  19. Offline


    Not sure if this was already covered, cause i kinda skimmed through this topic. But I had the problem not being able to connect to my server using my own IP, but others could.
    So i just tried connecting to localhost and it worked. If that doesn't work try connecting to what it says in your router which looks like
  20. Offline


    OMG. >_<

    I figured it out.
    I messed up so badly.......
    It was my own fault.

    I typoed my IP when I port Forwarded..... As you see, I had it listed as 198.168.044.
    My IP is actually lol.......

    That one little number threw everything off....

    Thank you everyone for all your help.
    ~Changing this thread to solved.
Thread Status:
Not open for further replies.

Share This Page