Solved BukkitPermissions bad formatting

Discussion in 'Bukkit Help' started by lukeyslife, Apr 13, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Hi i think i have a bad issue with my formatting as when i try to do commands such as "perms player setgroup" it says internal error

    if you wish to see my permissions file use the link:

    Thanks any help will be appreciated

  2. Offline


    Please always check your YML files with this tool ( ) if there seems to be an issue with them.

    I will check yours now.

    while parsing a block mapping
      in "<unicode string>", line 1, column 5:
    expected <block end>, but found '<block mapping start>'
      in "<unicode string>", line 5, column 7:
    lukeyslife likes this.
  3. Offline


    oh yeh i apologize i forgot to write i used that site and found some errors but im really clueless of how to fix it it does look pretty basic though (hopefully)

    do you mean 8 characters as in 8 spaces before it?

    ahh you mean i tab everything 4 times? although im looking at it and it looks all alligned to 1 column

    oh right ok thanks ill have to try it out
    does PEX support * nodes?

    ill repost me trying to edit the config could you re-check it again please (its partly done) to see if the formatting is correct , thanks


    right lol here's the third version is this correct?:
  4. Offline


    Your fifth line with ยจ kensol:"is not correctly aligned.
    It should have 8 space characters before it.

    In the mod group section, the essentials.kill permission has too many space characters before it.

    Actually, constantly throughout there is inconsistent spacing.

    Everything should be soft tabbed out (4 spaces where you would normally use the tab button) neatly.

    Can I recommend that you switch to PermissionsEX?
    PEX can easily be managed by a range of commands which will do all the YML formatting for you.

    Yes, PEX supports a lot in terms of nodes.

    If you are familiar with regex, you can use nodes such as essentials.(tpa|tpaccept|tpdeny) to give users access to /tpa, /tpaccept and /tpdeny.

    and essentials.* if you want to give them everything to do with essentials.

    /pex group admin create (Command to create group)
    /pex group admin add * (Command to give admin group all permissions)

    you can even add nodes to users / groups for a specified amount of time (in seconds)
    /pex user Notch timed add essentials.ban 3600
    to give player Notch the ability to use the ban command from essentials for one hour.

    It supports world-specific permissions and groups

    /pex group default add factions.kit.starter world_survival
    would give the factions.kit.starter node to all players in the default group while in world_survival

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 25, 2016
  5. Offline


      "users": {
        "lukeyslife": null,
        "kensol": null,
        "groups": [
    this is the output from the YAML Parser is this correct 
    unfortunately it is yes even though the whole permissions file is on there now :(
  6. Offline


    If that is the only output, that is not good.
  7. Offline


            - admin
            - admin
        essentials.warp: true
        essentials.spawn: true
        essentials.rules: true
        essentials.motd: true
        essentials.list: true
        essentials.helpop: true true
        essentials.realname: true false
        essentials.*: true
        permissions.*: true
        mcmmo.*: true
        factions.*: true
        factions.kit.admin: true
        colornames.*: true
        worldguard.*: true
        worldedit.*: true
        simplechestlock.*: true
        simplechestlock.command.*: true
        jobs.join*.: true true true
        jobs.admin.promote: true
        jobs.admin.demote: true
        jobs.admin.employ: true
        jobs.admin.grantxp: true
        jobs.admin.removexp: true
        jobs.admin.transfer: true
        essentials.spawn: true
        essentials.backup: true
        essentials.broadcast: true
        essentials.kick: true
        essentials.kill: true
        essentials.mute: true
        essentials.tempban: true
        essentials.tpahere: true true
        essentials.tpa: true
        essentials.tpdeny: true
        essentials.warp: true
        essentials.signs.use.balance: true true
        essentials.signs.use.sell: true
        essentials.signs.use.warp: true true
        essentials.msg: true
        factions.kit.mod: true
        factions.disband.any: true
        factions.setpermanent: true
        factions.setpermanentpower: true
        factions.setpeaceful: true
        factions.sethome.any: true
        mcmmo.defaultsop: true
        simplechestlock.*: true
        simplechestlock.command.*: true
        - player
        factions.kit.fullplayer: true
        factions.create: true
        mcmmo.defaults: true true
                    coolplugin.item: true
            - default
      build: '&cYou do not have permission to build here.'
    debug: false

    i'm sorry for the postage of the code on the forum but here it is
  8. Offline


    I will just re-format it for you.

    Do you want me to re-format the one you already have, or make you an entirely new YML file for PermissionsEX?
  9. Offline


    could you just reformat the one here please
    i really appreciate this and im sorry it has come down to this
  10. Offline


    Okay, I am on the job.

    Might be a short while as I am using a very old linux computer.
  11. Offline


    its ok, i'm lucky that there is someone doing it for me :) so dont worry about how long it takes or whatever

  12. Offline


    Tested it in the YAML parser and no errors, please let me know if you have any problems with it.

    If your issue is resolved, please change the prefix of your topic title to Solved by going to Thread Tools then 'Edit Thread'
  13. Offline


    ok thanks dude lemme try it
    will edit back

    nope i'm afraid problem still persist's when i try the commands like "perms player setgroup lukeyslife admin" it just says "an internal error occurred whilst attempting to perform this command"
  14. Offline


    hang on! hang on! I see a problem with my file <-- Updated with the correct link Sorry again X_X
    Here you go, sorry for the inconvenience.

    Also please make sure you copy it from the RAW output box at the bottom of the page to avoid possible problems

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 25, 2016
  15. Offline


    right trying it now :)

    yaya its done THANKS ever so much :) right ill resolve it now
  16. Offline


    Awesome, thanks for calling Bukkit Technical Support! Have a nice day :3
Thread Status:
Not open for further replies.

Share This Page