BukkitAdmin 0.4 PreAlpha ~ Premier Web Administrator [677]

Discussion in 'Bukkit Tools' started by MonsieurApple, Feb 24, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    h0us3cat

    I think my key is deactivated?
    I just updated to 0.3.1 and i can see max 5 players, but it says
    "Thank you for activating your copy of BukkitAdmin!"

    edit: I can see more then 5 players, it says now 6/5 :p
     
  2. Offline

    TnT Retired Staff

    I moved this to the Bukkit tools section as it does seem best fit here. This is a full admin web GUI - similar to other tools on here. Sure, it may use a plugin to interact, but so do other admin tools on here. I will bring this up with other mods - see what the consensus is, but I see tools like this more fitted to the tools section.

    I think there needs to be a cleanup of the plugin release section, as other tools (Webukkit for example) are also in there, but should be in this sub forum as well.
     
  3. Offline

    dragonhib

    I tested with the one include in BukkitAdmin package (R440). More recent builds (no recommended) make bukkitTCPserver plugin doesn't work...
     
  4. Offline

    MonsieurApple

    Bug, I'll fix it when I get home. I'm seeing the same thing, just forgot to fix it.
     
  5. Offline

    h0us3cat

    ok, not a big problem anyway :)
     
  6. Offline

    MonsieurApple

    Try unloading all other plugins and see if it works. If it does, reload plugins one at a time and see which one the culprit is.
     
  7. Offline

    AbsolutePolak

    I bought it, but where can i get my key?
    oh, also with the newest version, after i install it, whenver i try to login it doesnt work. says incorrect username and password yet in the bukkitadmin database it shows my username and a encrypted password.
     
  8. Offline

    MonsieurApple

    Sadly I need to add it manually which I will do when I get home in 20 minutes.

    I've been working on automatic integration, but haven't had luck with the google API and haven't looked at the paypal one.
     
  9. Offline

    h0us3cat

    manualy edit you config.php in a text editor. Look for the mysql database/user. I had the same problem.
     
  10. Offline

    MonsieurApple

    Yes, this is fixed in 0.3 already (Im 99% sure. If not, its definetly fixed in 0.3.2)
    --- merged: Mar 3, 2011 12:14 AM ---
    Version 0.3.2 Released
    - Fixed .htaccess​

    You only need to download this if 0.3.1 was not working for you.
     
  11. Offline

    AbsolutePolak

    Still doesnt actually start the server. Says its starting but its not.
     
  12. Offline

    MonsieurApple

    Go to <rooturl>/exec/start/ and tell me what it says.
     
  13. Offline

    AbsolutePolak

    {"message":"Server Started! Loading plugins..."}
     
  14. Offline

    Betaboon

    From your Screenshot it looks very promising.
    I just purchased it.

    Well i still got "some" problems.
    I set everything up on my server.
    after some problems not being able to login to BukkitAdmin (which i now figured out by manually editing config.php) i now got the following problem:
    no matter what page i go to (except index.php) i get "The requested URL /minecraft/log was not found on this server."
    I'm a professional php programmer aswell but due to the obfuscation i just can't debug it (without alot of work de-obfuscating it).

    any hints ?
     
  15. Offline

    h0us3cat

    check the .htacces
     
  16. Offline

    Betaboon

    in what way ? that i changed the RewriteBase? i did that.
    bukkitadmin is located in /var/www/minecraft/
    so i changed the .htaccess accordingly to "RewriteBase /minecraft/"

    am i missing something ?
     
  17. Offline

    MonsieurApple

    The rewrite base is what comes after the domain in the http url.

    For example: the rewritebase for http://www.example.com/test/dev/bukkitadmin/ would be /test/dev/bukkitadmin/

    Also, I just sent your key.
    And does it actually start? Can you connect? Does a java process appear to be running? Windows or Linux?
     
  18. Offline

    Betaboon

  19. Offline

    fffizzz

    When I save on step 3, it doesnt go any further. Then when i access /mc/index.php <-- where its installed i get a blank page. This wont work with 5.2.16 php ? I saw 5.3 on front page but cant use that version because i have to update some other scripts first. :(
     
  20. Offline

    AbsolutePolak

    it actually runs, but none can connect, since when i want to start the real server, it says the port is taken.
     
  21. Offline

    MonsieurApple

    Do a recursive chmod/chown, the permissions are probably wrong.
    --- merged: Mar 4, 2011 1:13 AM ---
    Because the port is probably taken.

    Kill all other java instances on the same port before starting silly :p
     
  22. Offline

    fffizzz

    All files are already 755 minus bin/global which are 777 and they ahve proper ownership.
     
  23. Offline

    MonsieurApple

    Version 0.3.3 Release
    - Fixed install bugs​
    - Fixed apache infinite loop bug​

    Download here or in the original post.

    @fffizzz after step 3, try changing ?s=3 to ?s=4 and see if you can continue. I'm not sure why it's doing that.
     
  24. Offline

    fffizzz

    I actually did try that, blank page :D Im a bit of a php coder myself.. Ill try latest version


    -----

    same behavior (see you fixed the database name being in the config to save on step 3) :)
     
  25. Offline

    MonsieurApple

    I don't think it will make a difference for you. Also, try upgrading php and see if it makes a difference.
     
  26. Offline

    fffizzz

    You need 5.3 because of the JSON support? because 5.2.16 has it also. I just have a few scripts that are protected by sourceguardian that i have to recreate before i can upgrade, i cant be bothered right now to do that lol. Ill see about it next week when i get back from vacation. :)
     
  27. Offline

    mebibyte

    Hello Apple,

    I'm the same mebibyte from the minecraftforums. I just downloaded the 0.3.3 release of your bukkitadmin. I have a question about step 4. What exactly is the installation suppose to do in step 4?

    When I was trying to install using the previous releases, step 4 would be skipped. This time, after creating the config.php file myself, I changed the ?3 to ?4 in the url. It said it successfully moved stuff from ../bin to /minecraft/bin (minecraft is the folder I have bukkitadmin in).

    However, the dashboard information is still stuck with "loading...", and the links to the other pages are still broken. They link to domain/minecraft/players, with minecraft being my folder name, and players being the page name. It doesn't have .php at the end of the links, and it's missing the /pages/ folder.

    I think I am confused about what BukkitAdmin is supposed to do. Is it creating a minecraft server on my website with a web based control panel?

    Thanks for the support, and awesome plugin!

    -Mebibyte
     
  28. Offline

    dragonhib

    Hi MrApple !!
    I've had already try to start server without plugins but not work...:(
    Now I have an other problem. Due to a migration I installed bukkitadmin on a fresh install of Ubuntu 64 (Desktop). Then now when I click on start button on the main page, craftbukkit start but the 'start' button still display "starting...". Players tabs displays that no players are connected and when I come back to Dashboard, CPU & RAM are at 0% but there is correct information about statut 'online' and connected players !! Almost log works perfectly... Do you have an idea ?
     
  29. Offline

    AbsolutePolak

    i reinstalled ubuntu since there was something wrong, reinstalled apache etc, now. Wordpress works, and the xenforo forum works but when i try to acess the folder for bukkitadmin it gives me a 500 error.
     
  30. Offline

    MonsieurApple

    Your
    Your htaccess is setup wrong then I'm guessing.
    --- merged: Mar 5, 2011 12:37 AM ---
    I believe the permissions are incorrect. Make sure www-data (or your apache user) can write to the entire folder AND its contents (recursive chmod + chown)
    --- merged: Mar 5, 2011 12:38 AM ---
    Quite a few people are reporting this same problem. I am going to examine it tomorrow and hopefully find a bug fix to release.
     
Thread Status:
Not open for further replies.

Share This Page