Bukkit Server can only connect through ipv4 adress

Discussion in 'Bukkit Help' started by Projester99, Jul 19, 2016.

Thread Status:
Not open for further replies.
  1. Offline

    Projester99

    A few days ago i made a bukkit server. Everything was going fine, until i told my friends to join and they said they couldn't connect. I was able to connect through the ipv4 address just fine. My friends couldn't connect through my external ip address. I port fowarded corrected, and windows firewall is off. However, when i go check to see if my port is open for my ip address it says port 25565 is closed on 192.168.x.x
    Here is my server file if there is anything wrong with it
    #Minecraft server properties
    #Tue Jul 19 15:42:41 PDT 2016
    spawn-protection=16
    max-tick-time=60000
    generator-settings=
    force-gamemode=false
    allow-nether=true
    gamemode=0
    broadcast-console-to-ops=true
    enable-query=false
    player-idle-timeout=0
    difficulty=2
    spawn-monsters=true
    op-permission-level=4
    announce-player-achievements=true
    pvp=true
    snooper-enabled=true
    level-type=DEFAULT
    hardcore=false
    enable-command-block=true
    max-players=100
    network-compression-threshold=256
    resource-pack-sha1=
    max-world-size=29999984
    server-port=25565
    server-ip=
    spawn-npcs=true
    allow-flight=false
    level-name=world
    view-distance=10
    resource-pack=
    spawn-animals=true
    white-list=false
    generate-structures=true
    online-mode=true
    max-build-height=256
    level-seed=
    enable-rcon=false
    motd=Freedom Factions
     
  2. Offline

    timtower Moderator Moderator

    @Projester99 That is a local adres.
    Get your external one
     
  3. Offline

    757fps

    look up my ip
     
  4. Offline

    timtower Moderator Moderator

  5. Offline

    Projester99

    Yes I am giving my friends my external ip address not the local one, only I use the local one

    My server ip is
    172.251.7.242:25565
    My friends cannot connect to this, and this is the external ip and i have port fowarded correctly. I have my server currently off right now if you would like me to turn it on just tell me :)
     
  6. Offline

    timtower Moderator Moderator

  7. Offline

    Projester99

    I can only connect through my local host only. Not the external ip.
     
  8. Offline

    AlvinB

  9. Offline

    Projester99

    Forgot to click reply button

    It said
    Error: I could not see your service on 172.251.7.242 on port (25565).

    But I'm 100% sure that i port foward correctly, so it's not a router issue.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jul 20, 2016
  10. Offline

    AlvinB

    @Projester99
    Have any firewalls on your computer/router? If so, try looking through them to see if the port/program is allowed.
     
  11. Offline

    Projester99

    Yes I made it so port 25565 is allowed
     
  12. Offline

    bwfcwalshy Retired Staff

    @Projester99 Screenshot your port forwarding

    You have either not port forwarded correctly or your firewall is blocking connections
     
  13. Offline

    Projester99

    upload_2016-7-26_18-31-10.png
     
  14. Offline

    AlvinB

    @Projester99
    The portforwarding looks correct, are you sure you actually added it to the right machine?
     
  15. Offline

    Projester99

    What do you mean right machine? i port fowarded to my ipv4 address
     
  16. Offline

    AlvinB

    @Projester99
    Well in the portforward configuration you have to add your local ip, in your network (starts with 192.168.1...), not your external ip. Are you sure you have done this correctly? Can you show us the list with devices using this portforward?
     
  17. Offline

    Projester99

    Yes I am using my local ip address. you can see the list in the screen shot i have posted it shows the list of device names
     
  18. Offline

    bwfcwalshy Retired Staff

    @Projester99 Can you do 'ipconfig' in cmd and then screenshot it.
     
  19. Offline

    Projester99

    upload_2016-7-28_9-16-20.png
     
  20. Offline

    Angel_ScarzXD

    I have been having this problem to everything was fine a week ago until now :(
     
  21. Offline

    HeartandSoul

    Code:
    #Minecraft server properties
    #Tue Jul 19 15:42:41 PDT 2016
    spawn-protection=16
    max-tick-time=60000
    generator-settings=
    force-gamemode=false
    allow-nether=true
    gamemode=0
    broadcast-console-to-ops=true
    enable-query=false
    player-idle-timeout=0
    difficulty=2
    spawn-monsters=true
    op-permission-level=4
    announce-player-achievements=true
    pvp=true
    snooper-enabled=true
    level-type=DEFAULT
    hardcore=false
    enable-command-block=true
    max-players=100
    network-compression-threshold=256
    resource-pack-sha1=
    max-world-size=29999984
    server-port=25565
    server-ip=
    spawn-npcs=true
    allow-flight=false
    level-name=world
    view-distance=10
    resource-pack=
    spawn-animals=true
    white-list=false
    generate-structures=true
    online-mode=true
    max-build-height=256
    level-seed=
    enable-rcon=false
    motd=Freedom Factions
    Your server-ip MUST be set to your PCs IPv4 Address. Sounds silly, but that points the server to a host (you).
    Once that's set, port forward on your router, or a Network firewall if you have one. Connect to the server with your External address and a semicolon, then port (i.e xxx.xxx.xxx.xxx:25565)

    enable-query should be set to true. It just works better that way. Default query port when enabled is 25565

    If you don't have a lot of people playing on this server (20 or less), set the max-players to 20.

    If you need any more help, PM me.
     
  22. Offline

    Projester99

    I put my ipv4 address in there 192.168.1.2, but no one can join still

    #Minecraft server properties
    #Fri Jul 29 12:15:38 PDT 2016
    spawn-protection=16
    max-tick-time=60000
    generator-settings=
    force-gamemode=false
    allow-nether=true
    gamemode=0
    broadcast-console-to-ops=true
    enable-query=false
    player-idle-timeout=0
    difficulty=2
    spawn-monsters=true
    op-permission-level=4
    announce-player-achievements=true
    pvp=true
    snooper-enabled=true
    level-type=DEFAULT
    hardcore=false
    enable-command-block=true
    max-players=100
    network-compression-threshold=256
    resource-pack-sha1=
    max-world-size=29999984
    server-port=25565
    server-ip=192.168.1.2
    spawn-npcs=true
    allow-flight=false
    level-name=world
    view-distance=10
    resource-pack=
    spawn-animals=true
    white-list=false
    generate-structures=true
    online-mode=true
    max-build-height=256
    level-seed=
    motd=Freedom Factions
    enable-rcon=false
     
  23. Offline

    mine-care

    Wy not just posting here? This way the rest of the comunity has a chance to respond. (Thats the purpose of forums)
     
  24. Offline

    techy569

  25. Offline

    HeartandSoul

    .

    Then you did not Port forward correctly. also make sure you're windows firewall is set up so java can use it
     
  26. Offline

    star5426

    Do you have two routers? i know youre thinking no but some motems have a build in router. Does your ISP provide a free wifi plan with your internet? If you so then you have two routers, Your router may be port forwarded but not your motem/router
     
Thread Status:
Not open for further replies.

Share This Page