Solved Bukkit gamemode command permission help

Discussion in 'Bukkit Help' started by Nebuler, Aug 9, 2015.

Thread Status:
Not open for further replies.
  1. Offline


    Ok I have a bukkit server, using pex and I have added the permission - bukkit.command.gamemode and I restart the server and do /gamemode and I have no permission. Yes, I am in the right group. Thankyou in advance.

    fyi - here's the groups permission file:
  2. Offline


    idk why try to do /prm
    tell me if this work.
  3. Offline


    essentials may be overriding the gamemode command
    Also, if you have modifyworld.jar plugin in your server, DELETE IT - if you have your default rank have modifyworld.* permissions, you're saying "I dont want anyone on this server to be stopped, frisked and checked for permissions for each step they take, each move they make, each action they take, to see if they are allowed to continue" so why then have the program stop them, frisk them, check them and allow them to continue when you know the answer is they are always allowed to continue. Its overhead lag and computations that dont need to be done, so remove the jar file.
  4. Offline


    /prm doesn't work @Iscurb

    @Boomer I don't have modifyworld.jar anywhere. When you said about esssentials overriding it? Can you explain more please.

    <Edited by bwfcwalshy: Merged posts, please use the edit button rather than double posting.>
    Last edited by a moderator: Aug 9, 2015
  5. Offline


    This means that the plugin Essentials may be overriding other plugins (or in this case, the servers) commands. Since your server has the command /gamemode, and so does Essentials, Essentials overrides it. The easiest way to fix your problem, however, is to give the permission essentials.gamemode instead of bukkit.command.gamemode :)

    You can disable Essentials commands in it's config.yml if you'd like though.
Thread Status:
Not open for further replies.

Share This Page