Solved Bukkit Crash

Discussion in 'Bukkit Help' started by CK6Speed, Jul 7, 2014.

Thread Status:
Not open for further replies.
  1. Offline


    Every time I try to start my minecraft server, I would get this message:

    [23:47:48 INFO]: Starting minecraft server version 1.7.9
    [23:47:48 INFO]: Loading properties
    [23:47:48 INFO]: Default game type: SURVIVAL
    [23:47:48 INFO]: Generating keypair
    [23:47:48 INFO]: Starting Minecraft server on *:19967
    [23:47:49 INFO]: This server is running CraftBukkit version git-Bukkit-1.7.9-R0.2-11-g3fd9db2-b3098jnks (MC: 1.7.9) (Implementing API version 1.7.9-R0.3-SNAPSHOT)
    [23:47:49 INFO]: [TimTheEnchanter] Loading TimTheEnchanter v3.0
    [23:47:49 INFO]: [RenamePlus] Loading RenamePlus v1.1
    [23:47:49 INFO]: [WorldEdit] Loading WorldEdit v5.6.1
    [23:47:49 INFO]: [PlotMe] Loading PlotMe v0.13f
    [23:47:49 INFO]: [PlayerHeads] Loading PlayerHeads v3.8-jenkins-PlayerHeads-1-48-ged24b6b
    [23:47:49 INFO]: [Multiverse-Core] Loading Multiverse-Core v2.4-b527
    [23:47:49 INFO]: [AutoSaveWorld] Loading AutoSaveWorld v4.13
    [23:47:49 INFO]: [Essentials] Loading Essentials v2.12.2
    [23:47:49 INFO]: [EssentialsChat] Loading EssentialsChat v2.12.2
    [23:47:49 INFO]: [EssentialsProtect] Loading EssentialsProtect v2.12.2
    [23:47:49 INFO]: [EssentialsSpawn] Loading EssentialsSpawn v2.12.2
    [23:47:49 INFO]: [EssentialsAntiBuild] Loading EssentialsAntiBuild v2.12.2
    [23:47:49 INFO]: [PlotMe] Enabling PlotMe v0.13f
    [23:47:51 INFO]: PlotMe 5 plots loaded
    [23:47:51 INFO]: [AutoSaveWorld] Enabling AutoSaveWorld v4.13
    [23:47:51 ERROR]: Encountered an unexpected exception Use JsonReader.setLenient(true) to accept malformed JSON at line 1 column 4
    at ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-11-g3fd9db2-b3098jnks]
    at ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-11-g3fd9db2-b3098jnks]
    at net.minecraft.server.v1_7_R3.JsonList.load( ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-11-g3fd9db2-b3098jnks]
    at net.minecraft.server.v1_7_R3.DedicatedPlayerList.y(SourceFile:99) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-11-g3fd9db2-b3098jnks]
    at net.minecraft.server.v1_7_R3.DedicatedPlayerList.<init>(SourceFile:25) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-11-g3fd9db2-b3098jnks]
    at net.minecraft.server.v1_7_R3.DedicatedServer.init( ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-11-g3fd9db2-b3098jnks]
    at [craftbukkit.jar:git-Bukkit-1.7.9-R0.2-11-g3fd9db2-b3098jnks]
    at [craftbukkit.jar:git-Bukkit-1.7.9-R0.2-11-g3fd9db2-b3098jnks]
    Caused by: Use JsonReader.setLenient(true) to accept malformed JSON at line 1 column 4
    at ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-11-g3fd9db2-b3098jnks]
    at ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-11-g3fd9db2-b3098jnks]
    at ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-11-g3fd9db2-b3098jnks]
    at ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-11-g3fd9db2-b3098jnks]
    at ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-11-g3fd9db2-b3098jnks]
    ... 7 more
    [23:47:51 ERROR]: This crash report has been saved to: /Users/chrisk/Desktop/./crash-reports/crash-2014-07-06_23.47.51-server.txt
    [23:47:53 INFO]: ----- Bukkit Auto Updater -----
    [23:47:53 INFO]: It appears that you're running a Development Build, when you've specified in bukkit.yml that you prefer to run Recommended Builds.
    [23:47:53 INFO]: If you would like to be kept informed about new Development Build releases, it is recommended that you change 'preferred-channel' in your bukkit.yml to 'dev'.
    [23:47:53 INFO]: With that set, you will be told whenever a new version is available for download, so that you can always keep up to date and secure with the latest fixes.
    [23:47:53 INFO]: If you would like to disable this warning, simply set 'suggest-channels' to false in bukkit.yml.
    [23:47:53 INFO]: ----- ------------------- -----
    Please help me. I tried deleting unused plug-ins, and tried upgraming to Recommended Builds. What am I doing wrong?
  2. Offline


    malformed JSON at line 1 column 4

    All this makes me think you have a .json file that is corrupted or you have edited it and messed something up. I don't see what actual file it is mad about but it is likely to be one of the files in your root server folder like one of the following:

    usercache.json ( <-- likely culprit if you didn't edit any of these )

  3. Offline


    Had the same issue. Deleted the usercache.json file. Hopefully that'll do it.
  4. Offline


    Thank you! It was my banned-players.json file. I accidently put down a name, but it didn't ban him because I didn't have something in it. Thanks!
Thread Status:
Not open for further replies.

Share This Page