Bukkit Console Window won't stay open...

Discussion in 'Bukkit Help' started by BlooMongoose, Jul 14, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    I downloaded the bukkit software and made my RUN.bat in the notepad, but when I double click the RUN file the CMD window pops up literally for a fraction of a second and disappears. Obviously, without the console I can't use server commands to make my character an OP or to shut the server off. Once the server is running, the only way for me to turn the server off is for me to restart my computer. The server is on due to the fact that i double clicked the "craftbukkit-0.0.1-SNAPSHOT" but aside from the fact that I can join via minecraft, I have no idea if the server is even on or not. Is there a way for me to get around this problem?

    I run on Windows 7 with Java 1.6.0_14 (64-bit as far as I know)
    Am I running the server with the correct startup information?

    I'm curently using: (this is what the wiki told me to use)
    "@ECHO OFF
    SET BINDIR=%~dp0
    CD /D "%BINDIR%"
    "%ProgramFiles(x86)%\Java\jre6\bin\java.exe" -Xincgc -Xmx1G -jar craftbukkit-0.0.1-SNAPSHOT.jar"

    Am I using the correct thing or am I forgetting something? Or is this not the problem and something else is? Any help in this matter would be greatly appreciated and I want to apologize ahead in advance if I did not make to much sense in my details and for the fact that i don't know my computer terminology very well.
  2. Offline


    try to start the .bat over console (cmd.exe) so you can see the message it prints, i guess it cant find your java.exe
  3. Offline


    I'm sorry, but how would I go about doing this? And is the fact that I have my craftbukkit download located on my desktop a problem and would that be why it can't locate it? It's literally in a folder I made on my desktop titled "Bukkit".
  4. Offline


    Put "PAUSE" (without the quotes) at the end of the .bat file, that way the window should stay opened and you should be able to read the error message(s).
  5. Offline


    Thanks! That helped and I solved my problem... I just had to rename the jar file. Turned out I was also not saving the RUN file as a .bat (woops :D).

    Thanks again!
  6. Offline


    i have the same problem but mine opens and says unable to acces jarfile.
    i copied my jarfile right where by default is craftbukkit.jar
Thread Status:
Not open for further replies.

Share This Page