Question Bukkit 1.5.2 API?

Discussion in 'Bukkit Help' started by BananaPuncher714, Oct 18, 2016.

Thread Status:
Not open for further replies.
  1. I have a 1.5.2 R.02 craftbukkit server, but I need the API for 1.5.2. When I try to build it from buildtools with "java-jar BuildTools.jar --rev 1.5.2", it gives me an error saying that 1.5.2 doesn't exist. I need it to re code some plugins so that they're compatible with my server for school. I couldn't find any solutions online on spigot and I didn't know if and what version of Buildtools that I needed.
    Here's the output when I try to build it from the latest version of Buildtools:
    http://pastebin.com/LzyNWkwE
    Can anyone tell me how to get the 1.5.2 API?
     
  2. Offline

    timtower Moderator Moderator

    @BananaPuncher714 That is a very old version.
    Try getting the school to update to a newer version.
    Or build on the craftbukkit server instead.
     
  3. Should I use the craftbukkit.jar as the API itself?
     
  4. Offline

    AlvinB

  5. Ok, thanks I will try it.
     
  6. Can anyone tell me where to find the overview for the 1.5.2 classes?
     
  7. Offline

    timtower Moderator Moderator

Thread Status:
Not open for further replies.

Share This Page