Blocks respawning bug?

Discussion in 'Bukkit Help' started by joopie, Feb 23, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    can anyone confirm this?
  2. Offline


    I have the same problem.
  3. Offline


    I have found that after a period of time, possibly with other activity occurring nearby, the blocks become breakable again. I haven't been able to confirm precisely what it is that causes the change, as usually I leave the unbreakable blocks for a while, do something else like chopping existing blocks etc, and when I come back later they are ok to break again.

    So I can say that a server restart is not the only way for this to become resolved, if that helps the troubleshooters at all.
  4. Offline


    This bug is currently still present.

    I used "//" (Super pick axe) on WorldEdit and it seemed to solve it.
  5. Offline


    If this is not a Bukkit problem, but rather an issue with the vanilla server.. Could someone PLEASE post it on GetSatisfaction, so we can all click it, and hopefully alert Mojang to fix it?
    Right now, the only posts I see with similar issues, are MONTHS old, and unrelated.
    And I do not understand this bug technically enough, to make the post myself.
  6. Offline


  7. Offline

    Black Isis

    I am just starting to dip my toes into bukkit and I noticed this problem last night as well -- so far, I've only noticed it when running bukkit but not with vanilla -- of course, since it's kind of hit or miss, I don't know if that's just because I've gotten lucky or because it's caused by bukkit.
  8. Offline


    [432]The problem doesn't pop up right away, and it does not affect everyone on the server simultaneously. When it is happening, broken blocks will not drop an item and then a couple seconds later the 'broken' block will reappear. Although invisible, the 'broken' block still collides with the avatar and prevents entering its space. Opping/de-opping the user does not fix it. There are no error messages at the console. This has happened to multiple users at very different points on the map, far from the spawn. Only restarting the server seems to be fixing it so far. says that it makes the world unbreakable, but not true. I've had one user with the problem while another was working normally. Maybe his comment was figurative?
  9. Offline


  10. Offline


    Wow it's disturbing seeing that the employees are considering this not a problem on the first topic... But then again, if you look at when it was posted it was way before MC 1.3 So they're prolly not gonna look at that one anymore. Thus it was a good idea to start a new topic :) Mayhaps you should've mentioned that it was an error with 1.3 specifically?
  11. Offline


    I'll add it now, thanks for the idea
  12. Offline


    No, after this commit: this issue changed from affecting only newly placed blocks (they were reporting invalid block types) to making every blocks unbreakable (but now they report the correct type), at least in my tests. You are using #432, which is before this addition; feel free to test this by using the latest #439.

    This problem (new blocks being unbreakeable / reporting wrong type) started happening a few days before the 1.3 update for us. Out of nowhere we suddenly had our grief alert system reporting people placing grass, water, diamond ore... while they were in fact placing dirt or cobblestone. Our logs are filled with people "breaking" air blocks that day too. I suspect that this might be the cause or at least what made this bug so much more frequent but I don't have enough time to fully test my hypothesis. It would at least explain the randomness of it, i.e. it would only happens after a chunk gets unloaded/reloaded from memory.

    The first time we were hit by this bug it happened minutes after updating but we were also running a server with about 50 players on at the time. Further testing on our test server with only 1 or 2 players running around usually require more time before the problem happens again.
  13. Offline


    It seems to be possible to induce the bug if you teleport alot (i.e. force chunks to be constantly reloaded). I tried this by myself on my test server and spammed a bunch of /home commands and that seemed to start it.
  14. Offline


    I've also noticed it can be triggered by dieing and reloading spawn and reloging.
  15. Offline


    Ok, nevermind. I just encountered the problem in craftbukkit [439] - This is definitely still not fixed. Is anyone with the bukkit team working on this one, or is it a confirmed Mojang bug?
  16. Offline


  17. Offline


    The brand new CraftBukkit [440] purportedly fixes this specific bug. Can everyone having these issues try it out and report?
  18. Offline


    Testing it now.
  19. Offline


    Ok, I loaded up [440] and tried all the things that normally seem to trigger the bug (Except playing for 1+ hrs). I slept in a bed, teleported around, killed myself, logged/relogged, used a minecart, all the while wandering around constantly placing and destroying blocks of dirt - No sign of the bug as of yet.

    On a possibly related note, this build also seems to have fixed the minor 'teleported a step backwards' bug I'd been seeing since 1.3. Specifically, while walking around I'd sometimes get teleported backwards a step, similar to lag, but definitely not lag. It was worst around doors and when rounding close to corners. Seems gone so far though.
  20. Offline


    Still noticing this bug.. more random than before, i can remove some blocks but not others nothing to do with the ones i place hrmm

    It appares it occurs after teleporting somewhere, it gets fixed with a relogin
  21. Offline


    I'm also seeing this problem with 440 but sometimes while I can place/destroy blocks I get random types reported... i.e placing & breaking dirt tells me it was grass, water or air through console debug. Took me a bit longer to trigger the bug though.
  22. Offline


  23. Offline


    its fixed in latest and recommend bukkit build...
  24. Offline


    No, this issue is not fixed yet. It's a Vanilla Minecraft issue but we're still looking into it.
  25. Offline


    Alright I tested with 443 and can confirm 2 things.

    1. The bug can be induced with teleportation.
    2. Unlike before, reloging does fix the issue. Making multiplayer somewhat playable.
    Also, if you notice, the fix loads the chunk the player teleports to immediately, so we're kinda given a hint that the issue comes from the way the game loads chunks, although most of you probably already knew that XD

    I decided to test this claim as well:
    And it seems feasible. I've tried creating a map from nothing and made 2 homes somewhat far apart from each other, then spammed teleport between the two. This doesn't seem to induce the bug.
  26. Offline


    @EvilSeph thanks for the confirmation : ) we will just have to live with it for now.
  27. Offline

    Jacob Litewski

    @Fugenshot this makes me think it's not how the game loads regions (chunks), but how the game converts the chunks to regions. Since after 1.3 all the chunks got converted to regions, there has to be something in the conversion code that is the root cause of this nasty bug. Since a newly created map after 1.3 doesn't need to use a conversion, it's fine.

    Note I didn't test this idea (computer isn't powerful enough), but it seems, logically, that's where I would look. And it's something Mojang should address too, since it is a vanilla bug.
  28. Offline


    For those experiancing issues can you try creating a fresh map and using that? I've been using multiverse with three maps and was having these same issues with periodic crashes. However on the same server info, by recreating the three maps as fresh worlds the issue seems to have gone away.
  29. Offline


    The situation is now much better with latest versions making the bug less impacting on gameplay. Thanks to the bukkit devs for there work on this issue.
  30. Offline


    @o0AzzA0o i disagree, i just updated my .jar to the latest 445, and i am still having this problem, but i could be crazy.

    fyi if you're just tuning in, the problem:
    i really hope this can be fixed, making an entirely new world is a big inconvenience, my users will not be pleased. im not complaining, not at all. things like this are just byproducts of being a part of beta :) BUT, i do hope it can be fixed.
Thread Status:
Not open for further replies.

Share This Page