Bad Packet id + 32 bit - 64 bit error?

Discussion in 'Bukkit Help' started by Lanuk, Apr 22, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    So basically I am having some errors while running my server. These did not show up until I tried updating my cb to 677 and it did not work. Before I show you my errors, here is some (hopefully) useful information.

    I have 64-bit Windows 7, latest 64-bit java, I am running no wrappers, I am running cb 670, I am using WorldEdit, WorldGuard, Essentials, Vanish, LyTreeHelper, mcMMO, NoCheat, iChat, Factions, BColoredChat, HeroicDeath, Permissions, PermissionsPlus, and WhichMob.

    My Errors?

    Running 670 cb I occassionaly get this:

    [SEVERE] Bad packet id 116
    2011-04-20 21:24:14 [SEVERE]     at net.minecraft.server.Packet.b(
    2011-04-20 21:24:14 [SEVERE]     at net.minecraft.server.NetworkManager.f(
    2011-04-20 21:24:14 [SEVERE]     at net.minecraft.server.NetworkManager.c(
    2011-04-20 21:24:14 [SEVERE]     at
    It happens a few times an hour or so. I did not pay too much attention.

    Also, I could not find this error again, but one day I just wanted to test cb677 so I simply tried starting my server without updating any plugins or anything (with the 677 cb replacing my old 670). It said something like: 32-bit IA could not load with 64-bit computer or something like that. I am assuming something might be wrong with my run.bat file? If so, here is what that looks like:

    @echo off
    "%ProgramFiles%\Java\jre6\bin\java.exe" -Xms4096M -Xmx4096M -jar craftbukkit-0.0.1-SNAPSHOT.jar
    Help would be greatly appreciated! I really want to fix these errors and hopefully get cb677. Thanks!

    Oh and also, my server has been having a lot of lag lately for some reason. My world folder is about 120mb and I guess I do have a fairly large amount of plugins. As you can see I use 4gb ram, but if there is a problem with the run.bat file, could my server possibly be using less than the 4gb ram I threw at it? o.o

    OH AND ALSO, as I said below, one more question. What is the furthest CB version... I thought it was 680-something and not 1.5 compatible yet, but apparently people are using bukkit in 1.5?! Help!?
  2. Offline


    Are you trying to connect to a 1.4 server with an 1.5 client? if so, update your craftbukkit to 709 and then you can connect with an 1.5 client.
  3. Offline


    No, I am trying to connect with a 1.4 client. Me and my friends can connect fine, but we are getting these errors and cannot even start a 677 server. Thanks for the help though!

    EDIT: But wait..... 706??? I thought it stopped at 680-something and wasn't 1.5 compatible yet.........
  4. Offline


    I had a similar issue with the 64bit... Its on the fourms and heres a link and a plugin dev helped me fix.

    Bukkit has also been updated for 15.01 You just need to download a developer build and 709 is pretty stable which you can get here,
    most plugins don't need any updating so your set by upgrading to it

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  5. Offline


    Download 714
  6. Offline


    A bad packet id error usually occurs when you're trying to connect an old client to a new server, or the other way around. You either have to wait for us to update to the latest version of Minecraft, or download the updated build if it is already available and tested.
  7. Offline


    Wait, but I have a 1.4 client. So you're saying I will stop getting this error when I upgrade to 1.5 and get the 714 build? If so then I will wait till a recommended build is promoted. I am not sure where you got the stable part as it says otherwise on the homepage. Thanks guys!

    But wait... what does a bad packet id even do... I don't see any changes in my server besides some lag maybe
  8. Offline


    hi iv been having the same problem when i try to join my friends server it comes up with blah blah random number thing and bad packet id 64. seriously wtf is that if u know how to fix this please message me back thanks :):):mad:
Thread Status:
Not open for further replies.

Share This Page