Auto-Mute

Discussion in 'Plugin Requests' started by gban, Dec 17, 2016.

Thread Status:
Not open for further replies.
  1. Offline

    gban

    If a player says a 3 messages within X seconds(can be changed in config) it will run "mute %player% 2m Spamming (Auto-Mute) -S" And everyone with the perm automute.see will be send the message &8(&e%player% has been automuted) then to bypass this you will need the perm automute.bypass
     
  2. Offline

    OTF Catastrophe

    It might take me a couple days but I can do this ^-^ Any specific version?
     
  3. @OTF Catastrophe , will you be doing this soon? If not I can get it done today.
     
  4. Offline

    OTF Catastrophe

    If you want you can take a crack at it, I won't be able to start it until tomorrow. PM me if anything changes and you can't finish the plugin so I can do it for him. Good luck ^-^
     
  5. Alright, I'll have a go. I'll edit this post if I can't do it.

    EDIT: @gban The plugin has been finished! You can download it from here when it has been approved.
     
    Last edited: Dec 19, 2016
  6. Offline

    gban

    Last edited: Dec 21, 2016
  7. @gban It will very likely work in 1.8 no reason why it shouldn't. Did you even try it?
     
  8. Offline

    gban

    @bwfcwalshy Yes I did.
    Im using 1.8

    It doesn't seem to load @ all

    @Sulphate

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Dec 21, 2016
  9. @Sulphate the code is kinda messy, but @gban is correct when he said that it doesn't seem to load at all.
    You are missing your description in plugin.yml, this is required to start the plugin (at least on old versions of Bukkit).
     
  10. Offline

    MrGeneralQ

    A couple days? You need help?

    UPDATE
    I'm wondering
    This Plugin requires another Plugin that has a specific mute command. Why not creating Your own mute system?

    It's not that hard.
     
    Last edited: Dec 21, 2016
  11. Because if he did, then it wouldn't be compatible with Essential's /unmute command
     
  12. Offline

    OTF Catastrophe

    Im not the one making the plugin ;p I'm in the process of setting up a server so that's why it'd take a couple days. Take a crack at it if you want. I'm sure yall could do it quicker.
     
  13. Offline

    MrGeneralQ

    Why does he need essentials to unmute?
    Why not implementing an unmute command?
     
  14. Right. Firstly, it works fine on 1.11, which is what my server is running on. Secondly, I've never used the description: in the plugin.yml, ever, and have never had any problems. As the wiki page says, the description element is not required.

    I will test on 1.8 now, and if it doesn't work I will update it.

    EDIT: Also how is the code messy?

    EDIT 2: .-. I tested it with 1.8.8, it works fine. I don't know what you guys are going on about. Anyway, I have downgraded it to 1.8.8, I have tested every possible aspect, and it is now working perfectly. File should be approved some time soon. Enjoy! (just make sure you have permissions set up and you aren't an OP when trying to run the command...)
     
    Last edited: Dec 22, 2016
  15. For my old 1.7 and 1.8 plugins, I got the same exact stack trace, maybe a new build was released for 1.8 that doesn't require this. But in either case here is the stack trace I am getting, anyway I ported your code over to 1.9 and it works perfectly.

    org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml
    at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:152) ~[bukkit.jar:git-Bukkit-53fac9f]
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:133) [bukkit.jar:git-Bukkit-53fac9f]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:289) [bukkit.jar:git-Bukkit-53fac9f]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.<init>(CraftServer.java:251) [bukkit.jar:git-Bukkit-53fac9f]
    at net.minecraft.server.v1_8_R3.PlayerList.<init>(PlayerList.java:69) [bukkit.jar:git-Bukkit-53fac9f]
    at net.minecraft.server.v1_8_R3.DedicatedPlayerList.<init>(SourceFile:14) [bukkit.jar:git-Bukkit-53fac9f]
    at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:179) [bukkit.jar:git-Bukkit-53fac9f]
    at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:503) [bukkit.jar:git-Bukkit-53fac9f]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_51]
     
  16. Offline

    MrGeneralQ

    Show me The content of plugin.yml
     
  17. name: AutoMute
    version: 1.2.2
    main: com.sulphate.automute.Main

    author: Sulphate​
     
  18. Offline

    MrGeneralQ

    Try removing The empty lines
     
  19. Online

    timtower Administrator Administrator Moderator

  20. Last edited: Dec 23, 2016
Thread Status:
Not open for further replies.

Share This Page