[ADMN/SEC/WEB] HawkEye [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by oliverw92, Aug 15, 2011.

  1. Offline


    sethgandy, phimt, matan7890 and 7 others like this.
  2. Offline


    Needs some work, still unsure about it. but it's making progress.
  3. Offline


    What is this?

    2011-08-21 01:12:31 [INFO] [HawkEye] Starting HawkEye initiation process...
    2011-08-21 01:12:31 [INFO] [HawkEye] Using Permissions for user permissions
    2011-08-21 01:12:31 [INFO] [HawkEye] Performing update check...
    2011-08-21 01:12:32 [INFO] [HawkEye] No updates available for HawkEye
    2011-08-21 01:12:32 [SEVERE] [HawkEye] Error whilst attempting to get connection: java.sql.SQLException: Access denied for user 'root'@'localhost' (using password: NO)
    2011-08-21 01:12:32 [SEVERE] [HawkEye] Error initiating HawkEye database connection, disabling plugin
    2011-08-21 01:12:32 [INFO] [HawkEye] Version 1.0.4 disabled!
    - 97
    - 98
        lava-bucket: true
        painting-place: true
        other: true
        pvp-death: true
        block-fade: true
        chat: true
        quit: true
        sign-place: true
        painting-break: true
        lava-flow: true
        flint-steel: true
        button: true
        command: true
        block-form: true
        teleport: true
        lever: true
        item-drop: true
        water-bucket: true
        block-burn: true
        sign-break: true
        block-break: true
        leaf-decay: true
        water-flow: true
        join: true
        door-interact: true
        block-place: true
        open-container: true
        item-pickup: true
        explosion: true
        container-transaction: true
        mob-death: true
        other-death: true
        max-lines: 0
        tool-block: '17'
        log-item-drops-on-death: false
        cleanse-age: '0'
        delete-data-on-rollback: false
        log-ip-addresses: true
        debug: false
        max-radius: 0
        default-here-radius: 5
        hawkeye-table: hawkeye
        port: 3306
        player-table: hawk_players
        username: root
        world-table: hawk_worlds
        hostname: localhost
        max-connections: 10
        password: ''
        database: minecraft
    version: 1.0.4
    - /login
    - /restartsrv
    - /register
  4. Offline


    I will probably use your config, but I really don't understand what "button" or "lever" is. I'm not particularly directing this question at you, but does it mean when a player interacts with one? Or when it is placed?
  5. Offline


    This would be interact.

    The biggest one I'm unsure myself is:
    Lava Bucket
    Water Bucket

    I assume he might have done separate logging for easy lookup?

    As there is also this:
    Lava Flow
    Water Flow

    And the Flow ones for sure you do not want heh.
  6. Offline


    I'm guessing it's just when a bucket (haha I hesitated because my hands wanted to spell "Bukkit") is used with either water or lava. I have protections set up so that it can't be used, but I have them on just in case. By no-lag, you mean "false" right?

    EDIT: Flow looks like just too much, but I guess the option is nice.
  7. I cant get it work

    hawkeye-table: bodocraft_table
    port: 25566
    username: bodocraft ---------------------->this is the username
    world-table: bodocraft_worlds
    max-connections: 10
    password: '**********'
    database: bodocraft
    version: 1.0.4

    I tried with hostame:cubehost.hu and cubehost.hu:25566 it didn't worked

  8. Offline


    I have had huge RAM errors with HawkEye, disabling everything to do with water and lava flow seemed to fix it.
  9. You left debug behind, that is with debug=false:

    11:57:25 [INFO] [HawkEye] open
    11:57:25 [INFO] [HawkEye] close interact
    11:57:25 [INFO] [HawkEye] open
    11:57:25 [INFO] [HawkEye] close interact
    11:57:25 [INFO] [HawkEye] open
    11:57:28 [INFO] [HawkEye] close interact
    11:57:28 [INFO] [HawkEye] open
    11:57:28 [INFO] [HawkEye] close interact
    11:57:28 [INFO] [HawkEye] open
  10. Offline


    You have to use the IP from the db and the mySQL Port (Default 3306)

    If the db runs on the same machine/VM as your mc server, try hostname: localhost.
  11. Offline


    Ok, I FINALLY fixed that: https://github.com/downloads/oliverw92/HawkEye/HawkEye v1.0.4.zip

    It means it is disabling itself on startup due to something. Please show me your console output when your server starts up

    Already planning to.

    Already planning to.

    I did quote you before - I can't replicate that bug at all.

    My bad, try this:

    INSERT INTO `datalog` (date, player_id, action, world_id, x, y, z, data, plugin
    SELECT date, player_id, action, world_id, x, y, z, data, plugin
    FROM `hawkeye`
    Dammit, thought I had fixed that issue with the filter order

    https://github.com/downloads/oliverw92/HawkEye/HawkEye v1.0.4.zip <- that version now hasn't got those messages

    It isn't connecting to the database for some reason. Can you show me your config.yml

    'Way too hard to install' - it is no different to BigBrother or LogBlock, apart from BigBrother using crappy flatfile by default (even N3X15 himself has said it was a terrible idea to make it H2 by default). If you have had so much experience with MySQL, you would understand storing millions of entries in a single file is a terrible idea and that using a proper DBMS is the BEST and most resource friendly solution.

    If you want me to help you, how about you actually give me some errors.

    Can you drop me a link to your UI in a pm with the password for it if one is set? I can directly debug it.


    I'll look into chest rollbacks.
    Doublechests are already linked in a way that the plugin is indifferent to whether it is double or a single.
    As I have told you before - I am overhauling the display manager for v1.1.0
    I have spoken with the WorldEdit devs. They weren't particularly helpful on the matter really - I said I would do anything they wanted to get a way to log worldedit stuff but it seemed like they couldn't really be bothered/didn't really care much for the idea. There is no way for me to do it without them making a proper event system.

    Did you try manually creating the tables...?

    Hm ok thanks.

    It already logs the commands, but if you want logging of their actual edits (like with tools etc) that won't be possible. I gave the reasons a few comments up.

    WorldEdit commands are already logged.

    Thanks :)

    Lava and water bucket is simply when someone places the bucket.
    Other is other plugins logging to HawkEye

    My database on my server has 70 million entries and still performs like it is a brand new database.

    It already logs the WorldEdit commands.

    Please say more than 'it needs some work' - suggest features, problems etc.

    I'll add in op permissions for v1.1.0 . For now, just use bukkit's built in permissions.

    'Access denied for user 'root'@'localhost'' - your username or password is wrong for your database.

    Flow logs whenever a block flows from one block to another. So if someone places a bucket, that will then trigger a series of flow logs.

    The port doesn't go on the end of the hostname, it goes in the 'port' field.

    Also that error is being caused because you have used tabs in your YAML file. Use spaces, not tabs.

    Interesting. Do you mean you had huge ram usage?

    Re-download, it's now

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016
  12. Offline


    @oliverw92 Thanks for taking the time to answer so many questions. I appreciate that.
  13. Offline



    Server would crash around 15 minutes after startup with OUTOFMEM errors. This has seemed to minimize it, however there is still heavier ram usage than BB and it will still happen after a while
  14. Offline


    Interesting, how much memory is your server running on
  15. Offline


    I want to confirm that there's a memory leak in this plugin. A pretty big one in my opinion. I run a 10gb server with about 90+ people online on average.

    The memory leak is pretty severe because where I normally can handle about 120 people without lag, the server couldn't hold even 40 people and it was co tangly crashing.

    I DON'T suggest this plugin. Stay at BigBrother for now, since this plugin will badly impact your server experience and performance.

    I hope the developer of HawkEye can resolve this since I don't feel I can enjoy the plugin in anyway now.

  16. Offline


    4gb. But like the above poster said, a memory link may be the problem as it will always crash after a while with RAM errors.
  17. Offline


    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'SELECT date, player_id, action, world_id, x, y, z, data, plugin FROM `hawkeye`' at line 2
    INSERT INTO `datalog` ( date, player_id,
    ACTION , world_id, x, y, z, data, plugin
    SELECT date, player_id,
    ACTION , world_id, x, y, z, data, plugin
    FROM `hawkeye` 
  18. Offline


    We just switched to HawkEye and so far, really awesome :) I love the web interface.

    I do however wonder if it would be possible to make players provide their own log for /hawkeye tool like the newer version of BigBrother does? This will prevent players from cloning wood for free using scripts.

    Thank you!
  19. Offline



    Us trying a full rollback of a player: (/hawk rollback p:xyz)

    Probably doesnt help a lot, but maybe it hints to some memory issues?

    # A fatal error has been detected by the Java Runtime Environment:
    #  SIGBUS (0x7) at pc=0x00000033ffe7c39b, pid=1206, tid=1101367616
    # JRE version: 7.0-b130
    # Java VM: Java HotSpot(TM) 64-Bit Server VM (21.0-b02 mixed mode linux-amd64 compressed oops)
    # C  [libc.so.6+0x7c39b]  memcpy+0x15b
    # Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
    # An error report file with more information is saved as:
    # If you would like to submit a bug report, please visit:
    #   http://java.sun.com/webapps/bugreport/crash.jsp
    # The crash happened outside the Java Virtual Machine in native code.
    # See problematic frame for where to report the bug.
  20. Offline


    I would kindly ask that you don't tell people not to use my plugin - currently only 2 people have brought up memory issues - everyone else is running fine and happy. Instead give me a chance to maybe help you fix the issue before telling people not to use it.

    Could you do the following:
    • Is your server running with proper garbage collection - please try the following (adjust the memory amoutns for your server): -server -Xmx12000m -Xms12000m -Xmn4500m -XX:+DisableExplicitGC -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:+UseLargePages -XX:+AggressiveOpts
    • Try disabling lava and water flow logging
    Please report back how these two things impact memory usage.

    Ok thanks.

    My bad:

    INSERT INTO `datalog` ( `date`, `player_id`, `action` , `world_id`, `x`, `y`, `z`, `data`, `plugin`
    SELECT `date`, `player_id`, `action` , `world_id`, `x`, `y`, `z`, `data`, `plugin`
    FROM `hawkeye
    I will add a config option to stop giving people the tool if they don't have a log. This should be in v1.1.0

    That does suggest to me it could be something to do with retrieving large amounts of results from the database. Could you run this query from me and tell me the result:

    SELECT count(*) FROM `hawkeye`, `hawk_players` WHERE `hawkeye`.player_id = `hawk_players`.player_id AND `hawk_players`.player = 'xyz'

    This will tell me how many results it tried to retrieve and whether that could be the cause. How much memory are you running with?
  21. Offline


    Only 1004 results, I guess it was simply a freak coincidence. We run with 4608mb and some good GC arguments.
  22. Offline


    If it happens again let me know.
  23. Offline


    Do you know when 1.10 will be out? Id rather not go through all the trouble of setting a permission manager up from scratch to use one mod and have an update come out a few days later that invalidates the need.

    You may also want to add the fact that it needs a permission manager to the Reqs list so that people like myself don't upgrade while operating under the impression that it does not need one like Datalog.

    Is there a way to downgrade back to Datalog if this will take awhile as I actually have a pending issue I had been hoping to resolve last night?
  24. Offline


    v1.1.0 won't be out until the beginning of September. I have an exam I have to revise for which needs to come first.

    You don't need to set up a permission manager - permissions are built into Bukkit now
  25. Offline


    He's adding OP only permissions very soon, just be patient. Leave the plugin installed so it will still log things.
  26. Offline


    Your a goof. Suggesting BigBrother is the dumbest thing ever since another plugin performs much better.
  27. Offline


    I installed HawkEye and imported LogBlock logs. Both have default table names. However, when I create a tower of blocks and use the /hawk tool to check the logs, it keeps saying "No results found." If I can get help on this, it would be much appreciated. Thank you.
  28. Offline


    Still not working that query

    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'SELECT `date`, `player_id`, `action`, `world_id`, `x`, `y`, `z`, `data`, `plugin' at line 2
    INSERT INTO `datalog` ( `date`, `player_id`, `action` , `world_id`, `x`, `y`, `z`, `data`, `plugin` SELECT `date`, `player_id`, `action`, `world_id`, `x`, `y`, `z`, `data`, `plugin` FROM `hawkeye
    Still not fixed that filter and I grabbed from your fixed console messages link.
  29. Offline


    Now now, everyone is entitled to their opinions.

    Could you tell me if it does the same thing if you start from a fresh installation? Is stuff being added to the database?

    The filter wasn't meant to be fixed in that. Unless you need it urgently I won't be doing it until v1.1.0 now.
  30. Offline


    I'll try it in a couple of hours and let you know.
  31. Offline


    I Agree but trying to convince people to use something even worse is not an opinion but stupidity :p

Share This Page