[ADMN/SEC/WEB] HawkEye [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by oliverw92, Aug 15, 2011.

  1. Offline


    sethgandy, phimt, matan7890 and 7 others like this.
  2. Offline


    I tried that sql query as its server quiet time but duplicate primary id's

    #1062 - Duplicate entry '1' for key 'PRIMARY'
    INSERT INTO `datalog`
    SELECT *
    FROM `hawkeye`
    Max filter still showing earliest.

    But we can manage with the calendar till its done.

    I don't like the console interact usage serverlog spam in the new version.

    Can we get that hidden from console.

    04:56:32 [INFO] [HawkEye] open
    04:56:34 [INFO] [HawkEye] close interact
    04:56:35 [INFO] [HawkEye] open
    04:56:39 [INFO] [HawkEye] close interact
    04:56:39 [INFO] [HawkEye] open
    04:56:49 [INFO] [HawkEye] close command
    04:56:49 [INFO] [Warpz0r] drguild teleported to abby
    04:57:00 [INFO] [HawkEye] open
    04:57:11 [INFO] [HawkEye] close interact
    04:57:11 [INFO] [HawkEye] open
    04:57:15 [INFO] [HawkEye] close interact
    04:57:15 [INFO] [HawkEye] open
    04:57:17 [INFO] [HawkEye] close interact
    04:57:17 [INFO] [HawkEye] open
    04:57:19 [INFO] [HawkEye] close interact
    04:57:19 [INFO] [HawkEye] open
    04:57:20 [INFO] [HawkEye] close interact
    04:57:20 [INFO] [HawkEye] open
    04:57:21 [INFO] [HawkEye] close interact
    04:57:21 [INFO] [HawkEye] open
    04:57:22 [INFO] [HawkEye] close interact
    04:57:22 [INFO] [HawkEye] open
  3. Offline


    Hmm Ok I'll think about that and I will create a mysql server on my computer.
    But I have another question - does Hawk support Pickup and Drop Items event (Compared to the BB plugin)?
    If it is, I'll change to that plugins ASAP
  4. Offline


    Got this err on startup:

    2011-08-20 23:16:25 [INFO] [HawkEye] Starting HawkEye initiation process...
    2011-08-20 23:16:25 [INFO] [HawkEye] Using Permissions for user permissions
    2011-08-20 23:16:25 [INFO] [HawkEye] Performing update check...
    2011-08-20 23:16:25 [INFO] [HawkEye] No updates available for HawkEye
    2011-08-20 23:16:30 [INFO] Connection reset
    2011-08-20 23:16:38 [INFO] Connection reset
    2011-08-20 23:16:46 [SEVERE] [HawkEye] Error whilst attempting to get connection: com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure
    The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.
  5. Offline


    Yes, it does.
    matan7890 likes this.
  6. Offline

    Cody Pawlowski

    Great idea, but the plugin overall is WAY too hard to install. Please make an easier setup and I will download. For now I'm sticking with BigBrother...
  7. Offline


    I literally dropped the jar in and setup the config file and it's all working.
  8. Offline


    Great plugin, however I can't seem to get the web UI working.

    It works to the extent that I can access it ok & it lets me login with my chosen password, but when i search it doesnt bring up any results, it just keeps searching and saying "Results" with the scrolly bar going across.

    I am using the latest version freshly installed today, and it works perfect in game. I also have the latest (1060) version of bukkit.

    Any ideas?
  9. Offline

    Cody Pawlowski

    You need to set up an entire MySQL database and after I did that, none of the commands worked or anything. Any suggestions? MySQL installation help? Thanks
  10. Offline


    Just to quote myself again:

    (it helps to read a thread ;) )

  11. Offline


  12. Offline

    Cody Pawlowski

  13. Offline


    No you are a noob. If you didn't setup the username/passworld/database name in the config.yml it won't work.
    This creates its' own tables beautifully, and works effortlessly.
    You also need to setup the permission nodes for the commands to work.
    But basically, it wouldn't have been easier if HawkEye just used "flatline" because you'd still have issues installing it, plus you'd be posting here going "MySQL PL0X!!?!11"
  14. Offline

    Cody Pawlowski

    I'm a java and C++ coder and I've been using MySQL for years. Don't call me a noob, noob. End of story.
  15. Offline


    Yet you can't setup a config file and can't post more of an error than "it don't wurk!?"; Perhaps you could fork hawkeye and make it "flatline" instead. Noob.
  16. Offline


    working great been running for 2 days now no problems, i really like the webui as well helps when lotta stuff going on ingame, thx alot!!
    codename_B likes this.
  17. Offline


    I agree, love this plugin! :D
  18. Offline

    Cody Pawlowski

    Mmhmm. Kthxbye

    Spamming my console with this error:

    19:55:09 [SEVERE] [HawkEye] Unable to add player to database: com.mysql.jdbc.exc
    eptions.jdbc4.MySQLSyntaxErrorException: Unknown column 'player' in 'field list'
    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016
  19. Offline


    Just want to report back after running with no restarts since last night, after we removed HawkEye and reverted to BigBrother our ram useage has been staying stable at 3GB as opposed to 4.4GB (in 30 minutes) with nearly no cached ram available. I hope you find the cause of this as I would love to use your plugin :)
  20. Offline


    Great Plugin, but would it be possible to log Worldedit activity? We sometimes get a rouge moderator on the loose with worldedit, and we have no means to catch them. If it is possible to log worldedit, this would be the best plugin ever.
    Jobsti likes this.
  21. Offline


    sounds like the best way to protect from that is only give moderator powers to people you trust
  22. Offline


    Try setting -Xmn####G to 3/8ths of your -Xmx####G If you havent already.
  23. Offline


    This. The command logging was the very reason I switched from BigBrother to HawkEye. I really need a way to track who does what with WorldEdit.
  24. Offline


    Witch of the anti-greifers plugins is most light weight
  25. Offline


    @oliverw92 Trying to see if my mods are willing go for the switch. I was wondering if you had a demo of the web interface by any chance?

    EDIT: Thanks to @Monstertke I got a tour of this feature. Very sexy!
  26. Offline


    World edit directly edits the World files. AFAIK there is no way to log this. Set up your block filtering, Block lava water, and physics objects. and set max blocks to something reasonable? World edit is the most dangerous tool there is. My server is at 99.79% uptime in 4 months, If I didnt have World Edit it would be at 99.9x.
  27. Offline



    That would be a great name for a plugin that restarts the server if it locks up/crashes :D
  28. Offline

    Cody Pawlowski

    Lmao, you're right
  29. Offline


    So after talking to a few my mods we don't get much griefing and we for a large server want the best performance. I assume enabling all features is just going to bite us in the ass.

    So I was thinking only enabling the following for basic and pretty good protection:
    Block Break
    Block Place
    Sign Place
    Teleport - NO LAG
    Lava Bucket - NO LAG (Or is this just the source spot only?)
    Water Bucket - NO LAG
    Door Interact - NO LAG
    PVP Death
    Flint Steel
    Lever - NO LAG
    Button - NO LAG
    Other (What is Other?)
    Explosion - NO LAG
    Block Burn - NO LAG
    Block Form - NO LAG
    Leaf Decay - NO LAG
    Mob Death - NO LAG
    Other Death - NO LAG
    Item Drop - NO LAG
    Item Pickup - NO LAG
    Block Fade - NO LAG
    Lava Flow - NO LAG
    Water Flow - NO LAG
    Chest Transaction
    Sign Break
    Painting Break
    Painting Place

    Does my thinking seam about right?

    Also how many million lines in the database do you think we can hold?
  30. Offline


    I don't need to have rollback ability, but can't it at least log that the command was used and who it was used by? This isn't possible in WorldEdit's API?
  31. Offline


    Just upgraded to Hawkeye from Datalog Thursday. For wahtever reason I used to be able to use Datalog just fine. Now when I try to use Hawkeye in my client I get back

    "You do not have permission to do that!
    /hawk help"

    I do not use any type of permission manager or mod. I am Op.

    When I decided to use the console instead, every variation of every command I have tried except for hawk help responds with "/hawk help". The only time it does not is when I do not specify parameters like "hawk search" will net me the help page for search.

    What am I doing wrong? Does this require a permission manager that I didn't see on the first post?

Share This Page