Inactive [ADMN/SEC] Regios v5.0.01 - Advanced Region Management! + Multi-World, Protection + More![1.0.1-R1]

Discussion in 'Inactive/Unsupported Plugins' started by Adamki11s, May 3, 2011.

  1. Regio's - Advanced Region Management! + Multiworld support, protection, entry control, health control, movement control, custom messages and more!
    Version : 5.0.01

    Changelog :​
    Version 5.0.01 : Fixed NPE's regarding ChunkGrids & Regions​
    Version 5.0.0 : Updated for 1.0.0 and fixed glaring protection issues.​
    Version 4.0.80 : Mobs Fixed and Economy Support for iConomy6 (Thanks to Pianosaurus)​
    Version 4.0.71 : Complete Recode.​
  2. Offline



    now i have another problem, i can create regios only when my nickname are in the ops.txt but the Admin group has the perm node "regios.restrictions.none" and the Mod group has this perm nodes:*

    but they cant regios too...

    I use Cb1337 with PEX (mysql)
  3. Offline


    I dont have essentials

    Is it possible that there are plugins other that can conflict with this? i have the plugins (its a lengthy list):

    CookieMonster(Gives you money when you kill monsters)
    Craftbook Package(Ive had this for a while and it wasnt conflicting with regios
    Darkbrotherhood(almost certain its not this, i got this after the regions broke)
    iConomy 6
    MonsterBox(lets you change what a mobspawner spawns)
    NoExp(gets rid of orbs when you die)
    NoLagg(deletes orbs on the enter of a command)
    PermissionsEx(i am positive it isnt this)
    Sortal(for some reason this broke too)
    WhichMob(controls what mobs are allowed to be spawned)

    If you actually take the time to figure this out i will praise you!
  4. What nodes should I use for users? I want them to no create regions, only buy and sell them, and don't break regions that are protected, because I create a region, I protect it, I expandmax it, and people can still break it. Help!
    [Postoff: Im the user that has made the page 100 of this plugin yay!]
  5. Offline


    Please help..:(
  6. Offline


    With Spout edit GUI when I change page it overlaps with the previous... it's only for me or it's a bug?
  7. Offline


    It's a known bug.
  8. Offline


    I closed my server down and I dont wanna open it until the protection is fixed pleas hlpe me with it
  9. Offline


    I'm really unsure of what it could be. Might be a permissions error, or a conflicting plugin. Hard to say.
  10. Offline


    do you think it would fix if i re-downloaded it?

    Also, how can i set it up so certain regions people can fight and in others people can't?
  11. Offline


    If you don't have a lot of regions, you might try reinstalling the plugin and setting them up again.

    Use the pvp flag to set pvp enabled or disabled. Check the wiki.
  12. Offline


    Ihave 28 regions yikes but im willing to do what it takes to fix it :pthanks

    cant i just keep the files for my regions and get rid of the rest?

    is this plugin compatible with permissionsex?

    I completely deleted regios, i made a new region, protected, got rid of all of my op status, and i could still break it!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
  13. Offline


    You got rid of OP, but did you remember to put youself in a non-admin permission group?
  14. Offline


    yeah, and i even set the region owner to another player
  15. Offline


    how does one add music urls to regions

    Add a music URL to the collection that will be played whilst inside a Region.
    /regios add-music-url <Region> <URL> []
    Remove a music URL from the collection.
    /regios rem-music-url <Region> <URL>[]
    Resets the list of music URL's.
    /regios rest-music-url <Region> []
    in a real general way this says it uses urls... but when i tried to type in some examples it wont work and when i use /regios edit <region> on page 7 the space is too small for anthing other then a shortened url like

    any suggestions?
  16. Offline


    I tried switching to BOSEconomy to fix the /buy issue.
    It just claims that I have insufficient funds..
  17. Offline


    I'm willing to pay to have these issues resolved. It's understandable seeing as it compatible version is 1185.
  18. Offline


    Yep. Is there a way to donate? Perhaps set up a bounty? I really don't want to switch to WorldGuard, but my users are getting impatient.
  19. Offline


    Hey, how to show who is whitelisted at the difrent regios? I dont found anything in the database...
  20. Sorry I have been very busy IRL and the new Minecraft versions have caused lots of problems. There are various donation methods listed in the initial post. I will try to fix these over the weekend, even sooner if I can. Could you please post a list of all problems you are encountering so I can check them out. Thanks.
  21. Offline


    One of the big ones right now is the /r buy problem.
    I did some more testing, and it buying a propery with the price set to zero works with BOSEconomy.
    I did check out the code, but as a .NET developer I have no idea on how to build and debug the code, so I guess there is little reason for me to mess around with it.
  22. Ok, if you could provide me with some stack traces so I can find the cause of the problem that would be very helpful. I'm also going to add some mass commands for main properties such as protection as well as adding endermen and other new creature spawns.
  23. Offline


    I do not get any console output at all. It seems like it fails the balance check in both iConomy and BOSE, and then refuses to sell me anything.
    Is there a way to get a debug build, or maybe even some help setting up my environment so I can debug this? (Eclipse with the code loaded via Git is in place already. Unsure about the next step, as java is not my usual environment)

    I checked some old logs. This was from when I tried buying a region with iConomy:

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
  24. Offline


    hey lars i tried testing to see why regios protection is not working, i put on no plugins except regios, protected it again and people are still able to break from it! I think its caused by permissionsEX

    EDIT: I played again without permissionsEX and it still lets non ops break stuff i am seriously getting frustrated. I tried looking for another protection thing and theyre all either too complicated or not complete enough to use well.
  25. Offline


    We get this error when loading the plugin. We must reload the plugin individually for it to work.

    I'm not sure if it's related but after awhile it will stop working, and can only be fixed by restarting the server and then again reloading the plugin.

    We've had alot of issues with spout after its recent updates, the spout menu is the only option we provide for people to edit their regions. Would be great if it could be tidied up a bit.

    Donation coming your way mate :)
  26. Thank you. I got your donation and really appreciate it :).

    I need to have a look at the new spout changes which has caused issues with the GUI menu.

    All you need to do is compile with Java and test on your server. You don't have to worry about this though as I will be doing lots of testing.

    Are you sure you're configuring permissions right as other servers running permissionsEX have no problems.
  27. Offline


    Ok. I will ahve to brush up on the fundamentals then. I would really like to be able to debug the plugins my server runs anyhow, so it will be good training.
  28. Offline


    To test, i made a completely new server. I added only the plugins regios and permissionsex. then, i created an admin and member group (correctly using in-game commands) and made it so admin had all permissions. I made it so the Member currently had modifyworld.* I created a test region, protected it, and to test i had my brother log in. He was still able to break the blocks. Then i deleted the permission to modifyworld.* and he could still break them.

    EDIT: Now I deleted ALL plugins except for regios. I set the config so that it has ALL protections and then I made a region. I marked the owner as my brother, protected it, deoped myself, and i COULD STILL BREAK IT. SO ITS NOT PERMISSIONS. Also, i think we are at different time zones and thats why its difficult for us to talk.
  29. Hopefully should be fixed now.
  30. Offline


    get this error please help
    2011-11-11 15:42:07 [SEVERE] Error occurred while enabling Regios v4.0.71 (Is it up to date?): null
    at couk.Adamki11s.Regios.Checks.ChunkGrid.<init>(
    at couk.Adamki11s.Regios.Regions.Region.<init>(
    at couk.Adamki11s.Regios.Data.LoaderCore.loadRegions(
    at couk.Adamki11s.Regios.Data.LoaderCore.setup(
    at couk.Adamki11s.Regios.Data.CreationCore.setup(
    at couk.Adamki11s.Regios.Main.Regios.onEnable(
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(
    at org.bukkit.craftbukkit.CraftServer.reload(
    at org.bukkit.Bukkit.reload(
    at org.bukkit.command.defaults.ReloadCommand.execute(
    at org.bukkit.command.SimpleCommandMap.dispatch(
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    at net.minecraft.server.NetServerHandler.handleCommand(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.Packet3Chat.a(
    at net.minecraft.server.NetworkManager.b(
    at net.minecraft.server.NetServerHandler.a(
    at org.getspout.spout.SpoutNetServerHandler.a(
    at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    at net.minecraft.server.MinecraftServer.h(
  31. Have you tried downloading the newest version? I did an update last night which should have fixed this.

Share This Page