Inactive [ADMN/SEC] Regios v5.0.01 - Advanced Region Management! + Multi-World, Protection + More![1.0.1-R1]

Discussion in 'Inactive/Unsupported Plugins' started by Adamki11s, May 3, 2011.

  1. Regio's - Advanced Region Management! + Multiworld support, protection, entry control, health control, movement control, custom messages and more!
    Version : 5.0.01

    Changelog :​
    Version 5.0.01 : Fixed NPE's regarding ChunkGrids & Regions​
    Version 5.0.0 : Updated for 1.0.0 and fixed glaring protection issues.​
    Version 4.0.80 : Mobs Fixed and Economy Support for iConomy6 (Thanks to Pianosaurus)​
    Version 4.0.71 : Complete Recode.​
  2. I'd recommend you run #818 this is not compiled against 820 and 820 is not supported or recommended so may have some bugs.
    Correct :)
    Let me know what's going wrong? I'm coming on now.
    rockxz2135 likes this.
  3. Offline


    I reverted back to 818 and they can still break but not place blocks.
  4. Offline


    I have this exact same problem! Lucky i decided to log in an alt account to test permissions! I destroyed parts of my "protected" road. CB 818. Users can destroy but not build when a region is protected. A fix would be nice! I don't want my "Spawn Shop" to turn to rubble.
  5. Offline


    I updated the plugin by deleting the old regios.jar, and replacing it with the new and when i restarted the server i went on and typed /plugins to make sure everything was running then i tried to protect some plots and when i typed a regios command it wouldnt respond with anything. and it still doesnt.
    What is your IGN(in game name)?
  6. Offline


    Mobs still don't spawn in subregions of regions where mobspawn is set to off.

  7. Nope, not working for me. Also i may have a problem with multiworld still (players are walking into zones that they have no permission to build in, guessing its Regios), although i havent tried 3.4 yet; i'll get back to you on it once ive got 3.4 working.
  8. Offline


    First of all, gr8 plugin, nicely done and easy to use. But i have a problem. When i set mobspawn for a region to true, it doesn't stay that way when i restart the server. Is that supposed to happen or did i missread something?
  9. Offline


    That plugin is really good. It's a great idea with a lot of potential. I tried it and i love it! I have some little ideas of little things you might add to it. The first one (which is more a request because i need it) is a command to change the light of a region. Let me explain: I made a big ..... box which contains 2 stargates (using the wormhole plugin) the walls the ceilling and the floor is made only of blocks of diamond. But its really dark in there so i tried placing torches on every block but it's still dark. So i'd like to make a region which would contain all the blocks and see in it like if it was day light. Like if light was coming from nowhere. Another idea: forbid some objects in a region and give them back when living it. I had other ideas but i can't remember them right now. How ever this plugin is wonderful and i hope it will continue to evoluate. Good luck ;)

    Ps: sorry for my bad english i'm french and it's nearly 01h30 in the morning so i'm a little tired ^^
  10. Offline


    i have found a bug!
    When i set mobspawn to true for a region it works until i reset the server! then its back to false!
    Please Fix!
  11. Please re-download. Updates so mobspawn settings now save and blocks cannot be placed in protected regions.
    AS1LV3RN1NJA likes this.
  12. Offline


    You mean so blocks cannot be broken?
  13. Yes, protection works as intended again
    AS1LV3RN1NJA likes this.
  14. i am really looking forward to this update.
    do you have any specific plans on how to tie in an economy?

    i was hoping for region prices based on squareblocks of the area (optional of course),
    it would also be pretty neat if region settings could charge money... i.e.: setting up your region to regen HP costs $100 a block...
    further more, an option to rent out properties and/or tax regions would be awesome too :p
    i know this is a lot at once, and i am not expecting you to implement them in, but i'm just throwing them out there :p

    edit: i guess the square block concept isn't very clear... what i mean is: the initial claim should cost a player money. that money will basically be charged by the server, so just disappears. but that way it's easily avoided that someone goes ahead into an unclaimed area and claims a huge area just to set it to push people out or something (basically griefing)...
    anyways, once claimed, the owner of the region can sell (or rent out) the region or several sub regions for a price that he sets.
  15. Yeah I think those features would be nice to include and while I work on 3.5 I will probably add quite a few features in along with rent and cost to update certain properties, I have a few API's which I will be support with v3.5 including EconomyCraft, iConomy and BoseEconomy. The initial release will probably be a stable base and then I can build on from that to add more advanced features.
    xelotar likes this.
  16. Offline


    Did that, didnt help. :(
  17. Someone else is getting this error as well. If you stick it on a test server it'll work fine, it works fine on mine and on the guys I was testing with. His server runs McMyAdmin which I think might be the cause. Could you please give as much detail as possible so I can find a solution to this problem. Like what website your server is hosted on, plugins running, if you use mcmyadmin or myabe some other form of wrapper. Also you can try downloading and older version of region and sticking with that one for now, and e-mail your server host, they might have a solution.

    I was doing a search for similar problems and found that renaming your craftbukkit.jar file will help stop this. So change the file-name from craftbukkit -0.0.1.SHAPSHOT or whatever it is to CraftBukkit of something simple. Then remember to also modify the name of the Jar file from that the .bat file points to the start the server.

    I just downloaded a fresh version of craftbukkit myself and compiled against that so try now.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  18. Offline


    Hi, I installed your plugin today and I'm having some issues:

    - When I download the latest version (3.4), and start up my server, I get an error message after it creates the regios folder in my plugin directory. When I check the folder (I have repeatedly re-download/re-installed multiple times - still get the same problem), the config file is missing.

    - I tried to counter this by installing a previous version (3.2 - which works PERFECTLY), keeping the config file from that, then just switching the jar file to the most recent version, which sort of works, in that I can now access 3.4 features and commands when I initially reboot my server (+ there seems to be no errors visible on my server cmd on startup). However when I try to perform certain commands in-game, or restart my server again, the plugin reverts all the changes I make, or simply doesn't acknowledge them, so I'm stuck with the config I made from 3.2

    I really love this plugin (from what I've seen in 3.2), and I would really like to use the updates in 3.4

    Any suggestions?
  19. @Paddy07 I don't know why your getting this error with the config file because it's bundled inside the Jar. I assume you're talking about the plugin.yml file? I understand what you mean about the updates :p

    For the download, i know you have tried but try using this link Release/Regios.jar I just did a minor update so it might help. Could you also paste the error message you get, that would help a lot, and if your still having trouble I can come onto your server and help out :)
  20. Offline


    I've got the same problem... Can't make it run :(
    2011-06-10 15:57:29 [INFO] [Regios] - v3.4 - Permissions support enabled
    2011-06-10 15:57:29 [INFO] [Regios] - v3.4 - SQL Tables created on first run.
    2011-06-10 15:57:29 [SEVERE] Error occurred while enabling Regios v3.4 (Is it up to date?): null
        at me.Adamki11s.Regios.RegiosFileManager.backupDatabase(
        at me.Adamki11s.Regios.RegiosFileManager.startupProcedure(
        at me.Adamki11s.Regios.Regios.onEnable(
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(
        at net.minecraft.server.MinecraftServer.e(
        at net.minecraft.server.MinecraftServer.a(
        at net.minecraft.server.MinecraftServer.init(
  21. Fixed, please re-download.
  22. Offline


    WoW! That was quick :D SuperB job!

    Now I'll go back to work hehe... Instead of working (php dev. =]) I do minecraft server lol :/
  23. No problem, I'm trying to get all of these bugs ironed out ASAP :D
  24. Offline


    Well, i did everything you said but still... I think its because the craftbukkit, or other jar files... I deactivated most of the plugins (only ones left were chest protection,and authentication), but still..

    Btw- Im really grateful for you tryng to help me :)
  25. The other person who was having this issue downloaded the new version and it worked for him :S

    Try whacking it on a test server and work up from there ;)
  26. Offline


    You are a legend! That download link magically solved my missing config.yml file, and now all is well.

  27. Offline



    can you make a option for true or false on protection on Lava and water?
  28. Offline


    how come i cant use water in regios areas?
    and how do i fix this?
  29. I know about this and am working on a fix now.
  30. Offline


    OK thanks your plugin is great btw :)
  31. Thank you :D

Share This Page