Inactive [ADMN/SEC] Incraftible v0.10 - Superperms-based Crafting [Spout] [1.1-R3]

Discussion in 'Inactive/Unsupported Plugins' started by taufiqkh, Aug 18, 2011.

  1. Offline


    Version: 0.10

    Download the plugin
    Source code for the devs
    Development build for the risk-takers on the bleeding edge (for 1.2)

    Provides permissions-based control of crafting for items and item groups. Runs on the Bukkit permissions API (Superperms), tested with bPermissions and PermissionsEx. It's Incraftible!

    • Fine-grained control over all known Bukkit materials
    • Configurable message*

    • Incraftible uses server-side Spout for its inventory crafting events as it allows for a simple, straightforward event listener.

    Incraftible has been tested with the following:
    • CraftBukkit recommended build #1.1 RB-3
    Other users have found Superperms and Permissions to sit happily side-by-side, but there have been reports of problems with the Permissions * wildcard. I have found issues when using PermissionsBukkit with the latest releases of Bukkit, and it is currently unsupported.


    Configuration of who can craft what is done via Bukkit permissions. All standard Bukkit materials are supported, and crafting of all standard items is enabled by default. You can disallow crafting of an item by settings its incraftible.craft node to false. For convenience, several permission nodes have been created that control permissions on a number of objects. These nodes are set in the standard permissions.yml file that Bukkit uses:

    A full list of permission nodes can be found at

    As an example, the following will create a permission node that disallows all tools greater than stone and all armor greater than leather:
        description: Restrict to basic tools and armor.
        default: true
  *: false
  *: false
  *: false
            incraftible.craft.armor.iron.*: false
  *: false
            incraftible.craft.armor.diamond.*: false
    Configuration of the plugin itself is via plugins/Incraftible/config.yml. Default behaviour is controlled by setting craft.default, which accepts the following values:
    • none disallow all crafting by default, using permissions to allow specific objects
    • all allow all crafting by default, using permissions to disallow specific objects
    The disallow message is configurable:

        disallowed: "You are not allowed to craft %s"

    Older versions (open)


    • Add control over remaining material data values.
    • Add material bundle entries for data values.
    • Investigate difficulty of adding control to furnace events.
    • Add more meaningful headers for config files.
    • Add support for purely id-based permissions.
    * Just the one, for now.
    fluxboy8 likes this.
  2. Offline


    First thanks for this. The way I have my server set up, this is very useful. In the todo you have stated something about difficulty with furnace events. So I'm not sure if that is why these aren't listed, but thought I'd mention it. I don't see steak or cooked chicken on this list. If you solve your issue with furnaces, would definitely like to see these items if possible. Thank you.
  3. Offline


    Yes, this only works on crafting, not furnaces. Steak and cooked chicken are controllable if you can craft them (through other plugins that allow custom recipes) using cooked_beef and cooked_chicken respectively, but not through furnaces.
  4. Offline


    It's the same for me, i'm using PermissionsEx but this nice plugin seems to be incompatible
  5. Offline


    First thanks for this plugin. It's very good and easy to use.
    But I have problems with some craft. For default group I define incraftible.craft.standard on false. For registered group I define incraftible.craft.bread, and incraftible.craft.wood_axe. In registered group I can craft bread but not wooden axe. I don't understand why.
    I check and recheck, but I don't found.

    Thanks to help

    Server run on RB-3 and use Superperms implementation.
  6. Offline


    Should work with all superperms compatible permissions plugins, but I'll take a look at PermissionsEx.

    Edit: I haven't been able to reproduce problems with PermissionsEx, seems to work for my minimal test config. As an example, I set the following in Incraftible's config.yml:
    craft.default: none
    That tells incraftible to treat all items as disallowed unless told otherwise. I then set the following for the PermissionsEx permissions.yml:
    permissions.yml (open)

    default: true
    - modifyworld.*
    - incraftible.craft.bread
    - incraftible.craft.wood_axe
    - registered

    This creates two groups, a default group that does not have permission to craft anything, and registered group that can craft wood axes and bread. Obviously this is a very simplified configuration - if you are having specific issues, then the easiest way for me to verify is for you to post your config, preferably in a spoiler but alternatively off-site.
    Hmm, ok, I'll take a look. Do you use any plugins for permissions? If you are using PermissionsEx, my reply to tellus30 should help.

    Edit: There have been issues with PermissionsBukkit with the latest Bukkit RBs. As PermissionsBukkit has not been updated for some time, I have some difficulty fixing some issues with it.
  7. Offline


    Thanks you, it works very good ;)

    Can you show me what objects are allowed by permission "incraftible.craft.standard" ?
  8. Offline



    My server is now totally dependant of your plugin

    I need you !... for upload in 1.2 ;)
  9. Offline


    The incraftible.craft.standard permission is intended to cover all objects that can normally be crafted in minecraft. It is a parent permission of the individual crafting permissions, so there are sometimes issues when it overlaps with another permission, or where a permissions plugin does not handle parent/child permissions well.

    Hopefully it works well for you! When I last checked there wasn't a 1.2 compatible version of Spout, so I wasn't able to test this against it. Once that is released (if it isn't already), you can try the current version of Incraftible (0.10 at the time of writing), or the developer version at Note that this version is not guaranteed to stay as it is - I update it on a regular basis when testing against new versions of Bukkit.
  10. Offline


    There is a Beta build who's very stable here :

    You can test with this perhaps ?

    The current version of Incraftible does not work with this Beta Build. I will test with the developer version.
    Edit : no work:(, with the developer version of spout plugin.
  11. Offline


    I've recompiled and updated the dev version. Seems to run against spout dev build #920 and Craftbukkit beta 1.2.3-R0.1 Can you try again, and post any error logs that come up?
  12. Offline


    OK :

    When a user wants to log in, a message appears "deconnected by server, you moved too quickly :( (hacking?)"

    Run with craftbukkit beta 1.23-R0.1, spout dev build #920 and your last dev-version
  13. Offline


    That's not my plugin, I don't do any movement checks whatsoever. Could be an automatic check for max speed that the server does.
  14. Offline


    But if i have not your plugin, we have never this message. Probably an imcompatibility with another plugin.

    Use Pex, Essentials, Modifyworld, Minequery, ChatManager.
  15. Offline


    Could be... so if you remove Incraftible, you don't get the messages any more? Were there any other changes made at the same time that you added Incraftible?
  16. Offline


    No, just your plugin + spout.

    If i remove Incraftible, i don't get this message.
  17. Offline


    Ok, thanks for checking. So it doesn't happen with Spout but not Incraftible? I've found other reports of this happening with Spout, but so far no reasons why. Will continue to investigate.

    I'll also try to reproduce the issue with the plugins you've listed.
  18. Offline


    I've tried with Spout only, without Incraftible. I don't get the message, but I have a bug with doors : it's impossible to pass a door.

    Maybe Incraftible-dev is stable, but Spout is the problem.
  19. Offline


    Thanks for checking that. There have been some recent changes to Bukkit that should hopefully mean that I can remove the dependency on Spout. I still can't be certain where the issue is but at least I can remove one possible cause of problems.

    Edit: Initial testing with the new changes has shown up a separate bug in CraftBukkit, for which I have submitted a patch.
  20. Offline


    I hope you can remove the dependency of Spout. Tell me here when you have news.
  21. Offline


    No great news so far. I found and fixed the Bukkit issue three days ago, but they don't seem to have looked at it since then. Raised a bug report as well (BUKKIT-1112), but nothing's happening as far as I can tell. They seem to be inundated with a lot of crap in amongst the valid bug reports, so it may take some time for them to get to it. Even then there's no guarantee that it will fix the issue that you're reporting - I haven't been able to pinpoint exactly where the problem lies, it just removes one possible cause.

    Edit: I have uploaded a temporary version with a workaround for BUKKIT-1112:

    I will take it down once the issue has been fixed.
  22. Offline


    Hi taufiqkh ! Is it possible to block custom recipes? By using the data number? Custom items from MoreMaterials plugin use the ID 318 and a data number.
  23. Offline


    That may be tricky, depending on how MoreMaterials represents the items - I won't support anything that introduces new dependencies. Do you have a link to the plugin? What does it require?

    Edit: Have you tried the latest dev build?
  24. Offline


    The plugin permits to create custom items and blocks. It uses ID and data values. For example, one of my items is represented by 318:1102 values (ID 318 and data value 1102).

    The link : More materials

    Thank you
  25. Offline


    Thanks, looks like the main page is at the new Spout site, here. MoreMaterials has its own permissions for crafting (ie. morematerials.craft.materialName) - don't they work?
  26. Offline


    Uh. The permissions system of Morematerials seems to be recent. I had never seen it. Thank you I'll try that.
  27. taufiqkh: Can I use your sources because I want to update it. Thanks :)
  28. Offline


    This plugin seems completely broken for me, I tried to disable the crafting of diamond armor (As it's over the top since 1.0 :p) and I tried crafting it, and nothing stopped me, even wearing it worked.

    I did de-op myself, I also moved myself to the default group. (Using essentials groupmanager cos' I'm a noob at permissions lol)

    Here is the default group:

    The config:
    That last line was because I was un-sure of wether to put that line in the config, or in the permissions lol

    Thanks in advance :)
  29. Offline


    Source code is listed in the thread post -
    Would be good to get some updates, I don't have much spare time these days.

    Ha, no, work sometimes gets in the way unfortunately.

    Hmm, ok, could be due to the way groups are dealt with. Can you try the individual permissions, ie:


Share This Page