Inactive [ADMN/SEC] bPermissions v2.9.2 - no support on this post, ask for support on bukkitdev [1.2.5]

Discussion in 'Inactive/Unsupported Plugins' started by codename_B, Jul 21, 2011.

  1. Offline

    codename_B

    kahlilnc, Lappy, Gobiel and 4 others like this.
  2. Offline

    codename_B

    It doesn't work with old version of bukkitcontrib - they don't unregister permission nodes properly and it NPE's.

    The newest builds of BukkitContrib are fine, but I thought I'd just assume that most people are using out of date plugins to save myself grief in the long run.
     
  3. Offline

    Sh00ck

    ok :D i will try this Plugin now... WISH me Luck <.<

    [i failed at PermissionsBukkit xD because his Bridge Nodes ,....]

    Edit//
    @codename_B
    Oh WAIT :eek:?
    How can i give the ADMIN all Rights ...?
     
  4. Offline

    codename_B

    bChat is done - just fyi

    BukkitPermissions doesn't support the '*' node so you need to add the nodes individually.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 17, 2016
  5. Offline

    Sh00ck

    ._.
    TOP -.-
    The Plugin so so Good -.-
    I started to do the Nodes from Permissions 3.X to them..
    and then no * or anything <.<

    PermissionsBukkit Support that ?
    with :
    permissions.*
    and
    bridgeblububu.*

    Than you have ALL Permissions... :(
    Can you make that too ?
    @codename_B ?
     
  6. Offline

    codename_B

    Not without editing the craftbukkit source.
     
  7. Offline

    Sh00ck

    did you can't make that ?..
    Sorry but i need something like * ...
     
  8. He can't do it, it's the nature of the built in permissions. you could kinda do it by editing permissions.yml and adding a parent permission for each plugin that contains all the plugin's nodes.
     
  9. Offline

    kookster

    hey codename_B just in case if I dont see you in the irc channel. I keep getting this error and also everytime I reload permissions break not for everything but pretty close, its come to the point where reload is useless. We gotta fix this!

    Code:
    22:17:29 [INFO] Reload complete.
    22:17:29 [WARNING] Can't keep up! Did the system time change, or is the server o
    verloaded?
    22:17:32 [INFO] reading regions...
    22:17:32 [INFO] 13 regions read.
    22:17:32 [INFO] 1489 blocks stored in memory
    22:17:44 [INFO] kookster tried to use command //
    22:17:44 [INFO] WorldEdit: kookster: /
    22:17:45 [INFO] [AutoHelp] Searching active plugins' plugin.yml files for comman
    d help
    22:17:45 [INFO] [AutoHelp] Skipping command 'help', already has a help entry
    22:17:45 [INFO] [AutoHelp] 'Help' support enabled.
    22:17:45 [INFO] kookster tried to use command //
    22:17:45 [INFO] WorldEdit: kookster: /
    22:17:49 [INFO] <[op] Luke> op kookster
    22:17:52 [INFO] kookster tried to use command /op kookster
    >op kookster
    22:17:56 [INFO] Opping kookster
    >setgroup kookster op world
    22:18:00 [WARNING] Unexpected exception while parsing console command
    org.bukkit.command.CommandException: Unhandled exception executing command 'setg
    roup' in plugin bPermissions v1.1
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:12
    9)
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:3
    12)
            at net.minecraft.server.MinecraftServer.b(MinecraftServer.java:480)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:465)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.IllegalArgumentException: Given attachment is not part of P
    ermissible object [email protected]
            at org.bukkit.permissions.PermissibleBase.removeAttachment(PermissibleBa
    se.java:147)
            at org.bukkitcontrib.player.ContribCraftPlayer.removeAttachment(ContribC
    raftPlayer.java:140)
            at com.ubempire.permissions.SuperPermissionHandler.unsetupPlayer(SuperPe
    rmissionHandler.java:39)
            at com.ubempire.permissions.PermissionFunctions.unsetPermissions(Permiss
    ionFunctions.java:43)
            at com.ubempire.permissions.PermissionFunctions.unsetAllPermissions(Perm
    issionFunctions.java:68)
            at com.ubempire.permissions.PermissionFunctions.refreshPermissions(Permi
    ssionFunctions.java:74)
            at com.ubempire.permissions.PermissionFunctions.setGroup(PermissionFunct
    ions.java:84)
            at com.ubempire.permissions.Permissions.onCommand(Permissions.java:117)
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
            ... 6 more
    >
     
  10. Offline

    codename_B

    I'm poring through the BukkitContrib source code atm to see what I can do. It might be caused by double permissions though - which is a thought. As I said, I'm looking into it.
     
  11. Offline

    Fafane

    Hi,
    bPermissions.build is the node for giving build rights...
    ... what are the other nodes(setgroup,etc.)
    Thanks in advance.
     
  12. Offline

    zetas2k

    It doesn't appear that inheritance is working. Also the groupnames seem to load alphabetically. If i have a group named Admin, members of it wont get the default group perms.

    Maybe i'm not formatting my groups/world.yml file properly? When i move essentials.give from the Moderator group to the ZAdmin group it works but it doesn't under Moderator which it should. Ok so maybe you don't allow for multi-level inheritance right? Well it doesn't work if i move it to SemiAdmin either :/ (which would be only 1 level of inheritance).

    p.s. i'm Zetas in #bukkit on espernet.

    Code:
    default:
     - essentials.list
     - essentials.motd
     - essentials.rules
     - essentials.spawn
     - multiverse.tp
     - bPermissions.build
    Builder:
     - essentials.afk
     - essentials.back.ondeath
     - essentials.balance
     - essentials.chat.shout
     - essentials.compass
     - essentials.give
     - essentials.home
     - essentials.kit
     - essentials.kit.tools
     - essentials.mail
     - essentials.mail.send
     - essentials.me
     - essentials.msg
     - essentials.nick
     - essentials.pay
     - essentials.portal
     - essentials.protect
     - essentials.sethome
     - essentials.signs.buy.use
     - essentials.signs.disposal.create
     - essentials.signs.disposal.use
     - essentials.signs.free.use
     - essentials.signs.heal.use
     - essentials.signs.mail.create
     - essentials.signs.mail.use
     - essentials.signs.protection.create
     - essentials.signs.protection.use
     - essentials.signs.sell.use
     - essentials.signs.trade.create
     - essentials.signs.trade.use
     - essentials.suicide
     - essentials.tpa
     - essentials.tpaccept
     - essentials.tpahere
     - essentials.tpdeny
     - essentials.warp
     - essentials.warp.list
     - essentials.worth
    Moderator:
     - essentials.back
     - essentials.ban
     - essentials.banip
     - essentials.broadcast
     - essentials.delwarp
     - essentials.depth
     - essentials.eco
     - essentials.getpos
     - essentials.jump
     - essentials.kick
     - essentials.kill
     - essentials.setwarp
     - essentials.time
     - essentials.togglejail
     - essentials.top
     - essentials.tp
     - essentials.tphere
     - essentials.tpo
     - essentials.tpohere
     - essentials.tppos
     - essentials.tptoggle
     - essentials.unban
     - essentials.unbanip
     - essentials.whois
     - essentials.world
     - essentials.ext
     - inherit.Builder
    SemiAdmin:
     - essentials
     - essentials.clearinventory
     - essentials.cooldown.bypass
     - essentials.deljail
     - essentials.god
     - essentials.heal
     - essentials.heal.others
     - essentials.invsee
     - essentials.item
     - essentials.jails
     - essentials.kickall
     - essentials.kit.*
     - essentials.mute
     - essentials.sell
     - essentials.setjail
     - essentials.signs.protection.override
     - essentials.spawnmob
     - essentials.teleport.cooldown.bypass
     - essentials.teleport.timer.bypass
     - essentials.togglejail
     - essentials.burn
     - inherit.Moderator
    ZAdmin:
     - inherit.SemiAdmin
     
  13. Offline

    Rocky

    You need more documentation, Like the default nodes for allowing building, and other various things, such as the built in bPermissions commands, nodes as well.

    There is that wiki, Which doesn't really explain much either.

    Great work, i can tell this is already easier the the other one in the list, but its somewhat un-necessary to need to scroll through the forum comments just to find out that bPermissions.build is the node for allowing to build. (Or so i think, i haven't gotten it to work yet)

    Don't consider me a complaining asshole, im just letting you know, that it might be easier for everyone to maybe throw up a list on the first post of the nodes in THIS plugin.
     
  14. Offline

    codename_B

    bPermissions.build
    bPermissions.admin

    Feel free to write up some documentation :p I don't really have the time.

    Inheritance isn't recursive

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 17, 2016
  15. Offline

    zetas2k

    I was also using the wrong version, i somehow downloaded 1.0 instead of 1.1

    Also, for anyone else that is confused, when you do /lsnode group world it should expand the inheritance. i.e. it should show you all the inherited nodes not just your inherit.groupname node.

    One more question, does every group implicitly inherit default: ?
     
  16. Offline

    codename_B

    No.
     
  17. Offline

    embty

    I can use this with superperms instead of Bukkitpermissions right? I dont quite get it :p
     
  18. Offline

    codename_B

    That's right. Hence why it's a "SuperPerms" manager.
     
  19. Offline

    embty

    Neat. :D
    Thanks alot!
     
  20. Offline

    zetas2k

    I cant seem to run nodereload or setgroup on the console without generating a warning and stack trace, though setgroup does seem to work even though the warning happens. If i attempt nodereload from inside the game it generates a Severe Error and stacktrace on the console.

    This happens quite often as well when a player leaves:
    Code:
    14:24:00 [SEVERE] Could not pass event PLAYER_QUIT to bPermissions
    java.lang.NullPointerException
            at com.ubempire.permissions.SuperPermissionHandler.unsetupPlayer(SuperPe
    rmissionHandler.java:41)
            at com.ubempire.permissions.PermissionFunctions.unsetPermissions(Permiss
    ionFunctions.java:43)
            at com.ubempire.permissions.EntityHandler.onPlayerQuit(EntityHandler.jav
    a:38)
            at org.bukkit.plugin.java.JavaPluginLoader$2.execute(JavaPluginLoader.ja
    va:251)
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
    a:58)
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
    ava:332)
            at net.minecraft.server.ServerConfigurationManager.disconnect(ServerConf
    igurationManager.java:146)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:608)
            at net.minecraft.server.NetworkManager.b(NetworkManager.java:231)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
     
  21. Offline

    Fafane


    Same here.
     
  22. I have the same problem with bPermissions that I have with PermissionsBukkit. Permissions are not being reloaded when people switch worlds. I use the multiverse plugin, if that matters. Also running spout (the new bukkitcontrib) anyone else having this problem with bPermissions?
     
  23. Offline

    codename_B

    Looking into this now.

    @Fafane @zetas2k
    I just uploaded a new version that I think fixes your bug.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 17, 2016
  24. Offline

    Fafane

    New version is broken for me.
     
  25. Offline

    Untouchablekill

    It seems that after i set my permission nodes me and my friends are unable to break and build.
    CB build 1000
     
  26. Offline

    Rocky

    Sure, i'll whip something up for you, Just so people aren't turned away from the Plugin, its really good work, and it would suck to lose users and feedback just from a few sentences of information.

    By the way,
    bPermissions.admin - is used for what, Administrative privileges for the built in commands?
     
  27. Offline

    codename_B

    Correct. I figured they needed some kind of permission nodes :p
     
  28. Offline

    undeadmach1ne

    since there is no more '*' for admins to easily have access to all commands, is there an easy way to find all the nodes for all my plugins? is my only option to come here and individually search for the thread/post on every plugin i use and manually find all their available nodes (in some cases requiring a trip to that plugins wiki/external site etc) and add them to my defaultGroups.yml? i have no problem converting my default user group because all the nodes i want them to have are already in my permissions 3.x config files.

    can i desperately make a feature request or two?

    -a group like 'admin' or similar (bananadmin would actually be awesome-er) that will automatically return 'true' to any permissions check made to a user in that group?

    or

    -a /command that will ask every installed plugin to return all available nodes, and then take that list and output a .txt file with all of them (or better yet, right into our defaultGroups.yml under a specified group)?

    aside from that ugly problem with superperms which has nothing to do with you or your plugin, thanks for this...if i am reading correctly its automatically simulating/bridging permissions 3.x for plugins that are currently incompatible with superperms, which is pure awesome and makes it much easier to switch right now to the new system.
     
  29. Offline

    codename_B

    You mean "op"?

    This is a feature of minecraft - you can type "op username" into the console and they will have all permissions (for plugins which are written to respect the "op system") - remember I'm not handling the permissions - just managing them (ie loading them into Bukkit) so all I can do is load the permission nodes and manage groups and worlds.

    Other than that - there's nothing I can do.
     
  30. Offline

    undeadmach1ne

    not all plugins are set up to respect op though. at this point finding which of the ones im using do or dont will be as 'easy' as getting a full list of nodes for all of them. as for passing back 'true' to the plugins when making a permission check, that was just me grasping at straws :) i should have realized you arent actually touching or even seeing the checks/requests...

    oh well, i guess ill clear my calendar for tomorrow night, pray that the forum stops timing out/page not found and dig in to my plugin folder :)

    how possible would the plugin idea i mentioned that returns a text file of all available nodes in active plugins be do you think? is that a realistic idea in any way or am i still grasping at straws?
     
  31. Offline

    Volkanlp

    i dont get how multiworld works on this

    what should this mean? do i need to create a .yml file which is called players/world.yml or should i create a folder called players and a folder called groups and put the yml files with the specified worldname in it?
     

Share This Page