Inactive [ADMN/SEC] AuthDB v2.3.6 - Database authentication and protection [1.1-1.4.5]

Discussion in 'Inactive/Unsupported Plugins' started by CraftFire, Mar 13, 2011.

  1. Offline


    In order to centralize support of our legacy projects, we will no longer be providing support on Bukkit. Please use for support with our projects going forward.
  2. Offline


    Likely they don't have permission. ;)
    What does your permissions config look like?

    Maybe, but no guarantees.

    I'll test it out and see if we can figure out what is going on. What build are you on?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 15, 2016
  3. Offline


    This is the "user" section of my permissions concerning AuthDB.

        - authdb.command.*
        - authdb.command.user.*
        - authdb.command.user.login
        - authdb.command.user.logout
        - authdb.command.user.register
        - authdb.command.user.unlink
          groups: []
          priority: '1000'
          prefix: '&7'
  4. Offline


    Wow, you have a lot of useless redundancy there. You should NOT be giving the .* wildcard nodes when you are specifying each node directly anyways. By giving the users the authdb.command.* node, you are giving them admin command permissions too. Just give them each node directly, don't use wildcards. :p
  5. Offline


    Even when I remove the * nodes, it still won't let anyone log in, because of permissions.
        - authdb.command.user.login
        - authdb.command.user.logout
        - authdb.command.user.register
        - authdb.command.user.unlink
          groups: []
          priority: '1000'
          prefix: '&7'
    I was using an old build of the rewritten version before, and that worked fine. Updated to the latest build of AuthDB legacy, and this happened.

    Do you have any idea why this is happening?

    Also, contex
    What happened to the rewrite? It seemed to have just disappeared from your jenkins and github..
  6. Offline


    Hello, I have a problem with Authdb, the problem in the console says this Could not pass event PlayerQuitEvent to AuthDB and this too: Could not pass event PlayerCommandPreprocessEvent to AuthDB And in the game the people lose his inventory every time they /login
  7. Offline


    What builds of AuthDB and CraftBukkit? Also, do you have a full log?
  8. Offline


    The version of my AuthDB is 2.3.6 and for Craftbukkit the newest for 1.2.5 A full log what do you mean? sorry my english Thank you.
  9. Offline


    Your server log or debug and error logs from your plugins/AuthDB/logs folder for today's state.
  10. Offline


    These failures did not appear in plugins/authdb/logs folder
  11. Offline


    Any chance we could get tekkit integration? I downloaded your latest dev build, and added [BuildCraft] to the white list, but quarry's still cannot build. Funny, if you manually make the frame, they will destroy.

    Funny, I try and log in with name [BuildCraft] and it boots me telling me illegal characters. But I have [BuildCraft] in the whitelist for ignoring characters.

    Removing AuthDB fixes the issue, allowing quarry's to build, but thats not quite a real world option for me. Just showing I do believe it is AuthDB.

    If you need any further info, please let me know!


    It appears changing any of the "guest" things to "true" is also not working. I attempted to allow guests to move, place, destroy, and chat, and nothing was working. I was changing the config, issuing /authdb reload, and logging the test characted in.

    I believe he means paste your entire startup log. So any interactions/issues/errors can be seen. Also show the log up to the point of a player logging in.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 15, 2016
  12. Offline


    This is my boot record:
    01:29 AM [INFO] [Pail] Loading Pail v0.8
    01:29 AM [INFO] [PermissionsBukkit] Loading PermissionsBukkit v1.6
    01:29 AM [INFO] [Spout] Loading Spout v1244
    01:29 AM [INFO] [Vault] Loading Vault v1.2.17-b224
    01:29 AM [INFO] [Glowstone Lanterns] Loading Glowstone Lanterns v0.5
    01:29 AM [INFO] [PvPToggle] Loading PvPToggle v2.1.0
    01:29 AM [INFO] [SpawnMob] Loading SpawnMob v3.0
    01:29 AM [INFO] [MobileAdmin] Loading MobileAdmin v3.2.4
    01:29 AM [INFO] [dynmap] Loading dynmap v0.70.1-1276
    01:29 AM [INFO] [MyWolf] Loading MyWolf v0.6.5 (1.2.5)
    01:29 AM [INFO] [SimpleVIPPerks] Loading SimpleVIPPerks v1.0
    01:29 AM [INFO] [iConomy] Loading iConomy v7.0
    01:29 AM [INFO] [AuthDB] Loading AuthDB v2.3.6.242
    01:29 AM [INFO] [CraftBukkitUpToDate] Loading CraftBukkitUpToDate v2.9.0
    01:29 AM [INFO] [MobDisguise] Loading MobDisguise v1.81
    01:29 AM [INFO] [SimpleClans] Loading SimpleClans v2.3.4
    01:29 AM [INFO] [ButtonWarp] Loading ButtonWarp v1.8.1
    01:29 AM [INFO] [MultiHome] Loading MultiHome v0.15
    01:29 AM [INFO] [Essentials] Loading Essentials v2.9.2
    01:29 AM [INFO] [WorldEdit] Loading WorldEdit v5.2
    01:29 AM [INFO] [EssentialsProtect] Loading EssentialsProtect v2.9.2
    01:29 AM [INFO] [EssentialsSpawn] Loading EssentialsSpawn v2.9.2
    01:29 AM [INFO] [Dynmap-SimpleClans] Loading Dynmap-SimpleClans v1.2.5
    01:29 AM [INFO] [LWC] Loading LWC v4.3.0 (b736-git-1b1150b1) (August 08, 2012)
    01:29 AM [INFO] [ChestShop] Loading ChestShop v3.46
    01:29 AM [INFO] [EssentialsChat] Loading EssentialsChat v2.9.2
    01:29 AM [INFO] [Residence] Loading Residence v2.6.4
    01:29 AM [INFO] [Pail] Enabling Pail v0.8
    01:29 AM [INFO] [Spout] Enabling Spout v1244
    01:29 AM [INFO] [Vault] Enabling Vault v1.2.17-b224
    01:29 AM [INFO] [Vault][Economy] Essentials Economy found: Waiting
    01:29 AM [WARNING] iConomy6 - If you are using Flatfile storage be aware that iCo6 has a CRITICAL bug which can wipe ALL iconomy data.
    01:29 AM [WARNING] if you're using Votifier, or any other plugin which handles economy data in a threaded manner your server is at risk!
    01:29 AM [WARNING] it is highly suggested to use SQL with iCo6 or to use an alternative economy plugin!
    01:29 AM [INFO] [Vault][Economy] iConomy 6 found: Waiting
    01:29 AM [INFO] [Vault][Permission] PermissionsBukkit hooked.
    01:29 AM [INFO] [Vault][Permission] PermissionsBukkit found: Waiting
    01:29 AM [INFO] [Vault][Permission] SuperPermissions loaded as backup permission system.
    01:29 AM [INFO] [Vault] Enabled Version 1.2.17-b224
    01:29 AM [INFO] [AuthDB] Enabling AuthDB v2.3.6.242
    01:29 AM [INFO] [AuthDB] messages language set to English
    01:29 AM [INFO] [AuthDB] commands language set to English
    01:29 AM [INFO] [AuthDB] 123 user registrations in database
    01:29 AM [INFO] [AuthDB] is enabled
    01:29 AM [INFO] [AuthDB] developed by CraftFire <[email protected]>
    01:29 AM [INFO] [LWC] Enabling LWC v4.3.0 (b736-git-1b1150b1) (August 08, 2012)
    01:29 AM [INFO] [LWC] Loaded 209 locale strings (0 overrides)
    01:29 AM [INFO] [LWC] Permissions API: §4VaultPermissions
    01:29 AM [INFO] [LWC] Currency API: §4VaultCurrency
    01:29 AM [INFO] [LWC] Connecting to SQLite
    01:29 AM [INFO] [LWC] Performing any necessary database updates
    01:29 AM [INFO] [LWC] Using database: Native
    01:29 AM [INFO] [LWC] Precached 3101 protections
    01:29 AM [INFO] Preparing level "World"
    01:29 AM [INFO] Default game type: 0
    01:29 AM [INFO] Preparing start region for level 0 (Seed: 2465171780496244762)
    01:29 AM [INFO] Preparing spawn area: 77%
    01:29 AM [INFO] Preparing start region for level 1 (Seed: 2465171780496244762)
    01:29 AM [INFO] Preparing spawn area: 73%
    01:29 AM [INFO] Preparing start region for level 2 (Seed: 2465171780496244762)
    01:29 AM [INFO] Preparing spawn area: 89%
    01:29 AM [INFO] [PermissionsBukkit] Enabling PermissionsBukkit v1.6
    01:29 AM [INFO] [PermissionsBukkit] Enabled successfully, 0 players registered
    01:29 AM [INFO] [Glowstone Lanterns] Enabling Glowstone Lanterns v0.5
    01:29 AM [INFO] [Glowstone Lanterns] Loading Glowstone Lanterns...
    01:29 AM [INFO] [Glowstone Lanterns] 376 Glowstone Lanterns loaded!
    01:29 AM [INFO] [Glowstone Lanterns] No permissions, defaulting to OP's
    01:29 AM [INFO] [Glowstone Lanterns] Glowstone Lanterns v0.5 Started
    01:29 AM [INFO] [PvPToggle] Enabling PvPToggle v2.1.0
    01:29 AM [INFO] [PvPToggle] Loading...
    01:29 AM [INFO] [PvPToggle] found and loaded world World
    01:29 AM [INFO] [PvPToggle] found and loaded world World_nether
    01:29 AM [INFO] [PvPToggle] found and loaded world World_the_end
    01:29 AM [INFO] [PvPToggle] Using SuperPerms for permissions checking
    01:29 AM [INFO] [PvPToggle] v2.1.0 enabled!
    01:29 AM [INFO] [SpawnMob] Enabling SpawnMob v3.0
    01:29 AM [INFO] Configuration files loaded.
    01:29 AM [INFO] [SpawnMob] Using ops.txt!
    01:29 AM [INFO] [SpawnMob] Version 3.0 enabled.
    01:29 AM [INFO] [MobileAdmin] Enabling MobileAdmin v3.2.4
    01:29 AM [INFO] [MobileAdmin] Loading server stats.
    01:29 AM [INFO] [MobileAdmin] Loading chat log.
    01:29 AM [INFO] [MobileAdmin] Loading users.
    01:29 AM [INFO] [MobileAdmin] Starting server...
    01:29 AM [INFO] [MobileAdmin] Version 3.2.4 is enabled!
    01:29 AM [INFO] [dynmap] Enabling dynmap v0.70.1-1276
    01:29 AM [INFO] [dynmap] Using PermissionsBukkit 1.6 for access control
    01:29 AM [INFO] [dynmap] Web interface permissions only available for online users
    01:29 AM [INFO] [MobileAdmin] Server listening on *:5839
    01:29 AM [INFO] [dynmap] Detected Spout
    01:29 AM [INFO] [dynmap] Loaded 0 Spout custom blocks
    01:29 AM [INFO] [dynmap] Loaded 20 shaders.
    01:29 AM [INFO] [dynmap] Loaded 82 perspectives.
    01:29 AM [INFO] [dynmap] Loaded 12 lightings.
    01:29 AM [INFO] [dynmap] Web server started on address
    01:29 AM [INFO] [dynmap] version 0.70.1-1276 is enabled - core version 0.70.1-331
    01:29 AM [INFO] [dynmap] Loaded 3 maps of world 'World'.
    01:29 AM [INFO] [dynmap] Loaded 2 maps of world 'World_nether'.
    01:29 AM [INFO] [dynmap] Loaded 2 maps of world 'World_the_end'.
    01:29 AM [INFO] [dynmap] Enabled
    01:29 AM [INFO] [MyWolf] Enabling MyWolf v0.6.5 (1.2.5)
    01:29 AM [INFO] [MyWolf] Vault integration enabled!
    01:29 AM [INFO] [MyWolf] No custom EXP-Script found (exp.js).
    01:29 AM [INFO] [MyWolf] 10 wolf/wolves loaded
    01:29 AM [INFO] [MyWolf] version 0.6.5 (1.2.5) ENABLED
    01:29 AM [INFO] [SimpleVIPPerks] Enabling SimpleVIPPerks v1.0
    01:29 AM [INFO] [SimpleVIPPerks] SimpleVIPPerks plugin has been enabled!
    01:29 AM [INFO] [iConomy] Enabling iConomy v7.0
    01:29 AM [INFO] [iConomy - April Fools] Enabled (26 ms)
    01:29 AM [INFO] [iConomy] Hello, I'm Nijikokun. Yes, this is an April Fools joke, but '/money top' was fixed! Enjoy :) - Rare Version!
    01:29 AM [INFO] [Vault][Economy] iConomy 6 hooked.
    01:29 AM [INFO] [iConomy - April Fools] Purged accounts with default balance.
    01:29 AM [INFO] [CraftBukkitUpToDate] Enabling CraftBukkitUpToDate v2.9.0
    01:29 AM [INFO] CraftBukkitUpToDate version 2.9.0 is enabled!
    01:29 AM [INFO] [MobDisguise] Enabling MobDisguise v1.81
    01:29 AM [INFO] [MobDisguise] by desmin88 version 1.81 enabled.
    01:29 AM [INFO] [SimpleClans] Enabling SimpleClans v2.3.4
    01:29 AM [INFO] [SimpleClans] Version 2.3.4 loaded
    01:29 AM [INFO] Spout features enabled
    01:29 AM [INFO] [SimpleClans] SQLite Connection successful
    01:29 AM [INFO] [SimpleClans] Clans: 2
    01:29 AM [INFO] [SimpleClans] Clan players: 28
    01:29 AM [INFO] [ButtonWarp] Enabling ButtonWarp v1.8.1
    01:29 AM [INFO] ButtonWarp 1.8.1 is enabled!
    01:29 AM [INFO] [MultiHome] Enabling MultiHome v0.15
    01:29 AM [INFO] [MultiHome] Using Vault for permissions system.
    01:29 AM [INFO] [MultiHome] Version 0.15 loaded.
    01:29 AM [INFO] [Essentials] Enabling Essentials v2.9.2
    01:29 AM [INFO] [Vault][Economy] Essentials Economy hooked.
    01:29 AM [INFO] Essentials: Using PermissionsBukkit based permissions.
    01:29 AM [INFO] [Essentials] Payment method found (Vault - Economy: iConomy 6 version: 1.2.17-b224)
    01:29 AM [INFO] [WorldEdit] Enabling WorldEdit v5.2
    01:29 AM [INFO] WorldEdit 5.2 enabled.
    01:29 AM [INFO] [EssentialsProtect] Enabling EssentialsProtect v2.9.2
    01:29 AM [INFO] CButD: CraftBukkit is Outdate, try to download new version
    01:29 AM [INFO] [EssentialsSpawn] Enabling EssentialsSpawn v2.9.2
    01:29 AM [INFO] [Dynmap-SimpleClans] Enabling Dynmap-SimpleClans v1.2.5
    01:29 AM [INFO] [Dynmap-SimpleClans] initializing
    01:29 AM [INFO] [Dynmap-SimpleClans] version 1.2.5 is activated
    01:29 AM [INFO] [ChestShop] Enabling ChestShop v3.46
    01:29 AM [INFO] [ChestShop] LWC version 4.3.0 (b736-git-1b1150b1) (August 08, 2012) loaded.
    01:29 AM [INFO] [ChestShop] Vault loaded - using iConomy 6
    01:29 AM [INFO] [EssentialsChat] Enabling EssentialsChat v2.9.2
    01:29 AM [INFO] [Residence] Enabling Residence v2.6.4
    01:29 AM [INFO] [Residence] Found Vault using permissions plugin:permissionsBukkit
    01:29 AM [INFO] [Residence] Failed to update language file: Chinese.yml, Error: unacceptable character '?' (0xFFFD) special characters are not allowed
    in "<string>", position 751
    01:29 AM [INFO] [Residence] Scanning for economy systems...
    01:29 AM [INFO] [Residence] Found Vault using economy system: iConomy 6
    01:29 AM [INFO] [Residence] Found WorldEdit
    01:29 AM [INFO] [Residence] Enabled! Version 2.6.4 by bekvon
    01:29 AM [INFO] Server permissions file permissions.yml is empty, ignoring it
    01:29 AM [INFO] CButD: Download-Process of CB: 10%.
    01:29 AM [INFO] CButD: Download-Process of CB: 20%.
    01:30 AM [INFO] CButD: Download-Process of CB: 30%.
    01:30 AM [INFO] CButD: Plugin-Update-Check started
    01:29 AM [INFO] Done (9.683s)! For help, type "help" or "?"
  13. Offline


    Is there a wordpress script for this? I see it is tested, but I don't see anything about the actual script or plugin?
  14. Offline


    I have AuthDB running with only a few kinks in Bukkit 1.3.1 R1.0:
    • YAML color codes are functional, but also leave behind "Â" symbols
    • Players occasionally have to relog due to everyone else becoming invisible
    If I notice anything else, I shall report; but I have done comprehensive tests, and that's all that I found.
    Here's my startup/shutdown log:
    Show Spoiler
    2012-08-18 09:48:09 [INFO] Starting minecraft server version 1.3.1
    2012-08-18 09:48:09 [INFO] Loading properties
    2012-08-18 09:48:09 [INFO] Default game type: SURVIVAL
    2012-08-18 09:48:09 [INFO] Generating keypair
    2012-08-18 09:48:09 [INFO] Starting Minecraft server on *:25565
    2012-08-18 09:48:09 [WARNING] The server will make no attempt to authenticate usernames. Beware.
    2012-08-18 09:48:09 [WARNING] While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
    2012-08-18 09:48:09 [WARNING] To change this, set "online-mode" to "true" in the file.
    2012-08-18 09:48:10 [INFO] This server is running CraftBukkit version git-Bukkit-1.3.1-R1.0-b2320jnks (MC: 1.3.1) (Implementing API version 1.3.1-R1.0)
    2012-08-18 09:48:10 [SEVERE] not found
    2012-08-18 09:48:10 [INFO] DataSourcePool [AuthDB] autoCommit[false] transIsolation[SERIALIZABLE] min[2] max[20]
    2012-08-18 09:48:10 [INFO] SubClassFactory parent ClassLoader []
    2012-08-18 09:48:11 [INFO] Entities enhanced[0] subclassed[1]
    2012-08-18 09:48:11 [INFO] [AuthDB] Loading AuthDB v2.3.6.242
    2012-08-18 09:48:11 [INFO] [AuthDB] Enabling AuthDB v2.3.6.242
    2012-08-18 09:48:11 [INFO] [AuthDB] messages language set to English
    2012-08-18 09:48:11 [INFO] [AuthDB] commands language set to English
    2012-08-18 09:48:11 [INFO] [AuthDB] 11 user registrations in database
    2012-08-18 09:48:11 [INFO] [AuthDB] is enabled
    2012-08-18 09:48:11 [INFO] [AuthDB] developed by CraftFire <[email protected]>
    2012-08-18 09:48:11 [INFO] Preparing level "1.3.1"
    2012-08-18 09:48:11 [INFO] Preparing start region for level 0 (Seed: 5630286869668990666)
    2012-08-18 09:48:12 [INFO] Preparing start region for level 1 (Seed: -707510761231177040)
    2012-08-18 09:48:12 [INFO] Preparing spawn area: 52%
    2012-08-18 09:48:13 [INFO] Preparing start region for level 2 (Seed: -707510761231177040)
    2012-08-18 09:48:13 [INFO] Server permissions file permissions.yml is empty, ignoring it
    2012-08-18 09:48:13 [INFO] Done (1.778s)! For help, type "help" or "?"
    2012-08-18 09:48:17 [INFO] CONSOLE: Stopping the server..
    2012-08-18 09:48:17 [INFO] Stopping server
    2012-08-18 09:48:17 [INFO] [AuthDB] Disabling AuthDB v2.3.6.242
    2012-08-18 09:48:17 [INFO] [AuthDB] has been disabled
    2012-08-18 09:48:17 [INFO] Saving players
    2012-08-18 09:48:17 [WARNING] DSCT: socket closed
    2012-08-18 09:48:17 [INFO] Closing listening thread
    2012-08-18 09:48:17 [INFO] Saving worlds
    2012-08-18 09:48:17 [INFO] Saving chunks for level '1.3.1'/net.minecraft.server.WorldProviderNormal@1b4ed400
    2012-08-18 09:48:18 [INFO] Saving chunks for level '1.3.1_nether'/net.minecraft.server.WorldProviderHell@6963c17d
    2012-08-18 09:48:18 [INFO] Saving chunks for level '1.3.1_the_end'/net.minecraft.server.WorldProviderTheEnd@6d1a542b
  15. Offline


    I am using AuthDB version and craftbukkit build 2326. But had same issue on CB 1.3.1-R1 recommended build...
  16. I don't know what I'm doing wrong, but it's ignoring the delay for the messages. Even with the default advanced.yml

    And...a feature request? I use buildcraft, forestry's, industirialcraft's fake user feature to make sure they don't ignore protections on peoples houses. I was using AuthMe before I switched to AuthDB for my new forums, but I've noticed there isn't an option for a unrestricted user. Could that be added in the future? They have the illegal characters in their name so normal people can't sign in as them. Like [forestry] for example.
  17. Offline


    Just remove [ and ] from the username username filter for the first part.

    Are you enclosing the sentence with " and "?

    Just remove [ and ] from the username username filter for the first part.

    For the last, guest are unregistered users. This means, if the username they are on is registered, none of those options apply.

    Script? You just configure the options in basic.yml to connect to your script database, in your case, WordPress.

    Try using the latest development build.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 15, 2016
  18. Well. That's not what I mean. I meant like skip the whole login process in general for the usernames. For now, I just have guests able to place and break...which really isn't much of an issue since they can't move and we have residence protections.

    So, be default does it automatically delay the register and login messages? I turned it in debug mode and it waits no seconds before sending it to the player. No matter if I set it to milliseconds or seconds.

    @Also, at userNo99, users becoming invisble isn't a problem with this plugin. It happens to me occasionally even before I had this plugin.
  19. Offline


    Did you disable forced registration under the register node?
  20. Offline


    Thanks for the reply!

    When I remove the characters, I get message "Kicked because username contains bad characters" This is when trying to log in as "[BuildCraft]", to see if the bypass is working.

    here is the relevent section of the advanced config file:

        action: kick                                    # Action to perform when a username matches the filter. Options are kick and rename.
        username: "`~!@#$%^&*()-=+{}|\\:;\"<,>.?/ "    # Characters and symbols to check for in usernames. We recommend leaving this as is.
        password: "$&\\\""                              # Characters and symbols to check for in passwords. We recommend leaving this as is.
        whitelist: Contex,Wulfspider,[RedPower],[BuildCraft],[IndustrialCraft]                    # Usernames to exclude from username and password filtering.


    Turns out there is an issue with my formatting of the advanced config. Below is startup and the conifg in full.

    Tried multiple ways of entering the whitelist names, all yelled at me for the comma....
  21. Offline


    Can you please send me an example, because I guess I missed it completly, I am using the buddypress social network plugin for wordpress. is it tested with that?
  22. Offline


    We never added support for BuddyPress, so unless it keeps the tables the same as in regular WordPress, it won't work.

    That is because you are using invalid YAML markup in the whitelist line. [ and ] are what enclose YAML a lot of the time in lists, so it thinks you have multiple lists and invalid markup in that line, which you do.

    You could try...

    whitelist: [Contex,Wulfspider,[RedPower],[BuildCraft],[IndustrialCraft]]

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 15, 2016
  23. Offline


    oooo I did not know, I will give that a shot, thanks.
  24. I'm using a modded server, and someone just let me know that when they sign off when wearing IndustrialCraft's Nano or Quantum armor, it loses it's charge when they log back in. Surprinsgly, it doesn't do this with the electric tools. :confused:

    EDIT: It's anything that's in the armor slots. If I put it in my inventory, it's perfectly fine.
  25. Offline


    but how do I tell it that it's a wordpress database, will it know by it self? I see settings to tell it it's a phpbb database, but it doesn't say how the others should be typed.
  26. Offline


    You replace the phpbb part with wordpress. ;)
  27. Offline


    Wulfspider any news on AuthDB revrite progress? I can't find it on Github :)
  28. Offline


  29. Offline


    I've just connected my WordPress mySQL database with AuthDB, so that users can register either on the site or on the minecraft server. It works great.
    But I've got a question. How can I make the user login also to be put into the columns user_nicename and display_name (look at the screenshot of phpMyAdmin) in my database? Because without these parametres user login is not being shown on the site after authorize.
    *4 accounts were registered via Wordpress, the 5th - via minecraft server.
    Sorry, if I've missed the question like this in the theme. I'm not English-speaking well.
    Waiting for you help :)
  30. Offline


    That is wierd indeed, are there any errors when inserting?
    The script is set to register Wordpress users with user_login, user_nicename and display_name, see code under.
    ps = MySQL.mysql.prepareStatement("INSERT INTO `" + Config.script_tableprefix + "users" + "` (`user_login`, `user_pass`, `user_nicename`, `user_email`, `user_registered`, `display_name`)  VALUES (?, ?, ?, ?, ?, ?)", 1);
    ps.setString(1, player); //user_login
    ps.setString(2, passwordhashed); //user_pass
    ps.setString(3, player); //user_nicename
    ps.setString(4, email); //user_email
    ps.setString(5, realdate); //user_registered
    ps.setString(6, player); //display_name
    Could you check the log if there are any errors during registration? Set debug to true in the basic.yml as well, would help figuring out what could be wrong.
  31. Offline


    Hey :)
    I am using AuthDB with Bukkit 1.3.2-R0.1 (b2352). It seems to work, but I get this error whenever a player joins the game:
    Show Spoiler
    2012-09-15 17:01:44 [INFO] Meister95[/**.***.**.**:*****] logged in with entity id 16032 at ([spielewiese] 624.7005618028105, 30.0, 1204.1276288812949)
    2012-09-15 17:01:46 [INFO] Can not test connection as heartbeatsql is not set
    2012-09-15 17:01:46 [INFO] Closing Connection[AuthDB.8] psReuse[59] psCreate[10] psSize[10]
    2012-09-15 17:01:46 [INFO] DataSourcePool [AuthDB] grow; id[AuthDB.9] busy[10] max[20]
    2012-09-15 17:01:46 [SEVERE] Could not pass event PlayerLoginEvent to AuthDB
        at org.bukkit.plugin.RegisteredListener.callEvent(
        at org.bukkit.plugin.SimplePluginManager.fireEvent(
        at org.bukkit.plugin.SimplePluginManager.callEvent(
        at net.minecraft.server.ServerConfigurationManagerAbstract.attemptLogin(
        at net.minecraft.server.NetLoginHandler.d(
        at net.minecraft.server.NetLoginHandler.c(
        at net.minecraft.server.DedicatedServerConnectionThread.a(
        at net.minecraft.server.DedicatedServerConnection.b(SourceFile:29)
        at net.minecraft.server.MinecraftServer.q(
        at net.minecraft.server.DedicatedServer.q(
        at net.minecraft.server.MinecraftServer.p(
    Caused by: javax.persistence.PersistenceException: ERROR executing DML bindLog[] error[[SQLITE_CONSTRAINT]  Abort due to constraint violation (PRIMARY KEY must be unique)]
        at com.avaje.ebeaninternal.server.persist.dml.DmlBeanPersister.execute(
        at com.avaje.ebeaninternal.server.persist.dml.DmlBeanPersister.insert(
        at com.avaje.ebeaninternal.server.persist.DefaultPersistExecute.executeInsertBean(
        at com.avaje.ebeaninternal.server.core.PersistRequestBean.executeNow(
        at com.avaje.ebeaninternal.server.core.PersistRequestBean.executeOrQueue(
        at com.avaje.ebeaninternal.server.persist.DefaultPersister.insert(
        at com.avaje.ebeaninternal.server.persist.DefaultPersister.saveVanillaInsert(
        at com.avaje.ebeaninternal.server.persist.DefaultPersister.saveVanillaRecurse(
        at com.avaje.ebeaninternal.server.persist.DefaultPersister.saveRecurse(
        at com.authdb.util.databases.EBean.sync(
        at com.authdb.util.databases.EBean.sync(
        at com.authdb.listeners.AuthDBPlayerListener.onPlayerLogin(
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(
        at java.lang.reflect.Method.invoke(
        ... 13 more
    Caused by: java.sql.SQLException: [SQLITE_CONSTRAINT]  Abort due to constraint violation (PRIMARY KEY must be unique)
        at org.sqlite.DB.newSQLException(
        at org.sqlite.DB.newSQLException(
        at org.sqlite.DB.execute(
        at org.sqlite.DB.executeUpdate(
        at org.sqlite.PrepStmt.executeUpdate(
        at com.avaje.ebeaninternal.server.lib.sql.ExtendedPreparedStatement.executeUpdate(
        at com.avaje.ebeaninternal.server.type.DataBind.executeUpdate(
        at com.avaje.ebeaninternal.server.persist.dml.InsertHandler.execute(
        at com.avaje.ebeaninternal.server.persist.dml.DmlBeanPersister.execute(
        ... 32 more

Share This Page