Inactive [ADMN] MultiCommand v2.1.2 - Execute many commands with one command and shortcuts [1.4.2-R0.2]

Discussion in 'Inactive/Unsupported Plugins' started by homerbond005, Jun 13, 2011.

  1. Maybe this page is outdated. Please see Bukkit Dev.

    Hello together!

    This is a plugin that executes many commands with one simple command that can be configured. You can add parameters and define shortcuts like /t can execute /time.
    Uses Metrics for sending completly anonomous data to for usage tracking. See and GitHub for more info.

    1. Copy MultiCommand.jar into /plugins/
    2. Restart/Reload your server.
    1. Creating a new command list:
    2. Type /muco create <name>
    3. Then add your commands with /muco add <name> <command>
      • Important:
      • Type your first command for executation first.
      • Don't forget the /
    4. Now type /muco <name> and the commands will be executed one after one.
    • Executing commands
      • Type /muco <name> - Requires MultiCommand.use.<name>
    • List all lists of commands
      • Type /muco list - Requires MultiCommand.list
    • List all commands in a list
      • Type /muco show <name> - Requires<name>
    • Remove a command from a list of commands
      • Type /muco remove <name> <command with /> - Requires MultiCommand.remove.<name>
    • Delete a list of commands
      • Type /muco delete <name> - Requires MultiCommand.delete.<name>
    • Reload the config
      • Type /muco reload - Requires MultiCommand.reload
    Parameters and variables:
    One simple example:
    1. Type /muco create exampleList - Requires MultiCommand.create.exampleList
    2. Then: /muco add exampleList /time set $1
    3. Maybe: /muco add exampleList /command dothis $1 $2
    4. Executation: /muco exampleList <$1> <$2>
    You can add $1, $2, $3, $4, $5 as variables for default. If you change the value for 'maxvariables' in the config.yml, you can define more than 5 variables.

    Optional parameters:

    You can define parameters as optional. Have a look at the following examples:
    • /muco add exampleList /command $1 [$2]
      • $1 is required, $2 is optional
    • /muco add exampleList /command [$1] [$2]
      • $1 and $2 are optional
    • /muco add exampleList /command $1 [$2] $3 This doesn't work!
      • This doesn't work. It will print out an error.
    • /muco add exampleList /command $1 [$3] $2
      • $1 and $2 are required, $3 is optional
      • If you want to execute this you have to type:
        • /muco exampleList $1 $2 [$3]
    I hope this understandable ;)

    Predefined Variables (player/server variables):
    • $playername : The name of the player that executes the command
      • You can change the behaviour of $playername in the config:
        • playerDisplayName: true -> Includes all formatting options (e. g. Essentials)
        • playerDisplayName: false -> Only the login name without formattings
    • $playerworld : The current world of the player that executes the command
    • $serveronlineplayers : Players, as a number, that are online
    • $servermaxplayers: Slots of the server
    You can add delays to commands in a list
    • Just put "[time in seconds]" in front of a command (without "")
    • Example:
      1. /muco create testlist
      2. /muco add testlist /say 3
      3. /muco add testlist [1]/say 2
      4. /muco add testlist [1]/say 1
      5. /muco add testlist [1]/stop
    • The output will be a countdown from 3 to 1 and after it the server will stop
    Executing commands as console:
    • You can explicitly executing a command as console
    • Just put "[$c]" in front of the command (in front of the delay, too) and the command will be executed as console
    • Examples:
      • [$c]/say I'm the console.
      • [$c][2]/say I'm the console and I knew this message 2 secs before you saw it.
    Disabling commands:

    You can prevent commands from being execute outside of mucos. But you can use it for disabling commands in general, too.
    • Disable a command: /muco disable disable <command with slash> - Requires MultiCommand.disable.disable
    • Reenable a command: /muco disable enable <command with slash> - Requires MultiCommand.disable.enable
    • List all disabled commands: /muco disable list - Requires MultiCommand.disable.list
    If you disable /say the commands /say hey, /say omg etc. will be disabled, too.
    If you disable /say hey the command /say hey you, /say hey all etc. will be disabled, too, but not /say hi.
    Allright? ;)

    1. Open the config.yml in /plugins/MultiCommand
    2. Edit the properties in Shortcuts
    3. One Example:
        t: time
        kill: ban
    • If you now type /t set 13000, the command /time set 13000 will be executed
    • That means everything you type after /t will be added behind /time
    • Note: This can override existing commands!
    • Permissions will be checked by the plugin that provides the command!
    Other Permissions:
    • All Permissions: MultiCommand.all
    • Create all: MultiCommand.create.all
    • Delete all: MultiCommand.delete.all
    • Show all:
    • All major permission systems supported
    • Nothing​

    • v2.1.2:
      • Added permission to ignore special disabled commands
      • Added permission to ignore all disabled commands
    Show Spoiler

    • v2.1.1:
      • The $playername variable will not be replaced with Console when executing a command as console ([$c])
    • v2.1:
      • Added execute as console option ([$c])
      • Changed updater (no more laggs while reloading)
    • v2.0:
      • Added command disabler
      • Added command specific delays
      • Changed updater (new server)
      • Commands will be parsed in console executation without slash
    • v1.8:
      • Added option for more than 5 variables
    • v1.7.2:
      • Fixed reload bug
    • v1.7.1:
      • Added option for the $playername behaviour
      • Fixed bug: No error if you miss the command name
      • Fixed bug in create method
    • v1.7:
      • Added reload command
      • Added show command
      • Added shortcut support for the console
      • Fixed spelling mistakes
      • Reduced code
    • v1.6:
      • Added update reminder
      • Fixed bugs with config.yml
      • Fixed permission bugs
    • v1.5:
      • Shortcuts are case-insensitive
      • Now sending anonymous usage data via Metrics to
    • v1.4.2:
      • Fixed bug when creating new config.yml
      • Update only required when you want to recreate the config.yml
    • v1.4.1:
      • Fixed permission bug
    • v1.4:
      • Added console support
      • Reintroduced /muco remove ... command
    • v1.3:
      • No more Commands directory
      • All commands are transfered to the config.yml
      • Fixed bug
      • Added predefined variables
    • v1.2:
      • Added optional parameters
      • Added verbooseMode setting to config.yml (default: false)
    • v1.1.1:
      • Ready for Minecraft 1.2 and Bukkit 1.1-R5
      • Added PermissionsEx support
    • v1.1:
      • Shortcuts added
    • v1.0:
      • Parameters and variables added
      • Many bug fixes
    • v0.9 Beta:
      • First release

    Have fun!

    Habbo4Life and 1234tree4321 like this.
  2. ZIP? Just press "v1.3" in Download.
  3. Offline

    Hello Its me :)

    It tell me ERROR when i press "v1.3" D:
  4. WTF? Please copy the URL that shows ERROR.
  5. link:


    Unable to access the network

    Google Chrome is having trouble accessing the network.

    This may be because your firewall or antivirus software wrongly thinks Google Chrome is an intruder on your computer and is blocking it from connecting to the Internet.

    Here are some suggestions:

    • Add Google Chrome as a permitted program in your firewall's or antivirus software's settings. If it is already a permitted program, try deleting it from the list of permitted programs and adding it again.

    Error 138 (net::ERR_NETWORK_ACCESS_DENIED): Unable to access the network.
    Firewall Blocked
  6. Offline


    I get the same error. works perfectly using the command ingame, but gives an error when trying to run the same command from the console. Im trying to integrate this with the buycraft plugin, which sends the command to the console, so i really need this to work with console commands asap ;D. Thanks!
  7. Holy crap.... Seems like your firewall blocks Try or Otherwise I have to use another webspace.

    Okay, I have added it to the todo list.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  8. Offline


    Awesome :D
    And btw the ingame commands are proving to be really useful, i made some lists for permissions editing ingame so i dont have to manually edit the group.yml files in the console, and it shortens 20+ commands down to one! :3
    Cant wait for the console commands though ;)
  9. I have added console support in v1.4. Have fun :)
  10. Offline


    hey, ich bekomme nach dem update auf 1.2.5 immer einen internal error wenn ich /muco benutze. sowohl mit 1.3 also auch mit 1.4, ich verwende das letzte recommend build für 1.2.5. der command an sich funktioniert, ich bekomme die hilfe seite angezeigt aber sobald ich z.b. /muco list eingebe bekomme ich den internal error. der command an sich funktioniert aber auch dort, denn über dem internal error zeigt er noch "following command lists are set" an. hast du ne idee woran das liegt?

    ... 12 more
    at org.bukkit.command.PluginCommand.execute(
    at de.HomerBond005.MultiCommand.MultiCommand.onCommand(
    at de.HomerBond005.MultiCommand.MultiCommand.commands(
    Caused by: java.lang.NullPointerException
    at net.minecraft.server.MinecraftServer.w(
    at net.minecraft.server.NetworkListenThread.a(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.NetworkManager.b(
    at net.minecraft.server.Packet3Chat.handle(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.NetServerHandler.handleCommand(
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    at org.bukkit.command.SimpleCommandMap.dispatch(
    at org.bukkit.command.PluginCommand.execute(
    org.bukkit.command.CommandException: Unhandled exception executing command 'muco' in plugin MultiCommand v1.4.1
    12:45:12 [SEVERE] null
  11. Offline


    I love this plugin. We've been using it a lot for editing world access permissions. :) What I was wondering is if you could make an option (with a new permission) for writing commands that bypass the permissions of the user that executes the command? I am aware of the dangers, but it would be nice to use such a feature to allow server staff to enable/disable world access without granting them full permissions access. More danger in the name of safety. ;)
  12. Offline


    I can't download this plugin.
    I try to connect those URL.
    But I have only this error and advertisement.
    Code:  Zugriff verweigert, Fehler 403.  Sorry, access forbidden, error 403.    Contact service provider
    What should I download this plugin?

    I'm Japanese.
    I live in Japan.
    So I can use English little.
    So you might feel that this sentence is unreadable.
    But please forgive me.
  13. Offline


    Thanks so much! :D now we can use enjinforumlink and buycraft and i can make people a certain group or add permissions from console, makes everything automatic :3
    homerbond005 likes this.
  14. Offline


    Currently the &playername variable looks at players chat name so if a player has a prefix of nickname it wont work correctly. Could you change this so it looks at the players actually name?
    Thanks, Recon
  15. Offline


    Please, add console support, cause i cannot use shortucts on console in bukkit 1.2.5 r2.0
  16. The prefixes and nicknames are changed by a plugin, e.g. Essentials. Which plugin do you use to handle these prefixes and nicknames? Maybe, I can add this feature in the next update.

    The normal muco commands work in console. I can't make the shortcuts console compatible, because bukkit doesn't provide such a function.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  17. Offline


    I'm kind of confused on the variables.

    I want make it so when someone types "/grief USERNAME" the command bans the person and puts the reason as grief and where to appeal.

    I tried using grief: ban $1 grief appeal at ______

    is there something else I should be doing? Does this functionality not work? Also it'd be cool to see a bukkit dev page. There was something else I was going to ask but I'll ask you later if I remember
  18. This seems correct. If it doesn't work or show anything, try switching on verbooseMode in config.yml. Maybe you forgot the /...
  19. Offline


    Here is my YML file.
      t: time
      survival: gm
      Survival: gm
      SURVIVAL: gm
      promote: pex promote
      Promote: pex promote
      PROMOTE: pex promote
      demote: pex demote
      DEMOTE: pex demote
      Demote: pex demote
      private: warp private
      Private: warp private
      PRIVATE: warp private
      privateworld: warp private
      Privateworld: warp private
      PrivateWorld: warp private
      PRIVATEWORLD: warp private
      creativeworld: warp creative
      Creativeworld: warp creative
      CreativeWorld: warp creative
      CREATIVEWORLD: warp creative
      survivalworld: warp survival
      Survivalworld: warp survival
      SurvivalWorld: warp survival
      SURVIVALWORLD: warp survival
      save: save-all
      Save: save-all
      SAVE: save-all
      rollback: lb rollback time 365days player
      ROLLBACK: lb rollback time 365days player
      Rollback: lb rollback time 365days player
      grief: ban $1 griefing submit appeal at
    verbooseMode: false
    I try do /grief storm_surge and nothing happens. It tries banning the player $1.

    Anyway to make the commands not case sensitive?
  20. Yes, you are right. I should make shortcuts case insensitive. The shortcuts seem to be correct. Did you try t: time ? Probably there is a mistake when handling shortcuts with arguments. And my second question: Do you get any errors in the console? (Maybe, when enabling the plugin?)
    The $1 isn't replaced?
  21. Offline


    I don't fully understand it...
    How can I make the '/muco promote <player>' execute:
    /manuadd <player> EconomieSurvivor world_economy
    /manuadd <player> EconomieSurvivor world_economy_the_end
    /manuadd <player> EconomieSurvivor Skylands
    /manuadd <player> EconomieSurvivor Nether
    /manuadd <player> CreativeBouwer Planetoids
    /manuadd <player> CreativeBouwer world_creative
    /manuadd <player> CreativeBouwer Flatlands
    /manuadd <player> CreativeBouwer Flatlands2

    How can I do that? So for example:
    When I type '/muco promote HarryPotter', it executes:
    /manuadd HarryPotter EconomieSurvivor world_economy
    /manuadd HarryPotter EconomieSurvivor world_economy_the_end
    /manuadd HarryPotter EconomieSurvivor Skylands
    /manuadd HarryPotter EconomieSurvivor Nether
    /manuadd HarryPotter CreativeBouwer Planetoids
    /manuadd HarryPotter CreativeBouwer world_creative
    /manuadd HarryPotter CreativeBouwer Flatlands
    /manuadd HarryPotter CreativeBouwer Flatlands2

    Please help...
  22. Offline

    timtower Administrator Administrator Moderator

    what is the difference between this en commandhelper?
  23. Offline


    Yeah, Essentials. Please do.
    Thanks, Recon
  24. Add the single commands via /muco add <list> /<command> <arguments> and replace the name of the player with $1. For example:
    /manuadd $1 EconomieSurvivor world_economy​
    If you execute /muco EconomieSurvivor HarryPotter it will execute:
    /manuadd HarryPotter EconomieSurvivor world_economy​
  25. Offline


    The download link doesn't seem to work :( could you maybe post the file as attachment?
    Strange, the website seems to be unaccessable for me. I tried a webservice that displays a page for you (to go around webblockers) and i was able to download the file. I tried using the google public dns, but it seems that i'm still blocked from opening that site, so probably a government/ISP block. You might want to switch to a different download site.
    You can put the download on github. That page is accessable for anyone i think, and you already have an account there. Just make a folder releases and in it folders with version numbers, where you can put the jar file in. You can also just make a downloadable file if you know how to do that.
  26. Yeah, I heard about this problem. If you are Chinese, Japanese, Thai or from Hong Kong the page is blocked by my webspace provider. I think I'll choose your suggestion and put the jar to Github.
  27. Offline


    If i have /muco apples run /i apple will i need the perm for /i apple or just multicommand.muco.apples ?

    If i have "bye: stop" in shortcuts can I add /bye to a /muco command?

    Tell me will this work? In shortcuts "kit: muco" "/kit create ores" then "/kit add ores /i diamond" and then "/kit diamond" will give diamonds to you?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  28. Offline


    doesnt work with 1.2.5 R3
  29. 1. What doesn't work?
    2. Console errors?
    3. Any other stuff you would like to say

    The sentence "doesn't work" does NOT help me. If YOU want ME to fix the problem, you have to DESCRIBE it.
  30. Offline


    This Consoler Error !
  31. Obviosly you have an error in your config.yml. Make a backup of it and then delete it. After a server restart/reload everything should work fine.

Share This Page