[ADMN] ModTRS v2.1 - Moderator Ticket Request System [1240]

Discussion in 'Inactive/Unsupported Plugins' started by Yetanotherx, Apr 4, 2011.

  1. Offline


    Please update this ;)
  2. Same error (bukkit sad) on /modreq.
    using PEX & Bukkit 1185
  3. Offline

    Torrey Leonard

    Bukkit sad :(

    Like, wtf?

    User intelligence has dropped dramatically since this plugin broke for me, so please, update/fix it if possible!
  4. Offline


    i think its only broke if you're using an old permissions system. after upgrading from permissions 2.7.x to bpermissions, all is well now.
  5. Offline

    Torrey Leonard

    I can't just change permissions like that, I tried bperms once a week ago and everything just, died.
    So I hope ModTRS can just be fixed for Perms 2
  6. Offline


    permissions 2 and permissions 3 are both dead projects. They wont be supported by new plugins and old plugins are moving to superperms. Id setup a test server and figure it out. :)
  7. Offline


    "Bukkit sad...."
    What about PermissionsEx?
    All other commands works except for /modreq (with PermissionsEx)
  8. Offline


    Simply everything works with PermissionsEX

    This only thing wrong with this is that "/modreq help" has been broken ever since 2.0 came out.
  9. Offline

    Daniel Few

    /modreq-ban [username]
    doesn't seem to be working.

    When I try and use it it just says
    /modreq-ban [username]

    Thanks for any help with this,
  10. Offline


    Does the modreq command work from the console?
    Would make quizzing players that applied much easier as staff could quiz them right after they apply. :)
  11. Offline


    Why it dont works with Permissions 3.1.6 - bukkit says....
  12. Offline


    Moved to bPermissions, but it still don't work ;(
  13. Offline


    I'm aware of the issues, and I'm working on a 1.8 release.
  14. Offline


    I'm confused... The thread title says [1185], isnt Bukkit 1185 ONLY a 1.8 jar anyways?
  15. Offline


    @kayloe some people arnt having problems with it using 1185 (like myself). I had issues when I was still using permissions 2.7.4, but since upgraded since both perms 2.7.x and 3.x are dead projects now.
  16. Offline


    Version 2.1 released. Included:

    • Allow commas in /check-id, etc.
    • Regular players can't reload the conflg anymore
    • Fix /version
    • Non-mods can see the "closed while offline" message.
    • The "closed while offline" message no longer accidentally persists during logins.
    • Support superperms for REAL.
  17. Offline


    I cant get it to work.
    When i hit anny command i get internal error message.
    ussing bukkit 1185
    last version of modtrs

    2011-09-29 21:01:39 [INFO] [ModTRS] Command: /check
    2011-09-29 21:01:39 [SEVERE] java.lang.NullPointerException
    2011-09-29 21:01:39 [SEVERE]     at yetanotherx.bukkitplugin.ModTRS.command.CheckCommand.onCommand(CheckCommand.java:83)
    2011-09-29 21:01:39 [SEVERE]     at yetanotherx.bukkitplugin.ModTRS.command.CommandHandler.onCommand(CommandHandler.java:129)
    2011-09-29 21:01:39 [SEVERE]     at yetanotherx.bukkitplugin.ModTRS.ModTRS.onCommand(ModTRS.java:140)
    2011-09-29 21:01:39 [SEVERE]     at org.bukkit.command.PluginCommand.execute(PluginCommand.java:39)
    2011-09-29 21:01:39 [SEVERE]     at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:163)
    2011-09-29 21:01:39 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:353)
    2011-09-29 21:01:39 [SEVERE]     at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:756)
    2011-09-29 21:01:39 [SEVERE]     at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:721)
    2011-09-29 21:01:39 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:714)
    2011-09-29 21:01:39 [SEVERE]     at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    2011-09-29 21:01:39 [SEVERE]     at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    2011-09-29 21:01:39 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:92)
    2011-09-29 21:01:39 [SEVERE]     at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:500)
    2011-09-29 21:01:39 [SEVERE]     at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    2011-09-29 21:01:40 [SEVERE]     at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:464)
    2011-09-29 21:01:40 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
    2011-09-29 21:01:40 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
  18. This seems like a wonderful plugin but for some reason my minecraft server gets over loaded with idiots who cannot remember these simple commands. Could you add a command remapping command/configure file?
  19. Still can't use /modreq (bukkit sad - using PEX) with * permissions.
    /modtrs reload cause "an internal error occured, please contact an administrator"

    Other commandes seems to work (check, modlist, mod-broadcast)
  20. Offline


    ModTRS 2.1 is working fine for me on Bukkit #1185, and PEX 1.14.
    It has fixed all previous bugs from 2.0. (Really only /modreq help)
  21. Offline


    Here's a REALLY BASIC output of the last 100 tickets, for anyone who's interested.

    I may do a bit more work on it later:

    $out=`sqlite3 -html /home/mcau/minecraft/1.8/plugins/ModTRS/ModTRS.db "select r.id,u.name,r.text,r.status from modtrs_request r, modtrs_user u where r.user_id=u.id order by r.id desc limit 100"`;
    <? print $out; ?>

    This was pretty basic actually. Luckily, one of our more webby guys has taken this and run with it, and we now have this:


    I'll package it up for those that want it.
    fffizzz likes this.
  22. Offline


    Can anyone confirm this is working with 1240? Also download link is broken.
  23. anyone got 2.1 download? please share
  24. Offline


    Of course it works with 1240. But I will not share the link with you sorry. Not my plugin. I do not want to obey any rules ;(
  25. Offline


    You can make aliases in bukkit.yml.

    What's the error in the console? Re-download and try again.

    Link is now fixed.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
    Rytis and _GWG_Sheepkiller2 like this.
  26. hmmm seems 2.1 doesnt work with 1240 for me anyways, it works for my local server on 1185 but its in my 1240 plugin folder and theres no sign of it working
  27. Offline


    i notice that when a modreq is completed while the player is offline, the notification shows forever afterwards, not just the next time they login. could you add a command to remove the notifications? the players must get spammed with notifications when they login, and i myself am annoyed just by the two i have.
  28. Offline


    Fixed in version 2.1. Redownload and try again.
  29. People can do the command, but admins (* permissions) can't do it, but that's no big deal.
  30. Offline


    Hey all,

    I can't seem to get ModTRS to hook into my permissions. I'm just using PermissionsBukkit.

    Any advice?

    EDIT: for clarity's sake it says "Permissions not found."

Share This Page