[ADMN] ModTRS v2.1 - Moderator Ticket Request System [1240]

Discussion in 'Inactive/Unsupported Plugins' started by Yetanotherx, Apr 4, 2011.

  1. Offline


    That's when you ban the player and use SQL queries to /done them. :p
  2. Offline


    Hehe don't get me wrong, I'm not pushing, just wondering if the option was explored yet :)

    EDIT: I had some time, so I read the thread. Seems like someone already brought it up, so apologies for the duplicate request. I hope you look into it further at your own perusal :) Thank you for this wonderful plugin.
  3. Offline


    It is already possible to throtle requests, though, so one person can't have more than a set number of requests.
  4. Offline


    I keep getting permissions error no matter what if im admin and have '*' permission still tells me no permissions for this command
  5. Offline


    May I add a feature request?

    I would like the ability to add messages/updates to a specific request/ticket. Would that be doable?
  6. Offline


    I've come to request the ability to use some of the commands in console! I run my server a lot from just the console, and it'd be nice to be able to use /mod-broadcast in it. Or /check even.

  7. Offline


    I'm working on a major update to the plugin, and this will be in the next version.
  8. Offline


    if it hasnt been requested, world would be fantastic addition to the ticket.
  9. Offline


    @Yetanotherx Awesome. Don't suppose you have a date in mind for when that update might happen?
  10. Offline


    Depends on my work schedule. It could be anywhere from a few days to a few weeks.
  11. Offline


    Could you change the id's written to the database into names?

    Now everyone is a number. Is there a way to change this?
  12. Offline


    Configuration link doesn't work? :(
  13. Offline


    I get this error after a server restart/reload.

    2011-07-20 05:51:15 [INFO] [ModTRS] Need to download 1 file(s)
    2011-07-20 05:51:15 [INFO] [ModTRS]  - Downloading file: libsqlitejdbc.so
    2011-07-20 05:51:15 [SEVERE] javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
    2011-07-20 05:51:15 [SEVERE]     at sun.security.ssl.Alerts.getSSLException(Alerts.java:192)
    2011-07-20 05:51:15 [SEVERE]     at sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1665)
    2011-07-20 05:51:15 [SEVERE]     at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:258)
    2011-07-20 05:51:15 [SEVERE]     at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:252)
    2011-07-20 05:51:15 [SEVERE]     at sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1165)
    2011-07-20 05:51:15 [SEVERE]     at sun.security.ssl.ClientHandshaker.processMessage(ClientHandshaker.java:154)
    2011-07-20 05:51:15 [SEVERE]     at sun.security.ssl.Handshaker.processLoop(Handshaker.java:610)
    2011-07-20 05:51:15 [SEVERE]     at sun.security.ssl.Handshaker.process_record(Handshaker.java:546)
    2011-07-20 05:51:15 [SEVERE]     at sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:913)
    2011-07-20 05:51:15 [SEVERE]     at sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1158)
    2011-07-20 05:51:15 [SEVERE]     at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1185)
    2011-07-20 05:51:15 [SEVERE]     at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1169)
    2011-07-20 05:51:15 [SEVERE]     at sun.net.www.protocol.https.HttpsClient.afterConnect(HttpsClient.java:440)
    2011-07-20 05:51:15 [SEVERE]     at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:185)
    2011-07-20 05:51:15 [SEVERE]     at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1139)
    2011-07-20 05:51:15 [SEVERE]     at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:254)
    2011-07-20 05:51:15 [SEVERE]     at java.net.URL.openStream(URL.java:1029)
    2011-07-20 05:51:15 [SEVERE]     at com.griefcraft.lwc.Updater.update(Updater.java:257)
    2011-07-20 05:51:15 [SEVERE]     at com.griefcraft.lwc.Updater.loadVersions(Updater.java:215)
    2011-07-20 05:51:15 [SEVERE]     at yetanotherx.bukkitplugin.ModTRS.ModTRS.onEnable(ModTRS.java:113)
    2011-07-20 05:51:15 [SEVERE]     at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
    2011-07-20 05:51:15 [SEVERE]     at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:878)
    2011-07-20 05:51:15 [SEVERE]     at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:272)
    2011-07-20 05:51:15 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:162)
    2011-07-20 05:51:15 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:146)
    2011-07-20 05:51:15 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.reload(CraftServer.java:380)
    2011-07-20 05:51:15 [SEVERE]     at org.bukkit.command.SimpleCommandMap$ReloadCommand.execute(SimpleCommandMap.java:281)
    2011-07-20 05:51:15 [SEVERE]     at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
    2011-07-20 05:51:15 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:320)
    2011-07-20 05:51:15 [SEVERE]     at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:713)
    2011-07-20 05:51:15 [SEVERE]     at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:677)
    2011-07-20 05:51:15 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:670)
    2011-07-20 05:51:15 [SEVERE]     at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    2011-07-20 05:51:15 [SEVERE]     at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    2011-07-20 05:51:15 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
    2011-07-20 05:51:15 [SEVERE]     at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    2011-07-20 05:51:15 [SEVERE]     at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    2011-07-20 05:51:15 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    2011-07-20 05:51:15 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    2011-07-20 05:51:15 [SEVERE] Caused by: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
    2011-07-20 05:51:15 [SEVERE]     at sun.security.validator.PKIXValidator.doBuild(PKIXValidator.java:324)
    2011-07-20 05:51:15 [SEVERE]     at sun.security.validator.PKIXValidator.engineValidate(PKIXValidator.java:224)
    2011-07-20 05:51:15 [SEVERE]     at sun.security.validator.Validator.validate(Validator.java:235)
    2011-07-20 05:51:15 [SEVERE]     at sun.security.ssl.X509TrustManagerImpl.validate(X509TrustManagerImpl.java:147)
    2011-07-20 05:51:15 [SEVERE]     at sun.security.ssl.X509TrustManagerImpl.checkServerTrusted(X509TrustManagerImpl.java:230)
    2011-07-20 05:51:15 [SEVERE]     at sun.security.ssl.X509TrustManagerImpl.checkServerTrusted(X509TrustManagerImpl.java:270)
    2011-07-20 05:51:15 [SEVERE]     at sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1144)
    2011-07-20 05:51:15 [SEVERE]     ... 34 more
    2011-07-20 05:51:15 [SEVERE] Caused by: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
    2011-07-20 05:51:15 [SEVERE]     at sun.security.provider.certpath.SunCertPathBuilder.engineBuild(SunCertPathBuilder.java:197)
    2011-07-20 05:51:15 [SEVERE]     at java.security.cert.CertPathBuilder.build(CertPathBuilder.java:255)
    2011-07-20 05:51:15 [SEVERE]     at sun.security.validator.PKIXValidator.doBuild(PKIXValidator.java:319)
    2011-07-20 05:51:15 [SEVERE]     ... 40 more
    2011-07-20 05:51:15 [INFO] [ModTRS] Using Permissions version 3.1.5 for permission handling
    2011-07-20 05:51:15 [INFO] [ModTRS] Plugin enabled! (version 1.4)

    My config

        requests_per_page: 5
        databases: {}
        blacklist: []
        notify_mods: true
        log_commands: false
        max_requests: -1
        autoupdate: true
        debug: false
            port: ''
            server: ''
            type: sqlite
            user: ''
            database: plugins\ModTRS\modtrs.db
            pass: ''

    Running on bukkit 1000
  14. Offline


    Just a quick update... I'm working on a major update to this plugin right now. It will contain many new features, and many have already been added, such as native Bukkit database usage, internalization, console commands, multiworld support, an API for other plugins to interact with, and many bug fixes. This will be released in a few weeks maximum, but if you would like to do some beta testing, message me and I'll be sure to send you a beta copy when finished.
  15. Offline


    One more feature request - have a /checkstatus or something to show the player where there request is in the list.
  16. Offline


    Major update is pretty much finished. It does break backward compatibility, and I will need to write a converter tool to transfer databases. (although it'd be easier if you just started fresh). A full changelog is shown here: https://github.com/yetanotherx/ModTRS/wiki/Changelog

    If you would like a beta version, please PM me and I'll send you a copy.
  17. Offline



    Yet, there is no history. It appears you have deleted it.
    Can we get some information on configuration?

    e.g. is 'max_requests' total max request, the number a player can have open at one time, the max any player may ever have, etc ,etc?
    royfort likes this.
  18. Offline


    The number a player can have open at one time.
  19. Offline


    can i import the modtrs.db to mysql ?
  20. Offline


    Amazing plugin, used it before. Today I reinstalled it, but the permissions weren't working right, only my admins could use the plugin, not my mods.

    Using PermissionsEx.
    /pex group mod add modtrs.command.modlist w:*
    My issue is that even though that it says the permission is added, my mods still cannot use the command.
  21. Offline


    After the server has been idea for a while, I get this when attempting to do anything with ModTRS (including whatever happens automatically when a player joins):

    Error Log (open)
    18:51:46 [SEVERE] com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: The last packet successfully received from the server was 66,564,284 milliseconds ago. The last packet sent successfully to the server was 66,564,288 milliseconds ago. is longer than the server configured value of 'wait_timeout'. You should consider either expiring and/or testing connection validity before use in your application, increasing the server configured values for client timeouts, or using the Connector/J connection property 'autoReconnect=true' to avoid this problem.
    18:51:46 [SEVERE] at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    18:51:46 [SEVERE] at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
    18:51:46 [SEVERE] at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
    18:51:46 [SEVERE] at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
    18:51:46 [SEVERE] at com.mysql.jdbc.Util.handleNewInstance(Util.java:407)
    18:51:46 [SEVERE] at com.mysql.jdbc.SQLError.createCommunicationsException(SQLError.java:1116)
    18:51:46 [SEVERE] at com.mysql.jdbc.MysqlIO.send(MysqlIO.java:3348)
    18:51:46 [SEVERE] at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:1967)
    18:51:46 [SEVERE] at com.mysql.jdbc.MysqlIO.sqlQueryDirect(MysqlIO.java:2140)
    18:51:46 [SEVERE] at com.mysql.jdbc.ConnectionImpl.execSQL(ConnectionImpl.java:2626)
    18:51:46 [SEVERE] at com.mysql.jdbc.PreparedStatement.executeInternal(PreparedStatement.java:2111)
    18:51:46 [SEVERE] at com.mysql.jdbc.PreparedStatement.executeQuery(PreparedStatement.java:2273)
    18:51:46 [SEVERE] at yetanotherx.bukkitplugin.ModTRS.sql.ModTRSRequestTable.getOpenRequests(ModTRSRequestTable.java:66)
    18:51:46 [SEVERE] at yetanotherx.bukkitplugin.ModTRS.listener.ModTRSPlayerListener.onPlayerJoin(ModTRSPlayerListener.java:39)
    18:51:46 [SEVERE] at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:244)
    18:51:46 [SEVERE] at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    18:51:46 [SEVERE] at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:332)
    18:51:46 [SEVERE] at net.minecraft.server.ServerConfigurationManager.c(ServerConfigurationManager.java:124)
    18:51:46 [SEVERE] at net.minecraft.server.NetLoginHandler.b(NetLoginHandler.java:97)
    18:51:46 [SEVERE] at net.minecraft.server.NetLoginHandler.a(NetLoginHandler.java:33)
    18:51:46 [SEVERE] at net.minecraft.server.NetworkListenThread.a(SourceFile:91)
    18:51:46 [SEVERE] at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    18:51:46 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    18:51:46 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    18:51:46 [SEVERE] Caused by: java.net.SocketException: Broken pipe
    18:51:46 [SEVERE] at java.net.SocketOutputStream.socketWrite0(Native Method)
    18:51:46 [SEVERE] at java.net.SocketOutputStream.socketWrite(SocketOutputStream.java:92)
    18:51:46 [SEVERE] at java.net.SocketOutputStream.write(SocketOutputStream.java:136)
    18:51:46 [SEVERE] at java.io.BufferedOutputStream.flushBuffer(BufferedOutputStream.java:65)
    18:51:46 [SEVERE] at java.io.BufferedOutputStream.flush(BufferedOutputStream.java:123)
    18:51:46 [SEVERE] at com.mysql.jdbc.MysqlIO.send(MysqlIO.java:3329)
    18:51:46 [SEVERE] ... 17 more

    (Running with MySQL, obviously, and mysqld is running and responsive)
  22. Offline


    This is a great mod and everything works smoothly. I would really like to see a feature like /tp-id that teleports the mod to where they were when they used /tp-id so that they can return to what they were doing before the ticket was filed.
  23. Offline


    To solve /modreq spam issues, I use the plugin CommandIconomy and charge my users a deposit of 25 iconomy dollars.

    If the ticket breaks the rules, is spam, or wastes my time, they don't get the money back. Problem solved!
  24. Offline


    Good idea! I think I will implement something similar if I run into spam issues.
    You could also use CommandHelper to script the return of the deposit to be automatic when your mods close the ticket - make one command for spam (just close) and one to payback (close + return deposit).
  25. Offline


    Could you add in localization?
  26. Offline


    Would love for the wiki to work :(
  27. Offline


    I have released version 2.0 of this plugin. Included in version 2.0 is multiworld support, internalization support, many bugfixes, a new database backend, and tons of other changes as seen here.

    Unfortunately, it is not backwards compatible, meaning that your config files and databases will need to be started from scratch. Additionally, you will also need to configure the database in bukkit.yml in the root folder. If you are using SQLite, no additional configuration is needed. If using MySQL, just change the user, password, and database options. Keep in mind that this is the same database that other plugins use, so if you want to avoid breakage, don't adjust these values if you've already configured them.

    Enjoy version 2.0!
  28. Offline


    Not letting me download? 404 error lol it says "This is not the page you are looking for"
  29. Offline


    There is a ' in the download link. Without the ' at the and, the link will work.
  30. Offline


    2.0. Thank you lordy. I can finally live 100% inside the console.

Share This Page