Inactive [ADMN] MineBackup v0.4.8.1 - Auto backup worlds ! [1060]

Discussion in 'Inactive/Unsupported Plugins' started by ThisIsAreku, Jun 24, 2011.

  1. Offline

    ThisIsAreku

  2. Offline

    dragos240

    Oh I see!
     
  3. Offline

    ThisIsAreku

    @dragos240
    I've made an error in the code, the time between backups was not correct. re-download the plugin, i've just fixed it
     
  4. Offline

    dragos240

    I see. Alright I've reloaded.

    So 86400 ticks = every 24h a backup is created?
     
  5. Offline

    ThisIsAreku

    yes, it is
     
  6. Offline

    Tobytheminer

    Dear ThisIsAreku

    I got this problem that my server won't take backups, instead making backups it makes theese folders
    '0.870498006029606'
    '0.5937157006355406'
    '0.06112639587328461'
    '0.7445895783182409'
    '0.9888647567256126'
    '0.31010090425995873'

    And all of theese folders in empty, under the minebackup folder there's no backups, and when i do the /mbck command nothing happends i tryed defrend versions what do you think is wrong, can it be the Groupmanager Permission mod i got?
     
  7. Offline

    ThisIsAreku

    mmh is there any errors in your log file ?
     
  8. Offline

    Tobytheminer

    2011-07-11 01:56:02 [INFO] [MineBackup] Creating 'worlds' config...
    2011-07-11 01:56:02 [INFO] [MineBackup] Creating 'backup-dir' config...
    2011-07-11 01:56:02 [INFO] [MineBackup] Creating 'tick' config...
    2011-07-11 01:56:02 [INFO] [MineBackup] 2 worlds loaded.
    2011-07-11 01:56:02 [INFO] [MineBackup] version 0.3.1 ready

    Thats all what im getting,

    also had this error

    2011-07-19 18:17:10 [INFO] [MineBackup] Starting backup...
    2011-07-19 18:17:10 [INFO] [MineBackup] * world10
    2011-07-19 18:17:10 [WARNING] [MineBackup] error; java.lang.NullPointerException

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 17, 2016
  9. Offline

    ThisIsAreku

    what's your OS ? and your craftbukkit version ?
     
  10. Offline

    Tobytheminer

    craftbukkit-0.0.1-SNAPSHOT
    Windows 7
     
  11. Offline

    jrtc27

    He means when it loads up - all versions have the file called craftbukkit-0.0.1-SNAPSHOT. You should see
    Code:
    This server is running Craftbukkit version
    followed by some numbers appear early on when you load up CraftBukkit. What does it say?
     
  12. Offline

    ACStache

    I'm going to try this out on RB1000 when I get a chance later today, can anyone confirm or deny it working on that build?
     
  13. Offline

    ThisIsAreku

    @ACStache It's compatible, I've just tested
     
  14. Offline

    ACStache

    awesome, thanks :)
     
  15. Offline

    Lord_Crusher

    Working well. Could you clarify the "delay" part of the config in the original post? I had to read the rest of the thread to figure out what it did. Just needs something simple like "Delay = time after server start until first backup".
     
  16. Offline

    jimathy

    i have a weird bug where it claims a world isn't loaded so it deletes it from the config...but it is loaded multiverse loads it at start

    RB: 1000
    Windows...2008? not sure its on a remote server
    worked before update :S
     
  17. Offline

    murlochieftain

    If I restart my server, the config file is read improperly and gives an error in the Yaml output. What happens is that the config file doesn't have hyphens in front of each line or sepeation of categories. The file is automatically over-written this way when a server is started, (if the file was changed before hand.) I would recommend you change this, it's an easy fix.
     
  18. Offline

    ThisIsAreku

    ok, but I was robbed yesterday and they took my computer, I need some time (maybe a week)
     
  19. Offline

    ThisIsAreku

  20. Offline

    godsyn

  21. Offline

    IncendiaDrakon

    Would it be safe to use this plugin in combination with an auto save plugin? I'm worried that if a save is made while a backup is in progress, something weird might happen.
     
  22. Offline

    ThisIsAreku

    @godsyn ok, i'm going to rename this key, because people doesn't understand.. It's ry the value in seconds, the plugin convert it in server ticks on load. (FYI, one second is 20 server ticks)

    @IncendiaDrakon it doesn't matter, the plugin perform a save off/save all/save on automatically during the backup process
     
  23. Offline

    rikell

    Hello
    Cool
    You can add the customysable message please ?
    thank
    £`/@]
     
  24. Offline

    ThisIsAreku

    @rikell : Ok; it's done. Update the plugin, restart your server and the config file will be recreated
     
  25. Offline

    rikell

    Hello
    Thank you !
    I love your plugin !
    £`/@]
     
  26. Offline

    IncendiaDrakon

    I'm worried about another plugin starting a save while a backup is in progress. I don't want corrupted backups.
     
  27. Offline

    ThisIsAreku

    @IncendiaDrakon
    I understand what you mean, but that does not depend on me ..
     
  28. Offline

    Fabis94

    I don't understand the 'delay' part. If there's an interval setting, why does it need a delay setting? Isn't that the same thing? Also can I make it so it doesn't delete old backups at all?
     
  29. Offline

    ThisIsAreku

    @Fabis94
    'delay' is the time after server start until first backup, to avoid overloading the server at start
    and also, to disable the deletion of old backups, set the property to 0
     
  30. Offline

    Sh4d0w

    next version with permissions to get the backup messages?
    i want to hide the messages for normal players
     
  31. Offline

    ThisIsAreku

    @Sh4d0w okay, I will do it tomorrow (for me, in France, it is 00:26 ...)
     

Share This Page