Inactive [ADMN] MineBackup v0.4.8.1 - Auto backup worlds ! [1060]

Discussion in 'Inactive/Unsupported Plugins' started by ThisIsAreku, Jun 24, 2011.

  1. Offline


    i guess not ill check that out

    yep that did it ty

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  2. Offline


    /backup dont do anything for me :/
    no errors in the console
    i have just "backup started" and nothing appears
  3. Offline


  5. Offline


    @ltguide Is there any way to get the message that the backups are starting before the lag actually starts? Could you possibly add some sort of a delay to it? Right now the server lags, then the start and stop finish messages come up together for me, which isnt really helpful.
    xsolar66 likes this.
  6. Offline


    @itguide thanks for updating ;)

    Does the plugin works for the next update ?
  7. Offline


    As of right now, it does :)
  8. Offline


    the plugin broke on CB 1240 for me.
  9. Offline


    You need to use this build
  10. Offline


    ok before complaining about errors, i would recommend reading the post near the TOP OF THE PAGE
  11. Offline


    I am getting an error that says that jar file is corrupt or invalid
  12. Offline


    Sorry, I typed the url out wrong. Try again.
  13. Offline


    sweet thank you!
  14. Offline


    Got an issue with when the backup starts, as it starts as soon as you join the server, you are for ever falling while the backup happens and often crash out with an 'end of stream' message. You have to wait till the server finishes the backup other wise you keep getting the 'end of stream' message.

    Edit: Have been able to avoid the 'end of stream' message by disabling compression. Still get the falling falling when it's backing up, but it doesn't last as long now
  15. Offline


    I have a problem with backing up in general.
    When players log on, it starts the backup as normal, but in the console, I get this:
    12:23:47 [WARNING] Task of 'MineBackup' generated an exception
    java.lang.NoSuchMethodError: org.bukkit.Server.getConsoleSender()Lorg/bukkit/com
            at alexoft.Minebackup.Backups.backupRun(
            at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(C
            at net.minecraft.server.MinecraftServer.h(
    I have it set to run from command prompt, not Pail.
    The plugins I have are PEX, Creeper Heal, Precious Stones, WorldEdit, and of course, MineBackup.
    Asaky likes this.
  16. Offline


    You need to use this build.
  17. Offline


    Any chance of having this updated for latest build? I get the following error with build 1219:

    10:00:47 [WARNING] Task of 'MineBackup' generated an exception
    java.lang.IllegalAccessError: tried to access method org.bukkit.command.ConsoleCommandSender.<init>(Lorg/bukkit/Ser
    ver;)V from class alexoft.Minebackup.Backups
            at alexoft.Minebackup.Backups.backupRun(
            at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(
            at net.minecraft.server.MinecraftServer.h(
    Alternatively, if anybody know of a simple alternative to this utility, please post a link.
  18. *cough*

    READ the post above yours!
  19. Offline


    2011-10-13 19:49:53 [SEVERE] Could not load 'plugins/MineBackup.jar' in folder 'plugins':
    java.lang.ClassNotFoundException: alexoft.Minebackup.MineBackup
        at Method)
        at java.lang.ClassLoader.loadClass(
        at java.lang.ClassLoader.loadClass(
        at java.lang.ClassLoader.loadClassInternal(
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(
        at org.bukkit.craftbukkit.CraftServer.<init>(
        at net.minecraft.server.ServerConfigurationManager.<init>(
        at net.minecraft.server.MinecraftServer.init(
    Caused by: invalid LOC header (bad signature)
        at Method)
        at sun.misc.Resource.getBytes(
        ... 18 more
    Can anyone help with this error? :( On my old server minebackup works, on the new not...
  20. Offline


    I saw that post, but it was talking about Pail, and PEX and other stuff which I'm not familiar with. I'm not in the habit of downloading things if I'm not sure.

    I'll try the suggested download and see if that works.

    Thank you for your reply.


    11:02:53 [INFO] [MineBackup] Backup started
    11:02:55 [INFO] [MineBackup] Starting backup...
    11:02:55 [INFO] [MineBackup]  * skyworld
    11:02:55 [INFO] [MineBackup]    Compressing...
    11:02:55 [INFO] [MineBackup]  * skyworld_nether
    11:02:55 [INFO] [MineBackup]  * world
    11:03:17 [INFO] [MineBackup]    Compressing...
    11:03:17 [INFO] [MineBackup]  * world_nether
    11:03:25 [INFO] [MineBackup] Done !
    11:03:25 [INFO] [MineBackup] Backup ended
    That seems to have worked. Thanks again.
  21. @sleite
    Glad i could help. And sorry if it did sound rude ;) Problem was he snipped the code part in his quote where the exact same error would have been shown.
  22. Offline


    I'm not sure. What CB build are you using? What version of java is the server running?
    Maybe a zip is corrupt. Did you copy old backups to the new server or is this after it creates new ones and you reloaded server?
  23. Offline


    Hey , Im kinda new to this stuff but I recently accidently knocked out the power plug of my comp and server is failing to run When I take away map files it works so i want to put back a backup file the mine backup plugin did . . . How do I do that? or is that not what mineback up does?
  24. Unzip the backups into their respective world directories. Ie, in my minebackup/world directory there's a bunch of .zip files organized by date. Unzip the appropriately dated .zip file into your server's world/ directory to restore the backup.
  25. Offline


    I can't find any zip files of maps and I can assure you I have backed up
  26. Offline


    You should have a minebackup folder in the root of your server directory (where bukkit*.jar is located).

    Thanks for taking the effort of fixing the consolesender errors, but I'm already on top of this. The zip files also have the wrong month which is fixed in mine. There's a billion posts pointing people to it.

    I'd appreciate it if you would remove your link because it'll just make this more confusing.

    I've asked for permission to take this over officially since it's not inactive yet.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  27. Offline


    aight ok. :D
  28. Offline


    Any chance of getting a change from 'days-to-keep' to something smaller and more configurable? I'd like to keep 3 hour backups, but my server is run on SSD's, and I can't save 8 backups of my 672MB world on 5.1 GB of space among all the other files. In my opinion, a 'seconds-to-keep' would be best, considering that this is the only option that isn't already in seconds as an amount of time, or at least a total backup count, so I could only keep 4 backups at once. I've only had this plugin for a short while, and I'm already almost out of space on my server. >_<

    Other than that, my other suggestion, is to make it so you can save the map files every so often without a backup, separate from Backup times. I want to be able to save my map every hour then backup that save every 3 hours.


    EDIT: Forgot to mention one thing, when it starts a save, it only announces the backup start/finish after it's finished. So there's about a 5 second lag on the server, then it says it started and stopped a backup.
  29. Hi i got this message,

    13:53:17 [INFO] [MineBackup] Backup started
    13:53:17 [INFO] CONSOLE: Disabling level saving..
    13:53:17 [INFO] CONSOLE: Forcing save..
    13:53:17 [INFO] CONSOLE: Save complete.
    13:53:17 [INFO] [MineBackup] Starting backup...
    13:53:17 [INFO] [MineBackup] * pvp
    13:53:17 [INFO] [MineBackup] Compressing...
    13:53:17 [INFO] [MineBackup] * world
    13:53:17 [SEVERE] [MineBackup] ---------------------------------------
    13:53:17 [SEVERE] [MineBackup] --- an unexpected error has occured ---
    13:53:17 [SEVERE] [MineBackup] -- please send line below to the dev --
    13:53:17 [SEVERE] [MineBackup] : null
    13:53:17 [SEVERE] [MineBackup] alexoft.Minebackup.Backups.copyWorld(
    13:53:17 [SEVERE] [MineBackup] alexoft.Minebackup.Backups.MakeBackup(
    13:53:17 [SEVERE] [MineBackup] alexoft.Minebackup.Backups.MakeBackup(
    13:53:17 [SEVERE] [MineBackup] alexoft.Minebackup.Backups.backupRun(
    13:53:17 [SEVERE] [MineBackup]
    13:53:17 [SEVERE] [MineBackup] org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(
    13:53:17 [SEVERE] [MineBackup] net.minecraft.server.MinecraftServer.h(
    13:53:17 [SEVERE] [MineBackup]
    13:53:17 [SEVERE] [MineBackup]
    13:53:17 [SEVERE] [MineBackup] ---------------------------------------
    13:53:17 [INFO] [MineBackup] Done !

    im using the build from the previous post, and my bukkit is 1240
  30. Offline


    2011-10-16 15:29:26 [INFO] ←[32m[MineBackup] Backup started←[0m
    2011-10-16 15:29:26 [WARNING] Task of 'MineBackup' generated an exception
    java.lang.IllegalAccessError: tried to access method org.bukkit.command.ConsoleC
    ommandSender.<init>(Lorg/bukkit/Server;)V from class alexoft.Minebackup.Backups
            at alexoft.Minebackup.Backups.backupRun(
            at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(C
            at net.minecraft.server.MinecraftServer.h(
    server has a plugin this may be the cause?

Share This Page