Inactive [ADMN/MECH] NoSpawn v1.5.3 - Stop mobs from spawning [1000]

Discussion in 'Inactive/Unsupported Plugins' started by xXLupoXx, Apr 22, 2011.

  1. Offline

    xXLupoXx

    GreyBishop likes this.
  2. Offline

    LeetPowerCraft

    This doesn't seem to work for me anymore.... I raised the TotalMobLimit from what I originally had to 200 because users were complaining that there were too few mobs. Ever since I raised the mob limit mobs have stopped spawning completely. Yes, yes, I have mobs turned on in my server.properties.
     
  3. Offline

    Darcion

    after removing all the mobspawner (configured with spawnmob) i didn't see any of this errors.
     
  4. Offline

    Blechbuexse

    Code:
    world:
            creature:
                Creeper:
                    spawn: true
                    BlockBlacklist: '20;4'
                    Limit: 0
                Chicken:
                    spawn: true
                    BlockBlacklist: '20;4'
                    Limit: 0
                Sheep:
                    spawn: true
                    BlockBlacklist: '20;4'
                    Limit: 0
                Giant:
                    spawn: true
                    BlockBlacklist: '20;4'
                    Limit: 0
                Zombie_Pigman:
                    spawn: true
                    BlockBlacklist: '20;4'
                    Limit: 0
                Slime:
                    spawn: true
                    BlockBlacklist: '20;4'
                    Limit: 0
                Spider:
                    spawn: true
                    BlockBlacklist: '20;4'
                    Limit: 0
                Pig:
                    spawn: true
                    BlockBlacklist: '20;4'
                    Limit: 0
                Squid:
                    spawn: true
                    BlockBlacklist: '20;4'
                    Limit: 0
                Wolf:
                    spawn: true
                    BlockBlacklist: '20;4'
                    Limit: 0
                Zombie:
                    spawn: true
                    BlockBlacklist: '20;4'
                    Limit: 0
                Cow:
                    spawn: true
                    BlockBlacklist: '20;4'
                    Limit: 0
                Ghast:
                    spawn: true
                    BlockBlacklist: '20;4'
                    Limit: 0
                Skeleton:
                    spawn: true
                    BlockBlacklist: '20;4'
                    Limit: 0
            properties:
                TotalMobLimit: 0
    
    ...and my home is safe?

    :)

    nice toll
     
  5. Offline

    TelephoneKiosk

    Does the /allowspawn command work with Monsters?
     
  6. Offline

    theVanyr

    Just dropping in to say: Thank you. This is a great Plug-in, no issues, easy to manage, and our community build projects have been creeper safe ever since I installed it.
     
  7. Offline

    ಠ_ಠ

    Does this only stop the natural spawns? or does it stop ALL spawns?
     
  8. Offline

    Cryt

    Work in 953 ?
     
  9. Offline

    Keyle

    In 1.5.2 it stops ALL spawns.
    v1.5.3 only stops normal spawns (also egg, bed-spawns)
    only unusual spawns like from plugins aren't stopped
    1.5.3 works with RB953

    1.5.3
    download here
     
  10. Offline

    Xmillsa

    Just thought id pop in to say, 1.5.2 is working fine for me with RB953.
     
  11. Offline

    Avaran

    Hey!
    How come when i type "/nospawn spawn pig 2" i get the error "spawn isn't a valid parameter! Please use allowspawn, denyspawn, despawn, setmoblimit, settotalmoblimit or settimer"
    Im not sure if im doing it right or wrong?
     
  12. Offline

    phondeux

    Was this ever fixed?
     
  13. Offline

    Steve Member

    1.5.3 is causing 100% cpu and unusable server here on b953
     
  14. Offline

    Keyle

    I removed the spawncommand from the plugin because there is no need anymore(for this plugin)
    please use anotherplugin to spawn creatures.
    this is not a bug in this plugin, it's a problem with the yaml format. A .(dot) is the delimiter in the plugin to jump in a deeper node
    please try this:
    Code:
    worlds:
        'world.biome':
            creature:
                Creeper:
                    spawn: true
                    BlockBlacklist: ''
                    Limit: 0
    ... deleted a bunch of creatures for brevity ...
                Skeleton:
                    spawn: true
                    BlockBlacklist: ''
                    Limit: 0
    But I think it will cause the same problems
    remove the .(dot) in the name and everything will work fine

    sure that THIS plugin cause it??
    I will look on it
     
  15. Offline

    ಠ_ಠ

    i get this error now...

    Code:
    22:51:05 [SEVERE] Error occurred while enabling NoSpawn v1.5.3 (Is it up to date?): For input string: ""
    java.lang.NumberFormatException: For input string: ""
        at java.lang.NumberFormatException.forInputString(NumberFormatException.java:48)
        at java.lang.Integer.parseInt(Integer.java:470)
        at java.lang.Integer.parseInt(Integer.java:499)
        at me.xXLupoXx.NoSpawn.ConfigBuffer.getBlacklist(ConfigBuffer.java:181)
        at me.xXLupoXx.NoSpawn.ConfigBuffer.readConfig(ConfigBuffer.java:105)
        at me.xXLupoXx.NoSpawn.NoSpawn.onEnable(NoSpawn.java:35)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:857)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:264)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:151)
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:136)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:284)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:271)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:148)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    
     
  16. Offline

    Keyle

    I think you have " (double quotes) in your config :p
    replace them with ' (single quotes)
    When it still don't work post your config please
     
  17. Offline

    ಠ_ಠ

    No double quotes :\ is it because they have to spawn on at least one block? but even then, i see them spawning in caves when the only block i allow is soulsand...
    Code:
    properties:
        RefreshTimer: 200000
    worlds:
        world_nether:
            creature:
                Creeper:
                    spawn: false
                    BlockBlacklist: ''
                    Limit: 0
                Chicken:
                    spawn: false
                    BlockBlacklist: ''
                    Limit: 0
                Sheep:
                    spawn: false
                    BlockBlacklist: ''
                    Limit: 0
                Giant:
                    spawn: false
                    BlockBlacklist: ''
                    Limit: 0
                Zombie_Pigman:
                    spawn: true
                    BlockBlacklist: ''
                    Limit: 0
                Slime:
                    spawn: false
                    BlockBlacklist: ''
                    Limit: 0
                Spider:
                    spawn: false
                    BlockBlacklist: ''
                    Limit: 0
                Pig:
                    spawn: false
                    BlockBlacklist: ''
                    Limit: 0
                Squid:
                    spawn: false
                    BlockBlacklist: ''
                    Limit: 0
                Wolf:
                    spawn: false
                    BlockBlacklist: ''
                    Limit: 0
                Zombie:
                    spawn: false
                    BlockBlacklist: ''
                    Limit: 0
                Cow:
                    spawn: false
                    BlockBlacklist: ''
                    Limit: 0
                Ghast:
                    spawn: false
                    BlockBlacklist: ''
                    Limit: 0
                Skeleton:
                    spawn: false
                    BlockBlacklist: ''
                    Limit: 0
            properties:
                TotalMobLimit: 0
        world:
            creature:
                Creeper:
                    spawn: true
                    BlockBlacklist: '1;2;3;4;5;6;7;8;9;10;11;12;13;14;15;16;17;18;19;20;21;22;23;24;25;26;27;28;29;30;31;32;33;34;35;36;37;38;39;40;41;42;43;44;45;46;47;48;49;50;51;52;53;54;55;56;57;58;59;60;61;62;63;64;65;66;67;68;69;70;71;72;73;74;75;76;77;78;79;80;81;82;83;84;85;86;87;88;89;90;91;92;93;94;95;96'
                    Limit: 0
                Chicken:
                    spawn: true
                    BlockBlacklist: ''
                    Limit: 0
                Sheep:
                    spawn: true
                    BlockBlacklist: ''
                    Limit: 0
                Giant:
                    spawn: true
                    BlockBlacklist: ''
                    Limit: 0
                Zombie_Pigman:
                    spawn: true
                    BlockBlacklist: ''
                    Limit: 0
                Slime:
                    spawn: false
                    BlockBlacklist: ''
                    Limit: 0
                Spider:
                    spawn: true
                    BlockBlacklist: '1;2;3;4;5;6;7;8;9;10;11;12;13;14;15;16;17;18;19;20;21;22;23;24;25;26;27;28;29;30;31;32;33;34;35;36;37;38;39;40;41;42;43;44;45;46;47;48;49;50;51;52;53;54;55;56;57;58;59;60;61;62;63;64;65;66;67;68;69;70;71;72;73;74;75;76;77;78;79;80;81;82;83;84;85;86;87;88;89;90;91;92;93;94;95;96'
                    Limit: 0
                Pig:
                    spawn: true
                    BlockBlacklist: ''
                    Limit: 0
                Squid:
                    spawn: false
                    BlockBlacklist: ''
                    Limit: 0
                Wolf:
                    spawn: true
                    BlockBlacklist: ''
                    Limit: 0
                Zombie:
                    spawn: true
                    BlockBlacklist: '1;2;3;4;5;6;7;8;9;10;11;12;13;14;15;16;17;18;19;20;21;22;23;24;25;26;27;28;29;30;31;32;33;34;35;36;37;38;39;40;41;42;43;44;45;46;47;48;49;50;51;52;53;54;55;56;57;58;59;60;61;62;63;64;65;66;67;68;69;70;71;72;73;74;75;76;77;78;79;80;81;82;83;84;85;86;87;88;89;90;91;92;93;94;95;96'
                    Limit: 0
                Cow:
                    spawn: true
                    BlockBlacklist: ''
                    Limit: 0
                Ghast:
                    spawn: false
                    BlockBlacklist: ''
                    Limit: 0
                Skeleton:
                    spawn: true
                    BlockBlacklist: ''1;2;3;4;5;6;7;8;9;10;11;12;13;14;15;16;17;18;19;20;21;22;23;24;25;26;27;28;29;30;31;32;33;34;35;36;37;38;39;40;41;42;43;44;45;46;47;48;49;50;51;52;53;54;55;56;57;58;59;60;61;62;63;64;65;66;67;68;69;70;71;72;73;74;75;76;77;78;79;80;81;82;83;84;85;86;87;88;89;90;91;92;93;94;95;96''
                    Limit: 0
            properties:
                TotalMobLimit: 0
    
     
  18. Offline

    Keyle

    Your problem is that you have 2 single qoutes before and after the value at:
    Worlds -> world - >Skeleton -> BlockBlacklist

    and why didn't you disable Zombies,Creeper,Skeletons and Spiders at all??
    if they don't can spawn at all blocks you can also set spawn to false :confused:
    That is easier to configurate and better for server perfomance
     
  19. Offline

    ಠ_ಠ

    Because if i disable them completly, they wont spawn from their spawners. i just dont want them randomly in caves or above ground. its a complicated server idea i have xD :p
     
  20. Offline

    Pim1234

    does limit: 0 means it is not limited?
     
  21. Offline

    Keyle

    Yes 0 means no limit
     
  22. Offline

    DevRW

    Just a heads up; conflicts with a fairly popular plugin: MobArena

    Whether or not you want to look at fixing it is up to you, just giving you a heads up. :)

    I tried blocking mobs in every possible way I could, but they spawned in arenas with grass blocks every time - even when added to a blacklist. And never any errors.

    My post from their thread:
     
  23. Offline

    Chris Herbert

    Not sure if this a problem with Bukkit #1000+ or if its always had this problem. I installed it to day and my processor usage shot up to between 100 and 140% with only 15 players on.

    I removed the plugin and it dropped back to a more reasonable 50-60%
     
  24. Offline

    Arton

    does this plugin Be Updated to [1000] i need something there stop mobs to spawn but like spawn it with a command
     
  25. Offline

    Jamie Tees

    Can you update this for us, We need it!
     
  26. Offline

    Keyle

    Sorry but this have to wait until I come back from holidays >.<
    except @xXLupoXx abase himself again to make an update:p
     
  27. Offline

    F_Synchro

    I like to note that this version works fine with V1000.
     
  28. Offline

    Jamie Tees

    doesn't for me :/
     
  29. Offline

    Keyle

    I think so too:p
    UNHELPFUL AND TOTALY USELESS:mad:
     
  30. Offline

    F_Synchro

    I'm using it on my server and works just fine, though an option to set the height of what mob can spawn would be nice, cause I don't want creepers to spawn near the area where stuff is being built, but having them deep underground would be nice and thrilling.
     
  31. Offline

    DudeGuy676

    Thanks! I don't like it when creepers spawn in my freebuild world. Really helpful!
     

Share This Page