Inactive [ADMN] MCTelnet v1.2.7 - Remote Console Access using Telnet [1185]

Discussion in 'Inactive/Unsupported Plugins' started by bekvon, Feb 21, 2011.

  1. Offline


    MCTelnet - A telnet server plugin for bukkit.
    Current Version: v1.2.7

    First off, this is not a wrapper, its a simple plugin. Plop it into your plugins folder, tweak the config file and your good to go.

    • Ability to access the server console from telnet.
    • Requires username + password on connect.
    • Port can be specified in config.yml
    • Additional users with different permissions can be set up.
    • Passwords can be encrypted in the config file (md5).
    • Contains a "sudo" command that will elevate you to the root user.
    Sample Config File:
    #Setup information
    encryptPasswords: true
    telnetPort: 8765
    allowAuthlessLocalhost: false
    #Root login information
    rootUser: console
    rootPass: abcd
    rootEncrypted: false
    #Other users
            log: true
            password: abcd
            commands: list, plugman, help
            passEncrypted: false
    Instructions by ScorchRaserik:
    • Possibly implementing usernames to log on with. Done
    • Possible Integration into Permissions. Not really possible right now.
    • Make config file write default values if missing. Done
    • Code cleanup
    • Make passwords hidden as you type (almost done).Done
    • Optional idle-timeout.
    • Sudo command (similar to linux). Done
    • Encrypt passwords in the config. Done
    Change Log:
    v1.2.7 - 9/23/2011
    - Fix chat color codes being printed on console.

    Change log (open)

    v1.2.6 - 8/16/2011
    - Fixed to work with CB 1060.

    v1.2.4 - 4/11/2011
    - Allowed periods to be used.

    v1.2.2 - 3/19/2011
    - Added ability to specify a listen address.
    - Rebuilt with latest CB (556)

    v1.2.1 - 2/28/2011
    - Rebuilt against latest recommended craftbukkit build (440 as of now).
    - Changed to static download link.

    v1.2 - 2/24/2011
    - Added sudo command.
    - Passwords will now be setup to be encrypted in the config file.
    - Passwords are now hidden as you type.
    - Other minor improvements.

    v1.1 - 2/22/2011
    - Added usernames, can now specify users and what commands they can use.
    - Cleaner config file with more information.
    - Missing config file is regenerated.
    - Many aesthetic improvements.

    v1.0 - 2/21/2011
    - Initial Release.

    File: MCTelnet
    Configuration File: config.yml
    Recommended Telnet Client: PuTTY

    Source: GitHub
    kittenchunks, umnumnum, sbeex and 7 others like this.
  2. Offline


    Every Time I type in my ip and port, the command window pops up, the disappears, producing an error sound. :/
  3. Offline



    This plugin is excellent, however, the latest RB of craftbukkit seems to have broken it. I think it has something to do with the permissions system for built-in commands, as I cannot execute any op commands -- even with the root account -- including save-all, stop, kick, and etc. Instead, I get the error "Sorry, Dave, but I can't do that for you." or something along those lines.

    Would really look forward to having an update. Some say I telnet more than I play on our server!
  4. Offline


    Think I got it fixed now :) Indeed it was the new bukkit permission system getting in the way. I may or may not have to make a few more tweaks to this later.
  5. Offline


    Fixed for a lot of commands, however, I still get "You do not have sufficient access to reload the server." Good progress though, I can live with this for now.

    Oops, another bug: I use the WelcomeMe plugin and MCTelnet is now spitting out the literal colour code characters, instead of something that just didn't have any colours. However, while the colour code character is "&" in the configuration file, it appears as the squiggly S character in the console. Obviously, this didn't happen in earlier versions. If it matters, both the server and client are running Windows; I use putty (anything else, like netcat or default telnet gives me more garbage characters).
    :§9W§ae§b§cl§dc§eo§fm§9e §at§bo §cG§di§fb§9s§at§bi§cc§dk§7'§fs §9s§ae§br§cv§de§fr
    Edit: This occurs for all console text that is supposed to be coloured.
  6. Offline


    Please fix colored text...
  7. Offline


    Pictures or Video?
  8. Offline


    Colored texts not working with the new version, I made a downgrade again.
  9. Offline


    i keep getting invaild username and password
  10. Offline


    Would it be possible to implement an SSH version of this?
  11. Offline


    Love the plugin. I am going to be moving my server onto another system that I will only have remote access to. I hope to use this to maintain control of my server. Bu I noticed a few problems.

    ? - does not work
    and " Quotes do not seem to work. I tried to issue this command and it translated it to...

    lb lookup chestaccess world "world" ---> lb lookup chestaccess world world

    As others have noted is it possible to strip the color codes?

    Thanks for the good plugin!
  12. Offline


    I'm getting "Invalid Username of Password" from putty. Also nothing is displayed when I type the password, but I'm thinking that's the way it should work. Any idea what may be wrong? I tried several configurations/passwords/etc. I'm using Xenon servers for host.
  13. Offline


    When you change the password, make sure you also set passEncrypted (or rootEncypted) to false. Then when the server starts up, the password will be automatically encrypted and the setting will be set to true. You can also force local echo with putty if you need to see what you're typing.
  14. Offline


    Thanks, everything works now.
  15. Offline


  16. Offline

    Robert Pendell

    I'm using the newest version and I'm getting a bunch of ? marks where there should probably be a color code or something similar.
    ??"??"????[MCTelnet] - Session Started!
    ????Logged In as console!
    Any ideas?

    Also I get an error saying I'm not allowed to use a command when managing permissions. The permissions plugin is Group Manager (yes I know it's old).
  17. Offline



    Like some other MCTelnet plugin users, I'm getting the following error:

    2011-09-09 02:16:50 [INFO] [MCTelnet] - Starting Up! Version: 1.2.6 by bekvon
    2011-09-09 02:16:50 [SEVERE] [MCTelnet] - Unable to Enable! Error: Address already in use: JVM_Bind
    It was working fine but the server host changed the IP address so I had updated the config.yml file with the new ListenAddress and add the port reopened at the host.

    What am I missing here?
  18. Offline


    Hey all, quick update, I fixed the chat color codes being printed to console :)
  19. Offline


    Thanks! Still working great, and it seems the issues with not having permissions have been solved by bukkit.
  20. Offline


    i don't see the chat or the commands form the player...
  21. Offline


    I got it to work and successfully logged in as rootuser but it says "You don't have permission to use this command"
    What do I do????

    never mind i got it to work

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016
  22. Offline


  23. Offline


    I was using the wrong user, i just changed my root user and password to 12345 lol
  24. Offline


    why cant i use signs like "!,.:;?=)(/&%$§-*'#\" in the Chat :(?
  25. Offline


    very nice works fine on CB 1317
    i use it with my iphone and the app pterm :D
  26. Offline


    I can't get this to work with xauth...
    If I type xauth, it works but where there's parameters it wont work
    Could it be possible to fix that ?
    BTW great work!!!
  27. make so time works.
  28. Offline


    wow a BIG THANK YOU! [diamond]
    this is exactly what i have been looking for for like ages ;)
    copied -> edited -> works like charm !
    your hard work is really appreciated [diamond]
  29. Offline


    Using CB 1550 and MCTelnet 1.2.7 I am no longer able to write broadcast / say / tell. I can kick using telnet but I cannot send a broadcast. It shows up correctly in the log but it does not show up ingame at all.
  30. Offline


    Best plugin ever! Using newest RB and broadcast/say/tell works. Thank you very much!
  31. Offline


    Which plugin do you use for those commands? CommandBook 1.7 does not work as of 1597.

Share This Page