Inactive [ADMN/INFO] Permissions v2.1 - Continuing the legacy.

Discussion in 'Inactive/Unsupported Plugins' started by Nijikokun, Jan 21, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 2.1 (Handler)
    Download 2.1 (Jar Only)
    Older: 2.0, 1.9, 1.8, 1.7, 1.6, 1.5, 1.4, 1.3, 1.2, 1.1, 1.0

    Permissions... Done right.
    Permissions allows plugin-authors to utalize a permission system that handles group inheritance, globalized permission settings, and more. All the features of a fine-grained permission system in one plugin.​

    1. Groups
    2. Group Inheritance, Allows for groups to gain permissions from other groups.
    3. User Permission System
    4. Fine Grained Permission system.
      1. Allowing for Globalized permissions
    5. Easy to use, setup, and implement.
    6. Two cache layers, first from file to memory, then from memory to cache.
      1. Plugins can control cache since version 2.1
    7. And much more.
    For the users

    Permissions gives server admins great control, mostly in-game reloading. Simply use /pr and the file will be re-cached and never touched again until you need to reload it. This allows you to quickly give your users the commands that they need without having to restart the server.

    Installation for 2.0 down:
    1. Download the archive.
    2. Extract contents to the /plugins folder.
    3. Open up /plugins/Permissions/config.yml
      1. Read / modify.
      2. Save.
    4. Reload Server.

    • 2.1
      • Multiple-World support
      • New cache layer, and cache control support for plugins
      • Editing features for plugins to hook into
      • Exempt nodes
      • World copying
    • 2.0
      • Forgot.
    • 1.9
      • Fully fixes inheritance.
        • Groups now inherit groups of groups that inherit groups of...
      • Cache system implemented.
      • Plugin authors can now delegate a variable system if needed.
      • API Updated with two new functions to get the point of what they do across.
        • Along with the new variable checks.
    • 1.8
      • Fixes the broken globalized node issue.
        • node.* is called a `globalized node`
    Supporting Plugins

    I have hit the character limit for this post.​

    Thanks to:
    • sk89q for hiearchical and node system idea.
    • Creator of GroupUsers for api implementation.
    This author has stopped development of this plugin. It is no longer supported and I wouldn't ask for help here, as you won't get any. New Permissions
  2. Offline


    I'm having the same problem as UnknownGamer and would really appreciate some help. Thanks. :)
  3. Offline


    I am unsure of the build, someone else installed this server. How can I determine this.

    I edited the file with nano, and the error isn't related to syntax (no unexpected characters and so on..)
  4. Offline



    The build = true/false is currently not working. You can ignore that function until the next update and build(s) allow the function to work.

    An easier way to restrict building is to make a large area around the spawn a cuboid/any areas with items in them using WorldEdit/WorldGuard which now support Permissions.
  5. Offline


    Thank-you! I'll be sure to watch for the update.
  6. Offline


    I'm implementing this for my plugin and had a minor code note related to your sample implementation.

    Java gets cranky about the static keyword usage. Specifically, Permissions is being specified as static:
    public static Permissions Permissions = null;
    And 'Security' within Permissions is also static.

    But the rest of the implementation is accessing these in a non-static way:
    if(this.Permissions == null) {
    if(!(YourPluginsMainClass).Permissions.Security.permission(player, "")){

    These examples should instead be:
    if(YourPlugin.Permissions == null){
    if(!Permissions.Security.permission(player, "")){
    Like I said, minor detail, but this might save people some unexpected warnings in their IDE of choice. :)
  7. Offline


    I don't See anywhere on here how to add people to a group
  8. Offline


    I am confused. If I use GroupUsers, does it invalidate the permissions in the permissions config file?
    --- merged: Jan 22, 2011 5:03 AM ---
    I think it is a bit troublesome to add people to a group. If you have many users it becomes a lot more work to add them.
    all relevant data in one line for one user would be much easier in my opinion, also to handle it with outside scripts such as PHP

    I cannot get my users to use /spawn. I can use it as an admin, but they cannot.

    i am using GroupUsers.


    permissions plugin config is unchanged except the "GroupUsers" in the top
    The people in the homeowners group can use /home however
  9. Offline


    Moin moin,

    I use Permissions and iChat, both working very fine. Thanks for this.
    But "Prefix" always adds the Groupname in front of the name.

    Group: admin
    prefix: '&2'
    suffix: '&4'
    Result: [admin] Jobsti

    prefix: '&2 wtf &3'
    suffix: '&4 rtfm &5'
    Result: [wtf admin rtfm] Jobsti

    My request is:
    prefix: '&2 [bravestar]'
    suffix: '&4'
    Result: [bravestar] Jobsti

    prefix: '&2 [he-man] &4'
    suffix: '&2'
    Result: [he-man] Jobsti: Chattext

    So I can say, admins, guests and mods get a prefix, members no prefix, but a colored name.
    In the past, I had this working:

    [admin] adminname: quiet pls
    [mod] nameofamod: i guess the cmd
    [guest] aguestname: rtfm mod
    membername: anyone cake?
  10. Offline


    Can you update Glonick to work with this, only admins can have nicknames right now.
  11. Offline


    Anyone have this working with CraftBukkit 118 or later? I get a NPE in (line 287) on every command (including /pr) with only Permissions loaded. Verified config file to be valid YAML. Using CraftBukkit 126 (had the same error with 118).

    Config file
  12. Offline


    Same problem as Delta404. Any suggestions?
  13. Offline


    You have a tab in your config. Replace it with spaces.
  14. Offline


    - Moderator

    But you have no mod, only "Pals"
  15. Offline



  16. Offline


    Thanks Timberjaw.

    Now it loads but default users can still edit even tho i disabled it.

  17. Offline


    Build command not supported yet...
  18. Offline


    I wish there was a way to put in a command that would extract every possible command from each plugin in your plugins folder, then log it to a file, so you'd know what commands were available.. This would be so much help imo.
  19. Offline


    Good idea!
  20. Offline


    I only converted members that aren't 'default' since it assumes you are default if you aren't in an assigned group.
  21. Offline


    Can anyone tell me what is wrong with this? Honestly I don't understand. I'm trying to use it with Essentials...

    Attached Files:

  22. Offline


    Same error as the other guy, cept I have 1500 users gruugg
  23. Offline


    I'd like to request storing ints or custom variables as permissions for plugins (similar to prefix and suffix)

    - 'mywarp.warp.create.public'

    would give someone permission to create public warps, but if I wanted to have a maximum number of warps for a group or user, it would have to be a global level, or hardcoded levels.

    So, something like:
    - 'mywarp.warp.create.public.num': 5

    Where an int can be specified after a given position

    Or, to make it look more standardized, something along the lines of
                general.spawn: true
                mywarp.warp.create.public: true
                mywarp.warp.create.public.num: 3

    Then, this number could be checked with something like:

    int numPublic = (YourPluginsMainClass).Permissions.Security.permissionInt(player, ""));
  24. Offline


    Okay, this is what i have for my prefix stuff but doesnt work:

            default: true
                prefix: '&2 Noob &2'
                suffix: '&4'
                build: false
    1) Is there a list of color codes some place so I can create the colors needed
    2) It wont show up at all, do i need to do a full restart of the server for them to work? or will /pr work?
  25. Offline


  26. Offline


    well is my code incorrect? cause all i get is white names with no text.
  27. Offline


    Don't know, save in UTF-8 instead af ANSI!
    And test the § instead of the &
  28. Offline


    can you show me your config?
  29. Offline


  30. Offline


    do i need to have a suffix defined?
  31. Offline


    Test it ;)
Thread Status:
Not open for further replies.

Share This Page