Inactive [ADMN/INFO] Permissions v2.1 - Continuing the legacy.

Discussion in 'Inactive/Unsupported Plugins' started by Nijikokun, Jan 21, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 2.1 (Handler)
    Download 2.1 (Jar Only)
    Older: 2.0, 1.9, 1.8, 1.7, 1.6, 1.5, 1.4, 1.3, 1.2, 1.1, 1.0

    Permissions... Done right.
    Permissions allows plugin-authors to utalize a permission system that handles group inheritance, globalized permission settings, and more. All the features of a fine-grained permission system in one plugin.​

    1. Groups
    2. Group Inheritance, Allows for groups to gain permissions from other groups.
    3. User Permission System
    4. Fine Grained Permission system.
      1. Allowing for Globalized permissions
    5. Easy to use, setup, and implement.
    6. Two cache layers, first from file to memory, then from memory to cache.
      1. Plugins can control cache since version 2.1
    7. And much more.
    For the users

    Permissions gives server admins great control, mostly in-game reloading. Simply use /pr and the file will be re-cached and never touched again until you need to reload it. This allows you to quickly give your users the commands that they need without having to restart the server.

    Installation for 2.0 down:
    1. Download the archive.
    2. Extract contents to the /plugins folder.
    3. Open up /plugins/Permissions/config.yml
      1. Read / modify.
      2. Save.
    4. Reload Server.

    • 2.1
      • Multiple-World support
      • New cache layer, and cache control support for plugins
      • Editing features for plugins to hook into
      • Exempt nodes
      • World copying
    • 2.0
      • Forgot.
    • 1.9
      • Fully fixes inheritance.
        • Groups now inherit groups of groups that inherit groups of...
      • Cache system implemented.
      • Plugin authors can now delegate a variable system if needed.
      • API Updated with two new functions to get the point of what they do across.
        • Along with the new variable checks.
    • 1.8
      • Fixes the broken globalized node issue.
        • node.* is called a `globalized node`
    Supporting Plugins

    I have hit the character limit for this post.​

    Thanks to:
    • sk89q for hiearchical and node system idea.
    • Creator of GroupUsers for api implementation.
    This author has stopped development of this plugin. It is no longer supported and I wouldn't ask for help here, as you won't get any. New Permissions
  2. Offline


    I really hope u people that are usein essentials are not just lowering your self down a group and testing to see if that group has access because even if you lower your self down you will still have all commands because you are an op you need to get a non op to test them. at that group.
  3. Offline


    Ok so i am moving from a hMod server over to bukkit. I have loaded and configured the Permissions plugin and even made a test world for this added my user permissions named the file correctly as instructed on the documentation page load my server up everything loaded without any errors so i enter the session and try and run any commands it basically spits back what it would should you try and run a command on a server when there is no permssions plugin or user defined ones at all which is no feed back to user but is logged on the server as "so and so tried command: such and such"

    any ideas? below is the server log
    note: replaced actual username with $USER and IP with $IPADDRESS

    2011-02-23 00:41:59 [INFO] Starting minecraft server version Beta 1.3
    2011-02-23 00:41:59 [INFO] Loading properties
    2011-02-23 00:41:59 [INFO] Starting Minecraft server on *:25565
    2011-02-23 00:41:59 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-443-g8f199f7-b421jnks (MC: 1.2_01)
    2011-02-23 00:41:59 [INFO] Preparing level "world"
    2011-02-23 00:41:59 [INFO] Preparing start region
    2011-02-23 00:41:59 [INFO] [Permissions] version [2.1] (Handler) loaded
    2011-02-23 00:41:59 [INFO] Done (668145000ns)! For help, type "help" or "?"
    2011-02-23 00:42:03 [INFO] 143 recipes
    2011-02-23 00:42:03 [INFO] $USER [/$IPADDRESS:64036] logged in with entity id 116
    2011-02-23 00:42:09 [INFO] $USER tried command: home
  4. Offline


    Permissions 2.1 does not add commands.
    You will need another modification to use /home /sethome /spawn /setspawn etc...
    Permissions just makes it so normal users cannot use commands like /item & spawn pass quantities of Diamond or lava.
  5. Offline

    Connor Griffin

    Our default world folder name is kc1, the YML configuration file is named kc1.yml, and the most recent (2.1) Permissions.jar file is in the plugins folder. Despite all this, I receive "Error: This server does not use Permissions." whenever I use any commands (/mod Player Group for example).
  6. Offline


    Re-uploaded permissions 2.1

    Contains fix to accessing group information.

    @Connor_Griffin that is due to the plugin trying to get Permissions data before permissions is loaded, see the link at the top of the thread alerting plugin authors of how to hook into it? Give that link to the plugin author whose plugin is having the issue, do not report that here. Thank you.
    --- merged: Feb 23, 2011 6:24 AM ---
    It wasn't my choice, bukkit authors changed the way that plugins load forcing plugin authors to do this. Don't blame me.
    --- merged: Feb 23, 2011 6:26 AM ---
    Please don't come into my thread spouting nonsense, thank you.
  7. Offline


    Niji Was that causing some of the problems that MultiVerse was having with the Group Blacklist he was trying to get working

    I hope it was (not that i hope that your plugin was making problems for other but If it was thats its fixed now cause iv wanted that blacklist working for over a week lol
  8. Offline


    I don't know about other people's plugins, I don't play minecraft anymore.
  9. Offline


    It isn't nonsense at all. Have you read the post in the GroupManager thread from the author of the Essentials package?
  10. Offline


    Again, please stop spouting nonsense.
  11. Offline


    The bug fix is here:

  12. Offline


  13. Offline


    @Nijikokun Question, is 2.1 needed now that 424 fixed the op check?
  14. Offline


    I, personally, don't believe so. I'm using 2.0 with 424 and my Essentials commands are properly limited.
  15. Offline


    Yeah, As are mine. updating to 2.1 tosses alot of errros from other plugins.
  16. Ok, I'm noticing two things with permissions right now

    ^ Is it supposed to be showing up as 2.0 even though I upgraded to 2.1?

    And this:

    I'm not even sure what this means tbh.

    Is this something that I can do anything about, or simply a thing that will eventually get fixed in time? Or is it even an issue?

    EDIT: I'm running craftbukkit build 423.
  17. Offline


    For one, Upgrade to 424 for fixed OPs.

    For two, at the moment, seems 2.0 is still better to be used.
  18. Offline


    Looks like GroupManager - Notice the org.anjocaido.groupmanager.GroupManager.*?
    Check if you have FakePermissions or GroupManager.
  19. Offline


    I just want to post this since people getting confused and upset with Essentials and permissions. Yes some developers have their own methods and ways and even flaws. But it seams at this time and I hope forever till built in bukkit one is added that permissions work just fine with Essentials.

    Please install the following Jar from Essentials:
    - EssentialsGroupBridge.jar

    Please Remove the following Jar from Essentials:
    - EssentialsGroupManager.jar

    Now EssentialsGroupManager.jar might not have to be removed but I heard some others having issues so if you don't use Essentials built in permissions then just remove it your not suppose to install all the plugins unless you use them really.!
  20. Offline


    In case you missed it:

    Nijikokun is taking a break from developing plug-ins for a while. The source code for the plug-ins developed are available.

    In spite of the drama, thanks for doing the footwork to get plug-ins up to this point.
  21. Offline


    Well I'm hoping someone can help. I'm at my wits end trying to get this to work. I believe that my permissions configuration file is completely being ignored. Would someone mind looking at it and letting me know?

    In game it doesn't let me use commands nor does it show my prefix.

    Show Spoiler
    # System is no longer used, but may become used in the future
    # Copies is for multiple-world support
    #  Put the name of the world you wish for it to be a clone of, otherwise leave it empty.
    #  Does not work for the default world.
            system: default
    # Groups can contain inheritance.
    #  To make a group inherit the permissions from another
    #  group simply place the groups name in the "inheritance:" like so:
    #  Example:
    #      inheritance:
    #          - Default
    #  All permissions including the asterisks must be placed in single quotes.
    #  like so:
    #      - 'general.spawn'
    #  Otherwise errors will happen!
    #  Globalized Permission settings:
    #      If a permission contains periods (.) you can denote a globalized parameter:
    #          - 'general.*'
    #      This will allow you to use all general commands.
    #  Single Asterisk denotes all commands:
    #      - '*'
    #  To exempt a node use the - prefix like so:
    #      - '-general.time'
            default: true
                prefix: Survivor
                build: true
            default: false
                build: true
                - Default
                - 'general.time'
                - 'general.teleport'
                - ''
                - 'general.player-info'
            default: false
                prefix: Survivor King
                build: true
                - '*'
                - 'spawnmob.*'
    # DarkGrave has control over all commands.
            group: Admin
  22. Offline


    As for the prefix... to get that to work, you need iChat :)

    second, What version of crafbukkit / permissions you using?

    Also, what other mods are on server that you are trying use this for?
  23. Offline


    *facepalm* gosh... does it say that ANYWHERE? lol.... okay good to know

    443 CraftBukkit and 2.1 permissions
  24. Offline


    443? How? Future builds everywhere! (Current highest build is 424)

    Also, what other mods are on server that you are trying use this for?
  25. Offline


    uhh.. really? gee I guess I hacked then? lol.... Well when I startup my server it says. I only assumed the 443 means version 443 :S I dont know too much about too much

    [INFO] This server is running Craftbukkit version git-Bukkit
    -0.0.0-443-g8f199f7-b420jnks (MC: 1.2_01)
  26. Offline


    Well I dunno what version that is, We will discuss that after, for now

    Please Downgrade (Down to Permissions 2.0 because you are still on a 1.2_01 server)

    && List the other plugins installed on the server :p
  27. Offline


    That's 420.
  28. Offline


    #424 is misreporting actually XD
    git-Bukkit-0.0.0-444-g9e8ca13-b424jnks (MC: 1.2_01)

    it looks like he's on #420
    --- merged: Feb 23, 2011 8:18 AM ---
    anyway, most plugins haven't been updated for Perm 2.1 yet, and #424 fixed the isOp() bug that was breaking Perm 2.0, so aside from multi-world support, there's not much gain to 2.1

    MultiVerse doesn't support 2.1 yet, so the multi-world support isn't used XD
  29. Offline


    @darkcammo -
    So yea, go back to 2.0 permissions then :p

    But still, I would like to see the other mods you have installed on the server to see what commands you are able to use, as Permissions itself does NOT have commands.
  30. Offline


    Oh I see. Plugins being used :

    CrowdControl 0.17
    [INFO] [DeathTpPlus] version 1.71 by lonelydime is enabled!
    2011-02-23 01:54:29 [INFO] LoginMessage 0.4_3 enabled
    2011-02-23 01:54:29 [INFO] [Permissions] version [2.1] (Handler) loaded
    2011-02-23 01:54:29 [INFO] Persistence version 0.48 is enabled
    2011-02-23 01:54:29 [INFO] [SpawnMob] Version 1.5.1 enabled.
    2011-02-23 01:54:29 [INFO] [SpawnMob] Permission system enabled.
  31. Offline


    Since the issue is permissions apparently being ignored, that falls under the isOp() bug... try upgrading to #424 and see if that fixes the issue.
Thread Status:
Not open for further replies.

Share This Page