Inactive [ADMN/INFO] Permissions v2.1 - Continuing the legacy.

Discussion in 'Inactive/Unsupported Plugins' started by Nijikokun, Jan 21, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    Nijikokun

    Permissions 2.1 (Handler)
    Download 2.1 (Jar Only)
    Older: 2.0, 1.9, 1.8, 1.7, 1.6, 1.5, 1.4, 1.3, 1.2, 1.1, 1.0

    Permissions... Done right.
    Permissions allows plugin-authors to utalize a permission system that handles group inheritance, globalized permission settings, and more. All the features of a fine-grained permission system in one plugin.​

    Features
    1. Groups
    2. Group Inheritance, Allows for groups to gain permissions from other groups.
    3. User Permission System
    4. Fine Grained Permission system.
      1. Allowing for Globalized permissions
    5. Easy to use, setup, and implement.
    6. Two cache layers, first from file to memory, then from memory to cache.
      1. Plugins can control cache since version 2.1
    7. And much more.
    For the users


    Permissions gives server admins great control, mostly in-game reloading. Simply use /pr and the file will be re-cached and never touched again until you need to reload it. This allows you to quickly give your users the commands that they need without having to restart the server.

    Installation for 2.0 down:
    1. Download the archive.
    2. Extract contents to the /plugins folder.
    3. Open up /plugins/Permissions/config.yml
      1. Read / modify.
      2. Save.
    4. Reload Server.
    Changelog

    • 2.1
      • Multiple-World support
      • New cache layer, and cache control support for plugins
      • Editing features for plugins to hook into
      • Exempt nodes
      • World copying
    • 2.0
      • Forgot.
    • 1.9
      • Fully fixes inheritance.
        • Groups now inherit groups of groups that inherit groups of...
      • Cache system implemented.
      • Plugin authors can now delegate a variable system if needed.
      • API Updated with two new functions to get the point of what they do across.
        • Along with the new variable checks.
    • 1.8
      • Fixes the broken globalized node issue.
        • node.* is called a `globalized node`
    Supporting Plugins




    I have hit the character limit for this post.​

    Thanks to:
    • sk89q for hiearchical and node system idea.
    • Creator of GroupUsers for api implementation.
    This author has stopped development of this plugin. It is no longer supported and I wouldn't ask for help here, as you won't get any. New Permissions
    -RightLegRed
     
  2. Offline

    chill1977

    that would work I guess lol , just dont paste a code with 40 players with independant groups for me to fix lmao
     
  3. Offline

    Thallo

    hey I only want to know the // comand(super picaxe) I dont want to give them the /wand command I alsow dont want to give them any other worldedit command.. I only want to give them the // command ... and sorry if i understood it in a wrong way but why should I post my config I only want to know a single command everything else is working ..
     
  4. Offline

    chill1977

    that needs to be in the worldedit forum , i do not use or know the worldedit commands
    --- merged: Jan 30, 2011 6:08 PM ---
    172loaded.png
     
  5. Offline

    reexe

    for some reason when i use /pr the server reloads every plugin, and a lot of ppl get kicked.
    earlier that did not happen, but after updating craftbukkit i have had that problem.. :/
     
  6. Offline

    luna0316

    So i am having issues where my ops.txt is giving permissions not the plugin, or does the plugin require that any players be in ops.txt? because i have me( the admin) and two moderators and it seems that i cannot use any commands unless im in ops.txt, same with the moderators. Plugins says to me that it is being loaded when it starts up and my plugins such as world guard and worldedit report that they are using the plugin, any thoughts? btw treid this on the last 3 builds from bukkit (unsure how to find version number as they all come named as snapshot) and with different builds of my plugins. here is some info that might help
    here is my Permissions .yml file
    Code:
    # Supports "Default" and "GroupUsers"
    plugin:
        permissions:
            system: default
    
    ##
    # Groups can contain inheritance.
    #   To make a group inherit the permissions from another 
    #   group simply place the groups name in the "inheritance:" 
    #   field seperated by commas.
    #
    #   Example: inheritance: Default,Admins,
    ##
    #   All permissions including the asterisks must be placed in single quotes.
    #   like so:
    #
    #       - 'general.spawn'
    #
    #   Otherwise errors will happen!
    ##
    #   Globalized Permission settings:
    #
    #       If a permission contains periods (.) you can denote a globalized parameter:
    #
    #           - 'general.*'
    #
    #       This will allow you to use all general commands.
    #
    ##
    #
    #   Single Asterisk denotes all commands:
    #
    #       - '*'
    ##
    groups:
        Default:
            default: true
            info:
                prefix: 
                suffix:
                build: true
            inheritance: 
            permissions:
                - 'general.spawn'
                - '/regionclaim'
                - '/motd'
                - '/locate'
                - '/rules'
                - '/commands'
                - '/news'
        Moderator:
            default: false
            info:
                prefix: 
                suffix:
                build: true
            inheritance:
                - Default
            permissions:
                - 'essentials.*'
                - '/mc'
        Admins:
            default: false
            info:
                prefix: 
                suffix:
                build: true
            inheritance:
                - Moderator
            permissions:
                - '*'
                - 'cleaner.*'
                - 'tplus.*'
                - '/stack'
                - '/region'
    
    
    
    
    
    ## Users
    users:
        lifeline24:
            group: Admins
            permissions:
    
        luna0316:
            group: Admins
            permissions:
    
        luvb3ar:
            group: Admins
            permissions:
    
                
    and here is my config file for WorldEdit
    Code:
    #
    # WorldEdit's configuration file
    #
    # About editing this file:
    # - DO NOT USE TABS. You MUST use spaces or Bukkit will complain. If
    #   you use an editor like Notepad++ (recommended for Windows users), you
    #   must configure it to "replace tabs with spaces." In Notepad++, this can
    #   be changed in Settings > Preferences > Language Menu.
    # - Don't get rid of the indents. They are indented so some entries are
    #   in categories (like "max-blocks-changed" is in the "limits"
    #   category.
    # - If you want to check the format of this file before putting it
    #   into WorldEdit, paste it into http://yaml-online-parser.appspot.com/
    #   and see if it gives "ERROR:".
    # - Lines starting with # are commentsand so they are ignored.
    #
    
    limits:
        max-blocks-changed:
            default: -1
            maximum: -1
        max-radius: -1
        max-super-pickaxe-size: 5
        max-brush-radius: 5
        disallowed-blocks: [6, 7, 14, 15, 16, 26, 27, 28, 29, 39, 31, 32, 33, 34, 36, 37, 38, 39, 40, 46, 50, 51, 56, 59, 69, 73, 74, 75, 76, 77, 81, 83]
    
    use-inventory:
        enable: false
        allow-override: true
    
    logging:
        log-commands: false
        file: worldedit.log
    
    super-pickaxe:
        drop-items: true
        many-drop-items: false
    
    snapshots:
        directory:
    
    navigation-wand:
        item: 345
        max-distance: 100
    
    scripting:
        timeout: 3000
    
    wand-item: 271
    shell-save-type:
    no-double-slash: false
    debug: false
    
    # See http://wiki.sk89q.com/wiki/WorldEdit/Permissions/Bukkit
    permissions:
        groups:
            default:
                permissions:
                    - /reloadwe
                    - /worldeditselect
            Admins:
                permissions:
                    - /reloadwe
                    - /worldeditselect
                    - /worldedit
                    - /reloadwe
        users:
            luna0316:
                permissions:
                    - /worldedit
                    - /reloadwe
            luvb3ar:
                permissions:
                    - /worldedit
                    - /reloadwe
    and lastly here is my world guard
    Code:
    #
    # WorldGuard's configuration file
    #
    # About editing this file:
    # - DO NOT USE TABS. You MUST use spaces or Bukkit will complain. If
    #   you use an editor like Notepad++ (recommended for Windows users), you
    #   must configure it to "replace tabs with spaces." In Notepad++, this can
    #   be changed in Settings > Preferences > Language Menu.
    # - Don't get rid of the indents. They are indented so some entries are
    #   in categories (like "enforce-single-session" is in the "protection"
    #   category.
    # - If you want to check the format of this file before putting it
    #   into WorldGuard, paste it into http://yaml-online-parser.appspot.com/
    #   and see if it gives "ERROR:".
    # - Lines starting with # are commentsand so they are ignored.
    #
    # WARNING:
    # Remember to check the compatibility spreadsheet for WorldGuard to see
    # if any features are currently broken in your version of Bukkit.
    #
    
    summary-on-start: on
    
    protection:
        enforce-single-session: on
        item-durability: on
    
    simulation:
        classic-water: off
        sponge:
            enable: on
            radius: 3
    
    physics:
        no-physics-gravel: off
        no-physics-sand: off
        allow-portal-anywhere: off
        disable-water-damage-blocks: []
    
    ignition:
        block-tnt: off
        block-lighter: off
    
    fire:
        disable-all-fire-spread: off
        disable-fire-spread-blocks: []
        disable-lava-fire-spread: on
        lava-spread-blocks: []
    
    mobs:
        block-creeper-explosions: off
        block-creeper-block-damage: off
    
    spawn:
        login-protection: 3
        spawn-protection: 0
        kick-on-death: off
        exact-respawn: off
        teleport-to-home-on-death: off
    
    player-damage:
        disable-fall-damage: off
        disable-lava-damage: off
        disable-fire-damage: off
        disable-drowning-damage: off
        disable-suffocation-damage: off
        disable-contact-damage: off
        teleport-on-suffocation: off
    
    regions:
        enable: on
        wand: 287
        default:
            build: true
            chest-access: false
    
    blacklist:
        logging:
            console:
                enable: on
            database:
                enable: off
                dsn: jdbc:mysql://localhost:3306/minecraft
                user: root
                password: pass
                table: blacklist_events
            file:
                enable: on
                path: worldguard/logs/%Y-%m-%d.log
                open-files: 10
    
    # See http://wiki.sk89q.com/wiki/WorldGuard/Permissions/Bukkit
    permissions:
        users:
            luna0316:
                permissions:
                    - /region
                    - /reloadwg
            luvb3ar:
                permissions:
                    - /region
                    - /reloadwg
    and this is what comes up when i start my server
    Code:
    2011-01-30 11:14:17 [INFO] Starting minecraft server version Beta 1.2_01
    2011-01-30 11:14:17 [INFO] Loading properties
    2011-01-30 11:14:17 [INFO] Starting Minecraft server on *:25565
    2011-01-30 11:14:17 [INFO] Preparing level "world"
    2011-01-30 11:14:17 [INFO] Preparing start region
    2011-01-30 11:14:18 [INFO] Preparing spawn area: 28%
    2011-01-30 11:14:19 [INFO] Preparing spawn area: 65%
    2011-01-30 11:14:20 [INFO] Preparing spawn area: 93%
    2011-01-30 11:14:20 [INFO] [iConomy] version [2.2] (Aime) loaded
    2011-01-30 11:14:20 [INFO] [Permissions] version [1.9] (Handler) loaded
    2011-01-30 11:14:20 [INFO] [WarpGate] version [1.4] (Polarized) loaded
    2011-01-30 11:14:20 [INFO] WorldEdit 3.0 loaded.
    2011-01-30 11:14:20 [INFO] WorldEdit: Permissions plugin detected! Using Permiss
    ions plugin for permissions.
    2011-01-30 11:14:20 [INFO] WorldGuard 3.2 loaded.
    2011-01-30 11:14:20 [INFO] WorldGuard: Permissions plugin detected! Using Permis
    sions plugin for permissions.
    2011-01-30 11:14:20 [INFO] WorldGuard: Single session is enforced.
    2011-01-30 11:14:20 [INFO] WorldGuard: TNT ignition is PERMITTED.
    2011-01-30 11:14:20 [INFO] WorldGuard: Lighters are PERMITTED.
    2011-01-30 11:14:20 [INFO] WorldGuard: Lava fire is blocked.
    2011-01-30 11:14:20 [INFO] WorldGuard: Fire spread is UNRESTRICTED.
    Deathify V:0.61 is Enabled!
    2011-01-30 11:14:20 [INFO] Loaded Essentials b130 by Zenexer, ementalo, Eris, an
    d EggRoll
    Take yourself wonder by wonder, using /magiccarpet or /mc. Magic Carpet version
    1.3 is enabled!
    MCDocs version 4.3 is enabled!
    2011-01-30 11:14:21 [INFO] WorldEdit: Permissions plugin detected! Using Permiss
    ions plugin for permissions.
    2011-01-30 11:14:21 [INFO] WorldGuard: Permissions plugin detected! Using Permis
    sions plugin for permissions.
    2011-01-30 11:14:21 [INFO] SpawnMob version 1.4.0 enabled.
    2011-01-30 11:14:21 [INFO] [TELEPLUS] Permissions enabled.
    2011-01-30 11:14:21 [INFO] TelePlus 1.5.3 enabled
    2011-01-30 11:14:21 [INFO] Done! For help, type "help" or "?"
    138 recipes
    Be glad to help with any other info that is needed
     
  7. Offline

    chill1977

    hmmm , i use it on craftbukkit build 172 with no issues, says permissions reloaded and reloads all plugins that are compatible with Permissions
    --- merged: Jan 30, 2011 7:32 PM ---
    WorldGuard and WorldEdit are having issues with Craftbukkit right now. Your beef is with those plugins. But, no, your name being in the ops.txt makes no difference when it comes to Permissions. Permissions simply makes the ops.tx obsolete by going over it's head.
     
  8. Offline

    luna0316

    well the thing must be them not being comaptable with permissions then, as the commands work as long as the names are in ops.txt, and its not only these plugins, i cant use any commands at all unless the names are in ops.txt, so is my permissions not overriding ops.txt?
    EDIT (tested it with magiccarpet, spawnmob, essentials, and warpgate)
     
  9. Offline

    Nic Walker

    how do i know which plugins this doesnt work for im using essentials, mywarp, spells, wand, worldedit and worldguard. But when i try to use permissions it doesnt work.
     
  10. Offline

    luna0316

    so your having the same problem as me it seems, what i did was just added the admins to ops.txt, but this shouldnt need you to do that permissions should be overridding it and btw it helps to post your config files in a code box, so we can see if its a problem with your config
     
  11. Offline

    xZise

    Hmmm, I think you doesn't understand him, but he want to execute the command in the console. Not in game.

    Fabian
     
  12. Offline

    chill1977

    i need to see your permissions config.yml code sry i see now i ahve already seen it lol
    --- merged: Jan 30, 2011 7:57 PM ---
    To start with you need to diable some commands in essentials if you are going to use mywarp as they have commands that are the same and this will cause issues.

    If you are using a version of Craftbukkit above 166 then WorldGuard and Worldedit probably arent working correctly either.

    Beyond that I would need to see your permissions config.yml to verify that it is correct.
    --- merged: Jan 30, 2011 8:02 PM ---
    @luna0316 another problem you may have is that you are running General and Essentials, they have the same commands and they will not work with 2 plugins trying to do the same thing, with Essentials General isnt needed, delete that plugin and try again.
     
  13. Offline

    aflyingturtle

    Does Permissions support making you own custom named groups?
    And does it support more than the default amount of groups?
     
  14. Offline

    Runelynx

    Ok I've removed all the null things... and I still get Error:null when I type /pr in-game, then everything breaks.
    What's wrong, I hate this ><

    Code:
    plugin:
      permissions: {system: default}
    groups:
      Citizen:
        default: true
        info: {prefix: '&f[&eCitizen&f]', build: true}
        permissions: [iConomy.payment, iConomy.rank, iConomy.list, essentials.spawn, essentials.tpdeny,
          essentials.tpaccept, essentials.helpop, essentials.home, essentials.help, essentials.sethome,
          essentials.list, essentials.mail, essentials.afk, essentials.depth, essentials.msg,
          essentials.me, essentials.warp, essentials.mail.*, essentials.motd, lwc.protect,
          mcbans.vote, mcbans.vote.msg, essentials.kit, essentials.kit.starter, petition]
      Mentor:
        default: false
        info: {prefix: '&f[&aMentor&f]', build: true}
        inheritance: [Citizen]
        permissions: [essentials.time, mcbans.vote.*]
      Mod:
        default: false
        info: {prefix: '&f[&bMod&f]', build: true}
        inheritance: [Citizen]
        permissions: [mcbans.vote.*, /worldguardnotify, essentials.warp, essentials.tp,
          essentials.tphere, essentials.item, essentials.give, essentials.getpos, /worldeditselect,
          //, /butcher, /ex, /fixwater, /fixlava, /region, //wand, //pos1, //pos2, //hpos1,
          //hpos2, //expand, //contract, //stack, //move, essentials.setspawn, essentials.tree,
          essentials.bigtree, essentials.top, essentials.time, essentials.heal, essentials.spawnmob,
          essentials.tele, essentials.tpa, essentials.tpahere, essentials.clearinventory,
          essentials.getpos, /stack, /stopfire, /allowfire, lwc.mod, mcbans.kick, mcbans.ban.*,
          mcbans.view_ban, mcbans.unban, mcbans.tempban, mcbans.reload, petition.moderate]
      Admin:
        default: false
        info: {prefix: '&f[&cAdmin&f]', build: true}
        inheritance: [Mod]
        permissions: ['*']
    users:
      runelynx: {group: Admin}
      erthael: {group: Admin}
      benbestvater: {group: Admin}
      kotone: {group: Mod}
      minikyuubi: {group: Mod}
      steveval: {group: Mod}
      robertr: {group: Mod}
      xenoxhawk: {group: Mentor}
      treminer: {group: Mentor}
      timetuner: {group: Mentor}
      SethyBoy0: {group: Mentor}
      levitater: {group: Mentor}
      jackwhitaker: {group: Mentor}
      hamish_g: {group: Mentor}
      giester: {group: Mentor}
      fingerpaint: {group: Mentor}
      fallz2772: {group: Mentor}
      ericson666: {group: Mentor}
      drage65: {group: Mentor}
      cowmanodoom: {group: Mentor}
      AlleyxD: {group: Mentor}
      clay3120: {group: Mentor}
      dethknaw: {group: Mentor}
    
     
  15. Offline

    Planitia

    Awesome thanks
     
  16. Offline

    captainawesome7

    I think I updated craftbukkit this morning and I just installed WorldEdit this morning. But it is kind of hard to tell what version of craftbukkit I am running because they all have the same name (i think).
     
  17. Offline

    loothelion

    Whenever I try to load my server Permissions gives me an error. Here is the output and config.yml.
    Code:
    Jan 30, 2011 4:15:07 PM org.bukkit.plugin.SimplePluginManager loadPlugins
    SEVERE: Could not load plugins/Permissions.jar in plugins: null
    org.bukkit.plugin.InvalidPluginException
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:77)
            at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:117)
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:82)
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:40)
            at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:153)
            at net.minecraft.server.MinecraftServer.c(MinecraftServer.java:140)
            at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:104)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:181)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:512)
    Caused by: java.lang.reflect.InvocationTargetException
            at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
            at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
            at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
            at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:75)
            ... 8 more
    Caused by: while parsing a block mapping
     in "<reader>", line 1, column 1:
        plugin:
        ^
    expected <block end>, but found BlockMappingStart
     in "<reader>", line 27, column 5:
            Admins:
            ^
    
            at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(ParserImpl.java:576)
            at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:163)
            at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
            at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:228)
            at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
            at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:122)
            at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105)
            at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:124)
            at org.yaml.snakeyaml.Yaml.load(Yaml.java:264)
            at org.bukkit.util.config.Configuration.load(Configuration.java:62)
            at org.bukkit.plugin.java.JavaPlugin.<init>(JavaPlugin.java:46)
            at com.nijikokun.bukkit.Permissions.Permissions.<init>(Permissions.java:76)
            ... 13 more
    
    
    
    Code:
    minecraftserver:/minecraft/plugins/Permissions# nano config.yml
      GNU nano 2.0.7                      File: config.yml
    
    plugin:
        permissions:
            system: default
    groups:
         Default:
            default: true
            info:
                prefix:
                suffix:
                build: true
            inheritance:
            permissions:
                - 'essentials.me'
                - 'essentials.tpahere'
                - 'essentials.warp'
                - 'essentials.mail.*'
                - 'essentials.helpop'
                - 'essentials.spawn'
                - 'essentials.kit.*'
                - 'essentials.help'
                - 'essentials.motd'
                - 'essentials.afk'
                - 'essentials.ping'
                - 'essentials.rules'
                - 'essentials.compass'
                - 'essentials.depth'
        Admins:
            default: false
            info:
                prefix: [ADMIN]
                suffix:
                build: true
            inheritance:
                - Default
            permissions:
                - '*'
    users:
        loothelion
            group: Admins
        timeser
            group: Admins
                   
          
     
  18. Offline

    shadydeath999

    is there a way to add people to the permissions list ingame?
     
  19. Offline

    Snipey

    no it has been said before several times
     
  20. Offline

    aflyingturtle

    I'm trying to get It so that the admins inherit the Norm group and Norm inherits default but it always comes out that the Admins can only use admin commands and not even /help, which should be allowed to the default group.
    Code:
     groups:
        default:
            default: true
            info:
                prefix:
                suffix:
                build: false
            inheritance:
            permissions:
                - 'essentials.spawn'
                - 'essentials.sethome'
                - 'essentials.home'
                - 'essentials.warp'
                - 'essentials.help'
                - 'essentials.msg'
                - 'essentials.ping'
                - 'essentials.compass'
                - 'essentials.rules'
                - 'essentials.list'
                - 'essentials.mail'
                - 'essentials.helpop'
                - 'essentials.afk'
                - 'essentials.whois'
                - 'lwc.protect'
        norm:
            default: false
            info:
                prefix:
                suffix:
                build: true
            inheritence:
                - default
            permissions:
                - 'essentials.kit'
                - 'essentials.kit.tools'
                - 'essentials.clearinventory'
                - 'essentials.tpa'
                - 'essentials.tpahere'
                - 'essentials.mail.send'
                - 'essentials.tpaccept'
                - 'essentials.tpdeny'
                - 'essentials.realname'
                - 'essentials.eco'
                - 'essentials.sell'
                - 'essentials.buy'
        admin:
            default: false
            info:
                prefix: Admin
                suffix:
                build: true
            inheritance:
                - norm
            permissions:
                - 'worldedit.*'
                - 'essentials.time'
                - 'essentials.kick'
                - 'essentials.ban'
                - 'essentials.unban'
                - 'essentials.plugin'
                - 'essentials.kill'
                - 'essentials.heal'
                - 'essentials.god'
                - 'essentials.item'
                - 'essentials.jump'
                - 'essentials.setwarp'
                - 'essentials.reload'
                - 'essentials.tp'
                - 'essentials.tphere'
                - 'essentials.tptoggle'
                - 'essentials.give'
                - 'essentials.tree'
                - 'essentials.bigtree'
                - 'essentials.essentials'
                - 'essentials.depth'
                - 'magiccarpet.mc'
                - 'essentials.top'
                - 'essentials.nick'
        owner:
            default: false
            info:
                prefix: Owner
                suffix:
                build: true
            inheritance:
                - Admin
            permissions:
                - '*' 
    I've looked over the config.yml many times but I can't figure out what's wrong.
     
  21. Offline

    matter123

  22. Offline

    xZise

    Try to parse your file here.

    Fabian
     
  23. Offline

    DerET

    /pr doesn't work correctly, too.
    Same issue (you're not allowed, bla bla) with /i...
     
  24. Offline

    matter123

    the output is
    Code:
    ERROR:
    
    mapping values are not allowed here
      in "<unicode string>", line 71, column 19:
                    suffix:
    
     
  25. Offline

    xZise

    Okay at first correct the indentation of the groups citizen and higher. And then there is a problem with the prefixes: If I remove all it works, and you should quote them with apostrophes (prefix: 'foo'). So you avoid, that the parser interprets your prefixes (e.g. the >).

    Fabian
    --- merged: Jan 30, 2011 10:45 PM ---
    Hehe ^^ I was to slow :p
     
  26. Offline

    chill1977

    After much testing I have verified that build 130 of Essentials breaks the inheritance in Permissions
     
  27. Offline

    xZise

    And loothelion place your group prefixes in single quotes.
     
  28. Offline

    chill1977

    Sorry everyone for my delay but I have been testing trying to find out what was going on. It seems that while Essentials had to update due to craftbukkit breaking it, now permissions must update due to essentials breaking it lol. This is called the chain effect lmao
     
  29. Offline

    matter123

    okay I'm using this config.yml and i get this error
     
  30. Offline

    chill1977

    To start with you havent got any permission nodes in there. From what I can tell you are trying to use essentials where the nodes would look like 'essentials.help' not /help, that is a command---UPDATE actually i see a few nodes for general but the rest I dont know what happened, what plugins are you trying to use here?
     
  31. Offline

    xZise

    Place a space between the prefix and colon:
    Code:
    - prefix: '&b<mod>'
    Then the parser returns no error.

    Nevertheless chill1977 is right, that your permissions are quite confusing. You normally don't use the command names (like /foo) instead the plugin defines the permissions it uses.

    Fabian
     
Thread Status:
Not open for further replies.

Share This Page