Inactive [ADMN/INFO] Permissions v2.1 - Continuing the legacy.

Discussion in 'Inactive/Unsupported Plugins' started by Nijikokun, Jan 21, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 2.1 (Handler)
    Download 2.1 (Jar Only)
    Older: 2.0, 1.9, 1.8, 1.7, 1.6, 1.5, 1.4, 1.3, 1.2, 1.1, 1.0

    Permissions... Done right.
    Permissions allows plugin-authors to utalize a permission system that handles group inheritance, globalized permission settings, and more. All the features of a fine-grained permission system in one plugin.​

    1. Groups
    2. Group Inheritance, Allows for groups to gain permissions from other groups.
    3. User Permission System
    4. Fine Grained Permission system.
      1. Allowing for Globalized permissions
    5. Easy to use, setup, and implement.
    6. Two cache layers, first from file to memory, then from memory to cache.
      1. Plugins can control cache since version 2.1
    7. And much more.
    For the users

    Permissions gives server admins great control, mostly in-game reloading. Simply use /pr and the file will be re-cached and never touched again until you need to reload it. This allows you to quickly give your users the commands that they need without having to restart the server.

    Installation for 2.0 down:
    1. Download the archive.
    2. Extract contents to the /plugins folder.
    3. Open up /plugins/Permissions/config.yml
      1. Read / modify.
      2. Save.
    4. Reload Server.

    • 2.1
      • Multiple-World support
      • New cache layer, and cache control support for plugins
      • Editing features for plugins to hook into
      • Exempt nodes
      • World copying
    • 2.0
      • Forgot.
    • 1.9
      • Fully fixes inheritance.
        • Groups now inherit groups of groups that inherit groups of...
      • Cache system implemented.
      • Plugin authors can now delegate a variable system if needed.
      • API Updated with two new functions to get the point of what they do across.
        • Along with the new variable checks.
    • 1.8
      • Fixes the broken globalized node issue.
        • node.* is called a `globalized node`
    Supporting Plugins

    I have hit the character limit for this post.​

    Thanks to:
    • sk89q for hiearchical and node system idea.
    • Creator of GroupUsers for api implementation.
    This author has stopped development of this plugin. It is no longer supported and I wouldn't ask for help here, as you won't get any. New Permissions
  2. Offline


    Just a simple bug report.
    I got this error :

    I had put the "Permissions" folder in the "plugin" folder, with "config.yml" inside it.
    As soon as I deleted the folder, relaunched the server, it worked again.

    And this is a great plugin!

    I tried again with the same config and it worked. I guess the plugin didn't manage to read the file the first time.
  3. Offline


    I set groups to have prefixes, but they aren't being shown.
  4. Offline


    Do you usse iChat? Because that is needed for that.
  5. Offline


    Support for ä ö ü ?
    (German servers could need this.)
  6. Offline


    Usage with LWC = Crashes all plugins icluding itself
    /pr doesnt work with LWC + w/o LWC it simpy gives a lot errors
    Essentials plugin doesnt work with this permissions plugin =/
  7. Offline


    /what does /pr have to do with lwc? unless you mean when lwc is installed then /pr does not reload the permissions file?

    are you sure you have everything configured correctly, most everyone is running essentials with permissions and not having issues
  8. Offline


    Yes i'm totally sure everything is okay, and yes, when i do /pr when LWC is installed it crashes all of the plugins.
    And with essentials i added 'essentials.who' and my users still get errors.
  9. Offline


    Yes you have to add each users maunally unless you want them to fall under the Default group. You don't set the mode to group users unless you are using the group user plugin.
    --- merged: Jan 29, 2011 10:20 PM ---
    Then go back to craftbukkit 166 and stop trying to stay right on top of the craftbukkit updates, plugin devs need time to update their codes as well. Craftbukkit 166 works fine with this
    --- merged: Jan 29, 2011 10:22 PM ---
    That is NOT ok. You have no format whatso ever. How does what you have posted even remotely resemble this:

            default: true
                build: true
                - 'general.spawn'
            default: false
                build: true
                - Default
                - '*'
  10. Offline


    I'm on 166 lolfail
  11. Offline


    i just started 168 with permissions and essentials with no errors at all, your config file is the fail, is down right now but as soona as it is back up i will verify that the commands work fine as well.

    I help here because I know Nijikokun's plugins work, and if they do stop because of a craftbukkit update, it's a matter of an hour or so before he has it updated. Long story short his plugins work, if they arent , it's something you did ;)
    --- merged: Jan 29, 2011 10:39 PM ---
    OK it's is now confirmed PErmissions works fine with craftbukkit 168 :) and latest version of essentials.
  12. Offline


    Oh, didn't know that. I was afraid iChat would interfere with CraftIRC, but I'll give it a shot.
  13. Offline


    Hello everyone! I am having some difficulty getting Permissions to work with Essentials. The problem is that only admins can use the Essentials commands. Normal users get a "You do not have access to that command." error when they try to use any command.

    My Permissions Configuration File:
    My Essentials Configuration File:

    Any help with this would be appreciated! Thanks.
  14. Offline


    The code is fine, get rid of General, it has the exact same commands as Essentials which is causing conflict. Also, you still have restricted commands in your Essentials file, you need to delete those as well.
    --- merged: Jan 29, 2011 11:53 PM ---
    nothing what is the problem?
  15. well, all the permissions compatible plugins report insufficient clearance
    (using bukkit 168)
  16. Offline


    Thank you, that did it!
  17. Offline


    While you make a valid point, i am afraid that is for another argument. /modify is not another feature to the game but another feature to an already existing plugin. To have 20 plugins doing the same thing that one plugin should be doing is messy and bad code. Handling the threads and closing and opening them properly, as well as many other picky processes, these are things that should be handled by the plugin designed to do just this. You are right that having segmented plugins are great, and even key so the entire system is not down when one goes bad, but with this logic each plugin should only have ONE command... lol

    Anyway, ill keep the argument out of here and wait for him to add /modify.
  18. Offline


    What plugins are you referring to? I just have ichat and essentials running test at the moment and those are fine, let me know what others you need and I will test.

    Also a screeny of the error report would be great to help figure out the problem.
  19. Offline


    Bukkit 167+ is bad imo, they changed something that gave me 8 errors on 8 seperate plugins so downgrading to 166 is the option I took.
  20. I don't get it... Permissions just doesn't load at all D:

    2011-01-29 17:58:20 [INFO] Starting minecraft server version Beta 1.2_01
    2011-01-29 17:58:20 [INFO] Loading properties
    2011-01-29 17:58:20 [INFO] Starting Minecraft server on
    2011-01-29 17:58:20 [INFO] Preparing level "Florae"
    2011-01-29 17:58:20 [INFO] Preparing start region
    2011-01-29 17:58:24 [INFO] [General] version [2.1] (Salvez) loaded
    2011-01-29 17:58:24 [INFO] [iChat] version [1.3] (Jack Frost) loaded
    2011-01-29 17:58:25 [INFO] Done! For help, type "help" or "?"
    2011-01-29 17:59:27 [INFO] Disconnecting Mr_FJ [/]: Took too long to log in
    2011-01-29 18:01:13 [INFO] Mr_FJ [/] logged in with entity id 195
    2011-01-29 18:01:25 [INFO] Mr_FJ issued server command: i 2
    2011-01-29 18:01:25 [INFO] Unknown console command. Type "help" for help.
    2011-01-29 18:02:00 [INFO] <Mr_FJ> :(
    2011-01-29 18:02:04
    Any ideas? I'm running build 161
  21. Offline


    Could some one help me? I have been trying for like 3 days. When someone joins, they cannot build or do anything. It is causing alot of people to leave. Please help.
  22. Offline


    Make sure the config.yml is located in the plugins/permissions folder
    --- merged: Jan 30, 2011 12:14 AM ---
    Exactly what information would you like me to derive a conclusion to your problems from. HKI errror, good luck on getting that to work.
  23. Offline


    My new players cannot build, destroy or open chests... I just need help on that.
  24. Offline


    Like I said HKI, you have no reason trying to run a server.


    *beats head against desk*
  25. Offline


    Okay well as chill is having a mental breakdown i'm going to use guessing to sort the problem :p

    Have you got anti-build?
    If so each group needs the line: Build: true
  26. defaulted to flatfile permission config
    I'm okay with that till sql support comes.
  27. Offline


    Im using Essentials with the permissions plugin... cant seem to put people into groups.... I want there to be three admins with all commands. Every other person who enters the server I want to fall under default with a limited amount of commands. However, this hasnt worked yet.... it gives all users 5 pages of commands.
    Here is my config, and help would be appreciated.
  28. Offline


    I'm sorry but Nijikokun has stated several times as well as I have, that we need the config.yml file, and something telling us EXACTLY what the problem is. Plugins installed would also be nice to know on a question like this. It could be 1 of 60 different plugins causing the problem.

    And if someone installed AntiBuild and set the config to build: false I would hope they knew why they did that. and the results it would have.
    --- merged: Jan 30, 2011 12:31 AM ---
    Just because it list all the available commands doesnt mean they can use them. Have you verified that commands not listed under default can be USED?

    Error in the code, give me a minute.
  29. Offline


    I seem to be getting this problem too, I'm trying to get Permissions to work with Essentials but I am unable to set myself as admin. The commands I have assigned to my default group though are working, as I can't set people into groups I'm going to assume that my other commands that I issued are working too but why can I not set myself as admin or other members into groups? I have pastebined my code below incase you guys would be nice enough to check it is okay for me.

    Is there something I'm missing do I have to take names out of admin.txt and ops.txt? Do I remove them files? That many files with the same defined ops in them might be conflicting? Did anybody else have to remove the igns or files from their server to make this work? I wondered because its not mentioned anywhere but I cant see what else it could be. Its a fresh server install, just to make sure with just Permissions, Essentials and General installed.

    This is all I really need working then the rest I will be alright with.

    Hope you guys can help me out,

  30. Offline


    @ODIN Here is the good code.

            system: default
            default: true
                build: false
              - ''
              - 'essentials.mail'
              - 'essentials.mail.send'
              - 'essentials.spawn'
              - ''
              - 'essentials.home'
              - 'essentials.sethome'
              - 'essentials.list'
              - 'essentials.afk'
              - 'essentials.tpahere'
              - 'essentials.tpa'
              - 'essentials.tpaaccept'
              - 'essentials.tpdeny'
              - 'essentials.warp'
              - 'essentials.motd'
              - 'essentials.rules'
            default: false
                prefix: '&aAdmin'
                suffix: '&a'
                build: true
                - Mod
                - '*'
            group: Admins
            group: Admins
            group: Admins
    --- merged: Jan 30, 2011 12:42 AM ---
    To start with there should be no admins.txt and the permissions will make the ops.txt obsolete so even having a name there wont really matter, but I would delete it. Looking at your code now.
Thread Status:
Not open for further replies.

Share This Page