Inactive [ADMN/GEN/INFO/TP/RPG] MyWorlds v1.48 - Multi-world plugin with a touch [2320]

Discussion in 'Inactive/Unsupported Plugins' started by bergerkiller, Aug 15, 2011.

  1. Offline



    You may wonder, why so many tags? Well, that is because this plugin simply contains a lot of features that fall under those tags! I originally made (parts of) this plugin for our server, but it proofed to be a 'publishable' plugin as well. :)


    This plugin features everything related to worlds. Features:
    • Load, unload, copy, delete, save and create worlds
    • Show information of worlds and list available chunk generators and worlds
    • Set world game mode, difficulty, time, weather, autosaving, PvP
    • Set world mob spawn restrictions
    • Evacuate worlds to clear them from players
    • Repair broken worlds to some extend
    • Make portals cross-world, one-way, simple, no commands needed
    • World-specific chat rooms using permissions
    • Automatically load worlds when the server starts and persistent settings
    • Extensive permission system, you can even set who can enter what world
    • Can act as a tool for other plugins to teleport players from one world to the other
    • Simple teleportation commands
    • Set OP lists for specific worlds to make players operator on certain worlds
    • Easy-to-remember commands: with aliases and chat-message help
    A nice tutorial by FrozdY

    BukkitDev page

    For configuration, commands, etc, look on the BukkitDev page under Links.
    All documentation pages are now on Bukkit Dev.

    Known bugs:
    - None
    Disclaimer (because things CAN go wrong)

    I am not responsible for world damages done by this plugin or by certain commands this plugin performs. If you, for example, loaded 20 worlds and hosted it on a buggy computer with 30 players, odds are the server (and your computer) will crash and worlds become corrupted. Repair can fix worlds, but this does not recover damaged chunks, so don't think you are always covered. Also, never forget to make backups of your worlds, but I guess this is common sense...

    - Different inventories per world? No, you can use World Inventories for that.
    - Or try MultiInv while it is still maintained.
    - Repair ruined your world? Backup of region files can be found in the region folder, simply restore.

    Important links:

    Download the MyWorlds.jar from GitHub
    Look at the source at GitHub
    BukkitDev page


    Show your appreciation for my plugins by donating
  2. Offline


    @mast3rpyr0 It's a (Craft)Bukkit configuration bug, something with the YAML parsers not getting closed correctly. I know, and it gets worse when your computer crashes: All configuration changes into 'null' chars :/

    The order swap is because of the fact that the nodes are sorted.
  3. Offline


    Can it be made to just read the file and then not touch it? I have to cancel notepad++ from reloading the file after every /reload.

    But anyway, I'm still having a bit of an issue. I recreated all the worlds, setup portals accordingly. I got Build to goto PvP, Pvp to goto Build. defaultPortal for both these worlds is build_nether. Nether defaults to build, however, it is going to my PvP portal.

    Also, if I dont set a defaultPortal, I just sit in the portal as everything goes purple, I never go anywhere.

    EDIT: I thought having a portalMessage: 'Welcome to {World}' for each world would be nice, in case you wanted to leave it blank and not say where you were, or have a different language/dialect message for each world. I think it would add even more dimensions to what the plugin offers :)

    {World} can either be the name of the world or the 4th line of the sign, or that could be removed in place of this variable
  4. Offline


    Hello! I've been using this on a server for a while now and I can't thank you enough for writing it. I have one minor quibble, however.

    Using /world delete [name] deletes the world folder, but not its entry in worlds.yml. This leads to some interesting problems if you ever create a different world with the same name. For example, if you used a non-standard chunk generator in the first world, it's impossible to set the normal chunk generator in the new world.

    I don't know if this was on purpose, but I can't see how saving this world metadata would be helpful when the command deletes everything else about the world.

    I searched this thread and didn't see anything related to this issue; hopefully it hasn't already been mentioned.
  5. Offline


    @mast3rpyr0 You can change the messages displayed in the localization file:
    • When entering a certain portal or any portal, where %name% is used
    • When world/portal access is denied
    • The various help messages (usage)
    • Maybe some others I can't remember adding
    I'll look at the default portals for a bit to see if it works out or not...

    @agrif Mh yeah that can be an issue. I can vaguely remember adding some sort of removal for it, but could be I removed it again. :)


    Say are right. I set the default portal to p1 and instead go to p2. This is rather strange...Let me fix this for you.
  6. Offline


    Hi I really like your plugin & it really helped me manage my worlds but I just wondering if you can add an extra command to allow teleporting other people to a world or portal instead of having to go there myself & teleporting them to me .
  7. Offline


    @DeathDragon mh yeah I guess I can add that to the /tpp command, to teleport another player to another world.
    Should this include player-player teleportation too, or is this not needed?

    Also found the bug of the default-failing portals.
  8. Offline


    Well player-player teleportaion isn't really neccery as I use the default /tp for that but I won't mind it , but if you can make something to allow teleporting severl player at the same time that would be perfect for what I need.
    Something like:
    /tpp [player1name],[player2name] [world/portalname]
  9. Offline


    @DeathDragon I guess it's simpler (for me and the sender) to do this:
    Player names simply split by spaces.

    Updated, you can now teleport multiple players to another portal or world using /tpp.
    Also fixed the default portals failing, it was using the destination found on the portal that was

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016
  10. Offline


    Okay that's even better thanks for the awesome plugin .
  11. Offline


    Thanks berger, that did the trick! Nice job
  12. Offline


    Having trouble keeping worlds loaded on restart.
    They stay loaded until server goes offline and starts back up, then they have to be manually loaded.
    I am using /world load [worldname]
    After I load them all I do /world save *
    Am I missing something?
    -Edit, before anyone asks. Yes I've used /stop to save the world data in hopes that it would also save loaded worlds. It hasn't worked yet.
  13. Offline


    @Silial does, after stopping the server, the worlds.yml file contain the worlds and a 'loaded' node? If it is left empty, or not all worlds are in there you previously used, then something is wrong with the save part of the Bukkit configuration. Also, what version of Craftbukkit do you use?
  14. Offline


    I am using bukkit 1131.
    Within the actual worlds.yml file every world stays "unloaded" except the actual starting world that I didn't create using MyWorlds. At one point, I made a backup file, manually changed them to loaded just to see what would happen, and then loaded my game up. Still nothing, still had to manually load them.

    On an off note, I really do like the plugin if I can get this sorted out. I like not having to look at a wikipedia page because I can't find the command for what I want in game. :p

    Edit - I realized I typed 1131. Wow it's been a bit. I should probably fix that and then see if it works. :)
  15. Offline


    @Silial I got the feeling that the 'deprecated' configuration finally broke...

    I'll test it out on 1131...does it work on 1137?
  16. Offline


    Permissions is out of date. This plugin doesn't seem to see bukkitpermissions :(
    Any way I can let anyone /tpp to other worlds, but leave the rest OP?
  17. Offline


    @ARandomBob if you want to use Bukkit permissions, set usePermissions to false. usePermissions is for the Permissions 3.* plugin, it doesn't enable permissions in general. (I could remove that actually...)
  18. Offline


    Hey that worked. Thanks for the quick reply!
  19. Offline


    @bergerkiller Updated bukkit, yet still can't get them to stay loaded. I've checked console and no errors come up. Any ideas?
  20. Offline


    @Silial not really, it's kinda strange...
  21. Offline



    I've got 2 idea's for your plugin:
    • when you use /tpp: not getting teleported where the portal is, because you'll get teleported directly to the place where that portal goes to.
    • when you're in a portal for longer than the teleport interval (in the config.yml) You'll still get teleported, because a lot of noob's keep saying the portals won't work. But when I set the telportInterval to 0 they won't stop teleporting.
  22. Offline


    @jespertheend Good suggestion, I can understand that people start saying that. (why are they teleporting from one spot to the other anyway?)

    The first one would only confuse a lot of people, because right then you can't use portals like a static teleport-to location, which makes /tpp so useful. Also not possible since it has to read the sign upon teleporting, which means that chunks near certain portals are constantly loaded and unloaded: bad idea.
  23. Offline


    I updated from 1.18 to 1.24 and I can no longer use generators.

    Generators come up fine with /mw listgenerators
    The plugin confirms I chose the generator before it starts creating the world
    After the world is created /mw info worldname shows no generator
    Visiting the world confirms no generator was used

    I went back to 1.18 and generators are working fine again. I'm using CleanroomGenerator and the new SkylandsPlus+ generator.
  24. Offline


    Hi! I use this plugin since its inception and I would like to thank the author for its updates. I'm having a problem: when I teleport me in another world, my plugin "iconomy" subtracts me 20 money. Is it normal? I would like to remove it. Can you help me?

  25. Offline


    @GameFAQsRolo bug confirmed, it was clearing world configuration after the chunk generator had been set, causing it to be never used. (you get to see that no chunk generator is used in the log too)

    Now working at the teleporting - after - interval system.

    @didzym I don't use iconomy in this entire plugin, so it can't be MyWorlds. Perhaps you can set a fee in the iconomy configuration, which a player has to pay to travel worlds?


    Updated it: chunk generator now works properly and you no longer have to re-enter a portal if you were too fast: you get teleported automatically. You still have time to exit the portal though.
  26. Offline


    Thank you for your response it allowed me to withdraw a hypothesis to solve my problem. The problem was the plugin babanaspace and it is resolved. Thank you for having responded as quickly.
  27. Offline


    It seems like you are not able (atleast I am not ;)) to teleport to a map spawn with the newest version anymore.
    "/world spawn" works fine.
    But "/world spawn Worldname" gives me a "You are not allowed to enter this world!".
    I have no permission system installed, permissions are disabled in the config and I am operator.
    Using Craftbukkit #1337 with MyWorlds v1.25.
  28. Offline


    There appears to be a problem between MyWorlds and PermissionsEX - specifically with the ModifyWorld.jar that PermissionsEX comes with. Here's the output when I run /mw listgenerators:

    2011-10-26 13:40:14 [INFO] Available chunk generators:
    2011-10-26 13:40:14 [SEVERE] java.lang.ClassNotFoundException: ru.tehkode.modifyworld.bukkit.Modifyworld
    2011-10-26 13:40:14 [SEVERE] at$ Source)
    2011-10-26 13:40:14 [SEVERE] at$ Source)
    2011-10-26 13:40:14 [SEVERE] at Method)
    2011-10-26 13:40:14 [SEVERE] at Source)
    2011-10-26 13:40:14 [SEVERE] at
    2011-10-26 13:40:14 [SEVERE] at
    2011-10-26 13:40:14 [SEVERE] at java.lang.ClassLoader.loadClass(Unknown Source)
    2011-10-26 13:40:14 [SEVERE] at java.lang.ClassLoader.loadClass(Unknown Source)
    2011-10-26 13:40:14 [SEVERE] at java.lang.Class.forName0(Native Method)
    2011-10-26 13:40:14 [SEVERE] at java.lang.Class.forName(Unknown Source)
    2011-10-26 13:40:14 [SEVERE] at
    2011-10-26 13:40:14 [SEVERE] at
    2011-10-26 13:40:14 [SEVERE] at org.bukkit.command.PluginCommand.execute(
    2011-10-26 13:40:14 [SEVERE] at org.bukkit.command.SimpleCommandMap.dispatch(
    2011-10-26 13:40:14 [SEVERE] at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    2011-10-26 13:40:14 [SEVERE] at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    2011-10-26 13:40:14 [SEVERE] at net.minecraft.server.MinecraftServer.b(
    2011-10-26 13:40:14 [SEVERE] at net.minecraft.server.MinecraftServer.h(
    2011-10-26 13:40:14 [SEVERE] at
    2011-10-26 13:40:14 [SEVERE] at
    2011-10-26 13:40:14 [INFO] CleanroomGenerator
    My Plugins:
    2011-10-26 13:42:33 [INFO] Plugins: AnyoneSleep, BananaChunk, Bedrock, bLift, BlockDoor, CleanroomGenerator, ConsoleFilter, Essentials, EssentialsSpawn, FenceStack, iConomy, MinecartManiaCore, MinecartManiaSignCommands, MinecartManiaStation, ModTRS, My Worlds, PermissionsEx, PluginInfo, PorteCoulissante, SignLink, Spout, Train Carts, WorldEdit, WorldGuard, BookWorm, ChatManager, MinecartManiaAdminControls, MinecartManiaChestControl, Modifyworld, Permissions, dynmap, LWC, NoLagg, Register, ScrollingMenuSign, VanishNoPacket, WorldBorder

    Now ModifyWorld isn't enabled right now so I don't know if that could be the cause. It's loaded but the config file sets it as disabled.
  29. Offline


    @glarter you can ignore that error, it is probably because of an invalid main class set in the plugin. Doesn't affect the plugin, it's just to notify that a (Chunk generator?) plugin is not properly set-up.
  30. Offline


    That's what I thought but it's nice to have confirmation.
    Is there any way that you can trap this exception in a future update?
  31. Offline


    I have a problem in game... I made a world and named it warhub. So i say /world spawn warhub and it says You are not allowed to enter this world! I have the essentials pluggin, do I need permissions in order for this to work.

    I have a problem in game... i do /world spawn warhub and i get this: You are not allowed to enter this world! Do you know why this is happing, I have essentials. I have the following plugins...

    Attached Files:

    Last edited by a moderator: May 18, 2016

Share This Page