Inactive [ADMN/FUN] NoClip v0.2 - Enable Zombe's and CJB NoClip on your server! [1.2.5-R4.0]

Discussion in 'Inactive/Unsupported Plugins' started by md_5, Jan 13, 2012.

  1. Offline

    md_5

    Use da latest CraftBukkit or download NoClip 1.0

    Version 1.2 is out, includes a config option to disable messages, general cleanup and new event system usage.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 23, 2016
  2. Offline

    Elfsovereign

    Ah thank you. When the new update is out I will try it out :) I just don't mess around with experimental builds of bukkit
     
  3. Offline

    sooi11

    Now im getting this with the 1.2 version D:
    Code:
    >08:03:40 [SEVERE] Error occurred while enabling NoClip v1.2 (Is it up to date?): com.md_5.noclip.NoClip.getLogger()Ljava/util/logging/Logger;
    java.lang.NoSuchMethodError: com.md_5.noclip.NoClip.getLogger()Ljava/util/logging/Logger;
    at com.md_5.noclip.NoClip.onEnable(NoClip.java:28)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:230)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:970)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:280)
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:190)
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:173)
    at net.minecraft.server.MinecraftServer.t(MinecraftServer.java:355)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:342)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:174)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:406)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)
     
  4. Offline

    King_KYl3

    I dunno but it says this when i try push the key to enable zombes no clip: zombe's noclip-mod is not enabled on this server. i have check though most my plugins to see if they disable it but found nothin please help thanks.
     
  5. Offline

    md_5

    Update Bukkit again!
    You need to be op or have the 'noclip' permission
     
  6. Offline

    sooi11

    Bukkit is up to date
    But it works fine with the noclip 1.0
     
  7. Offline

    King_KYl3

    Works epic love it Thanks :D, also how i make i dont need fly enable to use no clip with zombes?
     
  8. Offline

    md_5

    Trust me it's not up to date. 1.2 only works with the VERY latest.
    Not quite sure what you mean.
    If you mean in server.properties this disables fly kicking for all users using no clip.
     
  9. Offline

    King_KYl3

    nah, i mean like with my client its self i need zombes fly mod enabled to use noclip how i make it i can just use no clip with out fly :confused:
     
  10. Offline

    ShootToMaim

    I hope you know that I love you. :D.

    Btw, where's the BukkitDev page :O. ;D
     
    Tanite likes this.
  11. Offline

    md_5

    I have been thinking about that. RATE, COMMENT AND SUBSCRIBE!
    Whoops wrong place :p
    Anyway I am busy doing my first test compile of Zombe's growth mod for Bukkit, it using some pretty serious coding in order to modify Block spreading.
     
    ShootToMaim likes this.
  12. Offline

    ShootToMaim

    1 more question.
    You might know that I enjoy trolling plugin submissions and suggesting things to author's there that'll improve their post and get them in the plugin releases section. But there's one problem.
    Is it mandatory for plugins to have a BukkitDev page or no?
     
    Tanite likes this.
  13. Offline

    md_5

    It's not mandatory
     
  14. Offline

    emericask8ur

  15. Offline

    abcedea

    Thanks.
     
  16. Offline

    number1_Master

    XD in my mind i was thinking of you approving your own plugin
    nice plugin btw
     
  17. Offline

    imzedoctor

    getting an error when I start my server: Error occurred while enabling NoClip v1.2 (Is it up to date?): com.md_5.noclip.NoClip.getLogger()Ljava/util/logging/Logger;
     
  18. Offline

    md_5

    Just before anyone asks this IS compatible with the latest rb and with Spout.
    I may get round to releasing the start of Zombes4Bukkit tomorrow. It will include at least NoClip, Growth, Death mods.
     
  19. Offline

    sam501

    Time to update to 1.1
     
  20. Offline

    Stone_Tigris

    Wow. I disguised myself as a chicken, and was just appearing through peoples floors for about an hour.
     
  21. Offline

    sam501

    Ignore that it works with 1.1, and by the way, nice plugin now i can patrol easily
     
  22. Offline

    phanaticd

    i get this error every time i enable or disable noclip

    01:46:49 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'noclip' in plugin NoClip v1.2
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:42)
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:168)
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:386)
    at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:777)
    at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:737)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:725)
    at net.minecraft.server.Packet3Chat.handle(Packet3Chat.java:33)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:100)
    at net.minecraft.server.NetworkListenThread.a(NetworkListenThread.java:78)
    at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:537)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:435)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)
    Caused by: java.lang.NoSuchMethodError: net.minecraft.server.EntityPlayer.getPlayer()Lorg/bukkit/craftbukkit/entity/CraftPlayer;
    at com.md_5.noclip.NoClip.enableNoClip(NoClip.java:56)
    at com.md_5.noclip.NoClip.onCommand(NoClip.java:44)
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:40)
    ... 12 more
     
  23. Offline

    md_5

    What CraftBukkit version are you running? I haven't even had time to test on an rb, the namings may have changed.
    Same question as above please.

    EDIT: Works on 1.1-R1
     
  24. Offline

    Feed_Dante

    I get the same error on 1.1-R2, but I can still no-clip just fine. (I am now on 1.1-R3)
     
  25. Offline

    phanaticd

    im updating to R4 as i write this
     
  26. Offline

    ratty

    I get the same unhandled exception in R3, and just to add to this, it mostly works just fine despite the error, but sometimes after turning noclip on and off, after I warp somewhere far away, I'll end up falling through the ground as the chunks start to load and render. Everything worked great in R1.
     
  27. Offline

    md_5

    /sigh I won't have time till this weekend to update it.
    This error simply prevents the Enable / Disable message from being shown.

    It does not impact the plugins functionality or your servers performance in any way.
     
  28. Offline

    dylanpiera

    Can anybody send the download link from version 1.0
     
  29. Offline

    md_5

  30. Offline

    dylanpiera

    can you put download link from version 1.0 i need them
     

Share This Page