Inactive [ADMN/DEV] PermissionsEx (PEX) v1.19.5 - Tomorrow is Today! [1.4.6-R0.1]

Discussion in 'Inactive/Unsupported Plugins' started by t3hk0d3, May 21, 2011.

  1. Offline


    Version: 1.19.5


    PermissionsEx (PEX) is a new permissions plugin, based on Permissions ideas and supports all of its features. But PEX is more! It offers different backends, powerful ingame management, fine grained restrictions for world modification.


    Current features
    1. Bukkit Permissions (SuperPerms) compatible.
    2. Several backend support. Currently bundled backends is File (YAML) and SQL (MySQL, SQLite). Also it's possible to add your own.
    3. YAML backend, with new, fully rethinked, config schema. Now all user, groups and their permissions are stored in one file - permission.yml. BTW file name is adjustable too.
    4. SQL backend, most delicious. Currently MySQL and SQLite supported, but other DB (like Postgre) are possible too. PEX deploys the DB scheme (tables and initial data) automatically. This means, that you only need to provide data on how to connect to the db, everything else PEX will handle by itself.
    5. Flexible architecture and API - you can change a lot programmatically.
    6. Compatibility layer with TheYeti's Permissions (2.7.4) (as a separate part of the plugin). In most cases plugins, which use Permissions, will alsowork with PEX also.
    7. Rich chat/console command interface. You can do almost everything ingame. Command list below.
    8. Modifyworld - Embedded restrictions mechanism (we call it "modifyworld"), which provides the possibility to control players abilities, such as destroying/placing blocks, riding carts/boats or even getting spotted by mobs and much more. Disabled by default.
    9. Multigroup inheritance. User, as well as Group, can be member of several groups. And inherit their permissions, options and prefix/suffix.
    10. Permissions based upon Regular Expressions. This mean you can use regular expressions. Example: modifyworld.blocks.(destroy|place).(3|12) - this permission allow place or destroy only sand (12) or dirt (3) blocks. There is still limitation on dot usage in your regexps - dots are escaped by default.
    11. Multiworld permissions. Just don't specify world and permission would work in any world.
    12. Multiworld inheritance. You can inherit different groups in different worlds.
    13. Easy migration from Permissions 2.x. Converter for both YAML and SQL are embedded into PermissionsCompat. Just use simple instruction.
    14. Perfomance friendly. Low-level caching helps alot when you have 100+ online users :)
    15. Promotional/Demotional system. You can assign ranks to groups and promote/demote users to higher/lower ranked group.
    16. World-inheritance - permissions/option of one world can be inherited by another world.
    17. Timed Permissions - you can give user permission only for some amount of time.
    18. Chat Manager - small chat plugin, bundled with PEX. With prefixes/suffiex and colors. Check wiki for more details.


    Basic setup tutorial (Thanks to lycano)

    Nice tutorial made by Bennetman

    Stable version

    Development version (mostly stable) - always lastest dev build.



    Maven Repository

    Join us on #permissionsex, Feel free to ask any related questions.

    Tools !NEW!
    Pex Auto-Setup Tool - MySQL and FlatFile !

    Show Changelog (open)
    Proper intervals for timed commands (both group/permissions management), without pesky seconds calculations (like /pex user t3hk0d3 timed add cool.permission 10days)
    1.4.6 compatibility.

    Built for Bukkit 1.4.2-R0.1
    Added inventory permissions (modifyworld.items.put/take.<item>.of.<chest>)
    Added item hold permission (modifyworld.items.hold.<item>)
    Sdded monster egg spawn permission (modifyworld.spawn.<creature>)
    Few other minor fixes
    Modifyworld improvements (configurable messages, now independent from PEX)
    /pex help command
    Minor improvements and bugfixes
    New modifyworld permissions
    Some bugfixes
    Bugfix release
    Bukkit R6 compatible.
    Several bugfixes!
    Permissions now case-insensetive.
    Users logging and cleanup feature.
    Non-inheriting nodes feature.
    Several Bugfixes.
    PermissionsCompat is finally remove from default bundle.
    User/group specific management permissions (
    Fixed some superperms compatibility issues
    Fixed several bugs
    SuperPerms compatbility bridge were rewritten - no lags anymore and now with debug output (now you can view superperms checks).
    Numerous of bugs were fixed (Thanks you guys for reporting them)
    Modifyworld were improved (modifyworld.item.use)
    Compatiblity for 1317+
    Fixed perfomance issues with SuperPerms (if you still experience they try to disable "raw-permissions" in config.yml)
    Fixed issue with prefix inheritance
    Improved Options mechanism.
    Auto saving new users feature, disabled by default.
    SuperPerms bridge improved - more permissions supported by wildcards.
    File backend dumping now fully functional. SQL dumping is still bogus (do not dump world-specific inheritance and prefixes), will be fixed soon.
    Many bugfixes and minor improvements.
    Superperms (BukkitPerms) support
    Multiworld inheritance and prefixes/suffixes
    Groups weighting
    ChatManager, chat plugin which bundled with PEX.
    Modifyworld now separate plugin, but still bundled with PEX.
    API changed slightly, CustomEvents (PermissionsEntityEvent, PermissionsSystemEvent) introduced.
    Many lesser improvements and tons of bugfixes.
    API get slightly improved
    Ranking ladders.
    User/group name case-insensetivity.
    Timed permissions.
    Modifyworld rules are get improved.
    Tons of minor improvements and bugfixes.
    Many bugfixes and improvements.
    MySQL connection stability improved - reconnection mechanism.
    Promotional/Demotional system.
    Perfomance improvement, with new low-level caching system (thx Joy)
    Modifyworld improved.
    Many lesser improvements and bugfixes.
    New p2compat backend, for easy migration from Permissions 2.x to PEX.
    Users/Groups dumping (pex dump <backend> <file>).
    New commands pex promote/demote. Actually this is just aliases for "pex user group set/remove"
    Few bugfixes.
    Players now can be informed about changes (has been added to group, changed permission/option). Disabled by default - set "permissions.informplayers.changes" to "true"
    Config node "permissions.verbose", which responsible for player informing about modifyworld restrictions has been renamed to "permissions.infromplayers.modifyworld".
    Autocomplete has been improved.
    New command "pex config <node> [value]". This command help to manipulate configuration file (config.yml) from console/chat interface.
    Many bugfixes.
    Autocomplete for users (taken from registred users and online users) and groups names.
    New command for user removing (pex user <user> delete)
    Fixed several nasty bugs. Thanks for bugreports!
    Compatibility layer loading order issue fixed. Now most of plugins should work.
    Tested with new CB 803 build.
    Regular expression permissions support.
    Newer permissions now added above (bugfix).
    Several bugfixes.
    Initial public release.
    BRampersad, grid21, MrRazull and 71 others like this.
  2. Offline


    Hope you have PEX up and running soon for RB #1185.
    Best of luck when updating :D
    Rick Boss likes this.
  3. Offline


    Confirmed a re-compile against the latest Bukkit is all that's necessary. I just downloaded PEX source, re-built it against latest Bukkit (using maven) and re-deployed to my server and I'm up and running on RB #1185 with no issues.

    -- UPDATE --
    Ah I stand corrected, as previous poster points out, "dev 1.14" is working, which is what is currently checked into the source repositories. So I basically built 1.14 manually and it works fine. So just download that from the main thread and you should be good to go.
  4. Offline

    Don Redhorse

    confirmed... the developer version fixes the superperms issue... go download!!
  5. Offline


    what ? how ?? could you explain more simple ?
  6. Offline


    Version 1.14 released!
    This is compatibility/bugfix release caused by 1.8 release and changes in Bukkit :)

    • Improved Options mechanism.
    • Auto saving new users feature, disabled by default. Can be enabled by createUserRecords property in config.yml
    • SuperPerms bridge improved - more permissions supported by wildcards.
    • File backend dumping now fully functional. SQL dumping is still bogus (do not dump world-specific inheritance and prefixes), will be fixed soon.
    • Many bugfixes and minor improvements - more details.
    Don Redhorse likes this.
  7. Offline


    hey will you make one for 1.8.1 bukkit stable
  8. Offline


    You failed to read previous message? ;)
  9. Offline


    Thanks for continuing to update this -- I was afraid Bukkit's built in Permissions system would cause you to stop but I find PermissionsEx to be far better and hope you continue the great work you're doing.
  10. Offline


    Thank you for kind words :)
    Jobsti and Mitsugaru like this.
  11. Offline


    Hi, I have my self set to default usergroup and default has no permsions but I can still build and destroy and I just got blow up by 2 creepers.
  12. Offline


    For some reason some plugins permissions don't work, and they load my old Permissions 2.7 jar even though it was overwritten with the new one from PermissionsEx, what is wrong? Really annoying how it still loads permissions 2.7 but PEX is enabled for the other half..
  13. What other plugins are you using? I had this exact problem and it turned out that mcSimpleMail was making the bridge plugin act like the original yeti permissions plugin (2.x version).
  14. I'm having trouble getting this to run with MultiVerse, does anyone know of a noob-friendly guide, or could someone explain please? Basically I want 2 worlds, 1 Survival (no commands for anyone, even admins) and 1 Creative with ranks like Guest/Regular/Moderator/Admin, Guest being able to only walk around and Admin to do everything. I managed to follow the basic guide from the wiki and set up a few ranks but couldn't 'remove' them on my survival world.

    I have been checking Google and found 1 solution which I don't know how to implement into my current setup, Quoted:

    Thanks in advance.
  15. Offline


    Hi there, I wanted to thank you for this great plugin. I'm moving our server to this and chose to do a clean start, since updating from Permissions led to a nice bunch of errors (but I'm in no doubt the source of this hehe).

    I wanted to ask for something in particular: I followed step by step your basic installation, and everything is running fine, visitors with no rights but the chat, members doing fine, but... admins can't do anything more, except avoiding focus from mobs. I did do the /pex group Admins add "*" command. I used to write *.* with previous plugins, but I followed what's written on GitHub and went for the "*". What's wrong? Something to toggle in a config file that I would have missed? Is it something related to the fact that we have 2 worlds and 1 nether world, and I need to set this for every world?

    Thanks in advance for your help (or any user's who might shed some light on my issue). I must say this plugin seems to deal with permissions in a way I never saw before. I really like the default group which will allow us to receive visitors even when no admin is around.
  16. Greetings once again!

    I'm in the process of moving my server over to the latest bukkit and updating the plugins to match. Most of my settings for PEX seem to work just fine as is, with one exception...

    The default user for my server (AKA guests) have a very limited set of permissions. They can interact with objects, such as doors and buttons, but can not open containers. Building is also not allowed, nor are they allowed to hold anything.

    The problem came to light when I realized that the no items rule had one major flaw... they would starve! So, I changed the default user permissions to the following:
            - -modifyworld.blocks.interact.(23|25|54|61|62|84)
            - modifyworld.blocks.interact.*
            - modifyworld.usebeds
            - modifyworld.items.have.(260|319|320|360|363|364|365|366|367)
            - modifyworld.items.drop.(260|319|320|360|363|364|365|366|367)
            - modifyworld.items.pickup.(260|319|320|360|363|364|365|366|367)
    (modifyworld.items.*.(260|319|320|360|363|364|365|366|367) didn't seem to work :))

    This lets guests have all the common food items, but for some reason, they still can not pick them up, drop them, nor eat. Can anyone shed some light on the problem? I didn't see anything in the wiki under modifyworld on eating, and as I understand it, they should be able to pick up the items I listed.

    EDIT: Don't ask me how, but it's now working as I would have expected. :confused:
  17. Offline


    Been installing a new update 1185 of bukkit and Pex stopped working, here's the log:

    12:02:47 [INFO] Preparing start region for level 1 (Seed: -870961167107594113)
    12:02:48 [INFO] BorderGuard version 4.2 is enabled!
    12:02:48 [INFO] CraftBukkitUpToDate version 2.6.1 is enabled!
    12:02:48 [INFO] CButD: Permission system not detected, defaulting to OP
    12:02:48 [INFO] MultiCurrency v0.1 by [Ashtheking]
    12:02:48 [INFO] Loaded Currency: gold
    12:02:48 [WARNING] MultiCurrency has not found Permissions, and will now use OP.
    12:02:48 [INFO] [HeroChat] HeroChat version 4.10.3 enabled.
    12:02:48 [SEVERE] Error occurred while enabling PermissionsEx v1.13 (Is it up to date?): org.bukkit.plugin.PluginDescriptionFile.getPermissions()Ljava/util/ArrayList;
    12:02:48 [INFO] [Modifyworld] Modifyworld disabled. Check config.yml!
    12:02:48 [INFO] [Modifyworld] Modifyworld disabled!
    12:02:48 [INFO] [mcMMO] PermissionsEx found, using PermissionsEx.
    12:02:49 [INFO] Loading Config File...
    12:02:49 [INFO] CButD: CraftBukkit is up to Date
    12:02:50 [INFO] mcMMO version 1.1.14 is enabled!
    12:02:50 [INFO] mcMMO is keeping usage stats an. To opt-out for whatever bizarre reason, check plugins/stats.
    12:02:50 [INFO] [Towny] Database: [Load] flatfile [Save] flatfile
    12:02:50 [INFO] [Towny] Version: 0.76.0 - Mod Enabled
    12:02:50 [INFO] Server permissions file permissions.yml is empty, ignoring it
    12:02:50 [INFO] Done (0.309s)! For help, type "help" or "?"
    12:02:58 [INFO] The automatic update-Check only work every 6 hours, the last check was 70 minutes ago. 
  18. Offline



    How can I do a -permission.node with PEX?

  19. Offline


    As in deny? Just add the node like normally but put a hyphen in front of the node.
  20. Offline


    hey i think the download is broken...
  21. Offline


    I did that but it didn't work :(
  22. Offline


    first off: i love this plugin :D
    second: i have a problem that i think has something to do with chatmanager. i tried this plugin in my test world and everything seemed to work perfectly, but when i removed 'world' (the test world) and replaced it with my "real" world the prefixes were messed up.
    i have the prefixes set up like this: Admins prefix: '&4[Admin]&f ' meaning [admin] will be in red and the message in white. im in the group called admins but everytime i write something this comes up: <prefix.MyUserName.suffix>
    this wasnt a problem in my first world and ive tried resetting everything, ive tried messing around in the chatmanager config but nothing seems to work. doesnt matter which group im in, i still get <prefix.myusername.suffix> any ideas?

    everything else works perfectly, just the stupid colors hahahah
  23. I use PEX to do a guest system, so guests can't do anything.

    It was working fine, and it's still working fine until I found a guest with inventory full of items, he was able to open a chest. After lots of research, i found that guest can open any chest in a defined "bugged" CHUNK
    I tested with various other things (block break, placement, item pickup) only chests are affected with this "bug".

    I don't know how this was caused, i don't know if there's more of those chunk but that's pretty weird.
    I don't know if this is related to Modifyworld, but I want to let you know.

    Here is a picture :
  24. Offline


    Hey Guys.

    I have been using Permissions 2 and 3 for some time and decided to give this a shot. a couple problems i'm finding . 1) converting a permissions 2 based file (with groups on top and users on bottom) with no other permissions files being parsed, results in a PermissionsEx file that has users on top and groups on the bottom, and gives lots of the errors shoen above when users try to interact , for example:

    2011-09-23 16:00:28 [SEVERE] Could not pass event PLAYER_JOIN to PermissionsEx
    I had to build my groups from scratch, then append the users.yml portion from permissions 2/3 which will result in a proper permissions system (I hope this helps the rest of you).

    2) The biggest issue im still seeing is ichat says :

    08:26:59 [INFO] [iChat] Permissions not found, Checking for GroupManager.
    08:26:59 [INFO] iChat (v2.4.0-final) enabled

    Which is all fine and dandy, its enabled, but I dont have group manager, and It is not recognising the group prefixes ... See Permissions file example :

    prefix: '&6'
    suffix: ''
    - Default
    - 'essentials.tptoggle'


    See ichat config.yml file :

    iname-format: '+prefix+displayname'
    message-format: '+iname: +message'
    me-format: '* +name +message'
    date-format: 'HH:mm:ss'
    handle-me: true

    Any thoughts on why this is not working? other then that so far so good, I'm hoping to be able to use this with ichat. Do i have to use the p2compat system for this to work?
  25. Offline


    when I start PermissionsEx with PrivateWarp I receive this error:
    2011-09-23 18:02:13 [INFO] [PermissionsCompat] Compatibility Layer Initalized!
    2011-09-23 18:02:14 [SEVERE] Could not load 'plugins/PrivateWarp.jar' in folder 'plugins': PluginControl
    org.bukkit.plugin.UnknownDependencyException: PluginControl
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(
        at org.bukkit.craftbukkit.CraftServer.<init>(
        at net.minecraft.server.ServerConfigurationManager.<init>(
        at net.minecraft.server.MinecraftServer.init(
    What can I do?
  26. Offline


    It sounds like you forgot to install plugincontrol.jar which privatewarp depends on. I will watch this thread if you need any more help, go back to the privatewarp download page and get plugincontrol and install that, it should work fine, i have the latest privatewarp installed and it works fine with PermissionsEx
  27. Offline


  28. Offline



    Update ---- In the meantime i tried your chatmanager.jar and it seems to be able to replace the functionality i was using in ichat. i would switch back to ichat but it doesn't work with your plugin, and The other permissions systems don't look nearly as compatible with this one.

    Hey BadDog.

    I'm not sure this will help but I will do my best. When you manually look at the permissions.yml file you should have a group for Admins with the "*" permission node, as follows :

    - '*'

    But below you should also have the users who belong to that group, and that looks like this :

    - Admins

    Each one of your users needs to belong to the admin group, to make them part of the admin group, type this :

    Console: /pex user YourPlayerName group set Admins

    Please follow the Basic Setup examples :

    I hope that helps, I only answered because you bumped, and i don't know if you've looked at these basic steps yet.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  29. Offline


    I have insert plugin control, but it is loaded some rows after:
    2011-09-23 18:02:29 [INFO] PC: Loading PluginControl Version 1.2.0
    2011-09-23 18:02:29 [INFO] PC: Using Nijikokun's Permission plugin (new detection system)
    How can I make that PluginControl is loaded before PrivateWarp?
  30. Offline


    Thank you for your help. Here is what I have:

            prefix: '&0(&4Admins&0)&7 '
            - -modifyworld.mobtarget.*
            - '*'
                rank: '0'
                world3: {}
            - Admins
    And yet, I don't have permissions to use godmode, super pickaxe, teleport, and so on... Is it because of the option worlds: world3:{} ?
  31. Offline


    Hello Kaosvf..

    Thats definitely whats going on, i looked at my startup and plugincontrol gets loaded after PermissionsEx but before PrivateWarp. I will see if theres a way to change the order, but something else must be effecting it, i literally have only bukkit 1185 , Permissions Ex, and PrivateWarp installed, and it works via the correct order. make sure all these items are completely up to date. make sure they are all named their normal file names and in the ./plugins/ folder. I will see if theres a way to modify the order.

    Hey Kaosvf.

    I searched and found a similar issue in the private warp thread, check this link, and Read Ratty's posts :

    I hope that helps.

    Hello Bad Dog.

    I can see one error, you have - - modifyworld.mobtarget.* and I think its one dash too many. Litte syntax errors in yml files can cause all sorts of issues. if you don't specifiy a world (remove the worlds options) does it work? do you need to seperate worlds? or is one global setting for all worlds good enough? is so you may need to just remove that portion. I'm not certain how the world thingy works. im used to permissions 2/3 and i would have seperate folders/files for those normally. i have yet to try to work with worlds.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018

Share This Page