Inactive [ADMN/DEV] PermissionsEx (PEX) v1.19.5 - Tomorrow is Today! [1.4.6-R0.1]

Discussion in 'Inactive/Unsupported Plugins' started by t3hk0d3, May 21, 2011.

  1. Offline


    Version: 1.19.5


    PermissionsEx (PEX) is a new permissions plugin, based on Permissions ideas and supports all of its features. But PEX is more! It offers different backends, powerful ingame management, fine grained restrictions for world modification.


    Current features
    1. Bukkit Permissions (SuperPerms) compatible.
    2. Several backend support. Currently bundled backends is File (YAML) and SQL (MySQL, SQLite). Also it's possible to add your own.
    3. YAML backend, with new, fully rethinked, config schema. Now all user, groups and their permissions are stored in one file - permission.yml. BTW file name is adjustable too.
    4. SQL backend, most delicious. Currently MySQL and SQLite supported, but other DB (like Postgre) are possible too. PEX deploys the DB scheme (tables and initial data) automatically. This means, that you only need to provide data on how to connect to the db, everything else PEX will handle by itself.
    5. Flexible architecture and API - you can change a lot programmatically.
    6. Compatibility layer with TheYeti's Permissions (2.7.4) (as a separate part of the plugin). In most cases plugins, which use Permissions, will alsowork with PEX also.
    7. Rich chat/console command interface. You can do almost everything ingame. Command list below.
    8. Modifyworld - Embedded restrictions mechanism (we call it "modifyworld"), which provides the possibility to control players abilities, such as destroying/placing blocks, riding carts/boats or even getting spotted by mobs and much more. Disabled by default.
    9. Multigroup inheritance. User, as well as Group, can be member of several groups. And inherit their permissions, options and prefix/suffix.
    10. Permissions based upon Regular Expressions. This mean you can use regular expressions. Example: modifyworld.blocks.(destroy|place).(3|12) - this permission allow place or destroy only sand (12) or dirt (3) blocks. There is still limitation on dot usage in your regexps - dots are escaped by default.
    11. Multiworld permissions. Just don't specify world and permission would work in any world.
    12. Multiworld inheritance. You can inherit different groups in different worlds.
    13. Easy migration from Permissions 2.x. Converter for both YAML and SQL are embedded into PermissionsCompat. Just use simple instruction.
    14. Perfomance friendly. Low-level caching helps alot when you have 100+ online users :)
    15. Promotional/Demotional system. You can assign ranks to groups and promote/demote users to higher/lower ranked group.
    16. World-inheritance - permissions/option of one world can be inherited by another world.
    17. Timed Permissions - you can give user permission only for some amount of time.
    18. Chat Manager - small chat plugin, bundled with PEX. With prefixes/suffiex and colors. Check wiki for more details.


    Basic setup tutorial (Thanks to lycano)

    Nice tutorial made by Bennetman

    Stable version

    Development version (mostly stable) - always lastest dev build.



    Maven Repository

    Join us on #permissionsex, Feel free to ask any related questions.

    Tools !NEW!
    Pex Auto-Setup Tool - MySQL and FlatFile !

    Show Changelog (open)
    Proper intervals for timed commands (both group/permissions management), without pesky seconds calculations (like /pex user t3hk0d3 timed add cool.permission 10days)
    1.4.6 compatibility.

    Built for Bukkit 1.4.2-R0.1
    Added inventory permissions (modifyworld.items.put/take.<item>.of.<chest>)
    Added item hold permission (modifyworld.items.hold.<item>)
    Sdded monster egg spawn permission (modifyworld.spawn.<creature>)
    Few other minor fixes
    Modifyworld improvements (configurable messages, now independent from PEX)
    /pex help command
    Minor improvements and bugfixes
    New modifyworld permissions
    Some bugfixes
    Bugfix release
    Bukkit R6 compatible.
    Several bugfixes!
    Permissions now case-insensetive.
    Users logging and cleanup feature.
    Non-inheriting nodes feature.
    Several Bugfixes.
    PermissionsCompat is finally remove from default bundle.
    User/group specific management permissions (
    Fixed some superperms compatibility issues
    Fixed several bugs
    SuperPerms compatbility bridge were rewritten - no lags anymore and now with debug output (now you can view superperms checks).
    Numerous of bugs were fixed (Thanks you guys for reporting them)
    Modifyworld were improved (modifyworld.item.use)
    Compatiblity for 1317+
    Fixed perfomance issues with SuperPerms (if you still experience they try to disable "raw-permissions" in config.yml)
    Fixed issue with prefix inheritance
    Improved Options mechanism.
    Auto saving new users feature, disabled by default.
    SuperPerms bridge improved - more permissions supported by wildcards.
    File backend dumping now fully functional. SQL dumping is still bogus (do not dump world-specific inheritance and prefixes), will be fixed soon.
    Many bugfixes and minor improvements.
    Superperms (BukkitPerms) support
    Multiworld inheritance and prefixes/suffixes
    Groups weighting
    ChatManager, chat plugin which bundled with PEX.
    Modifyworld now separate plugin, but still bundled with PEX.
    API changed slightly, CustomEvents (PermissionsEntityEvent, PermissionsSystemEvent) introduced.
    Many lesser improvements and tons of bugfixes.
    API get slightly improved
    Ranking ladders.
    User/group name case-insensetivity.
    Timed permissions.
    Modifyworld rules are get improved.
    Tons of minor improvements and bugfixes.
    Many bugfixes and improvements.
    MySQL connection stability improved - reconnection mechanism.
    Promotional/Demotional system.
    Perfomance improvement, with new low-level caching system (thx Joy)
    Modifyworld improved.
    Many lesser improvements and bugfixes.
    New p2compat backend, for easy migration from Permissions 2.x to PEX.
    Users/Groups dumping (pex dump <backend> <file>).
    New commands pex promote/demote. Actually this is just aliases for "pex user group set/remove"
    Few bugfixes.
    Players now can be informed about changes (has been added to group, changed permission/option). Disabled by default - set "permissions.informplayers.changes" to "true"
    Config node "permissions.verbose", which responsible for player informing about modifyworld restrictions has been renamed to "permissions.infromplayers.modifyworld".
    Autocomplete has been improved.
    New command "pex config <node> [value]". This command help to manipulate configuration file (config.yml) from console/chat interface.
    Many bugfixes.
    Autocomplete for users (taken from registred users and online users) and groups names.
    New command for user removing (pex user <user> delete)
    Fixed several nasty bugs. Thanks for bugreports!
    Compatibility layer loading order issue fixed. Now most of plugins should work.
    Tested with new CB 803 build.
    Regular expression permissions support.
    Newer permissions now added above (bugfix).
    Several bugfixes.
    Initial public release.
    BRampersad, grid21, MrRazull and 71 others like this.
  2. Offline


    Behold! The Bukkit dev build page! :D

    Builds 1464+ are for MC 1.0.0.

    Beware, there's no recommended build of Bukkit for 1.0.0 yet, and a lot of plugins have not been updated, so YMMV. Some plugins still work fine, and PEX works to some extent, but I've not tested all the features yet.
  3. Offline


    Ah, thank you. I'll back up all my files and test it out.

    Still can't figure out why my prefixes aren't showing up when we type, even though they work with AFK and Online status.
  4. how to block all types of lava?
    Thanks for the plugin
  5. Offline


    Feature request: separate groups.yml and users.yml
    1. We host several servers and its a BIG PLUS to have a central groups.yml for folks
    2. If you are editing groups.yml and a user gets promoted you loose the promotion (or you loose your groups.yml edits, you decide)

    - -modifyworld.bucket.empty.(lava|327)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  6. whit - - or only -
  7. Offline


    How do you define the 'primary' group of a user? Let's say I have a player in group 'admin' and I want to also add him in 'worldedit' but I want the 'admin' group to remain as the primary one. Other plugins that uses the group name like Essentials for /list or iChat for the $group variable remains 'admin' instead of 'worldedit'?

    I'm coming from GroupManager and with this you add that concept of a group and sub groups so i'm wondering how that works with PEX.

    Other than that I'm just having excellent results using PEX 1.16. Things haven't been running smoother since 1.8. Great work!
  8. Offline


    Curious of the way to be able to set modifyworld block permissions in certain worlds? Say I want group Guest to only build in World but not Skylands, how would I set up such a permissions?
  9. Offline


    Hey this is kind of urgent, so how do you migrate to permissionsEx from groupmanager? We're having a really hard time trying to do this as we have 3000+ players in our system and they all have different ranks.
  10. Offline


    Can anyone help by linking me to a converter? Trying to convert Group manager config into PEX format
  11. Offline


  12. Offline


    Use MySQL storage
  13. Offline


    Doesnt work for me, i've done everything, wrote it in the console, added everything in the ''Basic Permissions Setup''
    link u've showed us, and i still get no prefix, and permissions doesnt work.
  14. Offline


    Can you tell us exact waht happens adn if you get any errors post them so we can see. Much easier to help then :p
  15. Offline


    it dont work
  16. Offline


    It looks like you didn't branch it properly. You need to press tab on a new line in order to let the system know it's "branching" from the one above it. Think of it like a tree trunk. You can't have every branch coming off of the trunk. Each section that is inside another section must be branched off of it, and not the main section itself. Take another look at the tutorial to see proper branching.
  17. Offline


    still dont work can u send me a copy of one plz. thank ku
  18. Offline


    The one I use hardly has anything in it. I didn't need many permissions. Could you upload a copy of yours to a file hosting site and link to it in a post so we can take a look at it?
  19. Offline


    in version 1.0 1467 build

    21:59:41 [INFO] [PermissionsEx] Initializing file backend
    21:59:41 [SEVERE] java.lang.ClassCastException: java.lang.Float cannot be cast to net.minecraft.server.EnumToolMaterial
    21:59:41 [SEVERE]       at org.getspout.spout.item.mcitem.CustomItemSpade.replaceSpades(
    21:59:41 [SEVERE]       at org.getspout.spout.Spout.onEnable(
    21:59:41 [SEVERE]       at
    21:59:41 [SEVERE]       at
    21:59:41 [SEVERE]       at org.bukkit.plugin.SimplePluginManager.enablePlugin(
    21:59:41 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    21:59:41 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.enablePlugins(
    21:59:41 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.<init>(
    21:59:41 [SEVERE]       at net.minecraft.server.ServerConfigurationManager.<init>(
    21:59:41 [SEVERE]       at net.minecraft.server.MinecraftServer.init(
    21:59:41 [SEVERE]       at
    21:59:41 [SEVERE]       at
    wait it think thats for spout?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  20. Offline


    1.16 seems to break permissions for WorldEdit, WorldGuard, CommandBook and possibly other addons. I use 1.15 and everything works fine. I upgrade to 1.16 and none of the users that should have permissions to use the above addons commands work. They all get a "You don't have permission." message. Downgrading to 1.15 fixes the issue.

    I am running CB1337, Minecraft 1.8.1, and I can post my permissions.yml file after I get home (I'm at work at the moment). Something in 1.16 isn't working correctly.
  21. Reread my post, starting down from the line "From"

    Someone else has posted the link to the dev builds of bukkit (1337 is the latest recommended build) , but I'm curious, what does a cracked MC client have to do with anything about running an older version of MC?

    The Minecraft Version Changer Tool works quite nicely for running earlier versions of minecraft + '\t'+that+cannot+start+any+token :p

    In short, you have a tab on that line. Replace it with four spaces.

    Considering that the current stable build of spout is broke under the dev bukkit built for MC 1.0.0, yes, I would say that's a spout crash

    For what it's worth, I have worldedit working on my server (prod and testing). Your permissions file is definitely something that will need to be looked at. :)

    1. You are running a dev build of permissions. The current stable is 1.16. You should be using that. Dev builds are not always going to be stable.
    2. Your permissions file isn't correct. I saw that the owner and admin groups have the * permission node wrong. (use - '*', not "*". Single quotes vs double quotes).
    Take your permissions file and drop it into an online YAML parser (there is one linked in the first post) to make sure that your file is formatted correctly for PEX to read it. If it reports no errors and you are still having problems, put it in a pastebin and link to that.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  22. Offline


    then we can't do
    vim groups.yml
    and its that simple.
    We also can't make the order of groups per user easily w/ MySql
    and that DOES make a difference for things like chat prefix / suffix.
  23. Offline


    For what it's worth, I've only tested the permissions from the Admin rank which leads me to believe what is breaking is the '*' global permission.

    permissions.yml in the main server folder is blank.

    permissions.yml from the PermissionsEX folder under plugins is as follows. All permissions, groups, prefix, etc were done using the /pex in-game commands under pex 1.13 and have worked perfectly until pex 1.16.

            default: true
                rank: '1000'
            prefix: '[&bNew&f] '
            prefix: '[&bAdmin&f] '
            - -worldedit.override.bedrock
            - '*'
                rank: '0'
            prefix: ''
            - mobarena.arenas.*
            - mobarena.classes.*
            - mobarena.use.*
            - multiverse.access.world_arena
            - multiverse.access.world_nether
            - multiverse.access.world_exire
            - multiverse.access.world_two
            - multiverse.core.spawn.self
            - multiverse.core.list.who
            - multiverse.core.list.worlds
            - multiverse.teleport.*
            - worldedit.navigation.up
            - worldedit.navigation.jumpto
            - worldedit.navigation.thru
            - worldedit.navigation.descend
            - worldedit.navigation.ascend
            - worldedit.navigation.unstuck
            - -worldedit.override.bedrock
            - -worldedit.superpickaxe.recursive
            - -worldedit.superpickaxe.area
            - worldedit.superpickaxe
            - chesscraft.basic
            - tpp.admin.bypass.notp
            - tpp.jump.up
            - minecartmania.signs.*
            - commandbook.whereami.compass
            - commandbook.whereami
            - commandbook.msg
            - commandbook.say
            - commandbook.time.check
            - commandbook.time
            - commandbook.rules
            - commandbook.motd
            - commandbook.who
            - modifyworld.*
                rank: '900'
            prefix: ''
            - multiverse.access.*
            - worldguard.ungod
            - worldguard.god
            - commandbook.more.*
            - commandbook.give.*
            - modifyworld.*
            - Member
                rank: '800'
            prefix: '[&bMod&f] '
            - commandbook.override.any-item
            - bukkit.command.give
            - bukkit.command.gamemode
            - mobdisguise.*
            - falsebook.*
            - worldedit.*
            - -worldedit.override.bedrock
            - modifyworld.*
            - VIP
            - Member
                rank: '100'
            - VIP
                    - worldedit.*
            - VIP
                    - worldedit.*
            - Admins
            - VIP
            - Moderator
            - Moderator
            - Admins
            - VIP
            - Member
            - VIP
  24. Hmm... In which way is * breaking?

    Am I correct in guessing that things like worldedit.* is what is not working as expected?

    1.16 changed a lot in the way it handles superperms as well. Potentially the quickest way to check is to turn on debug for PEX and in the config for superperms and see what it's checking for.
  25. Offline


    I hope you update really soon (today)
  26. Offline


    Hello guys,
    I need to learn how to set up the PermissionsEx "rank-ladders". I know the node for this is permissions.user.promote.<ladder>, but i NEED to know how to setup the ladder, so my Moderators can promote people!

  27. Offline


    Everything. You need the same client version as the server is set up for or it doesn't work. You can't access a 1.8.1 server with 1.0, and vice versa. You have to run a cracked or modded client with 1.8.1 in order to get into a 1.8.1 server. Try getting into a 1.8.1 server legit with a 1.0 normal client without changing anything, and you get the "outdated server" error.
  28. Offline


    The Admin rank, as you can see, has the '*' permission as well as removing one worldedit permission (that allows breaking bedrock). Under 1.15 this works as expected and gives the Admin group all permissions for all addons. Under 1.16, some of the mods I use (MultIVerse for example) still work, while WorldEdit, WorldGuard, and CommandBook at least do not think the Admin group is allowed to execute any commands. Rolling back to 1.15 restores functionality to WE, WG and CB.

    I did try enabling debug from the pex command ingame and try to use some commands but nothing extra showed up in the server log or console. I didn't enable the debug mode in config for superperms as well so I'll try that and get back to you.
  29. Offline


    This is happening to me as well. Happens whenever a new bukkit build is installed
  30. Offline



    What determines the group order of a player? Using the command to view a users groups, it seems that the first group listed is what determines what prefix or suffix a player inherits. The only thing that takes priority over this is if the player has a prefix or suffix set directly for them, then it displays that instead of the first groups prefix or suffix.

    Im trying to force the prefix and suffix of a certain group. I tried removing the suffix and prefix from the group listed first, and it just puts null before and after a players name.
  31. Offline


    Use the 'weight' option. Lowest weight is read by PEX first. I usually use weights like 0-100 for groups which take away specific perms, and weight 100-200 for groups that give perms.

Share This Page