Inactive [ADMN/DEV] Permissions v2.7.4 (Phoenix) - DISCONTINUED! 3.0 has a new home!

Discussion in 'Inactive/Unsupported Plugins' started by TheYeti, Feb 25, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 2.7.4 (Phoenix) - Now with AntiBuild built in!
    Latest Stable: Full Zip | Jar Only
    Latest Dev Build: Full Zip | Jar Only
    Previous Versions: 2.7.3 (JAR) | 2.7.2 (JAR) | 2.7.1 (JAR) | 2.7 (JAR) | 2.6 (JAR) | 2.5.5 (JAR) | 2.5.4 (JAR) | 2.5.3 (JAR) | 2.5.2 (JAR) | 2.5.1 (JAR) | 2.5 (JAR) | 2.4 (JAR) | 2.3 (JAR) | 2.2 (JAR)

    Plugin Authors: How to hook into Permissions

    Permissions 2.x is being discontinued! 3.0 can be found HERE!!!

    I am discontinuing Permissions 2.x and leaving the project. Permissions is not going away though! Since 2.6 I have been working closely with another developer and added them to the team. For the past several version they have not only been assisting with 2.x but also doing a lot of the development of much anticipated 3.x. rcjrrjcr will be taking over as lead developer of Permissions from 3.x forward. I have full faith in them and after working closely with them on the development on the last few version and the next major version I feel that I am leaving this project in more than capable hands. I put way to much work into this project to just leave it with anyone, and this is one of the few programs that I am incredibly proud of.

    Many people will probably wonder why I am leaving again after taking over the project just a few months ago. I could quote drama and headaches, of which there were quite a few with this project. Unfortunately real life happens. Many people already know that I have been having medical issues here lately. Unfortunately while they have gotten better, they have not gone away. This coupled with other real life commitments, going to school full time, and starting up my own company, I am currently in the process of being laid off from work. At this point I have so much stuff going on in my life and am being pulled in so many directions that I am not able to get any work done on anything. This has lead to me missing commitments and letting people down on multiple things.

    Permissions is also a very high maintenance plugin that requires a lot of attention and time. Right now I am not able to devote that time and do not feel it is fair for me to try to continue to be the lead developer on it. I had originally thought that adding other members to the team would be helpful, but unfortunately this just lead to frustration for them and myself as I just was not able to commit to the project enough. Hence, 3.0 has been rewritten almost exclusively by rcjrrjcr with minimal contributions by myself.

    At this point I will be stepping away from the project to focus more on real life and to try to free up some time for other projects and to work with more individual like the wonderful HeroCraft Coding team to fulfill some commitments that I made to them a long time ago and sadly did not come through on. I feel that this is the best for all involved, both myself and the other Permissions developers, as well as the community who deserve someone who can contribute more time and attention to them and supporting them. I do not want to see Permissions end up like many other plugins with an absentee programmer and just slowly wasting away from a great plugin with a lot of potential to a headache with no support.

    I will still be active in the community, just not as much as not in the same way. I'm sure my server will be more than happy to have their head admin back and active again as well.

    Thank you and happy gaming.

    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems
    • 2.6
      • Pulled in commits by rcjrrjcr
      • Fixed versioning. Last version should have technically been 2.6
      • Fixed invalid config file being written
      • Fixed erroneous conversion message.
    • 2.5.5
      • Updated to be compliant with CB600+
      • Further Maven Integration and Autobuilding
      • Better handling of configuration file errors.
        • If you do not have a world config file for the default world at startup it will now look for config.yml
        • If it cannot find that it will look for world.yml instead in case you named it that when that is not what is in level-name:
        • It will rewrite the config file to be the proper name. At this time it does not delete the old one though.
      • Removed defunct public abstract calls. If your not using the right one by now you should be shot anyway.
    • 2.5.4
        • Added Command aliases for perms and pr
        • Changed the way directories are handled.
        • Stopped it from creating an empty <world>.yml file in base directory
        • Moved project to using Maven.
    • 2.5.3
      • Change from File.pathSeparator to File.separator to fix multiworld perms
    • 2.5.2
      • Added more instructions to the included config file within the plugin
      • Added a check that will use the default world permissions if a world specific config file cannot be found.
      • Added a function to get only the group that a player is assigned to without checking for group inheritance.
      • Added a change to colorize() to fix it hopefully not adding an extra unneeded ascii character and thus creating a linebreak/color switch issue
      • Removed as it was not needed and was a artifact of testing I was doing.
    • 2.5.1
      • Fixed a bug that could cause a group to be returned as null for getGroups()
    • 2.5
      • Added in AntiBuild functionality to Permissions
      • Minor code tweaks
      • Added getGroups(world, player) to PermissionHandler so that plugins can call it to get all of a users groups
      • Fixed the inability to use the permissions -reload all command from within the console. I still need to do some more work on this as it doesn't seem to like to accept anything other than all from console.
    • 2.4
      • Refactored namespaces to keep in line with Java & Bukkit policy
        • This was cancelled as it ended up being not needed
      • Fixed setupPermissions()
    • 2.3
      • Undid removal of some code that I had overzealously purged during cleanup
      • Merged in last of Nijikokun's changes
      • Re-ordered the main class to attempt to fix the problems with Plugin API
    • 2.2
      • Developer change
      • Fixed reloading of configuration files
      • Moved commands to registering with plugin.yml
      • Commands now use onCommand instead of onPlayerCommand
      • Command is now /permissions instead of /pr
    mruczek, kahlilnc, Pii and 58 others like this.
  2. Offline


    To be honest, I got that error with 2.5.4 before, so I think your best bet is to make sure all the permissions you want people to have are already set up.
  3. Offline


    I just updated my CB from 610 to 617 and now it works :D
    Now I have to wait for @sk89q with his WorldGuard Plugin
  4. Offline


    anyone have any idea how to fix the config bug? (no config being generated, empty permissionsworld.yml created in plugins directory)

    I tried downloading the zip and just renaming the config file and copying my groups/users over. Seems to have fixed some things however typing /permissions results in the server telling me command doesnt exist. when there is no config file and only permissionsworld.yml though, /permissions works fine (except all the mods are fucked because theres no actual permissions set)
  5. Offline

    Tom Heek

    I get this error:
  6. Offline


    Does it works with MCMyAdmin?

    If I install Permissions and iChat plugins, how do I set them into MCMyAdmin?
    Thank you in advance.
  7. Offline


    I'm pretty sure we can confirm that the command is broken. You'll have to get used to restarting the server :/
    (Though I think that there is a command /reload, though I'm not actually sure what it does, if it's part of Permissions, or what.

    I think I'll add this to my list of errors.

    @Tom Heek
    What version of Permissions are you using, and what Bukkit version?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  8. Offline


    I'm using CB build 617 and i'm having the same issues as Tom Heek. Could it be my older permissions yml file with the latest permissions .jar causing the problem or does it just not work with that version?

    nevermind, apparently my admin was dumb and left out a character in the permissions yml file. removing his access to that now.
  9. Offline


    @Pugnacious Try using another version of CB, please?

    Actually, I need some testers. Can some people try different CB versions and give a list of which versions work for them?
  10. Offline

    Tom Heek

    I use the latest recommended version of Permissions and Bukkit.
  11. Offline


    Can you try downgrading?

    Permissions errors and how to solve them!

    Could not load plugins\Permission.jar in plugins:Null
    If you get this error:
    [SEVERE] Could not load plugins\Permissions.jar in plugins: null
    It means your CB version and your Permissions versions don't work together. Don't use Permissions 2.5.5 with anything below 600, and don't use 2.5.4 with anything above 600.
    [B][I][SIZE=5]Invalid Config file found and converted to proper name/format[/SIZE][/I][/B]
    This error:
    Invalid config file found and converted to proper name/format.
    Will happen almost no matter what. Ignore it, it doesn't do anything.

    Getting a permissions-worldname-.yml file in your plugins folder is a bug. It (I think) means that your real permissions config.yml has something wrong with it, or it's not there. I'm not quite so sure about this, but download the .zip file from the first post and extract the contents to your plugins folder. <<< Confirm please?

    Config file info:

    -They need spaces, not tabs.
    -If you have the - '*' permission, you don't need any other nodes for that person/group, unless you want to take a permission away from them. If you want to do that, give them a node vaguely like this: - '-example.node'
    (See that negative sign? It's important.)
    -Read the comments in the file, seriously. They say a lot.
    -When putting someone into a a group, make sure it's spelled correctly. Putting someone in the group "Admin" while the group is called "Admins" will not put them in that group.
    -If a group has the - '*' permission, don't have them inherit from another group.

    /Permissions -reload all command giving console errors
    There is no way that I know to fix this problem yet. Please just restart your server.

    (Any errors I've missed? Something I got wrong? Another way to fix an error? Tell me!)
    (Coppied this over to the new page for the sake of people seeing it.)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  12. Offline


    I'm having some problems with Multi world support.. I have two maps, one normal mp map with a lot of mods and such.. and one "pure" map, no mods, no commands, no nothing. Except for kick/ban for mods/admins.

    on the normal map, I have the admin set with the permission: - '*', but on the pure map the admin has only access to - 'multiverse.*', and nothing else (well, inherits kick, ban and that from mod), since I don't want admins there to have access to /time, /warp or anything like that.

    But the problem is, they have access to everything, just like it's set to '*', that is, it seems like they have the permission from the normal map. All other users get stripped of their commands when they go over to the pure map, but admins don't.

    Any ideas?
  13. Offline


    Each world has different files, I assume? Hmmm...
    Are the admins also OPs?
  14. Offline

    Tom Heek

    I have everything done correctly, at least I think, but it still says the null error, I have the last recommended build of Craftbukkit.
  15. Offline


    can someone please check my file and tell me what did i do wrong since its not working? im using 2.5.5 version of the plugin and i have 612 version of bukkit.The user RastaJake allways is assigned to the default group, even though i assigned it to admins. Please help im a total newbie :D
  16. Offline


    Have you tried downgrading yet?
    The Null error is when the Permissions version doesn't work with the CB version. One of them is wrong, try downgrading to 602 of CB with this, and tell me what happens. You could also try 612, here.

    Post it to Pastebin and give me a link, please!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  17. Offline


    i just installed permissions but umm , waht can i actually use it for ? any commands for admins ?
  18. Offline


    Does one of your mods require it? If not, it might be a good idea just to ignore Permissions, especially if you don't know what it's used for.
  19. Offline


    Last edited by a moderator: Jul 17, 2016
  20. Offline


    I don't see anything wrong with it...
    You could try giving Rastajake the - '*' permission. Or try making a separate group, just for him?
  21. Offline


    Different files of course, like I said, VIPs, Mods and Normies (normal users) works just fine. They have access to specific commands in the normal map, but no access to any commands in the pure map (there is just no permissions: in their section)
    I didn't think about server ops though, I'll try deopping and see if that changes anything.

    EDIT: That was the problem! deopped the admins and they don't have access to everything on the pure map any more! ;)
  22. Offline


    I imagine /Kick commands are from the vanilla Minecraft server. I don't think Permissions can do anything about those.
  23. Offline


    itssnowing - did that and that, still doesnt work. can you make me a file with the default group, the admin group, and RastaJake as admin (like all permisions) please? I would be very gratefull :D
  24. Offline


    @Norbertas I guess I can. No guarantee it'll work, though ;)
    (I'll make a post here and tag you in it when I'm done.)

    Try this. Good luck!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  25. Offline

    Tom Heek

  26. Offline


  27. Offline

    Tom Heek

    Oke, then that is fine, but even if I try to downgrade, it still doesn't work.
  28. Offline


    this just gave out a lot of errors about the colons you have added, so if deleted still doesn't work...
  29. Offline


    @Tom Heek What did you downgrade to?

    @Norbertas Can I see the errors?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  30. Offline

    Tom Heek

    The option you gave me 602 and 612, but still the same errors, can you help me via Teamviewer?
  31. Offline


    Sure. PM me your name/number thing?
Thread Status:
Not open for further replies.

Share This Page