Inactive [ADMN/DEV] Permissions v2.7.4 (Phoenix) - DISCONTINUED! 3.0 has a new home!

Discussion in 'Inactive/Unsupported Plugins' started by TheYeti, Feb 25, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 2.7.4 (Phoenix) - Now with AntiBuild built in!
    Latest Stable: Full Zip | Jar Only
    Latest Dev Build: Full Zip | Jar Only
    Previous Versions: 2.7.3 (JAR) | 2.7.2 (JAR) | 2.7.1 (JAR) | 2.7 (JAR) | 2.6 (JAR) | 2.5.5 (JAR) | 2.5.4 (JAR) | 2.5.3 (JAR) | 2.5.2 (JAR) | 2.5.1 (JAR) | 2.5 (JAR) | 2.4 (JAR) | 2.3 (JAR) | 2.2 (JAR)

    Plugin Authors: How to hook into Permissions

    Permissions 2.x is being discontinued! 3.0 can be found HERE!!!

    I am discontinuing Permissions 2.x and leaving the project. Permissions is not going away though! Since 2.6 I have been working closely with another developer and added them to the team. For the past several version they have not only been assisting with 2.x but also doing a lot of the development of much anticipated 3.x. rcjrrjcr will be taking over as lead developer of Permissions from 3.x forward. I have full faith in them and after working closely with them on the development on the last few version and the next major version I feel that I am leaving this project in more than capable hands. I put way to much work into this project to just leave it with anyone, and this is one of the few programs that I am incredibly proud of.

    Many people will probably wonder why I am leaving again after taking over the project just a few months ago. I could quote drama and headaches, of which there were quite a few with this project. Unfortunately real life happens. Many people already know that I have been having medical issues here lately. Unfortunately while they have gotten better, they have not gone away. This coupled with other real life commitments, going to school full time, and starting up my own company, I am currently in the process of being laid off from work. At this point I have so much stuff going on in my life and am being pulled in so many directions that I am not able to get any work done on anything. This has lead to me missing commitments and letting people down on multiple things.

    Permissions is also a very high maintenance plugin that requires a lot of attention and time. Right now I am not able to devote that time and do not feel it is fair for me to try to continue to be the lead developer on it. I had originally thought that adding other members to the team would be helpful, but unfortunately this just lead to frustration for them and myself as I just was not able to commit to the project enough. Hence, 3.0 has been rewritten almost exclusively by rcjrrjcr with minimal contributions by myself.

    At this point I will be stepping away from the project to focus more on real life and to try to free up some time for other projects and to work with more individual like the wonderful HeroCraft Coding team to fulfill some commitments that I made to them a long time ago and sadly did not come through on. I feel that this is the best for all involved, both myself and the other Permissions developers, as well as the community who deserve someone who can contribute more time and attention to them and supporting them. I do not want to see Permissions end up like many other plugins with an absentee programmer and just slowly wasting away from a great plugin with a lot of potential to a headache with no support.

    I will still be active in the community, just not as much as not in the same way. I'm sure my server will be more than happy to have their head admin back and active again as well.

    Thank you and happy gaming.

    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems
    • 2.6
      • Pulled in commits by rcjrrjcr
      • Fixed versioning. Last version should have technically been 2.6
      • Fixed invalid config file being written
      • Fixed erroneous conversion message.
    • 2.5.5
      • Updated to be compliant with CB600+
      • Further Maven Integration and Autobuilding
      • Better handling of configuration file errors.
        • If you do not have a world config file for the default world at startup it will now look for config.yml
        • If it cannot find that it will look for world.yml instead in case you named it that when that is not what is in level-name:
        • It will rewrite the config file to be the proper name. At this time it does not delete the old one though.
      • Removed defunct public abstract calls. If your not using the right one by now you should be shot anyway.
    • 2.5.4
        • Added Command aliases for perms and pr
        • Changed the way directories are handled.
        • Stopped it from creating an empty <world>.yml file in base directory
        • Moved project to using Maven.
    • 2.5.3
      • Change from File.pathSeparator to File.separator to fix multiworld perms
    • 2.5.2
      • Added more instructions to the included config file within the plugin
      • Added a check that will use the default world permissions if a world specific config file cannot be found.
      • Added a function to get only the group that a player is assigned to without checking for group inheritance.
      • Added a change to colorize() to fix it hopefully not adding an extra unneeded ascii character and thus creating a linebreak/color switch issue
      • Removed as it was not needed and was a artifact of testing I was doing.
    • 2.5.1
      • Fixed a bug that could cause a group to be returned as null for getGroups()
    • 2.5
      • Added in AntiBuild functionality to Permissions
      • Minor code tweaks
      • Added getGroups(world, player) to PermissionHandler so that plugins can call it to get all of a users groups
      • Fixed the inability to use the permissions -reload all command from within the console. I still need to do some more work on this as it doesn't seem to like to accept anything other than all from console.
    • 2.4
      • Refactored namespaces to keep in line with Java & Bukkit policy
        • This was cancelled as it ended up being not needed
      • Fixed setupPermissions()
    • 2.3
      • Undid removal of some code that I had overzealously purged during cleanup
      • Merged in last of Nijikokun's changes
      • Re-ordered the main class to attempt to fix the problems with Plugin API
    • 2.2
      • Developer change
      • Fixed reloading of configuration files
      • Moved commands to registering with plugin.yml
      • Commands now use onCommand instead of onPlayerCommand
      • Command is now /permissions instead of /pr
    mruczek, kahlilnc, Pii and 58 others like this.
  2. Offline


    Same thing happens to me!
  3. Offline


    @ Raaf one simple question: is the only thing you want/or need is total control over all the commands ?
    if the answer is yes, then go to your bukket root folder open the file ops and add your username. save, server restart
    and you have the same rights as with admin: '*' ... also check your worldfolder name and the permission.yml file name. the have to be exact the same.

    @Plasma Havent tested it yet, this block break error tends to be caused by a mismatch in worldname and permissions config file name. please check the spelling of both.
    I tested for this error:

    10:43:01 [SEVERE] Could not pass event BLOCK_BREAK to Permissions
    at com.nijiko.permissions.Control.getGroups(

    Solution: go to your permissions folder inside plugins.
    check your world.yml permissions filename and rename it so it matches your worldname.

    If there's a mismatch in the naming of this file and the worldname. the BLOCK_BREAK error will occur. If this mismatch happens a default file with RENAME-ME.yml will be present in the permissions folder.

    if you have 2 files in the permission folder
    1: worldname_oops_typo.yml
    2: RENAME-ME.yml

    rename your worldname_oops_typo.yml
    delete the default RENAME-ME.yml

    otherwise you have a default permissions file.

    yeti stated this last night. i'm just repeating :)
  4. Offline


    So just to clarify;

    There is NO "/modgrp name group" with Permissions 2.5.4?

    I run a server that allows people to create custom clans, and it basically involves people needing to be moved groups a few times every 10 minutes if not more... which means a LOT of fucking annoying alt-tabbing to manually add people to a god damn config file and its awful.

    /modgrp command please?

    Previous permissions guy did it.
  5. Offline


    use yeditor for in game edit of permissions.
  6. Offline


    Im gettin this one too!!
  7. Offline


  8. Offline


    there was a small change in how files are handled, It is possible that some plugins refer to the old method of 2.5.3 . In that case please ask the plugin developer to update his plugin to 2.5.4

    make sure you use the 2.5.4 version of permissions when testing

    to test wich one are the troublemakers:

    - make a new folder inside plugins and name it disabled

    - stop your server
    - move a plugin.yml to this folder
    - start your server

    - repeat this until you have no more errors
    - add plugins back one by one

    - please report the ones that are 2.5.4 incompatible.

    or just keep using 2.5.3 until the plugin developers have updated their plugins.
  9. Offline


    heres my error I get loading Craftbukkit 522 and permissions 2.5.4
    2011-03-09 06:14:50 [SEVERE] Could not load plugins\Permissions.jar in plugins: null
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at net.minecraft.server.MinecraftServer.e(
    at net.minecraft.server.MinecraftServer.a(
    at net.minecraft.server.MinecraftServer.d(
    Caused by: java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
    at java.lang.reflect.Constructor.newInstance(Unknown Source)
    ... 8 more
    Caused by: while parsing a block mapping
    in "<reader>", line 43, column 3:
    expected <block end>, but found BlockMappingStart
    in "<reader>", line 50, column 4:
    at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(
    at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(
    at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
    at org.yaml.snakeyaml.composer.Composer.composeNode(
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
    at org.yaml.snakeyaml.composer.Composer.composeNode(
    at org.yaml.snakeyaml.composer.Composer.composeDocument(
    at org.yaml.snakeyaml.composer.Composer.getSingleNode(
    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(
    at org.yaml.snakeyaml.Yaml.load(
    at org.bukkit.util.config.Configuration.load(
    at com.nijikokun.bukkit.Permissions.Permissions.<init>(
    ... 13 more
    and heres my config file, any problems?
    # System is no longer used, but may become used in the future
    # Copies is for multiple-world support
    #   Put the name of the world you wish for it to be a clone of, otherwise leave it empty.
    #   Does not work for the default world.
            system: default
    # Groups can contain inheritance.
    #   To make a group inherit the permissions from another
    #   group simply place the groups name in the "inheritance:" like so:
    #   Example:
    #       inheritance:
    #           - Default
    #   All permissions including the asterisks must be placed in single quotes.
    #   like so:
    #       - 'general.spawn'
    #   Otherwise errors will happen!
    #   Globalized Permission settings:
    #       If a permission contains periods (.) you can denote a globalized parameter:
    #           - 'general.*'
    #       This will allow you to use all general commands.
    #   Single Asterisk denotes all commands:
    #       - '*'
    #   To exempt a node use the - prefix like so:
    #       - '-general.time'
        default: true
        info: {prefix: '', suffix: '', build: false}
        inheritance: []
        permissions: [ general.spawn, general.time,,
        myhome.home.basic.home, myhome.home.basic.set, myhome.home.basic.delete,
        mywarp.warp.*, mywarp.warp.sign.warp]
        default: true
        info: {prefix: '', suffix: '', build: true}
        inheritance: [guest]
        permissions: [ general.spawn, general.time, lwc.protect,, flashlight.normal,
        myhome.home.basic.home, myhome.home.basic.set, myhome.home.basic.delete,
        mywarp.warp.*, mywarp.warp.sign.warp, general.teleport]
        default: false
        info: {prefix: '', suffix: '', build: true}
        inheritance: [vip]
        permissions: [general.time, general.teleport,,
        lwc.protect, godmode.god.self, essentials.god,]
        default: false
        info: {prefix: 'ADMIN', suffix: '', build: true}
        inheritance: [Mod]
        permissions: ['*', lwc.protect, lwc.admin,,,,, multiverse.portal.create, godmode.god.self,
        godmode.god.players, godmode.reconfig,, autosave.toggle, autosave.status,
        autosave.interval, autosave.broadcast, autosave.version, myhome.admin, mywarp.*,
    # DarkGrave has control over all commands.
        group: Admin
        permissions: []
        group: Admin
        permissions: []
        group: Admin
        permissions: []
        permissions: []
        group: vip
        permissions: []
        group: Mod
        permissions: []
        group: Admin
        permissions: []
        group: vip
        permissions: []
        group: vip
        permissions: []
        group: vip
        permissions: []
        group: vip
        permissions: []
        group: vip
        permissions: []
        group: vip
  10. Offline


    please take a look @ my typo guide

    in your permissions file there are a lot of [] and {} wich shouldn't be there.
    please replace all the rules within the [ ] with
    - 'plugin1.rule1'
    - 'plugin1.rule2'

    etc ....
  11. Offline


    I have problem in my config I put me Admin
    but in the game im not Admin!
    Here is my config:

    What I need to do ?!
  12. Offline


    @ Raaf one simple question: is the only thing you want/or need is total control over all the commands ?
    if the answer is yes, then go to your bukket root folder open the file ops and add your username. save, server restart
    and you have the same rights as with admin: '*' ... also check your worldfolder name and the permission.yml file name. the have to be exact the same.
  13. Offline


    thank you sooo much, it works! Now, I need an anti-guest build because the permissions build: false seems to nt work.. or does setting myself as guest rank and still having op not work?
  14. Offline


    I need to build config to server with Deafult,VIP,admins
    and I need to do command to everyone
    but they dont WORK!
  15. Offline


    OP overules all, so that's why you can build as guest
    i've made an example.yml for you
    please remove those # to make the rules working
    rename example.yml to your own worldname.yml

    place this new file in /plugins/permissions folder

    Attached Files:

  16. Offline


    No matter what I do, my permissions won't allow me and my friends to be the colored by the prefix, and the commands of my Essentials. I named my file to world.yml (my level name aka world name) I checked to see if all my code is right.
    But it wont allow me to be an admin/owner no matter what.
    It ends up like this
  17. Offline


    it could be because you're running your server in offline (insecure) mode.
    that way the server can't convert the proper usernames to the permissions.

    set "online-mode" to "true" in the server.settings file.
  18. Offline


    Dude steal not working!
    Im replace the config name to me world name!
    and i do everything you say and steal dont work!
    plzzzz help!
  19. Offline


    I'm having the same problem everyone else is .... users not getting astringent to there groups properly. another thing to note is that my Default group permissions are applying BUT prefixes are not. there needs to be some way to check a users permissions it could make diagnosing this bug SO much easier.

    @RaaF your not the only one having this same problem

    @saturnine_nl Lots of bugs in that man and i can't find the errors ether
  20. Offline


    After updating to 2.4 i get this with CB 522

    2011-03-09 09:02:42 [SEVERE] Could not load plugins/Permissions.jar in plugins: null
            at org.bukkit.plugin.SimplePluginManager.loadPlugin(
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(
            at net.minecraft.server.MinecraftServer.e(
            at net.minecraft.server.MinecraftServer.a(
            at net.minecraft.server.MinecraftServer.d(
    Caused by: java.lang.reflect.InvocationTargetException
            at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
            at sun.reflect.NativeConstructorAccessorImpl.newInstance(
            at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
            at java.lang.reflect.Constructor.newInstance(
            ... 8 more
    Caused by: java.lang.NullPointerException
            at com.nijiko.permissions.Control.<init>(
            at com.nijikokun.bukkit.Permissions.Permissions.setupPermissions(
            at com.nijikokun.bukkit.Permissions.Permissions.<init>(
            ... 13 more
  21. Offline


    same to me.
  22. Offline


    @Gordonzero could you pastebin your server console startup log ?
    and your permissions.yml so i can have a look
    ( )

    @RaaF could you do the same.

    Then i can see what's going on and hopely find the solution

    @Chaosboylu: seems you have to redownload permissions 2.5.4 there was an error in it wich has been fixed.
  23. Offline


    Here is my CMD:
    (There is no problem with permissions)
    But in game im not admin!weard
  24. Offline


    @ raaf : server is running in offline mode, so permissions has trouble giving each user the proper permissions.
    in main bukkitfolder open and set online-mode=true.

    also you use a lot of plugins, but the server warns that it has not enough RAM.
    how much memory do you have in your computer ?

    Hope this will bring us a step closer to victory [​IMG]
  25. Offline


    Now for the odd part ... it's working now (go figure) but there does seem to be a problem with the global permissions for admin ( the - '*' part) it doesent seem to want to work all the time ... for example it gives me the permissons for iConomy but not for other plugins. i'm wondering if the base permissons node needs to be called before * can be used. ex. - 'iConomy.*'

    not to sure on all this and prefixes still aren't working but at this point i don't even care.
  26. Offline


    redownload 2.5.4 :)
    just read in the op that it was bad originally.. fixed it for me.
  27. Offline


    I think there's a problem with iConomy and permissions, I'm not sure why though... [​IMG]
    maybe the iConomy Thread can give you more insight.
  28. Offline


    Hi, i have a problem with Permissions:

    Hope someone can help me :(
  29. OK, well I am pretty sure that the plugin v. 2.5.3 is working on my server except it doesn't.
    I think the problem is that I am running a minecraft server at, which has a different directory structure.....
    I mean to say inside the minecraft folder you have a different craftbukkit\plugins folder and a plugins folder directly inside minecraft.
    But the main problem is that the game world isn't stored in the game root directory, but inside a directory named maps, so in my case the world is stored in maps\world.
    Now I try to change the name to world.yml and store that in <game root>\minecraft\plugins\Permissions\ which makes hero chat work, so I think that is the correct place.
    IE. if I place this file somewhere else HeroChat doesn't work.
    Now I am sure that my config file is correct, but it still doesn't allow me to get users into a specified group. So when I am testing different settings, I can't add myself to the admin group and I can't add another person into my Moderator group.
    Am I right that this directory problem is an issue here?
  30. Offline


    you can work with multiple worlds inside a folder in your main bukkit.

    in my setup I use a Worlds folder

    /bukkit root
    world1 folder
    world2 folder
    world3 folder

    Inisde plugins i have permission mimmick the same structure
    /bukkit root

    This works with the latest permission 2.5.3
  31. So you have the permission yml file inside the game root folder, in my case minecraft?

    That is the one thing I haven't tried yet, so will report later if that worked.

    btw. for some strange reason this forum doesn't load from time to time, so I am writing this message through a remote desktop connection with a webserver of mine (not a minecraft server though)
Thread Status:
Not open for further replies.

Share This Page