Inactive [ADMN/DEV] Permissions v2.7.4 (Phoenix) - DISCONTINUED! 3.0 has a new home!

Discussion in 'Inactive/Unsupported Plugins' started by TheYeti, Feb 25, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 2.7.4 (Phoenix) - Now with AntiBuild built in!
    Latest Stable: Full Zip | Jar Only
    Latest Dev Build: Full Zip | Jar Only
    Previous Versions: 2.7.3 (JAR) | 2.7.2 (JAR) | 2.7.1 (JAR) | 2.7 (JAR) | 2.6 (JAR) | 2.5.5 (JAR) | 2.5.4 (JAR) | 2.5.3 (JAR) | 2.5.2 (JAR) | 2.5.1 (JAR) | 2.5 (JAR) | 2.4 (JAR) | 2.3 (JAR) | 2.2 (JAR)

    Plugin Authors: How to hook into Permissions

    Permissions 2.x is being discontinued! 3.0 can be found HERE!!!

    I am discontinuing Permissions 2.x and leaving the project. Permissions is not going away though! Since 2.6 I have been working closely with another developer and added them to the team. For the past several version they have not only been assisting with 2.x but also doing a lot of the development of much anticipated 3.x. rcjrrjcr will be taking over as lead developer of Permissions from 3.x forward. I have full faith in them and after working closely with them on the development on the last few version and the next major version I feel that I am leaving this project in more than capable hands. I put way to much work into this project to just leave it with anyone, and this is one of the few programs that I am incredibly proud of.

    Many people will probably wonder why I am leaving again after taking over the project just a few months ago. I could quote drama and headaches, of which there were quite a few with this project. Unfortunately real life happens. Many people already know that I have been having medical issues here lately. Unfortunately while they have gotten better, they have not gone away. This coupled with other real life commitments, going to school full time, and starting up my own company, I am currently in the process of being laid off from work. At this point I have so much stuff going on in my life and am being pulled in so many directions that I am not able to get any work done on anything. This has lead to me missing commitments and letting people down on multiple things.

    Permissions is also a very high maintenance plugin that requires a lot of attention and time. Right now I am not able to devote that time and do not feel it is fair for me to try to continue to be the lead developer on it. I had originally thought that adding other members to the team would be helpful, but unfortunately this just lead to frustration for them and myself as I just was not able to commit to the project enough. Hence, 3.0 has been rewritten almost exclusively by rcjrrjcr with minimal contributions by myself.

    At this point I will be stepping away from the project to focus more on real life and to try to free up some time for other projects and to work with more individual like the wonderful HeroCraft Coding team to fulfill some commitments that I made to them a long time ago and sadly did not come through on. I feel that this is the best for all involved, both myself and the other Permissions developers, as well as the community who deserve someone who can contribute more time and attention to them and supporting them. I do not want to see Permissions end up like many other plugins with an absentee programmer and just slowly wasting away from a great plugin with a lot of potential to a headache with no support.

    I will still be active in the community, just not as much as not in the same way. I'm sure my server will be more than happy to have their head admin back and active again as well.

    Thank you and happy gaming.

    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems
    • 2.6
      • Pulled in commits by rcjrrjcr
      • Fixed versioning. Last version should have technically been 2.6
      • Fixed invalid config file being written
      • Fixed erroneous conversion message.
    • 2.5.5
      • Updated to be compliant with CB600+
      • Further Maven Integration and Autobuilding
      • Better handling of configuration file errors.
        • If you do not have a world config file for the default world at startup it will now look for config.yml
        • If it cannot find that it will look for world.yml instead in case you named it that when that is not what is in level-name:
        • It will rewrite the config file to be the proper name. At this time it does not delete the old one though.
      • Removed defunct public abstract calls. If your not using the right one by now you should be shot anyway.
    • 2.5.4
        • Added Command aliases for perms and pr
        • Changed the way directories are handled.
        • Stopped it from creating an empty <world>.yml file in base directory
        • Moved project to using Maven.
    • 2.5.3
      • Change from File.pathSeparator to File.separator to fix multiworld perms
    • 2.5.2
      • Added more instructions to the included config file within the plugin
      • Added a check that will use the default world permissions if a world specific config file cannot be found.
      • Added a function to get only the group that a player is assigned to without checking for group inheritance.
      • Added a change to colorize() to fix it hopefully not adding an extra unneeded ascii character and thus creating a linebreak/color switch issue
      • Removed as it was not needed and was a artifact of testing I was doing.
    • 2.5.1
      • Fixed a bug that could cause a group to be returned as null for getGroups()
    • 2.5
      • Added in AntiBuild functionality to Permissions
      • Minor code tweaks
      • Added getGroups(world, player) to PermissionHandler so that plugins can call it to get all of a users groups
      • Fixed the inability to use the permissions -reload all command from within the console. I still need to do some more work on this as it doesn't seem to like to accept anything other than all from console.
    • 2.4
      • Refactored namespaces to keep in line with Java & Bukkit policy
        • This was cancelled as it ended up being not needed
      • Fixed setupPermissions()
    • 2.3
      • Undid removal of some code that I had overzealously purged during cleanup
      • Merged in last of Nijikokun's changes
      • Re-ordered the main class to attempt to fix the problems with Plugin API
    • 2.2
      • Developer change
      • Fixed reloading of configuration files
      • Moved commands to registering with plugin.yml
      • Commands now use onCommand instead of onPlayerCommand
      • Command is now /permissions instead of /pr
    mruczek, kahlilnc, Pii and 58 others like this.
  2. Offline


    Thanks Maxis010 ;)

    Another problem i've run into :
    I've firtsly set the group 'Colporteur' to build false. They correctly didn't have the permissions to destroy blocks etc...
    But when I reset the group to build: true, they still get the message 'you don't have the permission to do that' when destroying a block.
    I've tried a lot of things but nothing work. I hope you'll be able to help me :)

            system: default
            copies: null
            default: false
            - 'gs.use.goldenapple'
            - 'signColours.*'
            - Notable
                prefix: '&1<Dignitaire> '
                build: true
                suffix: ''
                rank: 6
            default: false
            - 'deathmessageplugin.getmessage'
            - 'dc.who'
            - 'ecoCreature.Creature.*'
            - 'iConomy.payment'
            - ''
            - ''
            - 'lockette.user.create.*'
            - ''
            - ''
            - ''
            inheritance: []
                prefix: '&7<Immigrant> '
                build: true
                suffix: ''
                rank: 2
            default: false
            - ''
            - Immigrant
                prefix: '&8<Resident> '
                build: true
                suffix: ''
                rank: 3
            default: false
            - 'gs.use.sprint'
            - 'gs.use.regen.*'
            - ''
            - ''
            - 'AutoRepair.*'
            - 'dc.home.self'
            - 'dc.sethome.self'
            - 'herochat.create'
            - 'herosneak.sneak'
            - 'iConomy.rank'
            - Bourgeois
                prefix: '&9<Notable> '
                build: true
                suffix: ''
                rank: 5
            default: false
            - '*'
            inheritance: []
                prefix: '&6<Conseiller> '
                build: true
                suffix: ''
                rank: 7
            default: false
            - 'deathmessageplugin.sendmessage'
            - Resident
                prefix: '&2<Bourgeois> '
                build: true
                suffix: ''
                rank: 4
            default: false
            - '*'
            inheritance: []
                prefix: '&4<Assemblee> '
                build: true
                suffix: ''
                rank: 10
            default: true
            - 'guestprev.interact.*'
            - ''
            - 'guestprev.attack.*'
            - '-guestprev.attack.sheeps'
            inheritance: null
                prefix: '&8<Colporteur> '
                build: true
                suffix: ''
                rank: 1
  3. Offline


    Okay. Major update of the dev build. Tons of major SQL bugs got weeded out. If you downloaded the dev build before this post, download a fresh copy.
  4. Offline


    Is there an IN-GAME command to change peoples permissions group ?
    ie : I've got a "builder" players group, and I would like my moderators to be able to do this :
    /permissionset <playernickname> <permissiongroup>
  5. Offline


    i tried taking out both but nothing happens ...
  6. Offline


    try this:
    dont know if its what you need.. just found it myself a couple of seconds ago..


    why is there no prefix / suffix when I write ingame? I'm in group Admin and Admin has prefix '[Admin] ' but it isn't displayed...

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  7. Offline


    Permssions 3.0 will have that capability.
    You need a chat plugin, like iChat or HeroChat.
  8. Offline


    You appear to be using GuestPrev (+1 Good Sir), give that group users the isAuthorised node and try again, GP might be blocking them

    You need a chat plugin (HeroChat, iChat etc) to use the prefix and suffix, permissions alone doesn't do anything with them

    EDIT: Cut to the quick by rcjrrjcr
  9. Offline


    I've got this problem before installing GuestPrev.
    I've tried anyway but it didn't solve it.
  10. Offline


    thanks :)
  11. Offline


    For anyone that is having a problem with the latest Dev Build. Trying going into the permissions folder and make the world file a .yml it will then create a new world folder and it should work.
  12. Offline


    What? How does that even help?
    What is your problem exactly? Is the world folder not being created properly?
  13. Offline


  14. Offline


    somehow this does not work for me.. i wonder if it crashes whit another plugin or if i am doing something wrong. but i thing i have done all of it the right way.. please help me!! :D if u know what can be the cause
  15. Offline


    thanks alot that helped me too, surprisingly. first time i used a forum search function with success! :D
  16. Offline


    Dev Build updated. More SQL fixes, and a new feature - world inheritance. This allows you to mirror a world and still be able to override permissions.
  17. Offline


    We have just resently updated permissions to its latest version and were having a problem.. its deniying admins the abelety to run some commands.

    The addon in question we are using giving us the permissions error is MultiVerse
  18. Offline


    After i updated bukkit to 766 it doesn't work anymore...
  19. Offline


    I get LinkageError, so Permissions is unusless. I have said this 4 times before + pm'ed the developer. Nobody is listen to me :(
  20. Offline


    it sais its suposed to work whit 766
  21. Offline


    permissions is 766 compatible on my end, I have no idea what the problem is for you guys
  22. Offline


    You give 0 information in your posts and I did respond to you but you decided to ignore it.
  23. Offline


    is their a way i can make it so i can make everyone have the permission and not go to each group? for 1 node
  24. Offline


    I did everythign right from what i know and the VIP and Admin prefix and suffix arent working when people talk there a node i have to use or something to make them work ?
  25. Offline


    could you use enter in permissions? or ONLY spaces o-o
  26. Offline


    You can give a group the - '*' permission and everyone will have access to everything. Put it in the default group and you won't even need to fill in any users.
    You need a chat mod for those to work.
    Nothing wrong with using the enter key in yml files.
  27. Offline


    that could be my reason though, that other players cannot use permissions, could you find anything wrong wen you tested it?
  28. Offline


    If you are talking about the other day when I looked at your latest file, I'm pretty sure I gave you a really complete answer on what I did down to every little detail I could think you might throw back at me. I didn't see any problems with it but the same as before, you didn't actually tell us anything that was wrong with it. Commands don't work just doesn't cut it. Look at the previous one. After 4+ messages, you finally tell us that List doesn't work. Well, you didn't give them list.
  29. Offline


    but then wat if they inherit it from a lower group that has list, do they get list too?

    hey dude i fixed it, there was a period after Adv. Builder so i guess it messed up with the scripting or w/e so i took it out and its working great.. except theres a problem in the console now.. D: theres an error and i cannot depict what it is about o-o
    Edit: Nvm fixed the problem... well thanks for your help ;D

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  30. Offline

    Alex H

    getting error when running with only permissions 2.7.3 on the server

    21:27:46 [SEVERE] Could not load 'plugins/Permissions.jar' in folder 'plugins':
    java.lang.UnsupportedClassVersionError: Bad version number in .class file
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(
    at Method)
    at java.lang.ClassLoader.loadClass(
    at java.lang.ClassLoader.loadClass(
    at java.lang.ClassLoader.loadClassInternal(
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at net.minecraft.server.MinecraftServer.e(
    at net.minecraft.server.MinecraftServer.a(
    at net.minecraft.server.MinecraftServer.init(
  31. Offline


    Update to Java v1.6.
Thread Status:
Not open for further replies.

Share This Page